Trouble installing ASP.Net app on 2003 enterprise server (404's)

Discussion in 'ASP .Net' started by Stefan, Aug 10, 2004.

  1. Stefan

    Stefan Guest

    I have a problem deploying a ASP.Net app on a 2003 Enterprise server.
    After installing the application I get 404's when I try to access the
    aspx pages on the server (not other pages like html or stylesheets).

    I installed IIS after the .Net runtime and ran aspnet_regiis
    afterwards. I checked, that the .aspx extension is mapped to the
    aspnet_isapi.dll for all verbs. Still no luck.

    An example W3C log entry is:

    ""2004-08-10 17:30:52 127.0.0.1 GET
    /SolutionsLicensing/ProductSelect.aspx - 80 TESTLAB\Stefan 127.0.0.1
    Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322)
    404 2 1260""

    My environment is IIS 6.0 on Windows Server 2003 Enterpise Edition.
    CLR version is 1.1.4322.

    I don't quite know where to go from here. Can somebody help me out
    here?
    Thanks!
    -Stefan
    Stefan, Aug 10, 2004
    #1
    1. Advertising

  2. Is the root directory of your ASP.Net app marked as an application?

    --
    HTH,
    Kevin Spencer
    ..Net Developer
    Microsoft MVP
    Big things are made up
    of lots of little things.

    "Stefan" <> wrote in message
    news:...
    > I have a problem deploying a ASP.Net app on a 2003 Enterprise server.
    > After installing the application I get 404's when I try to access the
    > aspx pages on the server (not other pages like html or stylesheets).
    >
    > I installed IIS after the .Net runtime and ran aspnet_regiis
    > afterwards. I checked, that the .aspx extension is mapped to the
    > aspnet_isapi.dll for all verbs. Still no luck.
    >
    > An example W3C log entry is:
    >
    > ""2004-08-10 17:30:52 127.0.0.1 GET
    > /SolutionsLicensing/ProductSelect.aspx - 80 TESTLAB\Stefan 127.0.0.1
    > Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322)
    > 404 2 1260""
    >
    > My environment is IIS 6.0 on Windows Server 2003 Enterpise Edition.
    > CLR version is 1.1.4322.
    >
    > I don't quite know where to go from here. Can somebody help me out
    > here?
    > Thanks!
    > -Stefan
    Kevin Spencer, Aug 10, 2004
    #2
    1. Advertising

  3. Stefan

    Stefan Guest

    Kevin,

    I'm new to IIS6, so how do you mark the app as application? It's
    configured to use the default application pool with execution
    permissions on scripts only.

    Thanks
    -Stefan

    "Kevin Spencer" <> wrote in message news:<>...
    > Is the root directory of your ASP.Net app marked as an application?
    >
    > --
    > HTH,
    > Kevin Spencer
    > .Net Developer
    > Microsoft MVP
    > Big things are made up
    > of lots of little things.
    >
    > "Stefan" <> wrote in message
    > news:...
    > > I have a problem deploying a ASP.Net app on a 2003 Enterprise server.
    > > After installing the application I get 404's when I try to access the
    > > aspx pages on the server (not other pages like html or stylesheets).
    > >
    > > I installed IIS after the .Net runtime and ran aspnet_regiis
    > > afterwards. I checked, that the .aspx extension is mapped to the
    > > aspnet_isapi.dll for all verbs. Still no luck.
    > >
    > > An example W3C log entry is:
    > >
    > > ""2004-08-10 17:30:52 127.0.0.1 GET
    > > /SolutionsLicensing/ProductSelect.aspx - 80 TESTLAB\Stefan 127.0.0.1
    > > Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322)
    > > 404 2 1260""
    > >
    > > My environment is IIS 6.0 on Windows Server 2003 Enterpise Edition.
    > > CLR version is 1.1.4322.
    > >
    > > I don't quite know where to go from here. Can somebody help me out
    > > here?
    > > Thanks!
    > > -Stefan
    Stefan, Aug 11, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Matthew Louden
    Replies:
    4
    Views:
    4,006
    Guest
    Nov 8, 2003
  2. Matthew Louden
    Replies:
    0
    Views:
    550
    Matthew Louden
    Dec 3, 2003
  3. Jonathan Folland
    Replies:
    2
    Views:
    1,615
    Jonathan Folland
    Mar 17, 2005
  4. Replies:
    3
    Views:
    541
  5. =?Utf-8?B?Q2hyaXN0aWFuIE51bmNpYXRv?=

    Deploying .NET 2.0 Web App from WinXP Pro to Server 2003: 404!

    =?Utf-8?B?Q2hyaXN0aWFuIE51bmNpYXRv?=, Jun 29, 2006, in forum: ASP .Net
    Replies:
    3
    Views:
    501
    Juan T. Llibre
    Jun 29, 2006
Loading...

Share This Page