trouble with el-ignored jsp setting in web.xml

Discussion in 'Java' started by Cid, Jul 23, 2004.

  1. Cid

    Cid Guest

    I'm not getting the expected behavior (as I understand it) from my
    web.xml file. I'm using tomcat5 with the default jsp & servlet libs it
    comes with (2.0 & 2.4 respectively). My web.xml file is of 2.3 format
    (just cause that was the sample on which I based it).

    So I expect (per the JSP spec) that EL is NOT evaluated by default
    because of the 2.3 web.xml. This is true.

    If I use the page directive, <%@ page isELIgnored='false'%>, then EL
    is evaluated as expected.

    So here's the kicker: I want to try turning EL on by default for jsp
    pages in my web app so I add the appropriate jsp-config block to my
    web.xml:

    <jsp-config>
    <jsp-property-group>
    <url-pattern>*.jsp</url-pattern>
    <el-ignored>false</el-ignored>
    </jsp-property-group>
    </jsp-config>

    With the page directive removed, I expect (per the spec) that EL will
    now be evaluated by default. Not so, still behaves as if it's off.

    There are no other groups or mappings in the web.xml that could
    override the .jsp mapping. I also tried setting the pattern explicitly
    to my test page (/index.jsp) to no avail. Also tried /*.jsp but that
    causes an error while trying to load the context.

    Nothing abnormal looking in the logs. Any suggestions?
     
    Cid, Jul 23, 2004
    #1
    1. Advertisements

  2. Cid

    sambo

    Joined:
    Oct 18, 2006
    Messages:
    1
    Likes Received:
    0
    Hi Cid,

    I was facing the same problem. I looked at various jsp configurations in 2.4 web.xml. The EL was not getting recognised if the
    <%@ page isELIgnored='false'%> header was not specified in the JSP file. Then I added this in web.xml

    <jsp-config>
    <jsp-property-group>
    <display-name>WebLogicServer 9.0 JSP 2.0 setting</display-name>
    <url-pattern>*.jsp</url-pattern>
    <el-ignored>false</el-ignored>
    <scripting-invalid>false</scripting-invalid>
    <is-xml>false</is-xml>
    </jsp-property-group>

    and still kept the header. I kept getting validation errors in we.xml. But after a long struggle it fixed itself. Then i took out the header from JSP page and also removed the prelude and coda tags, but the output was still working. Then i made <el-ignored>true</el-ignored>, it still was interpreting JSP EL in the JSP. Well, I am using Eclipse 3.2, BEA Weblogic 9.0 and they both support JSP 2.0 and Servlet 2.4 specs. At this stage i still dont know the problem. But it seems to be working fine. Cache related problems i think !! Anyway gud luck in your trials!
     
    sambo, Oct 18, 2006
    #2
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mek
    Replies:
    0
    Views:
    926
  2. =?Utf-8?B?QmlsbCBMb25n?=

    Web.Config file seems to be ignored

    =?Utf-8?B?QmlsbCBMb25n?=, Nov 25, 2005, in forum: ASP .Net
    Replies:
    4
    Views:
    2,288
    Karl Seguin
    Nov 29, 2005
  3. =?Utf-8?B?QnJpYW4=?=

    CSS ignored by dial up web accelerator

    =?Utf-8?B?QnJpYW4=?=, Mar 19, 2006, in forum: ASP .Net
    Replies:
    0
    Views:
    463
    =?Utf-8?B?QnJpYW4=?=
    Mar 19, 2006
  4. Replies:
    0
    Views:
    4,985
  5. Jeff
    Replies:
    4
    Views:
    491
  6. Bo Campbell via .NET 247

    Trouble setting security for new thread in web app.

    Bo Campbell via .NET 247, Aug 4, 2004, in forum: ASP .Net Security
    Replies:
    1
    Views:
    206
    Hernan de Lahitte
    Aug 4, 2004
  7. Tim

    xml mime type ignored

    Tim, Dec 18, 2003, in forum: ASP General
    Replies:
    1
    Views:
    244
    Martin Honnen
    Dec 22, 2003
  8. Erik Wasser
    Replies:
    5
    Views:
    862
    Peter J. Holzer
    Mar 5, 2006
Loading...