Unable to Deploy ASP.Net 2.0 App to Local IIS

Discussion in 'ASP .Net' started by Tim Brooks, Jun 24, 2006.

  1. Tim Brooks

    Tim Brooks Guest

    All,
    Not sure where else to go. I have: VS2005, XP SP2 Media Center, IIS5.1

    Problem:
    Apps developed (even simple "Hello WOrld") apps simply won't deploy properly
    to either my local IIS instance or to a 2nd server W2003K server.

    When I publish, create them as IIS apps, or copy, even after running
    both/either the ASP2.) security tab or the web admin (asp based) manager
    they will not enable properly.

    I have:
    - Set to anonymous access
    - Given permission to IUSR_ANONYMOUS
    - Turned off/uninstalled firewall, and Windows Defender
    - Read the even log
    - Uninstalled 1.1, and 2.0, repareid and re-installed 2.0
    - Re reged ASP with aspnet_regiis
    - Unistalled and re-installed IIS services
    - etc...

    App run fine with the built in Cassini server but won't deploy, won't run,
    etc...any other way. I always get a 403 (Access forbidden or 500 unknown)
    error.

    I have also tried hand-copying and setting permissions for anonymous
    manually....also does not work....
    Not sure where else to turn....
    I am starting to think that ASP in VS2005 is absolute rubbish....

    cheers,
    t
     
    Tim Brooks, Jun 24, 2006
    #1
    1. Advertising

  2. Tim Brooks

    Tim Brooks Guest

    Forgot to mention I've also:
    - Done a full Windows Update
    - Full VS2005 repair

    Is it my instance of IIS? VS2005? An ASP.Net set-up issue? Issues with XP
    Media Center?

    This is the most difficulty I've had with any variant of VS, IIS or
    ASP...and I have been using all since ASP first released....

    thx again


    "Tim Brooks" <> wrote in message
    news:OC9maB%...
    > All,
    > Not sure where else to go. I have: VS2005, XP SP2 Media Center, IIS5.1
    >
    > Problem:
    > Apps developed (even simple "Hello WOrld") apps simply won't deploy
    > properly to either my local IIS instance or to a 2nd server W2003K server.
    >
    > When I publish, create them as IIS apps, or copy, even after running
    > both/either the ASP2.) security tab or the web admin (asp based) manager
    > they will not enable properly.
    >
    > I have:
    > - Set to anonymous access
    > - Given permission to IUSR_ANONYMOUS
    > - Turned off/uninstalled firewall, and Windows Defender
    > - Read the even log
    > - Uninstalled 1.1, and 2.0, repareid and re-installed 2.0
    > - Re reged ASP with aspnet_regiis
    > - Unistalled and re-installed IIS services
    > - etc...
    >
    > App run fine with the built in Cassini server but won't deploy, won't run,
    > etc...any other way. I always get a 403 (Access forbidden or 500 unknown)
    > error.
    >
    > I have also tried hand-copying and setting permissions for anonymous
    > manually....also does not work....
    > Not sure where else to turn....
    > I am starting to think that ASP in VS2005 is absolute rubbish....
    >
    > cheers,
    > t
    >
    >
    >
     
    Tim Brooks, Jun 24, 2006
    #2
    1. Advertising

  3. re:
    > - Set to anonymous access
    > - Given permission to IUSR_ANONYMOUS


    Unless you've configured impersonation for the IUSR_ANONYMOUS account,
    you are giving permissions to the wrong account.

    Under XP, ASP.NET runs as the "MachineName\ASPNET" account.
    Under W2K3, ASP.NET runs as the "MachineName\Network Service" account.

    Give access permissions to the correct account.

    Also, under W2K3, you need to explicitly enable ASP.NET 2.0.

    Open the IIS Manager, scroll on the left to "Web Service Extensions",
    select that, go to the right pane and select the ASP.NET version you
    want to enable and click the "Allow" button.

    Repeat the sequence for all versions of ASP.NET you want to enable.




    Juan T. Llibre, asp.net MVP
    aspnetfaq.com : http://www.aspnetfaq.com/
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ===================================
    "Tim Brooks" <> wrote in message news:OC9maB%...
    > All,
    > Not sure where else to go. I have: VS2005, XP SP2 Media Center, IIS5.1
    >
    > Problem:
    > Apps developed (even simple "Hello WOrld") apps simply won't deploy properly to either my local
    > IIS instance or to a 2nd server W2003K server.
    >
    > When I publish, create them as IIS apps, or copy, even after running both/either the ASP2.)
    > security tab or the web admin (asp based) manager they will not enable properly.
    >
    > I have:
    > - Set to anonymous access
    > - Given permission to IUSR_ANONYMOUS
    > - Turned off/uninstalled firewall, and Windows Defender
    > - Read the even log
    > - Uninstalled 1.1, and 2.0, repareid and re-installed 2.0
    > - Re reged ASP with aspnet_regiis
    > - Unistalled and re-installed IIS services
    > - etc...
    >
    > App run fine with the built in Cassini server but won't deploy, won't run, etc...any other way. I
    > always get a 403 (Access forbidden or 500 unknown) error.
    >
    > I have also tried hand-copying and setting permissions for anonymous manually....also does not
    > work....
    > Not sure where else to turn....
    > I am starting to think that ASP in VS2005 is absolute rubbish....
    >
    > cheers,
    > t
    >
    >
    >
     
    Juan T. Llibre, Jun 25, 2006
    #3
  4. Tim Brooks

    TAB Guest

    Juan,

    Thanks for the response. I've since gotten it working and it all seemed to
    be because of the OS. I was using a machine that came pre-built with Media
    Center and, because VS2005 installed fine and ASP.Net seemed to work (and
    the docs said so, too) I assumed that it did.

    I have since completely rebuilt the entire machine with XP Pro...and ASP.Net
    worked correctly right out of the gate. Even got debugging working, had not
    worked previously for ASP.Net projects....

    Oh well.....
    thanks all...

    "Juan T. Llibre" <> wrote in message
    news:Otag0G$...
    > re:
    >> - Set to anonymous access
    >> - Given permission to IUSR_ANONYMOUS

    >
    > Unless you've configured impersonation for the IUSR_ANONYMOUS account,
    > you are giving permissions to the wrong account.
    >
    > Under XP, ASP.NET runs as the "MachineName\ASPNET" account.
    > Under W2K3, ASP.NET runs as the "MachineName\Network Service" account.
    >
    > Give access permissions to the correct account.
    >
    > Also, under W2K3, you need to explicitly enable ASP.NET 2.0.
    >
    > Open the IIS Manager, scroll on the left to "Web Service Extensions",
    > select that, go to the right pane and select the ASP.NET version you
    > want to enable and click the "Allow" button.
    >
    > Repeat the sequence for all versions of ASP.NET you want to enable.
    >
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > aspnetfaq.com : http://www.aspnetfaq.com/
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ===================================
    > "Tim Brooks" <> wrote in message
    > news:OC9maB%...
    >> All,
    >> Not sure where else to go. I have: VS2005, XP SP2 Media Center, IIS5.1
    >>
    >> Problem:
    >> Apps developed (even simple "Hello WOrld") apps simply won't deploy
    >> properly to either my local IIS instance or to a 2nd server W2003K
    >> server.
    >>
    >> When I publish, create them as IIS apps, or copy, even after running
    >> both/either the ASP2.) security tab or the web admin (asp based) manager
    >> they will not enable properly.
    >>
    >> I have:
    >> - Set to anonymous access
    >> - Given permission to IUSR_ANONYMOUS
    >> - Turned off/uninstalled firewall, and Windows Defender
    >> - Read the even log
    >> - Uninstalled 1.1, and 2.0, repareid and re-installed 2.0
    >> - Re reged ASP with aspnet_regiis
    >> - Unistalled and re-installed IIS services
    >> - etc...
    >>
    >> App run fine with the built in Cassini server but won't deploy, won't
    >> run, etc...any other way. I always get a 403 (Access forbidden or 500
    >> unknown) error.
    >>
    >> I have also tried hand-copying and setting permissions for anonymous
    >> manually....also does not work....
    >> Not sure where else to turn....
    >> I am starting to think that ASP in VS2005 is absolute rubbish....
    >>
    >> cheers,
    >> t
    >>
    >>
    >>

    >
    >
     
    TAB, Jun 25, 2006
    #4
  5. > I was using a machine that came pre-built with Media Center

    Thanks for reporting back on that. It's something to watch for!

    Ken
    Microsoft MVP [ASP.NET]

    "TAB" <> wrote in message
    news:%...
    > Juan,
    >
    > Thanks for the response. I've since gotten it working and it all seemed
    > to be because of the OS. I was using a machine that came pre-built with
    > Media Center and, because VS2005 installed fine and ASP.Net seemed to work
    > (and the docs said so, too) I assumed that it did.
    >
    > I have since completely rebuilt the entire machine with XP Pro...and
    > ASP.Net worked correctly right out of the gate. Even got debugging
    > working, had not worked previously for ASP.Net projects....
    >
    > Oh well.....
    > thanks all...
    >
    > "Juan T. Llibre" <> wrote in message
    > news:Otag0G$...
    >> re:
    >>> - Set to anonymous access
    >>> - Given permission to IUSR_ANONYMOUS

    >>
    >> Unless you've configured impersonation for the IUSR_ANONYMOUS account,
    >> you are giving permissions to the wrong account.
    >>
    >> Under XP, ASP.NET runs as the "MachineName\ASPNET" account.
    >> Under W2K3, ASP.NET runs as the "MachineName\Network Service" account.
    >>
    >> Give access permissions to the correct account.
    >>
    >> Also, under W2K3, you need to explicitly enable ASP.NET 2.0.
    >>
    >> Open the IIS Manager, scroll on the left to "Web Service Extensions",
    >> select that, go to the right pane and select the ASP.NET version you
    >> want to enable and click the "Allow" button.
    >>
    >> Repeat the sequence for all versions of ASP.NET you want to enable.
    >>
    >>
    >>
    >>
    >> Juan T. Llibre, asp.net MVP
    >> aspnetfaq.com : http://www.aspnetfaq.com/
    >> asp.net faq : http://asp.net.do/faq/
    >> foros de asp.net, en español : http://asp.net.do/foros/
    >> ===================================
    >> "Tim Brooks" <> wrote in message
    >> news:OC9maB%...
    >>> All,
    >>> Not sure where else to go. I have: VS2005, XP SP2 Media Center, IIS5.1
    >>>
    >>> Problem:
    >>> Apps developed (even simple "Hello WOrld") apps simply won't deploy
    >>> properly to either my local IIS instance or to a 2nd server W2003K
    >>> server.
    >>>
    >>> When I publish, create them as IIS apps, or copy, even after running
    >>> both/either the ASP2.) security tab or the web admin (asp based) manager
    >>> they will not enable properly.
    >>>
    >>> I have:
    >>> - Set to anonymous access
    >>> - Given permission to IUSR_ANONYMOUS
    >>> - Turned off/uninstalled firewall, and Windows Defender
    >>> - Read the even log
    >>> - Uninstalled 1.1, and 2.0, repareid and re-installed 2.0
    >>> - Re reged ASP with aspnet_regiis
    >>> - Unistalled and re-installed IIS services
    >>> - etc...
    >>>
    >>> App run fine with the built in Cassini server but won't deploy, won't
    >>> run, etc...any other way. I always get a 403 (Access forbidden or 500
    >>> unknown) error.
    >>>
    >>> I have also tried hand-copying and setting permissions for anonymous
    >>> manually....also does not work....
    >>> Not sure where else to turn....
    >>> I am starting to think that ASP in VS2005 is absolute rubbish....
    >>>
    >>> cheers,
    >>> t
    >>>
    >>>
    >>>

    >>
    >>

    >
    >
     
    Ken Cox [Microsoft MVP], Jun 26, 2006
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. NGM
    Replies:
    0
    Views:
    2,357
  2. Flip
    Replies:
    4
    Views:
    447
  3. =?Utf-8?B?QmlsbCBNYW5yaW5n?=

    Deploy ASP.NET App -ASP.NET Not Installed

    =?Utf-8?B?QmlsbCBNYW5yaW5n?=, Nov 24, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    774
    Eric Pearson
    Dec 16, 2005
  4. Replies:
    1
    Views:
    404
  5. GaryDean

    Deploy won't deploy Masterpage.master

    GaryDean, Apr 14, 2009, in forum: ASP .Net
    Replies:
    1
    Views:
    442
Loading...

Share This Page