Unable to start debugging on the webserver

Discussion in 'ASP .Net' started by 1388-2/HB, Feb 1, 2007.

  1. 1388-2/HB

    1388-2/HB Guest

    This is happening on a WinXP Pro SP2 machine with Visual Studio 2005 & local
    IIS as the debugger. Everything was working fine this morning (and had been
    working for weeks/months prior). After a trip to windows update (where I
    installed IE 7, .NET 3.0, VS 2005 SP1 and misc updates for XP such as
    timezone changes & a new sound driver) I can no longer debug my web app on
    IIS. I now receive this message:

    "Unable to start debugging on the web server. The web server is not
    configured correctly. See help for common configuration errors. Running the
    web page outside of the debugger may provide further information."

    I can visit the website without debugging directly at http://localhost/ in
    IE 7 (or FireFox 2.0) and the website functions 100% as expected, no errors.
    I have not changed any of the authentication methods for the website in IIS.
    Windows Authentication is enabled. IIS shows framework version 2.0 on the
    ASP.NET property tab of the website (as it always did) and the website code
    itself is still referencing objects from the 2.0 framework (no change).
    debug="true" in web.config (no change), VS 2005 still references a custom
    webserver url of http://localhost/ (no change). I cannot figure out what
    has changed but obviously something very critical has in fact changed.

    It was not getting this error message this morning before the updates. Any
    ideas?
     
    1388-2/HB, Feb 1, 2007
    #1
    1. Advertising

  2. 1388-2/HB

    bruce barker Guest

    the problem is caused by installing ie 7.0

    try adding localhost to the trusted sites, or upgrade to vista (the only
    enviroment i use ie 7.0).

    -- bruce (sqlwork.com)


    1388-2/HB wrote:
    > This is happening on a WinXP Pro SP2 machine with Visual Studio 2005 & local
    > IIS as the debugger. Everything was working fine this morning (and had been
    > working for weeks/months prior). After a trip to windows update (where I
    > installed IE 7, .NET 3.0, VS 2005 SP1 and misc updates for XP such as
    > timezone changes & a new sound driver) I can no longer debug my web app on
    > IIS. I now receive this message:
    >
    > "Unable to start debugging on the web server. The web server is not
    > configured correctly. See help for common configuration errors. Running the
    > web page outside of the debugger may provide further information."
    >
    > I can visit the website without debugging directly at http://localhost/ in
    > IE 7 (or FireFox 2.0) and the website functions 100% as expected, no errors.
    > I have not changed any of the authentication methods for the website in IIS.
    > Windows Authentication is enabled. IIS shows framework version 2.0 on the
    > ASP.NET property tab of the website (as it always did) and the website code
    > itself is still referencing objects from the 2.0 framework (no change).
    > debug="true" in web.config (no change), VS 2005 still references a custom
    > webserver url of http://localhost/ (no change). I cannot figure out what
    > has changed but obviously something very critical has in fact changed.
    >
    > It was not getting this error message this morning before the updates. Any
    > ideas?
    >
    >
     
    bruce barker, Feb 1, 2007
    #2
    1. Advertising

  3. 1388-2/HB

    1388-2/HB Guest

    After putting localhost in different zones (trusted, intranet) to no
    success, I simply uninstalled IE 7.

    I'm still getting the error when I try to debug the website. Was I wrong to
    install the VS 2005 SP1 upgrade on an XP Pro / IIS5 machine, is it meant for
    Vista / IIS 7 machines?

    This certainly isn't helping me meet any project deadlines, that's for sure.

    "bruce barker" <> wrote in message
    news:...
    > the problem is caused by installing ie 7.0
    >
    > try adding localhost to the trusted sites, or upgrade to vista (the only
    > enviroment i use ie 7.0).
    >
    > -- bruce (sqlwork.com)
    >
    >
     
    1388-2/HB, Feb 1, 2007
    #3
  4. 1388-2/HB

    1388-2/HB Guest

    Ok this doesn't make much sense, but it's reproduceable and it fixes the
    problem so who am I to argue. Turns out it doesn't have anything to do with
    localhost being in a low security zone, I think it has something to do with
    VS 2005's ability to attach to the aspnet worker process.

    This error is indeed caused by installing IE 7. Studying the behavior on my
    workstation, I can in fact get IE 7, VS 2005 and IIS 5.1 to all play nice
    together, but only if VS 2005 is installed *after* IE 7 is installed. From
    this I can only assume something in the IE 7 installation is modifying
    something that VS 2005 needs in order to attach to the aspnet worker
    process, because this is where it seems to be failing when it fails. And
    whatever that modification is that IE 7 makes, the IE 7 uninstaller does not
    "undo" it; meaning once IE 7 is installed, VS 2005's ability to debug on IIS
    is "broken" thereafter.

    But if I reinstall (or repair) VS 2005, this "fixes" whatever IE 7 "breaks".
    So I can in fact install IE 7 and use it while debugging, so long as VS 2005
    is installed or repaired "on top of" IE 7.

    On my machine I can consistantly "break" VS 2005 / IIS web debugging by
    re-installing IE 7, and in turn "fix" it by re-installing VS 2005. I never
    touch IIS or modify IE 7's security settings, just install the programs in a
    different order is all.

    Installed VS 2005 SP1 & updates for IE 7 and everything's fine now.

    "1388-2/HB" <> wrote in message
    news:A2dwh.57550$...
    > After putting localhost in different zones (trusted, intranet) to no
    > success, I simply uninstalled IE 7.
    >
    > I'm still getting the error when I try to debug the website. Was I wrong
    > to install the VS 2005 SP1 upgrade on an XP Pro / IIS5 machine, is it
    > meant for Vista / IIS 7 machines?
    >
    > This certainly isn't helping me meet any project deadlines, that's for
    > sure.
    >
    > "bruce barker" <> wrote in message
    > news:...
    >> the problem is caused by installing ie 7.0
    >>
    >> try adding localhost to the trusted sites, or upgrade to vista (the only
    >> enviroment i use ie 7.0).
    >>
    >> -- bruce (sqlwork.com)
    >>
    >>

    >
     
    1388-2/HB, Feb 5, 2007
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. loser
    Replies:
    3
    Views:
    1,343
    loser
    Aug 7, 2003
  2. Andrew
    Replies:
    0
    Views:
    306
    Andrew
    Aug 7, 2003
  3. logan
    Replies:
    1
    Views:
    805
    =?Utf-8?B?QWFydGhp?=
    Oct 18, 2005
  4. loser
    Replies:
    0
    Views:
    129
    loser
    Aug 7, 2003
  5. loser
    Replies:
    0
    Views:
    121
    loser
    Aug 7, 2003
Loading...

Share This Page