Unable to start debugging

Discussion in 'ASP .Net' started by Serdar Kalaycý, Aug 12, 2004.

  1. Hi everybody,

    My problem seems a bit clichè but I could not work around.

    Well I read lots of MSDN papers and discussions, but my problem is a bit
    different from them. When I tried to run the project in debug mode (by
    hitting F5) it gives an error message

    "Error while trying to run project: Unable to start debugging on the web
    server.
    Click Help for more information"

    While surfing the net I saw lots of error messages like this but all of them
    had an explanation with them like "Access is denied" or "The project is not
    configured for debugging" and so on. Mine has no explanations...

    I went through lots of guidelines that say re-registering aspnet_isapi.dll,
    running aspnet_regiis -i, checking server configuration whether it has
    'Integrated Windows Authantication', creating the project with the name of
    the server instead of the IP number and so on.

    I must also mention that I can attach the process manually without any
    problems.

    The server is:
    Win 2000 SP4 with IIS 5.0 and SQL 2000
    Domain Controller

    The client is:
    Win XP Professional

    Both has Framework 1.1 installed, and I also run Remote Debugging Setup from
    VS.Net CD1 on the server. Just one thing to mention, it gave a warning while
    installing Analyze Server concerning about it could not add the account to
    the Debugger Users group, since it's a domain controller.
    I log on using my domain account which is Administrator on client machine
    and is in Domain Administrators and Debugger Users on the server.

    Hope someone can help.

    Thanks in advance
    Serdar KALAYCI
    Serdar Kalaycý, Aug 12, 2004
    #1
    1. Advertising

  2. Hi Serdar,

    Are you running SP2 on your Windows XP machine by any chance?

    Jim Cheshire [MSFT]
    MCP+I, MCSE, MCSD, MCDBA
    Microsoft Developer Support


    This post is provided "AS-IS" with no warranties and confers no rights.

    --------------------
    >From: "Serdar Kalaycý" <>
    >Subject: Unable to start debugging
    >Date: Thu, 12 Aug 2004 18:27:12 +0300
    >Lines: 44
    >X-Priority: 3
    >X-MSMail-Priority: Normal
    >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    >Message-ID: <#>
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >NNTP-Posting-Host: 212.175.3.140
    >Path:

    cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    phx.gbl
    >Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:253914
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >Hi everybody,
    >
    >My problem seems a bit clichè but I could not work around.
    >
    >Well I read lots of MSDN papers and discussions, but my problem is a bit
    >different from them. When I tried to run the project in debug mode (by
    >hitting F5) it gives an error message
    >
    >"Error while trying to run project: Unable to start debugging on the web
    >server.
    >Click Help for more information"
    >
    >While surfing the net I saw lots of error messages like this but all of

    them
    >had an explanation with them like "Access is denied" or "The project is not
    >configured for debugging" and so on. Mine has no explanations...
    >
    >I went through lots of guidelines that say re-registering aspnet_isapi.dll,
    >running aspnet_regiis -i, checking server configuration whether it has
    >'Integrated Windows Authantication', creating the project with the name of
    >the server instead of the IP number and so on.
    >
    >I must also mention that I can attach the process manually without any
    >problems.
    >
    >The server is:
    >Win 2000 SP4 with IIS 5.0 and SQL 2000
    >Domain Controller
    >
    >The client is:
    >Win XP Professional
    >
    >Both has Framework 1.1 installed, and I also run Remote Debugging Setup

    from
    >VS.Net CD1 on the server. Just one thing to mention, it gave a warning

    while
    >installing Analyze Server concerning about it could not add the account to
    >the Debugger Users group, since it's a domain controller.
    >I log on using my domain account which is Administrator on client machine
    >and is in Domain Administrators and Debugger Users on the server.
    >
    >Hope someone can help.
    >
    >Thanks in advance
    >Serdar KALAYCI
    >
    >
    >
    Jim Cheshire [MSFT], Aug 12, 2004
    #2
    1. Advertising

  3. Hi Bengt,

    SP2 locks down your box. That's a very good thing . . . for the most part!
    It wreaks havoc for remote debugging because the firewall blocks DCOM
    communication, UDP ports, TCP ports, etc. You need to set up the firewall
    and open up the ports so that you can debug.

    Now before you say "typical Microsoft. How do I do that!?", here's an
    article that will walk you through it. (See, we DO think ahead!)

    http://msdn.microsoft.com/asp.net/using/understanding/security/default.aspx?
    pull=/library/en-us/dnwxp/html/xpsp2remotedebug.asp

    Jim Cheshire [MSFT]
    MCP+I, MCSE, MCSD, MCDBA
    Microsoft Developer Support


    This post is provided "AS-IS" with no warranties and confers no rights.


    --------------------
    >Thread-Topic: Unable to start debugging
    >thread-index: AcSAnif1rqcL0PHARUaHAnGDnE5bEg==
    >X-WBNR-Posting-Host: 213.238.211.15
    >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >References: <#>

    <>
    >Subject: RE: Unable to start debugging
    >Date: Thu, 12 Aug 2004 11:57:03 -0700
    >Lines: 99
    >Message-ID: <>
    >MIME-Version: 1.0
    >Content-Type: text/plain;
    > charset="Utf-8"
    >Content-Transfer-Encoding: 8bit
    >X-Newsreader: Microsoft CDO for Windows 2000
    >Content-Class: urn:content-classes:message
    >Importance: normal
    >Priority: normal
    >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:253973
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >Hi Jim
    >
    >Great to see someone from MS here.. :)
    >
    >Even if Serdars problem aren't XP SP2 we are a lot of developers right

    now,
    >including my self, having problem with remote debugging after the
    >installation of XP SP2. My problem is 'Access denied' when the debugger

    is
    >going to view the processes at the remote machine (a Win 2003 server).
    >
    >Do you have any info regarding the, very serious, issue? Can't do my work
    >right now...
    >
    >Regards
    >Bengt
    >
    >
    >
    >
    >"Jim Cheshire [MSFT]" wrote:
    >
    >> Hi Serdar,
    >>
    >> Are you running SP2 on your Windows XP machine by any chance?
    >>
    >> Jim Cheshire [MSFT]
    >> MCP+I, MCSE, MCSD, MCDBA
    >> Microsoft Developer Support
    >>
    >>
    >> This post is provided "AS-IS" with no warranties and confers no rights.
    >>
    >> --------------------
    >> >From: "Serdar Kalaycý" <>
    >> >Subject: Unable to start debugging
    >> >Date: Thu, 12 Aug 2004 18:27:12 +0300
    >> >Lines: 44
    >> >X-Priority: 3
    >> >X-MSMail-Priority: Normal
    >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    >> >Message-ID: <#>
    >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >NNTP-Posting-Host: 212.175.3.140
    >> >Path:

    >>

    cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    >> .phx.gbl
    >> >Xref: cpmsftngxa06.phx.gbl

    microsoft.public.dotnet.framework.aspnet:253914
    >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >
    >> >Hi everybody,
    >> >
    >> >My problem seems a bit clichè but I could not work around.
    >> >
    >> >Well I read lots of MSDN papers and discussions, but my problem is a bit
    >> >different from them. When I tried to run the project in debug mode (by
    >> >hitting F5) it gives an error message
    >> >
    >> >"Error while trying to run project: Unable to start debugging on the web
    >> >server.
    >> >Click Help for more information"
    >> >
    >> >While surfing the net I saw lots of error messages like this but all of

    >> them
    >> >had an explanation with them like "Access is denied" or "The project is

    not
    >> >configured for debugging" and so on. Mine has no explanations...
    >> >
    >> >I went through lots of guidelines that say re-registering

    aspnet_isapi.dll,
    >> >running aspnet_regiis -i, checking server configuration whether it has
    >> >'Integrated Windows Authantication', creating the project with the name

    of
    >> >the server instead of the IP number and so on.
    >> >
    >> >I must also mention that I can attach the process manually without any
    >> >problems.
    >> >
    >> >The server is:
    >> >Win 2000 SP4 with IIS 5.0 and SQL 2000
    >> >Domain Controller
    >> >
    >> >The client is:
    >> >Win XP Professional
    >> >
    >> >Both has Framework 1.1 installed, and I also run Remote Debugging Setup

    >> from
    >> >VS.Net CD1 on the server. Just one thing to mention, it gave a warning

    >> while
    >> >installing Analyze Server concerning about it could not add the account

    to
    >> >the Debugger Users group, since it's a domain controller.
    >> >I log on using my domain account which is Administrator on client

    machine
    >> >and is in Domain Administrators and Debugger Users on the server.
    >> >
    >> >Hope someone can help.
    >> >
    >> >Thanks in advance
    >> >Serdar KALAYCI
    >> >
    >> >
    >> >

    >>
    >>

    >
    Jim Cheshire [MSFT], Aug 12, 2004
    #3
  4. Hi Jim

    Thanks for your prompt reply.
    I have seen the article, even read it before I applied the service pack, so
    I don't think that is the issue since, I forgot to mention, I have disabled
    the ICF (Firewall).
    Text from the article:
    "If IFC is off, no firewall configuration is necessary."

    Other people, in other threads that also has the problem, have also disabled
    the ICF.

    I just I applied the SP1 for the 1.1 .Net framwork on the XP SP2 client but
    still the same problem. "Access is denied" when trying to show the processes
    on the remote server.

    My environment:
    Client: Windows XP SP2, Visual Studio 2003, 1.1 SP1 .Net framwork
    Server: Windows Server 2003

    Any other idées?

    Regards
    Bengt
    P.S. I think it's great that the box is locked down as default, no doubt
    about that D.S.

    "Jim Cheshire [MSFT]" wrote:

    > Hi Bengt,
    >
    > SP2 locks down your box. That's a very good thing . . . for the most part!
    > It wreaks havoc for remote debugging because the firewall blocks DCOM
    > communication, UDP ports, TCP ports, etc. You need to set up the firewall
    > and open up the ports so that you can debug.
    >
    > Now before you say "typical Microsoft. How do I do that!?", here's an
    > article that will walk you through it. (See, we DO think ahead!)
    >
    > http://msdn.microsoft.com/asp.net/using/understanding/security/default.aspx?
    > pull=/library/en-us/dnwxp/html/xpsp2remotedebug.asp
    >
    > Jim Cheshire [MSFT]
    > MCP+I, MCSE, MCSD, MCDBA
    > Microsoft Developer Support
    >
    >
    > This post is provided "AS-IS" with no warranties and confers no rights.
    >
    >
    > --------------------
    > >Thread-Topic: Unable to start debugging
    > >thread-index: AcSAnif1rqcL0PHARUaHAnGDnE5bEg==
    > >X-WBNR-Posting-Host: 213.238.211.15
    > >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    > >References: <#>

    > <>
    > >Subject: RE: Unable to start debugging
    > >Date: Thu, 12 Aug 2004 11:57:03 -0700
    > >Lines: 99
    > >Message-ID: <>
    > >MIME-Version: 1.0
    > >Content-Type: text/plain;
    > > charset="Utf-8"
    > >Content-Transfer-Encoding: 8bit
    > >X-Newsreader: Microsoft CDO for Windows 2000
    > >Content-Class: urn:content-classes:message
    > >Importance: normal
    > >Priority: normal
    > >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > >Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:253973
    > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >
    > >Hi Jim
    > >
    > >Great to see someone from MS here.. :)
    > >
    > >Even if Serdars problem aren't XP SP2 we are a lot of developers right

    > now,
    > >including my self, having problem with remote debugging after the
    > >installation of XP SP2. My problem is 'Access denied' when the debugger

    > is
    > >going to view the processes at the remote machine (a Win 2003 server).
    > >
    > >Do you have any info regarding the, very serious, issue? Can't do my work
    > >right now...
    > >
    > >Regards
    > >Bengt
    > >
    > >
    > >
    > >
    > >"Jim Cheshire [MSFT]" wrote:
    > >
    > >> Hi Serdar,
    > >>
    > >> Are you running SP2 on your Windows XP machine by any chance?
    > >>
    > >> Jim Cheshire [MSFT]
    > >> MCP+I, MCSE, MCSD, MCDBA
    > >> Microsoft Developer Support
    > >>
    > >>
    > >> This post is provided "AS-IS" with no warranties and confers no rights.
    > >>
    > >> --------------------
    > >> >From: "Serdar Kalaycý" <>
    > >> >Subject: Unable to start debugging
    > >> >Date: Thu, 12 Aug 2004 18:27:12 +0300
    > >> >Lines: 44
    > >> >X-Priority: 3
    > >> >X-MSMail-Priority: Normal
    > >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > >> >Message-ID: <#>
    > >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >NNTP-Posting-Host: 212.175.3.140
    > >> >Path:
    > >>

    > cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    > >> .phx.gbl
    > >> >Xref: cpmsftngxa06.phx.gbl

    > microsoft.public.dotnet.framework.aspnet:253914
    > >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >
    > >> >Hi everybody,
    > >> >
    > >> >My problem seems a bit clichè but I could not work around.
    > >> >
    > >> >Well I read lots of MSDN papers and discussions, but my problem is a bit
    > >> >different from them. When I tried to run the project in debug mode (by
    > >> >hitting F5) it gives an error message
    > >> >
    > >> >"Error while trying to run project: Unable to start debugging on the web
    > >> >server.
    > >> >Click Help for more information"
    > >> >
    > >> >While surfing the net I saw lots of error messages like this but all of
    > >> them
    > >> >had an explanation with them like "Access is denied" or "The project is

    > not
    > >> >configured for debugging" and so on. Mine has no explanations...
    > >> >
    > >> >I went through lots of guidelines that say re-registering

    > aspnet_isapi.dll,
    > >> >running aspnet_regiis -i, checking server configuration whether it has
    > >> >'Integrated Windows Authantication', creating the project with the name

    > of
    > >> >the server instead of the IP number and so on.
    > >> >
    > >> >I must also mention that I can attach the process manually without any
    > >> >problems.
    > >> >
    > >> >The server is:
    > >> >Win 2000 SP4 with IIS 5.0 and SQL 2000
    > >> >Domain Controller
    > >> >
    > >> >The client is:
    > >> >Win XP Professional
    > >> >
    > >> >Both has Framework 1.1 installed, and I also run Remote Debugging Setup
    > >> from
    > >> >VS.Net CD1 on the server. Just one thing to mention, it gave a warning
    > >> while
    > >> >installing Analyze Server concerning about it could not add the account

    > to
    > >> >the Debugger Users group, since it's a domain controller.
    > >> >I log on using my domain account which is Administrator on client

    > machine
    > >> >and is in Domain Administrators and Debugger Users on the server.
    > >> >
    > >> >Hope someone can help.
    > >> >
    > >> >Thanks in advance
    > >> >Serdar KALAYCI
    > >> >
    > >> >
    > >> >
    > >>
    > >>

    > >

    >
    >
    =?Utf-8?B?QmVuZ3QgSmF4?=, Aug 12, 2004
    #4
  5. I have XP SP1 installed and my ICF is disabled too...
    Serdar Kalaycý, Aug 13, 2004
    #5
  6. Serdar Kalaycý

    Sorin Sandu Guest

    Hi Jim
    "Great to see someone from MS here.. :)" too. Maybe you can solve our
    problem

    Exacly same problem like Bengt.
    Same configuration.
    ICF disable too.
    Applied you article too.
    What's wrong ?

    "Jim Cheshire [MSFT]" <> a scris în mesajul de
    ºtiri:...
    > Hi Bengt,
    >
    > SP2 locks down your box. That's a very good thing . . . for the most
    > part!
    > It wreaks havoc for remote debugging because the firewall blocks DCOM
    > communication, UDP ports, TCP ports, etc. You need to set up the firewall
    > and open up the ports so that you can debug.
    >
    > Now before you say "typical Microsoft. How do I do that!?", here's an
    > article that will walk you through it. (See, we DO think ahead!)
    >
    > http://msdn.microsoft.com/asp.net/using/understanding/security/default.aspx?
    > pull=/library/en-us/dnwxp/html/xpsp2remotedebug.asp
    >
    > Jim Cheshire [MSFT]
    > MCP+I, MCSE, MCSD, MCDBA
    > Microsoft Developer Support
    >
    >
    > This post is provided "AS-IS" with no warranties and confers no rights.
    >
    >
    > --------------------
    >>Thread-Topic: Unable to start debugging
    >>thread-index: AcSAnif1rqcL0PHARUaHAnGDnE5bEg==
    >>X-WBNR-Posting-Host: 213.238.211.15
    >>From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >>References: <#>

    > <>
    >>Subject: RE: Unable to start debugging
    >>Date: Thu, 12 Aug 2004 11:57:03 -0700
    >>Lines: 99
    >>Message-ID: <>
    >>MIME-Version: 1.0
    >>Content-Type: text/plain;
    >> charset="Utf-8"
    >>Content-Transfer-Encoding: 8bit
    >>X-Newsreader: Microsoft CDO for Windows 2000
    >>Content-Class: urn:content-classes:message
    >>Importance: normal
    >>Priority: normal
    >>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >>Newsgroups: microsoft.public.dotnet.framework.aspnet
    >>NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >>Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >>Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:253973
    >>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >>
    >>Hi Jim
    >>
    >>Great to see someone from MS here.. :)
    >>
    >>Even if Serdars problem aren't XP SP2 we are a lot of developers right

    > now,
    >>including my self, having problem with remote debugging after the
    >>installation of XP SP2. My problem is 'Access denied' when the debugger

    > is
    >>going to view the processes at the remote machine (a Win 2003 server).
    >>
    >>Do you have any info regarding the, very serious, issue? Can't do my work
    >>right now...
    >>
    >>Regards
    >>Bengt
    >>
    >>
    >>
    >>
    >>"Jim Cheshire [MSFT]" wrote:
    >>
    >>> Hi Serdar,
    >>>
    >>> Are you running SP2 on your Windows XP machine by any chance?
    >>>
    >>> Jim Cheshire [MSFT]
    >>> MCP+I, MCSE, MCSD, MCDBA
    >>> Microsoft Developer Support
    >>>
    >>>
    >>> This post is provided "AS-IS" with no warranties and confers no rights.
    >>>
    >>> --------------------
    >>> >From: "Serdar Kalaycý" <>
    >>> >Subject: Unable to start debugging
    >>> >Date: Thu, 12 Aug 2004 18:27:12 +0300
    >>> >Lines: 44
    >>> >X-Priority: 3
    >>> >X-MSMail-Priority: Normal
    >>> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    >>> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    >>> >Message-ID: <#>
    >>> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >>> >NNTP-Posting-Host: 212.175.3.140
    >>> >Path:
    >>>

    > cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    >>> .phx.gbl
    >>> >Xref: cpmsftngxa06.phx.gbl

    > microsoft.public.dotnet.framework.aspnet:253914
    >>> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >>> >
    >>> >Hi everybody,
    >>> >
    >>> >My problem seems a bit clichè but I could not work around.
    >>> >
    >>> >Well I read lots of MSDN papers and discussions, but my problem is a
    >>> >bit
    >>> >different from them. When I tried to run the project in debug mode (by
    >>> >hitting F5) it gives an error message
    >>> >
    >>> >"Error while trying to run project: Unable to start debugging on the
    >>> >web
    >>> >server.
    >>> >Click Help for more information"
    >>> >
    >>> >While surfing the net I saw lots of error messages like this but all of
    >>> them
    >>> >had an explanation with them like "Access is denied" or "The project is

    > not
    >>> >configured for debugging" and so on. Mine has no explanations...
    >>> >
    >>> >I went through lots of guidelines that say re-registering

    > aspnet_isapi.dll,
    >>> >running aspnet_regiis -i, checking server configuration whether it has
    >>> >'Integrated Windows Authantication', creating the project with the name

    > of
    >>> >the server instead of the IP number and so on.
    >>> >
    >>> >I must also mention that I can attach the process manually without any
    >>> >problems.
    >>> >
    >>> >The server is:
    >>> >Win 2000 SP4 with IIS 5.0 and SQL 2000
    >>> >Domain Controller
    >>> >
    >>> >The client is:
    >>> >Win XP Professional
    >>> >
    >>> >Both has Framework 1.1 installed, and I also run Remote Debugging Setup
    >>> from
    >>> >VS.Net CD1 on the server. Just one thing to mention, it gave a warning
    >>> while
    >>> >installing Analyze Server concerning about it could not add the account

    > to
    >>> >the Debugger Users group, since it's a domain controller.
    >>> >I log on using my domain account which is Administrator on client

    > machine
    >>> >and is in Domain Administrators and Debugger Users on the server.
    >>> >
    >>> >Hope someone can help.
    >>> >
    >>> >Thanks in advance
    >>> >Serdar KALAYCI
    >>> >
    >>> >
    >>> >
    >>>
    >>>

    >>

    >
    Sorin Sandu, Aug 13, 2004
    #6
  7. Serdar Kalaycý

    jagadeesh Guest

    Hi,
    IS your login is added debugger users group? .
    you need to be a member of debugger users group to debug a VS.Net project.
    Jagadeesh
    "Serdar Kalaycý" <> wrote in message
    news:%...
    > Hi everybody,
    >
    > My problem seems a bit clichè but I could not work around.
    >
    > Well I read lots of MSDN papers and discussions, but my problem is a bit
    > different from them. When I tried to run the project in debug mode (by
    > hitting F5) it gives an error message
    >
    > "Error while trying to run project: Unable to start debugging on the web
    > server.
    > Click Help for more information"
    >
    > While surfing the net I saw lots of error messages like this but all of
    > them
    > had an explanation with them like "Access is denied" or "The project is
    > not
    > configured for debugging" and so on. Mine has no explanations...
    >
    > I went through lots of guidelines that say re-registering
    > aspnet_isapi.dll,
    > running aspnet_regiis -i, checking server configuration whether it has
    > 'Integrated Windows Authantication', creating the project with the name of
    > the server instead of the IP number and so on.
    >
    > I must also mention that I can attach the process manually without any
    > problems.
    >
    > The server is:
    > Win 2000 SP4 with IIS 5.0 and SQL 2000
    > Domain Controller
    >
    > The client is:
    > Win XP Professional
    >
    > Both has Framework 1.1 installed, and I also run Remote Debugging Setup
    > from
    > VS.Net CD1 on the server. Just one thing to mention, it gave a warning
    > while
    > installing Analyze Server concerning about it could not add the account to
    > the Debugger Users group, since it's a domain controller.
    > I log on using my domain account which is Administrator on client machine
    > and is in Domain Administrators and Debugger Users on the server.
    >
    > Hope someone can help.
    >
    > Thanks in advance
    > Serdar KALAYCI
    >
    >
    jagadeesh, Aug 13, 2004
    #7
  8. As I said before the server is a domain controller at the same time, and my
    account is Domain Administrators and Debugger Users member.

    It cannot be something about authantication since I can attach the process
    manually. As far as I see, people with authantication problems cannot even
    see the server's processes.

    Serdar KALAYCI
    Serdar Kalaycý, Aug 13, 2004
    #8
  9. Hi Bengt,

    Are you an Administrator on the server? Is Windows Integrated
    authentication enabled?

    Jim Cheshire [MSFT]
    MCP+I, MCSE, MCSD, MCDBA
    Microsoft Developer Support


    This post is provided "AS-IS" with no warranties and confers no rights.


    --------------------
    >Thread-Topic: Unable to start debugging
    >thread-index: AcSAuu23A9j7wDUMTVKAVwndYW8Yjg==
    >X-WBNR-Posting-Host: 213.238.211.15
    >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >References: <#>

    <>
    <>
    <>
    >Subject: RE: Unable to start debugging
    >Date: Thu, 12 Aug 2004 15:23:01 -0700
    >Lines: 187
    >Message-ID: <>
    >MIME-Version: 1.0
    >Content-Type: text/plain;
    > charset="Utf-8"
    >Content-Transfer-Encoding: 8bit
    >X-Newsreader: Microsoft CDO for Windows 2000
    >Content-Class: urn:content-classes:message
    >Importance: normal
    >Priority: normal
    >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:254021
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >Hi Jim
    >
    >Thanks for your prompt reply.
    >I have seen the article, even read it before I applied the service pack,

    so
    >I don't think that is the issue since, I forgot to mention, I have

    disabled
    >the ICF (Firewall).
    >Text from the article:
    >"If IFC is off, no firewall configuration is necessary."
    >
    >Other people, in other threads that also has the problem, have also

    disabled
    >the ICF.
    >
    >I just I applied the SP1 for the 1.1 .Net framwork on the XP SP2 client

    but
    >still the same problem. "Access is denied" when trying to show the

    processes
    >on the remote server.
    >
    >My environment:
    >Client: Windows XP SP2, Visual Studio 2003, 1.1 SP1 .Net framwork
    >Server: Windows Server 2003
    >
    >Any other idées?
    >
    >Regards
    >Bengt
    >P.S. I think it's great that the box is locked down as default, no doubt
    >about that D.S.
    >
    >"Jim Cheshire [MSFT]" wrote:
    >
    >> Hi Bengt,
    >>
    >> SP2 locks down your box. That's a very good thing . . . for the most

    part!
    >> It wreaks havoc for remote debugging because the firewall blocks DCOM
    >> communication, UDP ports, TCP ports, etc. You need to set up the

    firewall
    >> and open up the ports so that you can debug.
    >>
    >> Now before you say "typical Microsoft. How do I do that!?", here's an
    >> article that will walk you through it. (See, we DO think ahead!)
    >>
    >>

    http://msdn.microsoft.com/asp.net/using/understanding/security/default.aspx?
    >> pull=/library/en-us/dnwxp/html/xpsp2remotedebug.asp
    >>
    >> Jim Cheshire [MSFT]
    >> MCP+I, MCSE, MCSD, MCDBA
    >> Microsoft Developer Support
    >>
    >>
    >> This post is provided "AS-IS" with no warranties and confers no rights.
    >>
    >>
    >> --------------------
    >> >Thread-Topic: Unable to start debugging
    >> >thread-index: AcSAnif1rqcL0PHARUaHAnGDnE5bEg==
    >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >> >References: <#>

    >> <>
    >> >Subject: RE: Unable to start debugging
    >> >Date: Thu, 12 Aug 2004 11:57:03 -0700
    >> >Lines: 99
    >> >Message-ID: <>
    >> >MIME-Version: 1.0
    >> >Content-Type: text/plain;
    >> > charset="Utf-8"
    >> >Content-Transfer-Encoding: 8bit
    >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >Content-Class: urn:content-classes:message
    >> >Importance: normal
    >> >Priority: normal
    >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >Xref: cpmsftngxa06.phx.gbl

    microsoft.public.dotnet.framework.aspnet:253973
    >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >
    >> >Hi Jim
    >> >
    >> >Great to see someone from MS here.. :)
    >> >
    >> >Even if Serdars problem aren't XP SP2 we are a lot of developers right

    >> now,
    >> >including my self, having problem with remote debugging after the
    >> >installation of XP SP2. My problem is 'Access denied' when the

    debugger
    >> is
    >> >going to view the processes at the remote machine (a Win 2003 server).
    >> >
    >> >Do you have any info regarding the, very serious, issue? Can't do my

    work
    >> >right now...
    >> >
    >> >Regards
    >> >Bengt
    >> >
    >> >
    >> >
    >> >
    >> >"Jim Cheshire [MSFT]" wrote:
    >> >
    >> >> Hi Serdar,
    >> >>
    >> >> Are you running SP2 on your Windows XP machine by any chance?
    >> >>
    >> >> Jim Cheshire [MSFT]
    >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> Microsoft Developer Support
    >> >>
    >> >>
    >> >> This post is provided "AS-IS" with no warranties and confers no

    rights.
    >> >>
    >> >> --------------------
    >> >> >From: "Serdar Kalaycý" <>
    >> >> >Subject: Unable to start debugging
    >> >> >Date: Thu, 12 Aug 2004 18:27:12 +0300
    >> >> >Lines: 44
    >> >> >X-Priority: 3
    >> >> >X-MSMail-Priority: Normal
    >> >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    >> >> >Message-ID: <#>
    >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >NNTP-Posting-Host: 212.175.3.140
    >> >> >Path:
    >> >>

    >>

    cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    >> >> .phx.gbl
    >> >> >Xref: cpmsftngxa06.phx.gbl

    >> microsoft.public.dotnet.framework.aspnet:253914
    >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >
    >> >> >Hi everybody,
    >> >> >
    >> >> >My problem seems a bit clichè but I could not work around.
    >> >> >
    >> >> >Well I read lots of MSDN papers and discussions, but my problem is a

    bit
    >> >> >different from them. When I tried to run the project in debug mode

    (by
    >> >> >hitting F5) it gives an error message
    >> >> >
    >> >> >"Error while trying to run project: Unable to start debugging on the

    web
    >> >> >server.
    >> >> >Click Help for more information"
    >> >> >
    >> >> >While surfing the net I saw lots of error messages like this but all

    of
    >> >> them
    >> >> >had an explanation with them like "Access is denied" or "The project

    is
    >> not
    >> >> >configured for debugging" and so on. Mine has no explanations...
    >> >> >
    >> >> >I went through lots of guidelines that say re-registering

    >> aspnet_isapi.dll,
    >> >> >running aspnet_regiis -i, checking server configuration whether it

    has
    >> >> >'Integrated Windows Authantication', creating the project with the

    name
    >> of
    >> >> >the server instead of the IP number and so on.
    >> >> >
    >> >> >I must also mention that I can attach the process manually without

    any
    >> >> >problems.
    >> >> >
    >> >> >The server is:
    >> >> >Win 2000 SP4 with IIS 5.0 and SQL 2000
    >> >> >Domain Controller
    >> >> >
    >> >> >The client is:
    >> >> >Win XP Professional
    >> >> >
    >> >> >Both has Framework 1.1 installed, and I also run Remote Debugging

    Setup
    >> >> from
    >> >> >VS.Net CD1 on the server. Just one thing to mention, it gave a

    warning
    >> >> while
    >> >> >installing Analyze Server concerning about it could not add the

    account
    >> to
    >> >> >the Debugger Users group, since it's a domain controller.
    >> >> >I log on using my domain account which is Administrator on client

    >> machine
    >> >> >and is in Domain Administrators and Debugger Users on the server.
    >> >> >
    >> >> >Hope someone can help.
    >> >> >
    >> >> >Thanks in advance
    >> >> >Serdar KALAYCI
    >> >> >
    >> >> >
    >> >> >
    >> >>
    >> >>
    >> >

    >>
    >>

    >
    Jim Cheshire [MSFT], Aug 13, 2004
    #9
  10. Hi again Jim

    I'm an Administrator on both machines and Windows Integrated authentication,
    it worked just fine before the upgrade.

    But actually I have get it up and running by doing this:
    1. Installed SP1 for 1.1 .Net framework (not sure if it's needed)
    2. Changed the settings for Component Services -> My Computer -> Properties
    -> COM Security -> Access Permissions -> Edit Limits...
    For ANONYMOUS LOGON I allowed Remote Access

    I believe I have opened a potential security hole, hopefully temporary, but
    at least I can debug.
    Same for my colleauge which also upgraded to SP2 today. Remote debugging
    didn't work but after performing these steps he got it working.

    Maybe someone more outthere could give the workaround a try and see if it
    works. Please post feedback if this get you up and running again.

    Regards
    Bengt

    "Jim Cheshire [MSFT]" wrote:

    > Hi Bengt,
    >
    > Are you an Administrator on the server? Is Windows Integrated
    > authentication enabled?
    >
    > Jim Cheshire [MSFT]
    > MCP+I, MCSE, MCSD, MCDBA
    > Microsoft Developer Support
    >
    >
    > This post is provided "AS-IS" with no warranties and confers no rights.
    >
    >
    > --------------------
    > >Thread-Topic: Unable to start debugging
    > >thread-index: AcSAuu23A9j7wDUMTVKAVwndYW8Yjg==
    > >X-WBNR-Posting-Host: 213.238.211.15
    > >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    > >References: <#>

    > <>
    > <>
    > <>
    > >Subject: RE: Unable to start debugging
    > >Date: Thu, 12 Aug 2004 15:23:01 -0700
    > >Lines: 187
    > >Message-ID: <>
    > >MIME-Version: 1.0
    > >Content-Type: text/plain;
    > > charset="Utf-8"
    > >Content-Transfer-Encoding: 8bit
    > >X-Newsreader: Microsoft CDO for Windows 2000
    > >Content-Class: urn:content-classes:message
    > >Importance: normal
    > >Priority: normal
    > >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > >Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:254021
    > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >
    > >Hi Jim
    > >
    > >Thanks for your prompt reply.
    > >I have seen the article, even read it before I applied the service pack,

    > so
    > >I don't think that is the issue since, I forgot to mention, I have

    > disabled
    > >the ICF (Firewall).
    > >Text from the article:
    > >"If IFC is off, no firewall configuration is necessary."
    > >
    > >Other people, in other threads that also has the problem, have also

    > disabled
    > >the ICF.
    > >
    > >I just I applied the SP1 for the 1.1 .Net framwork on the XP SP2 client

    > but
    > >still the same problem. "Access is denied" when trying to show the

    > processes
    > >on the remote server.
    > >
    > >My environment:
    > >Client: Windows XP SP2, Visual Studio 2003, 1.1 SP1 .Net framwork
    > >Server: Windows Server 2003
    > >
    > >Any other idées?
    > >
    > >Regards
    > >Bengt
    > >P.S. I think it's great that the box is locked down as default, no doubt
    > >about that D.S.
    > >
    > >"Jim Cheshire [MSFT]" wrote:
    > >
    > >> Hi Bengt,
    > >>
    > >> SP2 locks down your box. That's a very good thing . . . for the most

    > part!
    > >> It wreaks havoc for remote debugging because the firewall blocks DCOM
    > >> communication, UDP ports, TCP ports, etc. You need to set up the

    > firewall
    > >> and open up the ports so that you can debug.
    > >>
    > >> Now before you say "typical Microsoft. How do I do that!?", here's an
    > >> article that will walk you through it. (See, we DO think ahead!)
    > >>
    > >>

    > http://msdn.microsoft.com/asp.net/using/understanding/security/default.aspx?
    > >> pull=/library/en-us/dnwxp/html/xpsp2remotedebug.asp
    > >>
    > >> Jim Cheshire [MSFT]
    > >> MCP+I, MCSE, MCSD, MCDBA
    > >> Microsoft Developer Support
    > >>
    > >>
    > >> This post is provided "AS-IS" with no warranties and confers no rights.
    > >>
    > >>
    > >> --------------------
    > >> >Thread-Topic: Unable to start debugging
    > >> >thread-index: AcSAnif1rqcL0PHARUaHAnGDnE5bEg==
    > >> >X-WBNR-Posting-Host: 213.238.211.15
    > >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    > >> >References: <#>
    > >> <>
    > >> >Subject: RE: Unable to start debugging
    > >> >Date: Thu, 12 Aug 2004 11:57:03 -0700
    > >> >Lines: 99
    > >> >Message-ID: <>
    > >> >MIME-Version: 1.0
    > >> >Content-Type: text/plain;
    > >> > charset="Utf-8"
    > >> >Content-Transfer-Encoding: 8bit
    > >> >X-Newsreader: Microsoft CDO for Windows 2000
    > >> >Content-Class: urn:content-classes:message
    > >> >Importance: normal
    > >> >Priority: normal
    > >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > >> >Xref: cpmsftngxa06.phx.gbl

    > microsoft.public.dotnet.framework.aspnet:253973
    > >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >
    > >> >Hi Jim
    > >> >
    > >> >Great to see someone from MS here.. :)
    > >> >
    > >> >Even if Serdars problem aren't XP SP2 we are a lot of developers right
    > >> now,
    > >> >including my self, having problem with remote debugging after the
    > >> >installation of XP SP2. My problem is 'Access denied' when the

    > debugger
    > >> is
    > >> >going to view the processes at the remote machine (a Win 2003 server).
    > >> >
    > >> >Do you have any info regarding the, very serious, issue? Can't do my

    > work
    > >> >right now...
    > >> >
    > >> >Regards
    > >> >Bengt
    > >> >
    > >> >
    > >> >
    > >> >
    > >> >"Jim Cheshire [MSFT]" wrote:
    > >> >
    > >> >> Hi Serdar,
    > >> >>
    > >> >> Are you running SP2 on your Windows XP machine by any chance?
    > >> >>
    > >> >> Jim Cheshire [MSFT]
    > >> >> MCP+I, MCSE, MCSD, MCDBA
    > >> >> Microsoft Developer Support
    > >> >>
    > >> >>
    > >> >> This post is provided "AS-IS" with no warranties and confers no

    > rights.
    > >> >>
    > >> >> --------------------
    > >> >> >From: "Serdar Kalaycý" <>
    > >> >> >Subject: Unable to start debugging
    > >> >> >Date: Thu, 12 Aug 2004 18:27:12 +0300
    > >> >> >Lines: 44
    > >> >> >X-Priority: 3
    > >> >> >X-MSMail-Priority: Normal
    > >> >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > >> >> >Message-ID: <#>
    > >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >> >NNTP-Posting-Host: 212.175.3.140
    > >> >> >Path:
    > >> >>
    > >>

    > cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    > >> >> .phx.gbl
    > >> >> >Xref: cpmsftngxa06.phx.gbl
    > >> microsoft.public.dotnet.framework.aspnet:253914
    > >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >> >
    > >> >> >Hi everybody,
    > >> >> >
    > >> >> >My problem seems a bit clichè but I could not work around.
    > >> >> >
    > >> >> >Well I read lots of MSDN papers and discussions, but my problem is a

    > bit
    > >> >> >different from them. When I tried to run the project in debug mode

    > (by
    > >> >> >hitting F5) it gives an error message
    > >> >> >
    > >> >> >"Error while trying to run project: Unable to start debugging on the

    > web
    > >> >> >server.
    > >> >> >Click Help for more information"
    > >> >> >
    > >> >> >While surfing the net I saw lots of error messages like this but all

    > of
    > >> >> them
    > >> >> >had an explanation with them like "Access is denied" or "The project

    > is
    > >> not
    > >> >> >configured for debugging" and so on. Mine has no explanations...
    > >> >> >
    > >> >> >I went through lots of guidelines that say re-registering
    > >> aspnet_isapi.dll,
    > >> >> >running aspnet_regiis -i, checking server configuration whether it

    > has
    > >> >> >'Integrated Windows Authantication', creating the project with the

    > name
    > >> of
    > >> >> >the server instead of the IP number and so on.
    > >> >> >
    > >> >> >I must also mention that I can attach the process manually without

    > any
    > >> >> >problems.
    > >> >> >
    > >> >> >The server is:
    > >> >> >Win 2000 SP4 with IIS 5.0 and SQL 2000
    > >> >> >Domain Controller
    > >> >> >
    > >> >> >The client is:
    > >> >> >Win XP Professional
    > >> >> >
    > >> >> >Both has Framework 1.1 installed, and I also run Remote Debugging

    > Setup
    > >> >> from
    > >> >> >VS.Net CD1 on the server. Just one thing to mention, it gave a

    > warning
    > >> >> while
    > >> >> >installing Analyze Server concerning about it could not add the

    > account
    > >> to
    > >> >> >the Debugger Users group, since it's a domain controller.
    > >> >> >I log on using my domain account which is Administrator on client
    > >> machine
    > >> >> >and is in Domain Administrators and Debugger Users on the server.
    > >> >> >
    > >> >> >Hope someone can help.
    > >> >> >
    > >> >> >Thanks in advance
    > >> >> >Serdar KALAYCI
    > >> >> >
    > >> >> >
    > >> >> >
    > >> >>
    > >> >>
    > >> >
    > >>
    > >>

    > >

    >
    >
    =?Utf-8?B?QmVuZ3QgSmF4?=, Aug 13, 2004
    #10
  11. Hi,

    That is something that often has to be done. See this article:

    http://support.microsoft.com/?id=833977

    Jim Cheshire [MSFT]
    MCP+I, MCSE, MCSD, MCDBA
    Microsoft Developer Support


    This post is provided "AS-IS" with no warranties and confers no rights.

    --------------------
    >Thread-Topic: Unable to start debugging
    >thread-index: AcSBXLOFlzjcjZlhTcOmJLnQyCPCGw==
    >X-WBNR-Posting-Host: 213.238.211.15
    >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >References: <#>

    <>
    <>
    <>
    <>
    <>
    >Subject: RE: Unable to start debugging
    >Date: Fri, 13 Aug 2004 10:41:02 -0700
    >Lines: 279
    >Message-ID: <>
    >MIME-Version: 1.0
    >Content-Type: text/plain;
    > charset="Utf-8"
    >Content-Transfer-Encoding: 8bit
    >X-Newsreader: Microsoft CDO for Windows 2000
    >Content-Class: urn:content-classes:message
    >Importance: normal
    >Priority: normal
    >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:254227
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >Hi again Jim
    >
    >I'm an Administrator on both machines and Windows Integrated

    authentication,
    >it worked just fine before the upgrade.
    >
    >But actually I have get it up and running by doing this:
    >1. Installed SP1 for 1.1 .Net framework (not sure if it's needed)
    >2. Changed the settings for Component Services -> My Computer ->

    Properties
    >-> COM Security -> Access Permissions -> Edit Limits...
    >For ANONYMOUS LOGON I allowed Remote Access
    >
    >I believe I have opened a potential security hole, hopefully temporary,

    but
    >at least I can debug.
    >Same for my colleauge which also upgraded to SP2 today. Remote debugging
    >didn't work but after performing these steps he got it working.
    >
    >Maybe someone more outthere could give the workaround a try and see if it
    >works. Please post feedback if this get you up and running again.
    >
    >Regards
    >Bengt
    >
    >"Jim Cheshire [MSFT]" wrote:
    >
    >> Hi Bengt,
    >>
    >> Are you an Administrator on the server? Is Windows Integrated
    >> authentication enabled?
    >>
    >> Jim Cheshire [MSFT]
    >> MCP+I, MCSE, MCSD, MCDBA
    >> Microsoft Developer Support
    >>
    >>
    >> This post is provided "AS-IS" with no warranties and confers no rights.
    >>
    >>
    >> --------------------
    >> >Thread-Topic: Unable to start debugging
    >> >thread-index: AcSAuu23A9j7wDUMTVKAVwndYW8Yjg==
    >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >> >References: <#>

    >> <>
    >> <>
    >> <>
    >> >Subject: RE: Unable to start debugging
    >> >Date: Thu, 12 Aug 2004 15:23:01 -0700
    >> >Lines: 187
    >> >Message-ID: <>
    >> >MIME-Version: 1.0
    >> >Content-Type: text/plain;
    >> > charset="Utf-8"
    >> >Content-Transfer-Encoding: 8bit
    >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >Content-Class: urn:content-classes:message
    >> >Importance: normal
    >> >Priority: normal
    >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >Xref: cpmsftngxa06.phx.gbl

    microsoft.public.dotnet.framework.aspnet:254021
    >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >
    >> >Hi Jim
    >> >
    >> >Thanks for your prompt reply.
    >> >I have seen the article, even read it before I applied the service

    pack,
    >> so
    >> >I don't think that is the issue since, I forgot to mention, I have

    >> disabled
    >> >the ICF (Firewall).
    >> >Text from the article:
    >> >"If IFC is off, no firewall configuration is necessary."
    >> >
    >> >Other people, in other threads that also has the problem, have also

    >> disabled
    >> >the ICF.
    >> >
    >> >I just I applied the SP1 for the 1.1 .Net framwork on the XP SP2 client

    >> but
    >> >still the same problem. "Access is denied" when trying to show the

    >> processes
    >> >on the remote server.
    >> >
    >> >My environment:
    >> >Client: Windows XP SP2, Visual Studio 2003, 1.1 SP1 .Net framwork
    >> >Server: Windows Server 2003
    >> >
    >> >Any other idées?
    >> >
    >> >Regards
    >> >Bengt
    >> >P.S. I think it's great that the box is locked down as default, no

    doubt
    >> >about that D.S.
    >> >
    >> >"Jim Cheshire [MSFT]" wrote:
    >> >
    >> >> Hi Bengt,
    >> >>
    >> >> SP2 locks down your box. That's a very good thing . . . for the most

    >> part!
    >> >> It wreaks havoc for remote debugging because the firewall blocks

    DCOM
    >> >> communication, UDP ports, TCP ports, etc. You need to set up the

    >> firewall
    >> >> and open up the ports so that you can debug.
    >> >>
    >> >> Now before you say "typical Microsoft. How do I do that!?", here's

    an
    >> >> article that will walk you through it. (See, we DO think ahead!)
    >> >>
    >> >>

    >>

    http://msdn.microsoft.com/asp.net/using/understanding/security/default.aspx?
    >> >> pull=/library/en-us/dnwxp/html/xpsp2remotedebug.asp
    >> >>
    >> >> Jim Cheshire [MSFT]
    >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> Microsoft Developer Support
    >> >>
    >> >>
    >> >> This post is provided "AS-IS" with no warranties and confers no

    rights.
    >> >>
    >> >>
    >> >> --------------------
    >> >> >Thread-Topic: Unable to start debugging
    >> >> >thread-index: AcSAnif1rqcL0PHARUaHAnGDnE5bEg==
    >> >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >> >> >References: <#>
    >> >> <>
    >> >> >Subject: RE: Unable to start debugging
    >> >> >Date: Thu, 12 Aug 2004 11:57:03 -0700
    >> >> >Lines: 99
    >> >> >Message-ID: <>
    >> >> >MIME-Version: 1.0
    >> >> >Content-Type: text/plain;
    >> >> > charset="Utf-8"
    >> >> >Content-Transfer-Encoding: 8bit
    >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >> >Content-Class: urn:content-classes:message
    >> >> >Importance: normal
    >> >> >Priority: normal
    >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >> >Xref: cpmsftngxa06.phx.gbl

    >> microsoft.public.dotnet.framework.aspnet:253973
    >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >
    >> >> >Hi Jim
    >> >> >
    >> >> >Great to see someone from MS here.. :)
    >> >> >
    >> >> >Even if Serdars problem aren't XP SP2 we are a lot of developers

    right
    >> >> now,
    >> >> >including my self, having problem with remote debugging after the
    >> >> >installation of XP SP2. My problem is 'Access denied' when the

    >> debugger
    >> >> is
    >> >> >going to view the processes at the remote machine (a Win 2003

    server).
    >> >> >
    >> >> >Do you have any info regarding the, very serious, issue? Can't do my

    >> work
    >> >> >right now...
    >> >> >
    >> >> >Regards
    >> >> >Bengt
    >> >> >
    >> >> >
    >> >> >
    >> >> >
    >> >> >"Jim Cheshire [MSFT]" wrote:
    >> >> >
    >> >> >> Hi Serdar,
    >> >> >>
    >> >> >> Are you running SP2 on your Windows XP machine by any chance?
    >> >> >>
    >> >> >> Jim Cheshire [MSFT]
    >> >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> >> Microsoft Developer Support
    >> >> >>
    >> >> >>
    >> >> >> This post is provided "AS-IS" with no warranties and confers no

    >> rights.
    >> >> >>
    >> >> >> --------------------
    >> >> >> >From: "Serdar Kalaycý" <>
    >> >> >> >Subject: Unable to start debugging
    >> >> >> >Date: Thu, 12 Aug 2004 18:27:12 +0300
    >> >> >> >Lines: 44
    >> >> >> >X-Priority: 3
    >> >> >> >X-MSMail-Priority: Normal
    >> >> >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    >> >> >> >Message-ID: <#>
    >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >> >NNTP-Posting-Host: 212.175.3.140
    >> >> >> >Path:
    >> >> >>
    >> >>

    >>

    cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    >> >> >> .phx.gbl
    >> >> >> >Xref: cpmsftngxa06.phx.gbl
    >> >> microsoft.public.dotnet.framework.aspnet:253914
    >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >> >
    >> >> >> >Hi everybody,
    >> >> >> >
    >> >> >> >My problem seems a bit clichè but I could not work around.
    >> >> >> >
    >> >> >> >Well I read lots of MSDN papers and discussions, but my problem

    is a
    >> bit
    >> >> >> >different from them. When I tried to run the project in debug

    mode
    >> (by
    >> >> >> >hitting F5) it gives an error message
    >> >> >> >
    >> >> >> >"Error while trying to run project: Unable to start debugging on

    the
    >> web
    >> >> >> >server.
    >> >> >> >Click Help for more information"
    >> >> >> >
    >> >> >> >While surfing the net I saw lots of error messages like this but

    all
    >> of
    >> >> >> them
    >> >> >> >had an explanation with them like "Access is denied" or "The

    project
    >> is
    >> >> not
    >> >> >> >configured for debugging" and so on. Mine has no explanations...
    >> >> >> >
    >> >> >> >I went through lots of guidelines that say re-registering
    >> >> aspnet_isapi.dll,
    >> >> >> >running aspnet_regiis -i, checking server configuration whether

    it
    >> has
    >> >> >> >'Integrated Windows Authantication', creating the project with

    the
    >> name
    >> >> of
    >> >> >> >the server instead of the IP number and so on.
    >> >> >> >
    >> >> >> >I must also mention that I can attach the process manually

    without
    >> any
    >> >> >> >problems.
    >> >> >> >
    >> >> >> >The server is:
    >> >> >> >Win 2000 SP4 with IIS 5.0 and SQL 2000
    >> >> >> >Domain Controller
    >> >> >> >
    >> >> >> >The client is:
    >> >> >> >Win XP Professional
    >> >> >> >
    >> >> >> >Both has Framework 1.1 installed, and I also run Remote Debugging

    >> Setup
    >> >> >> from
    >> >> >> >VS.Net CD1 on the server. Just one thing to mention, it gave a

    >> warning
    >> >> >> while
    >> >> >> >installing Analyze Server concerning about it could not add the

    >> account
    >> >> to
    >> >> >> >the Debugger Users group, since it's a domain controller.
    >> >> >> >I log on using my domain account which is Administrator on client
    >> >> machine
    >> >> >> >and is in Domain Administrators and Debugger Users on the server.
    >> >> >> >
    >> >> >> >Hope someone can help.
    >> >> >> >
    >> >> >> >Thanks in advance
    >> >> >> >Serdar KALAYCI
    >> >> >> >
    >> >> >> >
    >> >> >> >
    >> >> >>
    >> >> >>
    >> >> >
    >> >>
    >> >>
    >> >

    >>
    >>

    >
    Jim Cheshire [MSFT], Aug 13, 2004
    #11
  12. Hi Bengt,

    If you look at the bottom of the article, it lists a workaround for VS.NET
    2002 (which also applies to VS.NET 2003.) It tells you to do exactly what
    you did to make this work. Hope that clears it up.

    Jim Cheshire [MSFT]
    MCP+I, MCSE, MCSD, MCDBA
    Microsoft Developer Support


    This post is provided "AS-IS" with no warranties and confers no rights.

    --------------------
    >Thread-Topic: Unable to start debugging
    >thread-index: AcSDvhEbeG5Ird3hRGyE6Tgl585HrA==
    >X-WBNR-Posting-Host: 213.238.211.15
    >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >References: <#>

    <>
    <>
    <>
    <>
    <>
    <>
    <>
    >Subject: RE: Unable to start debugging
    >Date: Mon, 16 Aug 2004 11:23:02 -0700
    >Lines: 382
    >Message-ID: <>
    >MIME-Version: 1.0
    >Content-Type: text/plain;
    > charset="Utf-8"
    >Content-Transfer-Encoding: 8bit
    >X-Newsreader: Microsoft CDO for Windows 2000
    >Content-Class: urn:content-classes:message
    >Importance: normal
    >Priority: normal
    >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:254559
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >Hello Jim
    >
    >I'm not sure that I agree that the content of article solves my problem.
    >This is for two reasons:
    >1. Configure the ICF is not a problem for me as I have disabled the ICF.
    >Text from article:
    >"If ICF is off, you may not have to configure a firewall."
    >
    >2. Configuring COM Security in the Component Services part is only

    relevant
    >if you are not an Administrator of the client or the server. I'm on both

    the
    >client and the server.
    >Text from article:
    >"If you run the debugger as a normal user (not as an Administrator), you
    >must give full access rights to the folder where the executables are
    >located." and
    >"In addition, if you are not an Administrator of the remote computer, you
    >must have access permissions and launch permissions."
    >
    >What I did to make it work was not to add myself as user, I had to allow
    >Remote Access for ANONYMOUS LOGON.
    >
    >One thing that could solve my issue could be that I haven't installed SP1
    >for .Net framework on the server since I do not have the distribution

    package
    >for Win 2003 Server only for XP.
    >
    >I also received a mail today from MS regarding Biztalk 2004 and XP SP2.
    >http://support.microsoft.com/default.aspx?scid=kb;en-us;841893
    >I think the problem with remote debugging is very similar to the Biztalk
    >problem. This explains the change of the RPC behaviour in SP2 and why it

    work
    >with ANONYMOUS LOGN, this was the default before SP2.
    >
    >Regards
    >Bengt
    >
    >"Jim Cheshire [MSFT]" wrote:
    >
    >> Hi,
    >>
    >> That is something that often has to be done. See this article:
    >>
    >> http://support.microsoft.com/?id=833977
    >>
    >> Jim Cheshire [MSFT]
    >> MCP+I, MCSE, MCSD, MCDBA
    >> Microsoft Developer Support
    >>
    >>
    >> This post is provided "AS-IS" with no warranties and confers no rights.
    >>
    >> --------------------
    >> >Thread-Topic: Unable to start debugging
    >> >thread-index: AcSBXLOFlzjcjZlhTcOmJLnQyCPCGw==
    >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >> >References: <#>

    >> <>
    >> <>
    >> <>
    >> <>
    >> <>
    >> >Subject: RE: Unable to start debugging
    >> >Date: Fri, 13 Aug 2004 10:41:02 -0700
    >> >Lines: 279
    >> >Message-ID: <>
    >> >MIME-Version: 1.0
    >> >Content-Type: text/plain;
    >> > charset="Utf-8"
    >> >Content-Transfer-Encoding: 8bit
    >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >Content-Class: urn:content-classes:message
    >> >Importance: normal
    >> >Priority: normal
    >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >Xref: cpmsftngxa06.phx.gbl

    microsoft.public.dotnet.framework.aspnet:254227
    >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >
    >> >Hi again Jim
    >> >
    >> >I'm an Administrator on both machines and Windows Integrated

    >> authentication,
    >> >it worked just fine before the upgrade.
    >> >
    >> >But actually I have get it up and running by doing this:
    >> >1. Installed SP1 for 1.1 .Net framework (not sure if it's needed)
    >> >2. Changed the settings for Component Services -> My Computer ->

    >> Properties
    >> >-> COM Security -> Access Permissions -> Edit Limits...
    >> >For ANONYMOUS LOGON I allowed Remote Access
    >> >
    >> >I believe I have opened a potential security hole, hopefully temporary,

    >> but
    >> >at least I can debug.
    >> >Same for my colleauge which also upgraded to SP2 today. Remote

    debugging
    >> >didn't work but after performing these steps he got it working.
    >> >
    >> >Maybe someone more outthere could give the workaround a try and see if

    it
    >> >works. Please post feedback if this get you up and running again.
    >> >
    >> >Regards
    >> >Bengt
    >> >
    >> >"Jim Cheshire [MSFT]" wrote:
    >> >
    >> >> Hi Bengt,
    >> >>
    >> >> Are you an Administrator on the server? Is Windows Integrated
    >> >> authentication enabled?
    >> >>
    >> >> Jim Cheshire [MSFT]
    >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> Microsoft Developer Support
    >> >>
    >> >>
    >> >> This post is provided "AS-IS" with no warranties and confers no

    rights.
    >> >>
    >> >>
    >> >> --------------------
    >> >> >Thread-Topic: Unable to start debugging
    >> >> >thread-index: AcSAuu23A9j7wDUMTVKAVwndYW8Yjg==
    >> >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >> >> >References: <#>
    >> >> <>
    >> >> <>
    >> >> <>
    >> >> >Subject: RE: Unable to start debugging
    >> >> >Date: Thu, 12 Aug 2004 15:23:01 -0700
    >> >> >Lines: 187
    >> >> >Message-ID: <>
    >> >> >MIME-Version: 1.0
    >> >> >Content-Type: text/plain;
    >> >> > charset="Utf-8"
    >> >> >Content-Transfer-Encoding: 8bit
    >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >> >Content-Class: urn:content-classes:message
    >> >> >Importance: normal
    >> >> >Priority: normal
    >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >> >Xref: cpmsftngxa06.phx.gbl

    >> microsoft.public.dotnet.framework.aspnet:254021
    >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >
    >> >> >Hi Jim
    >> >> >
    >> >> >Thanks for your prompt reply.
    >> >> >I have seen the article, even read it before I applied the service

    >> pack,
    >> >> so
    >> >> >I don't think that is the issue since, I forgot to mention, I have
    >> >> disabled
    >> >> >the ICF (Firewall).
    >> >> >Text from the article:
    >> >> >"If IFC is off, no firewall configuration is necessary."
    >> >> >
    >> >> >Other people, in other threads that also has the problem, have also
    >> >> disabled
    >> >> >the ICF.
    >> >> >
    >> >> >I just I applied the SP1 for the 1.1 .Net framwork on the XP SP2

    client
    >> >> but
    >> >> >still the same problem. "Access is denied" when trying to show the
    >> >> processes
    >> >> >on the remote server.
    >> >> >
    >> >> >My environment:
    >> >> >Client: Windows XP SP2, Visual Studio 2003, 1.1 SP1 .Net framwork
    >> >> >Server: Windows Server 2003
    >> >> >
    >> >> >Any other idées?
    >> >> >
    >> >> >Regards
    >> >> >Bengt
    >> >> >P.S. I think it's great that the box is locked down as default, no

    >> doubt
    >> >> >about that D.S.
    >> >> >
    >> >> >"Jim Cheshire [MSFT]" wrote:
    >> >> >
    >> >> >> Hi Bengt,
    >> >> >>
    >> >> >> SP2 locks down your box. That's a very good thing . . . for the

    most
    >> >> part!
    >> >> >> It wreaks havoc for remote debugging because the firewall blocks

    >> DCOM
    >> >> >> communication, UDP ports, TCP ports, etc. You need to set up the
    >> >> firewall
    >> >> >> and open up the ports so that you can debug.
    >> >> >>
    >> >> >> Now before you say "typical Microsoft. How do I do that!?",

    here's
    >> an
    >> >> >> article that will walk you through it. (See, we DO think ahead!)
    >> >> >>
    >> >> >>
    >> >>

    >>

    http://msdn.microsoft.com/asp.net/using/understanding/security/default.aspx?
    >> >> >> pull=/library/en-us/dnwxp/html/xpsp2remotedebug.asp
    >> >> >>
    >> >> >> Jim Cheshire [MSFT]
    >> >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> >> Microsoft Developer Support
    >> >> >>
    >> >> >>
    >> >> >> This post is provided "AS-IS" with no warranties and confers no

    >> rights.
    >> >> >>
    >> >> >>
    >> >> >> --------------------
    >> >> >> >Thread-Topic: Unable to start debugging
    >> >> >> >thread-index: AcSAnif1rqcL0PHARUaHAnGDnE5bEg==
    >> >> >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt

    >
    >> >> >> >References: <#>
    >> >> >> <>
    >> >> >> >Subject: RE: Unable to start debugging
    >> >> >> >Date: Thu, 12 Aug 2004 11:57:03 -0700
    >> >> >> >Lines: 99
    >> >> >> >Message-ID: <>
    >> >> >> >MIME-Version: 1.0
    >> >> >> >Content-Type: text/plain;
    >> >> >> > charset="Utf-8"
    >> >> >> >Content-Transfer-Encoding: 8bit
    >> >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >> >> >Content-Class: urn:content-classes:message
    >> >> >> >Importance: normal
    >> >> >> >Priority: normal
    >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >> >> >Xref: cpmsftngxa06.phx.gbl
    >> >> microsoft.public.dotnet.framework.aspnet:253973
    >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >> >
    >> >> >> >Hi Jim
    >> >> >> >
    >> >> >> >Great to see someone from MS here.. :)
    >> >> >> >
    >> >> >> >Even if Serdars problem aren't XP SP2 we are a lot of developers

    >> right
    >> >> >> now,
    >> >> >> >including my self, having problem with remote debugging after the
    >> >> >> >installation of XP SP2. My problem is 'Access denied' when the
    >> >> debugger
    >> >> >> is
    >> >> >> >going to view the processes at the remote machine (a Win 2003

    >> server).
    >> >> >> >
    >> >> >> >Do you have any info regarding the, very serious, issue? Can't do

    my
    >> >> work
    >> >> >> >right now...
    >> >> >> >
    >> >> >> >Regards
    >> >> >> >Bengt
    >> >> >> >
    >> >> >> >
    >> >> >> >
    >> >> >> >
    >> >> >> >"Jim Cheshire [MSFT]" wrote:
    >> >> >> >
    >> >> >> >> Hi Serdar,
    >> >> >> >>
    >> >> >> >> Are you running SP2 on your Windows XP machine by any chance?
    >> >> >> >>
    >> >> >> >> Jim Cheshire [MSFT]
    >> >> >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> >> >> Microsoft Developer Support
    >> >> >> >>
    >> >> >> >>
    >> >> >> >> This post is provided "AS-IS" with no warranties and confers no
    >> >> rights.
    >> >> >> >>
    >> >> >> >> --------------------
    >> >> >> >> >From: "Serdar Kalaycý"

    <>
    >> >> >> >> >Subject: Unable to start debugging
    >> >> >> >> >Date: Thu, 12 Aug 2004 18:27:12 +0300
    >> >> >> >> >Lines: 44
    >> >> >> >> >X-Priority: 3
    >> >> >> >> >X-MSMail-Priority: Normal
    >> >> >> >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    >> >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    >> >> >> >> >Message-ID: <#>
    >> >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >> >> >NNTP-Posting-Host: 212.175.3.140
    >> >> >> >> >Path:
    >> >> >> >>
    >> >> >>
    >> >>

    >>

    cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    >> >> >> >> .phx.gbl
    >> >> >> >> >Xref: cpmsftngxa06.phx.gbl
    >> >> >> microsoft.public.dotnet.framework.aspnet:253914
    >> >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >> >> >
    >> >> >> >> >Hi everybody,
    >> >> >> >> >
    >> >> >> >> >My problem seems a bit clichè but I could not

    work around.
    >> >> >> >> >
    >> >> >> >> >Well I read lots of MSDN papers and discussions, but my

    problem
    >> is a
    >> >> bit
    >> >> >> >> >different from them. When I tried to run the project in debug

    >> mode
    >> >> (by
    >> >> >> >> >hitting F5) it gives an error message
    >> >> >> >> >
    >> >> >> >> >"Error while trying to run project: Unable to start debugging

    on
    >> the
    >> >> web
    >> >> >> >> >server.
    >> >> >> >> >Click Help for more information"
    >> >> >> >> >
    >> >> >> >> >While surfing the net I saw lots of error messages like this

    but
    >> all
    >> >> of
    >> >> >> >> them
    >> >> >> >> >had an explanation with them like "Access is denied" or "The

    >> project
    >> >> is
    >> >> >> not
    >> >> >> >> >configured for debugging" and so on. Mine has no

    explanations...
    >> >> >> >> >
    >> >> >> >> >I went through lots of guidelines that say re-registering
    >> >> >> aspnet_isapi.dll,
    >> >> >> >> >running aspnet_regiis -i, checking server configuration

    whether
    >> it
    >> >> has
    >> >> >> >> >'Integrated Windows Authantication', creating the project with

    >> the
    >> >> name
    >> >> >> of
    >> >> >> >> >the server instead of the IP number and so on.
    >> >> >> >> >
    >> >> >> >> >I must also mention that I can attach the process manually

    >> without
    >> >> any
    >> >> >> >> >problems.
    >> >> >> >> >
    >> >> >> >> >The server is:
    >> >> >> >> >Win 2000 SP4 with IIS 5.0 and SQL 2000
    >> >> >> >> >Domain Controller
    >> >> >> >> >
    >> >> >> >> >The client is:
    >> >> >> >> >Win XP Professional
    >> >> >> >> >
    >> >> >> >> >Both has Framework 1.1 installed, and I also run Remote

    Debugging
    >> >> Setup
    >> >> >> >> from
    >> >> >> >> >VS.Net CD1 on the server. Just one thing to mention, it gave a
    >> >> warning
    >> >> >> >> while
    >> >> >> >> >installing Analyze Server concerning about it could not add

    the
    >> >> account
    >> >> >> to
    >> >> >> >> >the Debugger Users group, since it's a domain controller.
    >> >> >> >> >I log on using my domain account which is Administrator on

    client
    >> >> >> machine
    >> >> >> >> >and is in Domain Administrators and Debugger Users on the

    server.
    >> >> >> >> >
    >> >> >> >> >Hope someone can help.
    >> >> >> >> >
    >> >> >> >> >Thanks in advance
    >> >> >> >> >Serdar KALAYCI
    >> >> >> >> >
    >> >> >> >> >
    >> >> >> >> >
    >> >> >> >>
    >> >> >> >>
    >> >> >> >
    >> >> >>
    >> >> >>
    >> >> >
    >> >>
    >> >>
    >> >

    >>
    >>

    >
    Jim Cheshire [MSFT], Aug 16, 2004
    #12
  13. Serdar Kalaycý

    thor2001 Guest

    No offense, but you really should indicate that it applies to VS.NET
    2003. That is not clear at all and is leading to a lot of confusion.
    I will reinstall SP2 (after many wasted hours) at some point in the
    future. Hopefully it will work.

    (Jim Cheshire [MSFT]) wrote in message news:<>...
    > Hi Bengt,
    >
    > If you look at the bottom of the article, it lists a workaround for VS.NET
    > 2002 (which also applies to VS.NET 2003.) It tells you to do exactly what
    > you did to make this work. Hope that clears it up.
    >
    > Jim Cheshire [MSFT]
    > MCP+I, MCSE, MCSD, MCDBA
    > Microsoft Developer Support
    >
    >
    > This post is provided "AS-IS" with no warranties and confers no rights.
    >
    > --------------------
    > >Thread-Topic: Unable to start debugging
    > >thread-index: AcSDvhEbeG5Ird3hRGyE6Tgl585HrA==
    > >X-WBNR-Posting-Host: 213.238.211.15
    > >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    > >References: <#>

    > <>
    > <>
    > <>
    > <>
    > <>
    > <>
    > <>
    > >Subject: RE: Unable to start debugging
    > >Date: Mon, 16 Aug 2004 11:23:02 -0700
    > >Lines: 382
    > >Message-ID: <>
    > >MIME-Version: 1.0
    > >Content-Type: text/plain;
    > > charset="Utf-8"
    > >Content-Transfer-Encoding: 8bit
    > >X-Newsreader: Microsoft CDO for Windows 2000
    > >Content-Class: urn:content-classes:message
    > >Importance: normal
    > >Priority: normal
    > >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > >Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:254559
    > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >
    > >Hello Jim
    > >
    > >I'm not sure that I agree that the content of article solves my problem.
    > >This is for two reasons:
    > >1. Configure the ICF is not a problem for me as I have disabled the ICF.
    > >Text from article:
    > >"If ICF is off, you may not have to configure a firewall."
    > >
    > >2. Configuring COM Security in the Component Services part is only

    > relevant
    > >if you are not an Administrator of the client or the server. I'm on both

    > the
    > >client and the server.
    > >Text from article:
    > >"If you run the debugger as a normal user (not as an Administrator), you
    > >must give full access rights to the folder where the executables are
    > >located." and
    > >"In addition, if you are not an Administrator of the remote computer, you
    > >must have access permissions and launch permissions."
    > >
    > >What I did to make it work was not to add myself as user, I had to allow
    > >Remote Access for ANONYMOUS LOGON.
    > >
    > >One thing that could solve my issue could be that I haven't installed SP1
    > >for .Net framework on the server since I do not have the distribution

    > package
    > >for Win 2003 Server only for XP.
    > >
    > >I also received a mail today from MS regarding Biztalk 2004 and XP SP2.
    > >http://support.microsoft.com/default.aspx?scid=kb;en-us;841893
    > >I think the problem with remote debugging is very similar to the Biztalk
    > >problem. This explains the change of the RPC behaviour in SP2 and why it

    > work
    > >with ANONYMOUS LOGN, this was the default before SP2.
    > >
    > >Regards
    > >Bengt
    > >
    > >"Jim Cheshire [MSFT]" wrote:
    > >
    > >> Hi,
    > >>
    > >> That is something that often has to be done. See this article:
    > >>
    > >> http://support.microsoft.com/?id=833977
    > >>
    > >> Jim Cheshire [MSFT]
    > >> MCP+I, MCSE, MCSD, MCDBA
    > >> Microsoft Developer Support
    > >>
    > >>
    > >> This post is provided "AS-IS" with no warranties and confers no rights.
    > >>
    > >> --------------------
    > >> >Thread-Topic: Unable to start debugging
    > >> >thread-index: AcSBXLOFlzjcjZlhTcOmJLnQyCPCGw==
    > >> >X-WBNR-Posting-Host: 213.238.211.15
    > >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    > >> >References: <#>
    > >> <>
    > >> <>
    > >> <>
    > >> <>
    > >> <>
    > >> >Subject: RE: Unable to start debugging
    > >> >Date: Fri, 13 Aug 2004 10:41:02 -0700
    > >> >Lines: 279
    > >> >Message-ID: <>
    > >> >MIME-Version: 1.0
    > >> >Content-Type: text/plain;
    > >> > charset="Utf-8"
    > >> >Content-Transfer-Encoding: 8bit
    > >> >X-Newsreader: Microsoft CDO for Windows 2000
    > >> >Content-Class: urn:content-classes:message
    > >> >Importance: normal
    > >> >Priority: normal
    > >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > >> >Xref: cpmsftngxa06.phx.gbl

    > microsoft.public.dotnet.framework.aspnet:254227
    > >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >
    > >> >Hi again Jim
    > >> >
    > >> >I'm an Administrator on both machines and Windows Integrated

    > authentication,
    > >> >it worked just fine before the upgrade.
    > >> >
    > >> >But actually I have get it up and running by doing this:
    > >> >1. Installed SP1 for 1.1 .Net framework (not sure if it's needed)
    > >> >2. Changed the settings for Component Services -> My Computer ->

    > Properties
    > >> >-> COM Security -> Access Permissions -> Edit Limits...
    > >> >For ANONYMOUS LOGON I allowed Remote Access
    > >> >
    > >> >I believe I have opened a potential security hole, hopefully temporary,

    > but
    > >> >at least I can debug.
    > >> >Same for my colleauge which also upgraded to SP2 today. Remote

    > debugging
    > >> >didn't work but after performing these steps he got it working.
    > >> >
    > >> >Maybe someone more outthere could give the workaround a try and see if

    > it
    > >> >works. Please post feedback if this get you up and running again.
    > >> >
    > >> >Regards
    > >> >Bengt
    > >> >
    > >> >"Jim Cheshire [MSFT]" wrote:
    > >> >
    > >> >> Hi Bengt,
    > >> >>
    > >> >> Are you an Administrator on the server? Is Windows Integrated
    > >> >> authentication enabled?
    > >> >>
    > >> >> Jim Cheshire [MSFT]
    > >> >> MCP+I, MCSE, MCSD, MCDBA
    > >> >> Microsoft Developer Support
    > >> >>
    > >> >>
    > >> >> This post is provided "AS-IS" with no warranties and confers no

    > rights.
    > >> >>
    > >> >>
    > >> >> --------------------
    > >> >> >Thread-Topic: Unable to start debugging
    > >> >> >thread-index: AcSAuu23A9j7wDUMTVKAVwndYW8Yjg==
    > >> >> >X-WBNR-Posting-Host: 213.238.211.15
    > >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    > >> >> >References: <#>
    > >> >> <>
    > >> >> <>
    > >> >> <>
    > >> >> >Subject: RE: Unable to start debugging
    > >> >> >Date: Thu, 12 Aug 2004 15:23:01 -0700
    > >> >> >Lines: 187
    > >> >> >Message-ID: <>
    > >> >> >MIME-Version: 1.0
    > >> >> >Content-Type: text/plain;
    > >> >> > charset="Utf-8"
    > >> >> >Content-Transfer-Encoding: 8bit
    > >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    > >> >> >Content-Class: urn:content-classes:message
    > >> >> >Importance: normal
    > >> >> >Priority: normal
    > >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > >> >> >Xref: cpmsftngxa06.phx.gbl

    > microsoft.public.dotnet.framework.aspnet:254021
    > >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >> >
    > >> >> >Hi Jim
    > >> >> >
    > >> >> >Thanks for your prompt reply.
    > >> >> >I have seen the article, even read it before I applied the service

    > pack,
    > so
    > >> >> >I don't think that is the issue since, I forgot to mention, I have

    > disabled
    > >> >> >the ICF (Firewall).
    > >> >> >Text from the article:
    > >> >> >"If IFC is off, no firewall configuration is necessary."
    > >> >> >
    > >> >> >Other people, in other threads that also has the problem, have also

    > disabled
    > >> >> >the ICF.
    > >> >> >
    > >> >> >I just I applied the SP1 for the 1.1 .Net framwork on the XP SP2

    > client
    > but
    > >> >> >still the same problem. "Access is denied" when trying to show the

    > processes
    > >> >> >on the remote server.
    > >> >> >
    > >> >> >My environment:
    > >> >> >Client: Windows XP SP2, Visual Studio 2003, 1.1 SP1 .Net framwork
    > >> >> >Server: Windows Server 2003
    > >> >> >
    > >> >> >Any other idÃ?Æ?Ã?©es?
    > >> >> >
    > >> >> >Regards
    > >> >> >Bengt
    > >> >> >P.S. I think it's great that the box is locked down as default, no

    > doubt
    > >> >> >about that D.S.
    > >> >> >
    > >> >> >"Jim Cheshire [MSFT]" wrote:
    > >> >> >
    > >> >> >> Hi Bengt,
    > >> >> >>
    > >> >> >> SP2 locks down your box. That's a very good thing . . . for the

    > most
    > part!
    > >> >> >> It wreaks havoc for remote debugging because the firewall blocks

    > DCOM
    > >> >> >> communication, UDP ports, TCP ports, etc. You need to set up the

    > firewall
    > >> >> >> and open up the ports so that you can debug.
    > >> >> >>
    > >> >> >> Now before you say "typical Microsoft. How do I do that!?",

    > here's
    > an
    > >> >> >> article that will walk you through it. (See, we DO think ahead!)
    > >> >> >>
    > >> >> >>
    > >> >>
    > >>

    > http://msdn.microsoft.com/asp.net/using/understanding/security/default.aspx?
    > >> >> >> pull=/library/en-us/dnwxp/html/xpsp2remotedebug.asp
    > >> >> >>
    > >> >> >> Jim Cheshire [MSFT]
    > >> >> >> MCP+I, MCSE, MCSD, MCDBA
    > >> >> >> Microsoft Developer Support
    > >> >> >>
    > >> >> >>
    > >> >> >> This post is provided "AS-IS" with no warranties and confers no

    > rights.
    > >> >> >>
    > >> >> >>
    > >> >> >> --------------------
    > >> >> >> >Thread-Topic: Unable to start debugging
    > >> >> >> >thread-index: AcSAnif1rqcL0PHARUaHAnGDnE5bEg==
    > >> >> >> >X-WBNR-Posting-Host: 213.238.211.15
    > >> >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt

    > >
    > >> >> >> >References: <#>

    > <>
    > >> >> >> >Subject: RE: Unable to start debugging
    > >> >> >> >Date: Thu, 12 Aug 2004 11:57:03 -0700
    > >> >> >> >Lines: 99
    > >> >> >> >Message-ID: <>
    > >> >> >> >MIME-Version: 1.0
    > >> >> >> >Content-Type: text/plain;
    > >> >> >> > charset="Utf-8"
    > >> >> >> >Content-Transfer-Encoding: 8bit
    > >> >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    > >> >> >> >Content-Class: urn:content-classes:message
    > >> >> >> >Importance: normal
    > >> >> >> >Priority: normal
    > >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > >> >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > >> >> >> >Xref: cpmsftngxa06.phx.gbl

    > microsoft.public.dotnet.framework.aspnet:253973
    > >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >> >> >
    > >> >> >> >Hi Jim
    > >> >> >> >
    > >> >> >> >Great to see someone from MS here.. :)
    > >> >> >> >
    > >> >> >> >Even if Serdars problem aren't XP SP2 we are a lot of developers

    > right
    > now,
    > >> >> >> >including my self, having problem with remote debugging after the
    > >> >> >> >installation of XP SP2. My problem is 'Access denied' when the

    > debugger
    > is
    > >> >> >> >going to view the processes at the remote machine (a Win 2003

    > server).
    > >> >> >> >
    > >> >> >> >Do you have any info regarding the, very serious, issue? Can't do

    > my
    > work
    > >> >> >> >right now...
    > >> >> >> >
    > >> >> >> >Regards
    > >> >> >> >Bengt
    > >> >> >> >
    > >> >> >> >
    > >> >> >> >
    > >> >> >> >
    > >> >> >> >"Jim Cheshire [MSFT]" wrote:
    > >> >> >> >
    > >> >> >> >> Hi Serdar,
    > >> >> >> >>
    > >> >> >> >> Are you running SP2 on your Windows XP machine by any chance?
    > >> >> >> >>
    > >> >> >> >> Jim Cheshire [MSFT]
    > >> >> >> >> MCP+I, MCSE, MCSD, MCDBA
    > >> >> >> >> Microsoft Developer Support
    > >> >> >> >>
    > >> >> >> >>
    > >> >> >> >> This post is provided "AS-IS" with no warranties and confers no

    > rights.
    > >> >> >> >>
    > >> >> >> >> --------------------
    > >> >> >> >> >From: "Serdar KalaycÃ?Æ?Ã?â??Ã?â??Ã?½"

    > <>
    > >> >> >> >> >Subject: Unable to start debugging
    > >> >> >> >> >Date: Thu, 12 Aug 2004 18:27:12 +0300
    > >> >> >> >> >Lines: 44
    > >> >> >> >> >X-Priority: 3
    > >> >> >> >> >X-MSMail-Priority: Normal
    > >> >> >> >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > >> >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > >> >> >> >> >Message-ID: <#>
    > >> >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >> >> >> >NNTP-Posting-Host: 212.175.3.140
    > >> >> >> >> >Path:
    > >> >> >> >>
    > >> >> >>
    > >> >>
    > >>

    > cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    > >> >> >> >> .phx.gbl
    > >> >> >> >> >Xref: cpmsftngxa06.phx.gbl

    > microsoft.public.dotnet.framework.aspnet:253914
    > >> >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >> >> >> >
    > >> >> >> >> >Hi everybody,
    > >> >> >> >> >
    > >> >> >> >> >My problem seems a bit clichÃ?Æ?Ã?â??Ã?â??Ã?¨ but I could not

    > work around.
    > >> >> >> >> >
    > >> >> >> >> >Well I read lots of MSDN papers and discussions, but my

    > problem
    > is a
    > bit
    > >> >> >> >> >different from them. When I tried to run the project in debug

    > mode
    > (by
    > >> >> >> >> >hitting F5) it gives an error message
    > >> >> >> >> >
    > >> >> >> >> >"Error while trying to run project: Unable to start debugging

    > on
    > the
    > web
    > >> >> >> >> >server.
    > >> >> >> >> >Click Help for more information"
    > >> >> >> >> >
    > >> >> >> >> >While surfing the net I saw lots of error messages like this

    > but
    > all
    > of
    > them
    > >> >> >> >> >had an explanation with them like "Access is denied" or "The

    > project
    > is
    > not
    > >> >> >> >> >configured for debugging" and so on. Mine has no

    > explanations...
    > >> >> >> >> >
    > >> >> >> >> >I went through lots of guidelines that say re-registering

    > aspnet_isapi.dll,
    > >> >> >> >> >running aspnet_regiis -i, checking server configuration

    > whether
    > it
    > has
    > >> >> >> >> >'Integrated Windows Authantication', creating the project with

    > the
    > name
    > of
    > >> >> >> >> >the server instead of the IP number and so on.
    > >> >> >> >> >
    > >> >> >> >> >I must also mention that I can attach the process manually

    > without
    > any
    > >> >> >> >> >problems.
    > >> >> >> >> >
    > >> >> >> >> >The server is:
    > >> >> >> >> >Win 2000 SP4 with IIS 5.0 and SQL 2000
    > >> >> >> >> >Domain Controller
    > >> >> >> >> >
    > >> >> >> >> >The client is:
    > >> >> >> >> >Win XP Professional
    > >> >> >> >> >
    > >> >> >> >> >Both has Framework 1.1 installed, and I also run Remote

    > Debugging
    > Setup
    > from
    > >> >> >> >> >VS.Net CD1 on the server. Just one thing to mention, it gave a

    > warning
    > while
    > >> >> >> >> >installing Analyze Server concerning about it could not add

    > the
    > account
    > to
    > >> >> >> >> >the Debugger Users group, since it's a domain controller.
    > >> >> >> >> >I log on using my domain account which is Administrator on

    > client
    > machine
    > >> >> >> >> >and is in Domain Administrators and Debugger Users on the

    > server.
    > >> >> >> >> >
    > >> >> >> >> >Hope someone can help.
    > >> >> >> >> >
    > >> >> >> >> >Thanks in advance
    > >> >> >> >> >Serdar KALAYCI
    > >> >> >> >> >
    > >> >> >> >> >
    > >> >> >> >> >
    > >> >> >> >>
    > >> >> >> >>
    > >> >> >> >
    > >> >> >>
    > >> >> >>
    > >> >> >
    > >> >>
    > >> >>
    > >> >
    > >>
    > >>

    > >
    thor2001, Aug 18, 2004
    #13
  14. Yeah, I'm not sure why they stated VS.NET 2002 only. I have submitted a
    change request for the article.

    Jim Cheshire [MSFT]
    MCP+I, MCSE, MCSD, MCDBA
    Microsoft Developer Support


    This post is provided "AS-IS" with no warranties and confers no rights.

    --------------------
    >Thread-Topic: Unable to start debugging
    >thread-index: AcSD2Swz9525t3xiRA+nZRyIdPg+Yw==
    >X-WBNR-Posting-Host: 213.238.211.15
    >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >References: <#>

    <>
    <>
    <>
    <>
    <>
    <>
    <>
    <>
    <>
    >Subject: RE: Unable to start debugging
    >Date: Mon, 16 Aug 2004 14:37:04 -0700
    >Lines: 471
    >Message-ID: <>
    >MIME-Version: 1.0
    >Content-Type: text/plain;
    > charset="Utf-8"
    >Content-Transfer-Encoding: 8bit
    >X-Newsreader: Microsoft CDO for Windows 2000
    >Content-Class: urn:content-classes:message
    >Importance: normal
    >Priority: normal
    >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:254608
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >Hi again Jim
    >
    >Sorry no excuse I didn’t see that...
    >Maybe the 2002 made me confused so I missed the section or I'm still in
    >vaccation mode...
    >
    >An idé maybe could be to highlight that section more since I think many
    >developers has disabled the ICF and are Admins on both client and

    server...
    >
    >Thanks for your time
    >Regards
    >Bengt
    >
    >"Jim Cheshire [MSFT]" wrote:
    >
    >> Hi Bengt,
    >>
    >> If you look at the bottom of the article, it lists a workaround for

    VS.NET
    >> 2002 (which also applies to VS.NET 2003.) It tells you to do exactly

    what
    >> you did to make this work. Hope that clears it up.
    >>
    >> Jim Cheshire [MSFT]
    >> MCP+I, MCSE, MCSD, MCDBA
    >> Microsoft Developer Support
    >>
    >>
    >> This post is provided "AS-IS" with no warranties and confers no rights.
    >>
    >> --------------------
    >> >Thread-Topic: Unable to start debugging
    >> >thread-index: AcSDvhEbeG5Ird3hRGyE6Tgl585HrA==
    >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >> >References: <#>

    >> <>
    >> <>
    >> <>
    >> <>
    >> <>
    >> <>
    >> <>
    >> >Subject: RE: Unable to start debugging
    >> >Date: Mon, 16 Aug 2004 11:23:02 -0700
    >> >Lines: 382
    >> >Message-ID: <>
    >> >MIME-Version: 1.0
    >> >Content-Type: text/plain;
    >> > charset="Utf-8"
    >> >Content-Transfer-Encoding: 8bit
    >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >Content-Class: urn:content-classes:message
    >> >Importance: normal
    >> >Priority: normal
    >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >Xref: cpmsftngxa06.phx.gbl

    microsoft.public.dotnet.framework.aspnet:254559
    >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >
    >> >Hello Jim
    >> >
    >> >I'm not sure that I agree that the content of article solves my

    problem.
    >> >This is for two reasons:
    >> >1. Configure the ICF is not a problem for me as I have disabled the ICF.
    >> >Text from article:
    >> >"If ICF is off, you may not have to configure a firewall."
    >> >
    >> >2. Configuring COM Security in the Component Services part is only

    >> relevant
    >> >if you are not an Administrator of the client or the server. I'm on

    both
    >> the
    >> >client and the server.
    >> >Text from article:
    >> >"If you run the debugger as a normal user (not as an Administrator),

    you
    >> >must give full access rights to the folder where the executables are
    >> >located." and
    >> >"In addition, if you are not an Administrator of the remote computer,

    you
    >> >must have access permissions and launch permissions."
    >> >
    >> >What I did to make it work was not to add myself as user, I had to

    allow
    >> >Remote Access for ANONYMOUS LOGON.
    >> >
    >> >One thing that could solve my issue could be that I haven't installed

    SP1
    >> >for .Net framework on the server since I do not have the distribution

    >> package
    >> >for Win 2003 Server only for XP.
    >> >
    >> >I also received a mail today from MS regarding Biztalk 2004 and XP SP2.
    >> >http://support.microsoft.com/default.aspx?scid=kb;en-us;841893
    >> >I think the problem with remote debugging is very similar to the

    Biztalk
    >> >problem. This explains the change of the RPC behaviour in SP2 and why

    it
    >> work
    >> >with ANONYMOUS LOGN, this was the default before SP2.
    >> >
    >> >Regards
    >> >Bengt
    >> >
    >> >"Jim Cheshire [MSFT]" wrote:
    >> >
    >> >> Hi,
    >> >>
    >> >> That is something that often has to be done. See this article:
    >> >>
    >> >> http://support.microsoft.com/?id=833977
    >> >>
    >> >> Jim Cheshire [MSFT]
    >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> Microsoft Developer Support
    >> >>
    >> >>
    >> >> This post is provided "AS-IS" with no warranties and confers no

    rights.
    >> >>
    >> >> --------------------
    >> >> >Thread-Topic: Unable to start debugging
    >> >> >thread-index: AcSBXLOFlzjcjZlhTcOmJLnQyCPCGw==
    >> >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >> >> >References: <#>
    >> >> <>
    >> >> <>
    >> >> <>
    >> >> <>
    >> >> <>
    >> >> >Subject: RE: Unable to start debugging
    >> >> >Date: Fri, 13 Aug 2004 10:41:02 -0700
    >> >> >Lines: 279
    >> >> >Message-ID: <>
    >> >> >MIME-Version: 1.0
    >> >> >Content-Type: text/plain;
    >> >> > charset="Utf-8"
    >> >> >Content-Transfer-Encoding: 8bit
    >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >> >Content-Class: urn:content-classes:message
    >> >> >Importance: normal
    >> >> >Priority: normal
    >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >> >Xref: cpmsftngxa06.phx.gbl

    >> microsoft.public.dotnet.framework.aspnet:254227
    >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >
    >> >> >Hi again Jim
    >> >> >
    >> >> >I'm an Administrator on both machines and Windows Integrated
    >> >> authentication,
    >> >> >it worked just fine before the upgrade.
    >> >> >
    >> >> >But actually I have get it up and running by doing this:
    >> >> >1. Installed SP1 for 1.1 .Net framework (not sure if it's needed)
    >> >> >2. Changed the settings for Component Services -> My Computer ->
    >> >> Properties
    >> >> >-> COM Security -> Access Permissions -> Edit Limits...
    >> >> >For ANONYMOUS LOGON I allowed Remote Access
    >> >> >
    >> >> >I believe I have opened a potential security hole, hopefully

    temporary,
    >> >> but
    >> >> >at least I can debug.
    >> >> >Same for my colleauge which also upgraded to SP2 today. Remote

    >> debugging
    >> >> >didn't work but after performing these steps he got it working.
    >> >> >
    >> >> >Maybe someone more outthere could give the workaround a try and see

    if
    >> it
    >> >> >works. Please post feedback if this get you up and running again.
    >> >> >
    >> >> >Regards
    >> >> >Bengt
    >> >> >
    >> >> >"Jim Cheshire [MSFT]" wrote:
    >> >> >
    >> >> >> Hi Bengt,
    >> >> >>
    >> >> >> Are you an Administrator on the server? Is Windows Integrated
    >> >> >> authentication enabled?
    >> >> >>
    >> >> >> Jim Cheshire [MSFT]
    >> >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> >> Microsoft Developer Support
    >> >> >>
    >> >> >>
    >> >> >> This post is provided "AS-IS" with no warranties and confers no

    >> rights.
    >> >> >>
    >> >> >>
    >> >> >> --------------------
    >> >> >> >Thread-Topic: Unable to start debugging
    >> >> >> >thread-index: AcSAuu23A9j7wDUMTVKAVwndYW8Yjg==
    >> >> >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt

    >
    >> >> >> >References: <#>
    >> >> >> <>
    >> >> >> <>
    >> >> >> <>
    >> >> >> >Subject: RE: Unable to start debugging
    >> >> >> >Date: Thu, 12 Aug 2004 15:23:01 -0700
    >> >> >> >Lines: 187
    >> >> >> >Message-ID: <>
    >> >> >> >MIME-Version: 1.0
    >> >> >> >Content-Type: text/plain;
    >> >> >> > charset="Utf-8"
    >> >> >> >Content-Transfer-Encoding: 8bit
    >> >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >> >> >Content-Class: urn:content-classes:message
    >> >> >> >Importance: normal
    >> >> >> >Priority: normal
    >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >> >> >Xref: cpmsftngxa06.phx.gbl
    >> >> microsoft.public.dotnet.framework.aspnet:254021
    >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >> >
    >> >> >> >Hi Jim
    >> >> >> >
    >> >> >> >Thanks for your prompt reply.
    >> >> >> >I have seen the article, even read it before I applied the

    service
    >> >> pack,
    >> >> >> so
    >> >> >> >I don't think that is the issue since, I forgot to mention, I

    have
    >> >> >> disabled
    >> >> >> >the ICF (Firewall).
    >> >> >> >Text from the article:
    >> >> >> >"If IFC is off, no firewall configuration is necessary."
    >> >> >> >
    >> >> >> >Other people, in other threads that also has the problem, have

    also
    >> >> >> disabled
    >> >> >> >the ICF.
    >> >> >> >
    >> >> >> >I just I applied the SP1 for the 1.1 .Net framwork on the XP SP2

    >> client
    >> >> >> but
    >> >> >> >still the same problem. "Access is denied" when trying to show

    the
    >> >> >> processes
    >> >> >> >on the remote server.
    >> >> >> >
    >> >> >> >My environment:
    >> >> >> >Client: Windows XP SP2, Visual Studio 2003, 1.1 SP1 .Net framwork
    >> >> >> >Server: Windows Server 2003
    >> >> >> >
    >> >> >> >Any other idées?
    >> >> >> >
    >> >> >> >Regards
    >> >> >> >Bengt
    >> >> >> >P.S. I think it's great that the box is locked down as default,

    no
    >> >> doubt
    >> >> >> >about that D.S.
    >> >> >> >
    >> >> >> >"Jim Cheshire [MSFT]" wrote:
    >> >> >> >
    >> >> >> >> Hi Bengt,
    >> >> >> >>
    >> >> >> >> SP2 locks down your box. That's a very good thing . . . for

    the
    >> most
    >> >> >> part!
    >> >> >> >> It wreaks havoc for remote debugging because the firewall

    blocks
    >> >> DCOM
    >> >> >> >> communication, UDP ports, TCP ports, etc. You need to set up

    the
    >> >> >> firewall
    >> >> >> >> and open up the ports so that you can debug.
    >> >> >> >>
    >> >> >> >> Now before you say "typical Microsoft. How do I do that!?",

    >> here's
    >> >> an
    >> >> >> >> article that will walk you through it. (See, we DO think

    ahead!)
    >> >> >> >>
    >> >> >> >>
    >> >> >>
    >> >>

    >>

    http://msdn.microsoft.com/asp.net/using/understanding/security/default.aspx?
    >> >> >> >> pull=/library/en-us/dnwxp/html/xpsp2remotedebug.asp
    >> >> >> >>
    >> >> >> >> Jim Cheshire [MSFT]
    >> >> >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> >> >> Microsoft Developer Support
    >> >> >> >>
    >> >> >> >>
    >> >> >> >> This post is provided "AS-IS" with no warranties and confers no
    >> >> rights.
    >> >> >> >>
    >> >> >> >>
    >> >> >> >> --------------------
    >> >> >> >> >Thread-Topic: Unable to start debugging
    >> >> >> >> >thread-index: AcSAnif1rqcL0PHARUaHAnGDnE5bEg==
    >> >> >> >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >> >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt

    >> >
    >> >> >> >> >References: <#>
    >> >> >> >> <>
    >> >> >> >> >Subject: RE: Unable to start debugging
    >> >> >> >> >Date: Thu, 12 Aug 2004 11:57:03 -0700
    >> >> >> >> >Lines: 99
    >> >> >> >> >Message-ID:

    <>
    >> >> >> >> >MIME-Version: 1.0
    >> >> >> >> >Content-Type: text/plain;
    >> >> >> >> > charset="Utf-8"
    >> >> >> >> >Content-Transfer-Encoding: 8bit
    >> >> >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >> >> >> >Content-Class: urn:content-classes:message
    >> >> >> >> >Importance: normal
    >> >> >> >> >Priority: normal
    >> >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >> >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >> >> >> >Xref: cpmsftngxa06.phx.gbl
    >> >> >> microsoft.public.dotnet.framework.aspnet:253973
    >> >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >> >> >
    >> >> >> >> >Hi Jim
    >> >> >> >> >
    >> >> >> >> >Great to see someone from MS here.. :)
    >> >> >> >> >
    >> >> >> >> >Even if Serdars problem aren't XP SP2 we are a lot of

    developers
    >> >> right
    >> >> >> >> now,
    >> >> >> >> >including my self, having problem with remote debugging after

    the
    >> >> >> >> >installation of XP SP2. My problem is 'Access denied' when

    the
    >> >> >> debugger
    >> >> >> >> is
    >> >> >> >> >going to view the processes at the remote machine (a Win 2003
    >> >> server).
    >> >> >> >> >
    >> >> >> >> >Do you have any info regarding the, very serious, issue? Can't

    do
    >> my
    >> >> >> work
    >> >> >> >> >right now...
    >> >> >> >> >
    >> >> >> >> >Regards
    >> >> >> >> >Bengt
    >> >> >> >> >
    >> >> >> >> >
    >> >> >> >> >
    >> >> >> >> >
    >> >> >> >> >"Jim Cheshire [MSFT]" wrote:
    >> >> >> >> >
    >> >> >> >> >> Hi Serdar,
    >> >> >> >> >>
    >> >> >> >> >> Are you running SP2 on your Windows XP machine by any chance?
    >> >> >> >> >>
    >> >> >> >> >> Jim Cheshire [MSFT]
    >> >> >> >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> >> >> >> Microsoft Developer Support
    >> >> >> >> >>
    >> >> >> >> >>
    >> >> >> >> >> This post is provided "AS-IS" with no warranties and confers

    no
    >> >> >> rights.
    >> >> >> >> >>
    >> >> >> >> >> --------------------
    >> >> >> >> >> >From: "Serdar KalaycÃÂÂÃ

    ‚½"
    >> <>
    >> >> >> >> >> >Subject: Unable to start debugging
    >> >> >> >> >> >Date: Thu, 12 Aug 2004 18:27:12 +0300
    >> >> >> >> >> >Lines: 44
    >> >> >> >> >> >X-Priority: 3
    >> >> >> >> >> >X-MSMail-Priority: Normal
    >> >> >> >> >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    >> >> >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    >> >> >> >> >> >Message-ID: <#>
    >> >> >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >> >> >> >NNTP-Posting-Host: 212.175.3.140
    >> >> >> >> >> >Path:
    >> >> >> >> >>
    >> >> >> >>
    >> >> >>
    >> >>

    >>

    cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    >> >> >> >> >> .phx.gbl
    >> >> >> >> >> >Xref: cpmsftngxa06.phx.gbl
    >> >> >> >> microsoft.public.dotnet.framework.aspnet:253914
    >> >> >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >> >> >> >
    >> >> >> >> >> >Hi everybody,
    >> >> >> >> >> >
    >> >> >> >> >> >My problem seems a bit clichÃÃâ€Å

    ¡Ãƒâ€šÃ‚¨ but I could not
    >> work around.
    >> >> >> >> >> >
    >> >> >> >> >> >Well I read lots of MSDN papers and discussions, but my

    >> problem
    >> >> is a
    >> >> >> bit
    >> >> >> >> >> >different from them. When I tried to run the project in

    debug
    >> >> mode
    >> >> >> (by
    >> >> >> >> >> >hitting F5) it gives an error message
    >> >> >> >> >> >
    >> >> >> >> >> >"Error while trying to run project: Unable to start

    debugging
    >> on
    >> >> the
    >> >> >> web
    >> >> >> >> >> >server.
    >> >> >> >> >> >Click Help for more information"
    >> >> >> >> >> >
    >> >> >> >> >> >While surfing the net I saw lots of error messages like

    this
    >> but
    >> >> all
    >> >> >> of
    >> >> >> >> >> them
    >> >> >> >> >> >had an explanation with them like "Access is denied" or

    "The
    >> >> project
    >> >> >> is
    >> >> >> >> not
    >> >> >> >> >> >configured for debugging" and so on. Mine has no

    >> explanations...
    >> >> >> >> >> >
    >> >> >> >> >> >I went through lots of guidelines that say re-registering
    >> >> >> >> aspnet_isapi.dll,
    >> >> >> >> >> >running aspnet_regiis -i, checking server configuration

    >> whether
    >> >> it
    >> >> >> has
    >> >> >> >> >> >'Integrated Windows Authantication', creating the project

    with
    >> >> the
    >> >> >> name
    >> >> >> >> of
    >> >> >> >> >> >the server instead of the IP number and so on.
    >> >> >> >> >> >
    >> >> >> >> >> >I must also mention that I can attach the process manually
    >> >> without
    >> >> >> any
    >> >> >> >> >> >problems.
    >> >> >> >> >> >
    >> >> >> >> >> >The server is:
    >> >> >> >> >> >Win 2000 SP4 with IIS 5.0 and SQL 2000
    >> >> >> >> >> >Domain Controller
    >> >> >> >> >> >
    >> >> >> >> >> >The client is:
    >> >> >> >> >> >Win XP Professional
    >> >> >> >> >> >
    >> >> >> >> >> >Both has Framework 1.1 installed, and I also run Remote

    >> Debugging
    >> >> >> Setup
    >> >> >> >> >> from
    >> >> >> >> >> >VS.Net CD1 on the server. Just one thing to mention, it

    gave a
    >> >> >> warning
    >> >> >> >> >> while
    >> >> >> >> >> >installing Analyze Server concerning about it could not add

    >> the
    >> >> >> account
    >> >> >> >> to
    >> >> >> >> >> >the Debugger Users group, since it's a domain controller.
    >> >> >> >> >> >I log on using my domain account which is Administrator on

    >> client
    >> >> >> >> machine
    >> >> >> >> >> >and is in Domain Administrators and Debugger Users on the

    >> server.
    >> >> >> >> >> >
    >> >> >> >> >> >Hope someone can help.
    >> >> >> >> >> >
    >> >> >> >> >> >Thanks in advance
    >> >> >> >> >> >Serdar KALAYCI
    >> >> >> >> >> >
    >> >> >> >> >> >
    >> >> >> >> >> >
    >> >> >> >> >>
    >> >> >> >> >>
    >> >> >> >> >
    >> >> >> >>
    >> >> >> >>
    >> >> >> >
    >> >> >>
    >> >> >>
    >> >> >
    >> >>
    >> >>
    >> >

    >>
    >>

    >
    Jim Cheshire [MSFT], Aug 19, 2004
    #14
  15. No offense taken. You are dead on. I have submitted a change request so
    that we can get that corrected.

    Thanks.

    Jim Cheshire [MSFT]
    MCP+I, MCSE, MCSD, MCDBA
    Microsoft Developer Support


    This post is provided "AS-IS" with no warranties and confers no rights.


    --------------------
    >From: (thor2001)
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >Subject: Re: Unable to start debugging
    >Date: 18 Aug 2004 13:12:56 -0700
    >Organization: http://groups.google.com
    >Lines: 460
    >Message-ID: <>
    >References: <#>

    <>
    <>
    <>
    <>
    <>
    <>
    <>
    <>
    <>
    >NNTP-Posting-Host: 67.176.120.6
    >Content-Type: text/plain; charset=ISO-8859-1
    >Content-Transfer-Encoding: 8bit
    >X-Trace: posting.google.com 1092860018 10257 127.0.0.1 (18 Aug 2004

    20:13:38 GMT)
    >X-Complaints-To:
    >NNTP-Posting-Date: Wed, 18 Aug 2004 20:13:38 +0000 (UTC)
    >Path:

    cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.sul.t-online.de!t-onlin
    e.de!news-spur1.maxwell.syr.edu!news.maxwell.syr.edu!postnews2.google.com!no
    t-for-mail
    >Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:255155
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >No offense, but you really should indicate that it applies to VS.NET
    >2003. That is not clear at all and is leading to a lot of confusion.
    > I will reinstall SP2 (after many wasted hours) at some point in the
    >future. Hopefully it will work.
    >
    > (Jim Cheshire [MSFT]) wrote in message

    news:<>...
    >> Hi Bengt,
    >>
    >> If you look at the bottom of the article, it lists a workaround for

    VS.NET
    >> 2002 (which also applies to VS.NET 2003.) It tells you to do exactly

    what
    >> you did to make this work. Hope that clears it up.
    >>
    >> Jim Cheshire [MSFT]
    >> MCP+I, MCSE, MCSD, MCDBA
    >> Microsoft Developer Support
    >>
    >>
    >> This post is provided "AS-IS" with no warranties and confers no rights.
    >>
    >> --------------------
    >> >Thread-Topic: Unable to start debugging
    >> >thread-index: AcSDvhEbeG5Ird3hRGyE6Tgl585HrA==
    >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >> >References: <#>

    >> <>
    >> <>
    >> <>
    >> <>
    >> <>
    >> <>
    >> <>
    >> >Subject: RE: Unable to start debugging
    >> >Date: Mon, 16 Aug 2004 11:23:02 -0700
    >> >Lines: 382
    >> >Message-ID: <>
    >> >MIME-Version: 1.0
    >> >Content-Type: text/plain;
    >> > charset="Utf-8"
    >> >Content-Transfer-Encoding: 8bit
    >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >Content-Class: urn:content-classes:message
    >> >Importance: normal
    >> >Priority: normal
    >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >Xref: cpmsftngxa06.phx.gbl

    microsoft.public.dotnet.framework.aspnet:254559
    >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >
    >> >Hello Jim
    >> >
    >> >I'm not sure that I agree that the content of article solves my

    problem.
    >> >This is for two reasons:
    >> >1. Configure the ICF is not a problem for me as I have disabled the ICF.
    >> >Text from article:
    >> >"If ICF is off, you may not have to configure a firewall."
    >> >
    >> >2. Configuring COM Security in the Component Services part is only

    >> relevant
    >> >if you are not an Administrator of the client or the server. I'm on

    both
    >> the
    >> >client and the server.
    >> >Text from article:
    >> >"If you run the debugger as a normal user (not as an Administrator),

    you
    >> >must give full access rights to the folder where the executables are
    >> >located." and
    >> >"In addition, if you are not an Administrator of the remote computer,

    you
    >> >must have access permissions and launch permissions."
    >> >
    >> >What I did to make it work was not to add myself as user, I had to

    allow
    >> >Remote Access for ANONYMOUS LOGON.
    >> >
    >> >One thing that could solve my issue could be that I haven't installed

    SP1
    >> >for .Net framework on the server since I do not have the distribution

    >> package
    >> >for Win 2003 Server only for XP.
    >> >
    >> >I also received a mail today from MS regarding Biztalk 2004 and XP SP2.
    >> >http://support.microsoft.com/default.aspx?scid=kb;en-us;841893
    >> >I think the problem with remote debugging is very similar to the

    Biztalk
    >> >problem. This explains the change of the RPC behaviour in SP2 and why

    it
    >> work
    >> >with ANONYMOUS LOGN, this was the default before SP2.
    >> >
    >> >Regards
    >> >Bengt
    >> >
    >> >"Jim Cheshire [MSFT]" wrote:
    >> >
    >> >> Hi,
    >> >>
    >> >> That is something that often has to be done. See this article:
    >> >>
    >> >> http://support.microsoft.com/?id=833977
    >> >>
    >> >> Jim Cheshire [MSFT]
    >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> Microsoft Developer Support
    >> >>
    >> >>
    >> >> This post is provided "AS-IS" with no warranties and confers no

    rights.
    >> >>
    >> >> --------------------
    >> >> >Thread-Topic: Unable to start debugging
    >> >> >thread-index: AcSBXLOFlzjcjZlhTcOmJLnQyCPCGw==
    >> >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    >> >> >References: <#>
    >> >> <>
    >> >> <>
    >> >> <>
    >> >> <>
    >> >> <>
    >> >> >Subject: RE: Unable to start debugging
    >> >> >Date: Fri, 13 Aug 2004 10:41:02 -0700
    >> >> >Lines: 279
    >> >> >Message-ID: <>
    >> >> >MIME-Version: 1.0
    >> >> >Content-Type: text/plain;
    >> >> > charset="Utf-8"
    >> >> >Content-Transfer-Encoding: 8bit
    >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >> >Content-Class: urn:content-classes:message
    >> >> >Importance: normal
    >> >> >Priority: normal
    >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >> >Xref: cpmsftngxa06.phx.gbl

    >> microsoft.public.dotnet.framework.aspnet:254227
    >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >
    >> >> >Hi again Jim
    >> >> >
    >> >> >I'm an Administrator on both machines and Windows Integrated

    >> authentication,
    >> >> >it worked just fine before the upgrade.
    >> >> >
    >> >> >But actually I have get it up and running by doing this:
    >> >> >1. Installed SP1 for 1.1 .Net framework (not sure if it's needed)
    >> >> >2. Changed the settings for Component Services -> My Computer ->

    >> Properties
    >> >> >-> COM Security -> Access Permissions -> Edit Limits...
    >> >> >For ANONYMOUS LOGON I allowed Remote Access
    >> >> >
    >> >> >I believe I have opened a potential security hole, hopefully

    temporary,
    >> but
    >> >> >at least I can debug.
    >> >> >Same for my colleauge which also upgraded to SP2 today. Remote

    >> debugging
    >> >> >didn't work but after performing these steps he got it working.
    >> >> >
    >> >> >Maybe someone more outthere could give the workaround a try and see

    if
    >> it
    >> >> >works. Please post feedback if this get you up and running again.
    >> >> >
    >> >> >Regards
    >> >> >Bengt
    >> >> >
    >> >> >"Jim Cheshire [MSFT]" wrote:
    >> >> >
    >> >> >> Hi Bengt,
    >> >> >>
    >> >> >> Are you an Administrator on the server? Is Windows Integrated
    >> >> >> authentication enabled?
    >> >> >>
    >> >> >> Jim Cheshire [MSFT]
    >> >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> >> Microsoft Developer Support
    >> >> >>
    >> >> >>
    >> >> >> This post is provided "AS-IS" with no warranties and confers no

    >> rights.
    >> >> >>
    >> >> >>
    >> >> >> --------------------
    >> >> >> >Thread-Topic: Unable to start debugging
    >> >> >> >thread-index: AcSAuu23A9j7wDUMTVKAVwndYW8Yjg==
    >> >> >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt

    >
    >> >> >> >References: <#>
    >> >> >> <>
    >> >> >> <>
    >> >> >> <>
    >> >> >> >Subject: RE: Unable to start debugging
    >> >> >> >Date: Thu, 12 Aug 2004 15:23:01 -0700
    >> >> >> >Lines: 187
    >> >> >> >Message-ID: <>
    >> >> >> >MIME-Version: 1.0
    >> >> >> >Content-Type: text/plain;
    >> >> >> > charset="Utf-8"
    >> >> >> >Content-Transfer-Encoding: 8bit
    >> >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >> >> >Content-Class: urn:content-classes:message
    >> >> >> >Importance: normal
    >> >> >> >Priority: normal
    >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >> >> >Xref: cpmsftngxa06.phx.gbl

    >> microsoft.public.dotnet.framework.aspnet:254021
    >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >> >
    >> >> >> >Hi Jim
    >> >> >> >
    >> >> >> >Thanks for your prompt reply.
    >> >> >> >I have seen the article, even read it before I applied the

    service
    >> pack,
    >> so
    >> >> >> >I don't think that is the issue since, I forgot to mention, I

    have
    >> disabled
    >> >> >> >the ICF (Firewall).
    >> >> >> >Text from the article:
    >> >> >> >"If IFC is off, no firewall configuration is necessary."
    >> >> >> >
    >> >> >> >Other people, in other threads that also has the problem, have

    also
    >> disabled
    >> >> >> >the ICF.
    >> >> >> >
    >> >> >> >I just I applied the SP1 for the 1.1 .Net framwork on the XP SP2

    >> client
    >> but
    >> >> >> >still the same problem. "Access is denied" when trying to show

    the
    >> processes
    >> >> >> >on the remote server.
    >> >> >> >
    >> >> >> >My environment:
    >> >> >> >Client: Windows XP SP2, Visual Studio 2003, 1.1 SP1 .Net framwork
    >> >> >> >Server: Windows Server 2003
    >> >> >> >
    >> >> >> >Any other idÃ?Æ?Ã?©es?
    >> >> >> >
    >> >> >> >Regards
    >> >> >> >Bengt
    >> >> >> >P.S. I think it's great that the box is locked down as default,

    no
    >> doubt
    >> >> >> >about that D.S.
    >> >> >> >
    >> >> >> >"Jim Cheshire [MSFT]" wrote:
    >> >> >> >
    >> >> >> >> Hi Bengt,
    >> >> >> >>
    >> >> >> >> SP2 locks down your box. That's a very good thing . . . for

    the
    >> most
    >> part!
    >> >> >> >> It wreaks havoc for remote debugging because the firewall

    blocks
    >> DCOM
    >> >> >> >> communication, UDP ports, TCP ports, etc. You need to set up

    the
    >> firewall
    >> >> >> >> and open up the ports so that you can debug.
    >> >> >> >>
    >> >> >> >> Now before you say "typical Microsoft. How do I do that!?",

    >> here's
    >> an
    >> >> >> >> article that will walk you through it. (See, we DO think

    ahead!)
    >> >> >> >>
    >> >> >> >>
    >> >> >>
    >> >>

    >>

    http://msdn.microsoft.com/asp.net/using/understanding/security/default.aspx?
    >> >> >> >> pull=/library/en-us/dnwxp/html/xpsp2remotedebug.asp
    >> >> >> >>
    >> >> >> >> Jim Cheshire [MSFT]
    >> >> >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> >> >> Microsoft Developer Support
    >> >> >> >>
    >> >> >> >>
    >> >> >> >> This post is provided "AS-IS" with no warranties and confers no

    >> rights.
    >> >> >> >>
    >> >> >> >>
    >> >> >> >> --------------------
    >> >> >> >> >Thread-Topic: Unable to start debugging
    >> >> >> >> >thread-index: AcSAnif1rqcL0PHARUaHAnGDnE5bEg==
    >> >> >> >> >X-WBNR-Posting-Host: 213.238.211.15
    >> >> >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt

    >> >
    >> >> >> >> >References: <#>

    >> <>
    >> >> >> >> >Subject: RE: Unable to start debugging
    >> >> >> >> >Date: Thu, 12 Aug 2004 11:57:03 -0700
    >> >> >> >> >Lines: 99
    >> >> >> >> >Message-ID:

    <>
    >> >> >> >> >MIME-Version: 1.0
    >> >> >> >> >Content-Type: text/plain;
    >> >> >> >> > charset="Utf-8"
    >> >> >> >> >Content-Transfer-Encoding: 8bit
    >> >> >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    >> >> >> >> >Content-Class: urn:content-classes:message
    >> >> >> >> >Importance: normal
    >> >> >> >> >Priority: normal
    >> >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    >> >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    >> >> >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    >> >> >> >> >Xref: cpmsftngxa06.phx.gbl

    >> microsoft.public.dotnet.framework.aspnet:253973
    >> >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >> >> >
    >> >> >> >> >Hi Jim
    >> >> >> >> >
    >> >> >> >> >Great to see someone from MS here.. :)
    >> >> >> >> >
    >> >> >> >> >Even if Serdars problem aren't XP SP2 we are a lot of

    developers
    >> right
    >> now,
    >> >> >> >> >including my self, having problem with remote debugging after

    the
    >> >> >> >> >installation of XP SP2. My problem is 'Access denied' when

    the
    >> debugger
    >> is
    >> >> >> >> >going to view the processes at the remote machine (a Win 2003

    >> server).
    >> >> >> >> >
    >> >> >> >> >Do you have any info regarding the, very serious, issue? Can't

    do
    >> my
    >> work
    >> >> >> >> >right now...
    >> >> >> >> >
    >> >> >> >> >Regards
    >> >> >> >> >Bengt
    >> >> >> >> >
    >> >> >> >> >
    >> >> >> >> >
    >> >> >> >> >
    >> >> >> >> >"Jim Cheshire [MSFT]" wrote:
    >> >> >> >> >
    >> >> >> >> >> Hi Serdar,
    >> >> >> >> >>
    >> >> >> >> >> Are you running SP2 on your Windows XP machine by any chance?
    >> >> >> >> >>
    >> >> >> >> >> Jim Cheshire [MSFT]
    >> >> >> >> >> MCP+I, MCSE, MCSD, MCDBA
    >> >> >> >> >> Microsoft Developer Support
    >> >> >> >> >>
    >> >> >> >> >>
    >> >> >> >> >> This post is provided "AS-IS" with no warranties and confers

    no
    >> rights.
    >> >> >> >> >>
    >> >> >> >> >> --------------------
    >> >> >> >> >> >From: "Serdar KalaycÃ?Æ?Ã?â??Ã?â??Ã?½"

    >> <>
    >> >> >> >> >> >Subject: Unable to start debugging
    >> >> >> >> >> >Date: Thu, 12 Aug 2004 18:27:12 +0300
    >> >> >> >> >> >Lines: 44
    >> >> >> >> >> >X-Priority: 3
    >> >> >> >> >> >X-MSMail-Priority: Normal
    >> >> >> >> >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    >> >> >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    >> >> >> >> >> >Message-ID: <#>
    >> >> >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >> >> >> >> >> >NNTP-Posting-Host: 212.175.3.140
    >> >> >> >> >> >Path:
    >> >> >> >> >>
    >> >> >> >>
    >> >> >>
    >> >>

    >>

    cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    >> >> >> >> >> .phx.gbl
    >> >> >> >> >> >Xref: cpmsftngxa06.phx.gbl

    >> microsoft.public.dotnet.framework.aspnet:253914
    >> >> >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >> >> >> >> >> >
    >> >> >> >> >> >Hi everybody,
    >> >> >> >> >> >
    >> >> >> >> >> >My problem seems a bit clichÃ?Æ?Ã?â??Ã?â??Ã?¨ but I could

    not
    >> work around.
    >> >> >> >> >> >
    >> >> >> >> >> >Well I read lots of MSDN papers and discussions, but my

    >> problem
    >> is a
    >> bit
    >> >> >> >> >> >different from them. When I tried to run the project in

    debug
    >> mode
    >> (by
    >> >> >> >> >> >hitting F5) it gives an error message
    >> >> >> >> >> >
    >> >> >> >> >> >"Error while trying to run project: Unable to start

    debugging
    >> on
    >> the
    >> web
    >> >> >> >> >> >server.
    >> >> >> >> >> >Click Help for more information"
    >> >> >> >> >> >
    >> >> >> >> >> >While surfing the net I saw lots of error messages like

    this
    >> but
    >> all
    >> of
    >> them
    >> >> >> >> >> >had an explanation with them like "Access is denied" or

    "The
    >> project
    >> is
    >> not
    >> >> >> >> >> >configured for debugging" and so on. Mine has no

    >> explanations...
    >> >> >> >> >> >
    >> >> >> >> >> >I went through lots of guidelines that say re-registering

    >> aspnet_isapi.dll,
    >> >> >> >> >> >running aspnet_regiis -i, checking server configuration

    >> whether
    >> it
    >> has
    >> >> >> >> >> >'Integrated Windows Authantication', creating the project

    with
    >> the
    >> name
    >> of
    >> >> >> >> >> >the server instead of the IP number and so on.
    >> >> >> >> >> >
    >> >> >> >> >> >I must also mention that I can attach the process manually

    >> without
    >> any
    >> >> >> >> >> >problems.
    >> >> >> >> >> >
    >> >> >> >> >> >The server is:
    >> >> >> >> >> >Win 2000 SP4 with IIS 5.0 and SQL 2000
    >> >> >> >> >> >Domain Controller
    >> >> >> >> >> >
    >> >> >> >> >> >The client is:
    >> >> >> >> >> >Win XP Professional
    >> >> >> >> >> >
    >> >> >> >> >> >Both has Framework 1.1 installed, and I also run Remote

    >> Debugging
    >> Setup
    >> from
    >> >> >> >> >> >VS.Net CD1 on the server. Just one thing to mention, it

    gave a
    >> warning
    >> while
    >> >> >> >> >> >installing Analyze Server concerning about it could not add

    >> the
    >> account
    >> to
    >> >> >> >> >> >the Debugger Users group, since it's a domain controller.
    >> >> >> >> >> >I log on using my domain account which is Administrator on

    >> client
    >> machine
    >> >> >> >> >> >and is in Domain Administrators and Debugger Users on the

    >> server.
    >> >> >> >> >> >
    >> >> >> >> >> >Hope someone can help.
    >> >> >> >> >> >
    >> >> >> >> >> >Thanks in advance
    >> >> >> >> >> >Serdar KALAYCI
    >> >> >> >> >> >
    >> >> >> >> >> >
    >> >> >> >> >> >
    >> >> >> >> >>
    >> >> >> >> >>
    >> >> >> >> >
    >> >> >> >>
    >> >> >> >>
    >> >> >> >
    >> >> >>
    >> >> >>
    >> >> >
    >> >>
    >> >>
    >> >

    >
    Jim Cheshire [MSFT], Aug 19, 2004
    #15
  16. Hi,

    I have a different kind of problem.

    I have installed windows xp service pack 2, but in firewall.cpl, I can only
    see three tabs General, Exceptions and Advanced. I can't see any other tabs.
    Am I missing something here.

    Another thing, I am not doing remote debugging, I am trying to do local
    dubugging which used work before win xp 2, now gives the error that we are
    discussing.

    Please help me.

    thank you

    Bhanu Prakash

    "Jim Cheshire [MSFT]" wrote:

    > No offense taken. You are dead on. I have submitted a change request so
    > that we can get that corrected.
    >
    > Thanks.
    >
    > Jim Cheshire [MSFT]
    > MCP+I, MCSE, MCSD, MCDBA
    > Microsoft Developer Support
    >
    >
    > This post is provided "AS-IS" with no warranties and confers no rights.
    >
    >
    > --------------------
    > >From: (thor2001)
    > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >Subject: Re: Unable to start debugging
    > >Date: 18 Aug 2004 13:12:56 -0700
    > >Organization: http://groups.google.com
    > >Lines: 460
    > >Message-ID: <>
    > >References: <#>

    > <>
    > <>
    > <>
    > <>
    > <>
    > <>
    > <>
    > <>
    > <>
    > >NNTP-Posting-Host: 67.176.120.6
    > >Content-Type: text/plain; charset=ISO-8859-1
    > >Content-Transfer-Encoding: 8bit
    > >X-Trace: posting.google.com 1092860018 10257 127.0.0.1 (18 Aug 2004

    > 20:13:38 GMT)
    > >X-Complaints-To:
    > >NNTP-Posting-Date: Wed, 18 Aug 2004 20:13:38 +0000 (UTC)
    > >Path:

    > cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.sul.t-online.de!t-onlin
    > e.de!news-spur1.maxwell.syr.edu!news.maxwell.syr.edu!postnews2.google.com!no
    > t-for-mail
    > >Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:255155
    > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >
    > >No offense, but you really should indicate that it applies to VS.NET
    > >2003. That is not clear at all and is leading to a lot of confusion.
    > > I will reinstall SP2 (after many wasted hours) at some point in the
    > >future. Hopefully it will work.
    > >
    > > (Jim Cheshire [MSFT]) wrote in message

    > news:<>...
    > >> Hi Bengt,
    > >>
    > >> If you look at the bottom of the article, it lists a workaround for

    > VS.NET
    > >> 2002 (which also applies to VS.NET 2003.) It tells you to do exactly

    > what
    > >> you did to make this work. Hope that clears it up.
    > >>
    > >> Jim Cheshire [MSFT]
    > >> MCP+I, MCSE, MCSD, MCDBA
    > >> Microsoft Developer Support
    > >>
    > >>
    > >> This post is provided "AS-IS" with no warranties and confers no rights.
    > >>
    > >> --------------------
    > >> >Thread-Topic: Unable to start debugging
    > >> >thread-index: AcSDvhEbeG5Ird3hRGyE6Tgl585HrA==
    > >> >X-WBNR-Posting-Host: 213.238.211.15
    > >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    > >> >References: <#>
    > >> <>
    > >> <>
    > >> <>
    > >> <>
    > >> <>
    > >> <>
    > >> <>
    > >> >Subject: RE: Unable to start debugging
    > >> >Date: Mon, 16 Aug 2004 11:23:02 -0700
    > >> >Lines: 382
    > >> >Message-ID: <>
    > >> >MIME-Version: 1.0
    > >> >Content-Type: text/plain;
    > >> > charset="Utf-8"
    > >> >Content-Transfer-Encoding: 8bit
    > >> >X-Newsreader: Microsoft CDO for Windows 2000
    > >> >Content-Class: urn:content-classes:message
    > >> >Importance: normal
    > >> >Priority: normal
    > >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > >> >Xref: cpmsftngxa06.phx.gbl

    > microsoft.public.dotnet.framework.aspnet:254559
    > >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >
    > >> >Hello Jim
    > >> >
    > >> >I'm not sure that I agree that the content of article solves my

    > problem.
    > >> >This is for two reasons:
    > >> >1. Configure the ICF is not a problem for me as I have disabled the ICF.
    > >> >Text from article:
    > >> >"If ICF is off, you may not have to configure a firewall."
    > >> >
    > >> >2. Configuring COM Security in the Component Services part is only
    > >> relevant
    > >> >if you are not an Administrator of the client or the server. I'm on

    > both
    > >> the
    > >> >client and the server.
    > >> >Text from article:
    > >> >"If you run the debugger as a normal user (not as an Administrator),

    > you
    > >> >must give full access rights to the folder where the executables are
    > >> >located." and
    > >> >"In addition, if you are not an Administrator of the remote computer,

    > you
    > >> >must have access permissions and launch permissions."
    > >> >
    > >> >What I did to make it work was not to add myself as user, I had to

    > allow
    > >> >Remote Access for ANONYMOUS LOGON.
    > >> >
    > >> >One thing that could solve my issue could be that I haven't installed

    > SP1
    > >> >for .Net framework on the server since I do not have the distribution
    > >> package
    > >> >for Win 2003 Server only for XP.
    > >> >
    > >> >I also received a mail today from MS regarding Biztalk 2004 and XP SP2.
    > >> >http://support.microsoft.com/default.aspx?scid=kb;en-us;841893
    > >> >I think the problem with remote debugging is very similar to the

    > Biztalk
    > >> >problem. This explains the change of the RPC behaviour in SP2 and why

    > it
    > >> work
    > >> >with ANONYMOUS LOGN, this was the default before SP2.
    > >> >
    > >> >Regards
    > >> >Bengt
    > >> >
    > >> >"Jim Cheshire [MSFT]" wrote:
    > >> >
    > >> >> Hi,
    > >> >>
    > >> >> That is something that often has to be done. See this article:
    > >> >>
    > >> >> http://support.microsoft.com/?id=833977
    > >> >>
    > >> >> Jim Cheshire [MSFT]
    > >> >> MCP+I, MCSE, MCSD, MCDBA
    > >> >> Microsoft Developer Support
    > >> >>
    > >> >>
    > >> >> This post is provided "AS-IS" with no warranties and confers no

    > rights.
    > >> >>
    > >> >> --------------------
    > >> >> >Thread-Topic: Unable to start debugging
    > >> >> >thread-index: AcSBXLOFlzjcjZlhTcOmJLnQyCPCGw==
    > >> >> >X-WBNR-Posting-Host: 213.238.211.15
    > >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    > >> >> >References: <#>
    > >> >> <>
    > >> >> <>
    > >> >> <>
    > >> >> <>
    > >> >> <>
    > >> >> >Subject: RE: Unable to start debugging
    > >> >> >Date: Fri, 13 Aug 2004 10:41:02 -0700
    > >> >> >Lines: 279
    > >> >> >Message-ID: <>
    > >> >> >MIME-Version: 1.0
    > >> >> >Content-Type: text/plain;
    > >> >> > charset="Utf-8"
    > >> >> >Content-Transfer-Encoding: 8bit
    > >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    > >> >> >Content-Class: urn:content-classes:message
    > >> >> >Importance: normal
    > >> >> >Priority: normal
    > >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > >> >> >Xref: cpmsftngxa06.phx.gbl
    > >> microsoft.public.dotnet.framework.aspnet:254227
    > >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >> >
    > >> >> >Hi again Jim
    > >> >> >
    > >> >> >I'm an Administrator on both machines and Windows Integrated
    > >> authentication,
    > >> >> >it worked just fine before the upgrade.
    > >> >> >
    > >> >> >But actually I have get it up and running by doing this:
    > >> >> >1. Installed SP1 for 1.1 .Net framework (not sure if it's needed)
    > >> >> >2. Changed the settings for Component Services -> My Computer ->
    > >> Properties
    > >> >> >-> COM Security -> Access Permissions -> Edit Limits...
    > >> >> >For ANONYMOUS LOGON I allowed Remote Access
    > >> >> >
    > >> >> >I believe I have opened a potential security hole, hopefully

    > temporary,
    > >> but
    > >> >> >at least I can debug.
    > >> >> >Same for my colleauge which also upgraded to SP2 today. Remote
    > >> debugging
    > >> >> >didn't work but after performing these steps he got it working.
    > >> >> >
    > >> >> >Maybe someone more outthere could give the workaround a try and see

    > if
    > >> it
    > >> >> >works. Please post feedback if this get you up and running again.
    > >> >> >
    > >> >> >Regards
    > >> >> >Bengt
    > >> >> >
    > >> >> >"Jim Cheshire [MSFT]" wrote:
    > >> >> >
    > >> >> >> Hi Bengt,
    > >> >> >>
    > >> >> >> Are you an Administrator on the server? Is Windows Integrated
    > >> >> >> authentication enabled?
    > >> >> >>
    > >> >> >> Jim Cheshire [MSFT]
    > >> >> >> MCP+I, MCSE, MCSD, MCDBA
    > >> >> >> Microsoft Developer Support
    > >> >> >>
    > >> >> >>
    > >> >> >> This post is provided "AS-IS" with no warranties and confers no
    > >> rights.
    > >> >> >>
    > >> >> >>
    > >> >> >> --------------------
    > >> >> >> >Thread-Topic: Unable to start debugging
    > >> >> >> >thread-index: AcSAuu23A9j7wDUMTVKAVwndYW8Yjg==
    > >> >> >> >X-WBNR-Posting-Host: 213.238.211.15
    > >> >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt

    > >
    > >> >> >> >References: <#>
    > >> >> >> <>
    > >> >> >> <>
    > >> >> >> <>
    > >> >> >> >Subject: RE: Unable to start debugging
    > >> >> >> >Date: Thu, 12 Aug 2004 15:23:01 -0700
    > >> >> >> >Lines: 187
    > >> >> >> >Message-ID: <>
    > >> >> >> >MIME-Version: 1.0
    > >> >> >> >Content-Type: text/plain;
    > >> >> >> > charset="Utf-8"
    > >> >> >> >Content-Transfer-Encoding: 8bit
    > >> >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    > >> >> >> >Content-Class: urn:content-classes:message
    > >> >> >> >Importance: normal
    > >> >> >> >Priority: normal
    > >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > >> >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > >> >> >> >Xref: cpmsftngxa06.phx.gbl
    > >> microsoft.public.dotnet.framework.aspnet:254021
    > >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >> >> >
    > >> >> >> >Hi Jim
    > >> >> >> >
    > >> >> >> >Thanks for your prompt reply.
    > >> >> >> >I have seen the article, even read it before I applied the

    > service
    > >> pack,
    > >> so
    > >> >> >> >I don't think that is the issue since, I forgot to mention, I

    > have
    > >> disabled
    > >> >> >> >the ICF (Firewall).
    > >> >> >> >Text from the article:
    > >> >> >> >"If IFC is off, no firewall configuration is necessary."
    > >> >> >> >
    > >> >> >> >Other people, in other threads that also has the problem, have

    > also
    > >> disabled
    > >> >> >> >the ICF.
    > >> >> >> >
    > >> >> >> >I just I applied the SP1 for the 1.1 .Net framwork on the XP SP2
    > >> client
    > >> but
    > >> >> >> >still the same problem. "Access is denied" when trying to show

    > the
    > >> processes
    > >> >> >> >on the remote server.
    > >> >> >> >
    > >> >> >> >My environment:
    > >> >> >> >Client: Windows XP SP2, Visual Studio 2003, 1.1 SP1 .Net framwork
    > >> >> >> >Server: Windows Server 2003
    > >> >> >> >
    > >> >> >> >Any other idÃ?Æ?Ã?©es?
    > >> >> >> >
    > >> >> >> >Regards
    > >> >> >> >Bengt
    > >> >> >> >P.S. I think it's great that the box is locked down as default,

    > no
    > >> doubt
    > >> >> >> >about that D.S.
    > >> >> >> >
    > >> >> >> >"Jim Cheshire [MSFT]" wrote:
    > >> >> >> >
    > >> >> >> >> Hi Bengt,
    > >> >> >> >>
    > >> >> >> >> SP2 locks down your box. That's a very good thing . . . for

    > the
    > >> most
    > >> part!
    > >> >> >> >> It wreaks havoc for remote debugging because the firewall

    > blocks
    > >> DCOM
    > >> >> >> >> communication, UDP ports, TCP ports, etc. You need to set up

    > the
    > >> firewall
    > >> >> >> >> and open up the ports so that you can debug.
    > >> >> >> >>
    > >> >> >> >> Now before you say "typical Microsoft. How do I do that!?",
    > >> here's
    > >> an
    > >> >> >> >> article that will walk you through it. (See, we DO think

    > ahead!)
    > >> >> >> >>
    > >> >> >> >>
    > >> >> >>
    > >> >>
    > >>

    > http://msdn.microsoft.com/asp.net/using/understanding/security/default.aspx?
    > >> >> >> >> pull=/library/en-us/dnwxp/html/xpsp2remotedebug.asp
    > >> >> >> >>
    > >> >> >> >> Jim Cheshire [MSFT]
    > >> >> >> >> MCP+I, MCSE, MCSD, MCDBA
    > >> >> >> >> Microsoft Developer Support
    > >> >> >> >>
    > >> >> >> >>
    > >> >> >> >> This post is provided "AS-IS" with no warranties and confers no
    > >> rights.
    > >> >> >> >>
    > >> >> >> >>
    > >> >> >> >> --------------------
    > >> >> >> >> >Thread-Topic: Unable to start debugging
    > >> >> >> >> >thread-index: AcSAnif1rqcL0PHARUaHAnGDnE5bEg==
    > >> >> >> >> >X-WBNR-Posting-Host: 213.238.211.15
    > >> >> >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt
    > >> >
    > >> >> >> >> >References: <#>
    > >> <>
    > >> >> >> >> >Subject: RE: Unable to start debugging
    > >> >> >> >> >Date: Thu, 12 Aug 2004 11:57:03 -0700
    > >> >> >> >> >Lines: 99
    > >> >> >> >> >Message-ID:

    > <>
    > >> >> >> >> >MIME-Version: 1.0
    > >> >> >> >> >Content-Type: text/plain;
    > >> >> >> >> > charset="Utf-8"
    > >> >> >> >> >Content-Transfer-Encoding: 8bit
    > >> >> >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    > >> >> >> >> >Content-Class: urn:content-classes:message
    > >> >> >> >> >Importance: normal
    > >> >> >> >> >Priority: normal
    > >> >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > >> >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >> >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > >> >> >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > >> >> >> >> >Xref: cpmsftngxa06.phx.gbl
    > >> microsoft.public.dotnet.framework.aspnet:253973
    > >> >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >> >> >> >
    > >> >> >> >> >Hi Jim
    > >> >> >> >> >
    > >> >> >> >> >Great to see someone from MS here.. :)
    > >> >> >> >> >
    > >> >> >> >> >Even if Serdars problem aren't XP SP2 we are a lot of

    > developers
    > >> right
    > >> now,
    > >> >> >> >> >including my self, having problem with remote debugging after

    > the
    > >> >> >> >> >installation of XP SP2. My problem is 'Access denied' when

    > the
    > >> debugger
    > >> is
    > >> >> >> >> >going to view the processes at the remote machine (a Win 2003
    > >> server).
    > >> >> >> >> >
    > >> >> >> >> >Do you have any info regarding the, very serious, issue? Can't

    > do
    > >> my
    > >> work
    > >> >> >> >> >right now...
    > >> >> >> >> >
    > >> >> >> >> >Regards
    > >> >> >> >> >Bengt
    > >> >> >> >> >
    > >> >> >> >> >
    > >> >> >> >> >
    > >> >> >> >> >
    > >> >> >> >> >"Jim Cheshire [MSFT]" wrote:
    > >> >> >> >> >
    > >> >> >> >> >> Hi Serdar,
    > >> >> >> >> >>
    > >> >> >> >> >> Are you running SP2 on your Windows XP machine by any chance?
    > >> >> >> >> >>
    > >> >> >> >> >> Jim Cheshire [MSFT]
    > >> >> >> >> >> MCP+I, MCSE, MCSD, MCDBA
    > >> >> >> >> >> Microsoft Developer Support
    > >> >> >> >> >>
    > >> >> >> >> >>
    > >> >> >> >> >> This post is provided "AS-IS" with no warranties and confers

    > no
    > >> rights.
    > >> >> >> >> >>
    > >> >> >> >> >> --------------------
    > >> >> >> >> >> >From: "Serdar KalaycÃ?Æ?Ã?â??Ã?â??Ã?½"
    > >> <>
    > >> >> >> >> >> >Subject: Unable to start debugging
    > >> >> >> >> >> >Date: Thu, 12 Aug 2004 18:27:12 +0300
    > >> >> >> >> >> >Lines: 44
    > >> >> >> >> >> >X-Priority: 3
    > >> >> >> >> >> >X-MSMail-Priority: Normal
    > >> >> >> >> >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > >> >> >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > >> >> >> >> >> >Message-ID: <#>
    > >> >> >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > >> >> >> >> >> >NNTP-Posting-Host: 212.175.3.140
    > >> >> >> >> >> >Path:
    > >> >> >> >> >>
    > >> >> >> >>
    > >> >> >>
    > >> >>
    > >>

    > cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    > >> >> >> >> >> .phx.gbl
    > >> >> >> >> >> >Xref: cpmsftngxa06.phx.gbl
    > >> microsoft.public.dotnet.framework.aspnet:253914
    > >> >> >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > >> >> >> >> >> >
    > >> >> >> >> >> >Hi everybody,
    > >> >> >> >> >> >
    > >> >> >> >> >> >My problem seems a bit clichÃ?Æ?Ã?â??Ã?â??Ã?¨ but I could

    > not
    > >> work around.
    > >> >> >> >> >> >
    > >> >> >> >> >> >Well I read lots of MSDN papers and discussions, but my
    > >> problem
    > >> is a
    > >> bit
    > >> >> >> >> >> >different from them. When I tried to run the project in

    > debug
    > >> mode
    > >> (by
    > >> >> >> >> >> >hitting F5) it gives an error message
    > >> >> >> >> >> >
    > >> >> >> >> >> >"Error while trying to run project: Unable to start

    > debugging
    > >> on
    > >> the
    > >> web
    > >> >> >> >> >> >server.
    > >> >> >> >> >> >Click Help for more information"
    > >> >> >> >> >> >
    > >> >> >> >> >> >While surfing the net I saw lots of error messages like

    > this
    > >> but
    > >> all
    > >> of
    > >> them
    > >> >> >> >> >> >had an explanation with them like "Access is denied" or

    > "The
    > >> project
    > >> is
    > >> not
    > >> >> >> >> >> >configured for debugging" and so on. Mine has no
    > >> explanations...
    > >> >> >> >> >> >
    > >> >> >> >> >> >I went through lots of guidelines that say re-registering
    > >> aspnet_isapi.dll,
    > >> >> >> >> >> >running aspnet_regiis -i, checking server configuration
    > >> whether
    > >> it
    > >> has
    > >> >> >> >> >> >'Integrated Windows Authantication', creating the project

    > with
    > >> the
    > >> name
    > >> of
    > >> >> >> >> >> >the server instead of the IP number and so on.
    > >> >> >> >> >> >
    > >> >> >> >> >> >I must also mention that I can attach the process manually
    > >> without
    > >> any
    > >> >> >> >> >> >problems.
    > >> >> >> >> >> >
    > >> >> >> >> >> >The server is:
    > >> >> >> >> >> >Win 2000 SP4 with IIS 5.0 and SQL 2000
    > >> >> >> >> >> >Domain Controller
    > >> >> >> >> >> >
    > >> >> >> >> >> >The client is:
    > >> >> >> >> >> >Win XP Professional
    > >> >> >> >> >> >
    > >> >> >> >> >> >Both has Framework 1.1 installed, and I also run Remote
    > >> Debugging
    > >> Setup
    > >> from
    > >> >> >> >> >> >VS.Net CD1 on the server. Just one thing to mention, it

    > gave a
    > >> warning
    > >> while
    > >> >> >> >> >> >installing Analyze Server concerning about it could not add
    > >> the
    > >> account
    > >> to
    > >> >> >> >> >> >the Debugger Users group, since it's a domain controller.
    > >> >> >> >> >> >I log on using my domain account which is Administrator on
    > >> client
    > >> machine
    > >> >> >> >> >> >and is in Domain Administrators and Debugger Users on the
    > >> server.
    > >> >> >> >> >> >
    > >> >> >> >> >> >Hope someone can help.
    > >> >> >> >> >> >
    > >> >> >> >> >> >Thanks in advance
    > >> >> >> >> >> >Serdar KALAYCI
    > >> >> >> >> >> >
    > >> >> >> >> >> >
    > >> >> >> >> >> >
    > >> >> >> >> >>
    > >> >> >> >> >>
    > >> >> >> >> >
    > >> >> >> >>
    > >> >> >> >>
    > >> >> >> >
    > >> >> >>
    > >> >> >>
    > >> >> >
    > >> >>
    > >> >>
    > >> >

    > >

    >
    >
    =?Utf-8?B?QmhhbnUgUHJha2FzaA==?=, Sep 28, 2004
    #16
  17. Bhani,

    Those are the only three tabs you should see.

    What URL are you using when opening the site? What exact error message are
    you seeing?

    Jim Cheshire [MSFT]
    MCP+I, MCSE, MCSD, MCDBA
    ASP.NET Developer Support


    This post is provided "AS-IS" with no warranties and confers no rights.


    --------------------
    | Thread-Topic: Unable to start debugging
    | thread-index: AcSlZhxxmqERKunzSyu0mkVNAlYnAQ==
    | X-WBNR-Posting-Host: 195.229.241.181
    | From: "=?Utf-8?B?QmhhbnUgUHJha2FzaA==?="
    <>
    | References: <#>
    <>
    <>
    <>
    <>
    <>
    <>
    <>
    <>
    <>
    <>
    <>
    | Subject: Re: Unable to start debugging
    | Date: Tue, 28 Sep 2004 07:19:05 -0700
    | Lines: 568
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 8bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    | Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:263980
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    |
    | Hi,
    |
    | I have a different kind of problem.
    |
    | I have installed windows xp service pack 2, but in firewall.cpl, I can
    only
    | see three tabs General, Exceptions and Advanced. I can't see any other
    tabs.
    | Am I missing something here.
    |
    | Another thing, I am not doing remote debugging, I am trying to do local
    | dubugging which used work before win xp 2, now gives the error that we
    are
    | discussing.
    |
    | Please help me.
    |
    | thank you
    |
    | Bhanu Prakash
    |
    | "Jim Cheshire [MSFT]" wrote:
    |
    | > No offense taken. You are dead on. I have submitted a change request
    so
    | > that we can get that corrected.
    | >
    | > Thanks.
    | >
    | > Jim Cheshire [MSFT]
    | > MCP+I, MCSE, MCSD, MCDBA
    | > Microsoft Developer Support
    | >
    | >
    | > This post is provided "AS-IS" with no warranties and confers no rights.
    | >
    | >
    | > --------------------
    | > >From: (thor2001)
    | > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > >Subject: Re: Unable to start debugging
    | > >Date: 18 Aug 2004 13:12:56 -0700
    | > >Organization: http://groups.google.com
    | > >Lines: 460
    | > >Message-ID: <>
    | > >References: <#>
    | > <>
    | > <>
    | > <>
    | > <>
    | > <>
    | > <>
    | > <>
    | > <>
    | > <>
    | > >NNTP-Posting-Host: 67.176.120.6
    | > >Content-Type: text/plain; charset=ISO-8859-1
    | > >Content-Transfer-Encoding: 8bit
    | > >X-Trace: posting.google.com 1092860018 10257 127.0.0.1 (18 Aug 2004
    | > 20:13:38 GMT)
    | > >X-Complaints-To:
    | > >NNTP-Posting-Date: Wed, 18 Aug 2004 20:13:38 +0000 (UTC)
    | > >Path:
    | >
    cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.sul.t-online.de!t-onlin
    | >
    e.de!news-spur1.maxwell.syr.edu!news.maxwell.syr.edu!postnews2.google.com!no
    | > t-for-mail
    | > >Xref: cpmsftngxa06.phx.gbl
    microsoft.public.dotnet.framework.aspnet:255155
    | > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > >
    | > >No offense, but you really should indicate that it applies to VS.NET
    | > >2003. That is not clear at all and is leading to a lot of confusion.
    | > > I will reinstall SP2 (after many wasted hours) at some point in the
    | > >future. Hopefully it will work.
    | > >
    | > > (Jim Cheshire [MSFT]) wrote in message
    | > news:<>...
    | > >> Hi Bengt,
    | > >>
    | > >> If you look at the bottom of the article, it lists a workaround for
    | > VS.NET
    | > >> 2002 (which also applies to VS.NET 2003.) It tells you to do
    exactly
    | > what
    | > >> you did to make this work. Hope that clears it up.
    | > >>
    | > >> Jim Cheshire [MSFT]
    | > >> MCP+I, MCSE, MCSD, MCDBA
    | > >> Microsoft Developer Support
    | > >>
    | > >>
    | > >> This post is provided "AS-IS" with no warranties and confers no
    rights.
    | > >>
    | > >> --------------------
    | > >> >Thread-Topic: Unable to start debugging
    | > >> >thread-index: AcSDvhEbeG5Ird3hRGyE6Tgl585HrA==
    | > >> >X-WBNR-Posting-Host: 213.238.211.15
    | > >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    | > >> >References: <#>
    | > >> <>
    | > >> <>
    | > >> <>
    | > >> <>
    | > >> <>
    | > >> <>
    | > >> <>
    | > >> >Subject: RE: Unable to start debugging
    | > >> >Date: Mon, 16 Aug 2004 11:23:02 -0700
    | > >> >Lines: 382
    | > >> >Message-ID: <>
    | > >> >MIME-Version: 1.0
    | > >> >Content-Type: text/plain;
    | > >> > charset="Utf-8"
    | > >> >Content-Transfer-Encoding: 8bit
    | > >> >X-Newsreader: Microsoft CDO for Windows 2000
    | > >> >Content-Class: urn:content-classes:message
    | > >> >Importance: normal
    | > >> >Priority: normal
    | > >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | > >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    | > >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | > >> >Xref: cpmsftngxa06.phx.gbl
    | > microsoft.public.dotnet.framework.aspnet:254559
    | > >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > >> >
    | > >> >Hello Jim
    | > >> >
    | > >> >I'm not sure that I agree that the content of article solves my
    | > problem.
    | > >> >This is for two reasons:
    | > >> >1. Configure the ICF is not a problem for me as I have disabled the
    ICF.
    | > >> >Text from article:
    | > >> >"If ICF is off, you may not have to configure a firewall."
    | > >> >
    | > >> >2. Configuring COM Security in the Component Services part is only
    | > >> relevant
    | > >> >if you are not an Administrator of the client or the server. I'm on
    | > both
    | > >> the
    | > >> >client and the server.
    | > >> >Text from article:
    | > >> >"If you run the debugger as a normal user (not as an
    Administrator),
    | > you
    | > >> >must give full access rights to the folder where the executables
    are
    | > >> >located." and
    | > >> >"In addition, if you are not an Administrator of the remote
    computer,
    | > you
    | > >> >must have access permissions and launch permissions."
    | > >> >
    | > >> >What I did to make it work was not to add myself as user, I had to
    | > allow
    | > >> >Remote Access for ANONYMOUS LOGON.
    | > >> >
    | > >> >One thing that could solve my issue could be that I haven't
    installed
    | > SP1
    | > >> >for .Net framework on the server since I do not have the
    distribution
    | > >> package
    | > >> >for Win 2003 Server only for XP.
    | > >> >
    | > >> >I also received a mail today from MS regarding Biztalk 2004 and XP
    SP2.
    | > >> >http://support.microsoft.com/default.aspx?scid=kb;en-us;841893
    | > >> >I think the problem with remote debugging is very similar to the
    | > Biztalk
    | > >> >problem. This explains the change of the RPC behaviour in SP2 and
    why
    | > it
    | > >> work
    | > >> >with ANONYMOUS LOGN, this was the default before SP2.
    | > >> >
    | > >> >Regards
    | > >> >Bengt
    | > >> >
    | > >> >"Jim Cheshire [MSFT]" wrote:
    | > >> >
    | > >> >> Hi,
    | > >> >>
    | > >> >> That is something that often has to be done. See this article:
    | > >> >>
    | > >> >> http://support.microsoft.com/?id=833977
    | > >> >>
    | > >> >> Jim Cheshire [MSFT]
    | > >> >> MCP+I, MCSE, MCSD, MCDBA
    | > >> >> Microsoft Developer Support
    | > >> >>
    | > >> >>
    | > >> >> This post is provided "AS-IS" with no warranties and confers no
    | > rights.
    | > >> >>
    | > >> >> --------------------
    | > >> >> >Thread-Topic: Unable to start debugging
    | > >> >> >thread-index: AcSBXLOFlzjcjZlhTcOmJLnQyCPCGw==
    | > >> >> >X-WBNR-Posting-Host: 213.238.211.15
    | > >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt
    >
    | > >> >> >References: <#>
    | > >> >> <>
    | > >> >> <>
    | > >> >> <>
    | > >> >> <>
    | > >> >> <>
    | > >> >> >Subject: RE: Unable to start debugging
    | > >> >> >Date: Fri, 13 Aug 2004 10:41:02 -0700
    | > >> >> >Lines: 279
    | > >> >> >Message-ID: <>
    | > >> >> >MIME-Version: 1.0
    | > >> >> >Content-Type: text/plain;
    | > >> >> > charset="Utf-8"
    | > >> >> >Content-Transfer-Encoding: 8bit
    | > >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    | > >> >> >Content-Class: urn:content-classes:message
    | > >> >> >Importance: normal
    | > >> >> >Priority: normal
    | > >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | > >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    | > >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | > >> >> >Xref: cpmsftngxa06.phx.gbl
    | > >> microsoft.public.dotnet.framework.aspnet:254227
    | > >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > >> >> >
    | > >> >> >Hi again Jim
    | > >> >> >
    | > >> >> >I'm an Administrator on both machines and Windows Integrated
    | > >> authentication,
    | > >> >> >it worked just fine before the upgrade.
    | > >> >> >
    | > >> >> >But actually I have get it up and running by doing this:
    | > >> >> >1. Installed SP1 for 1.1 .Net framework (not sure if it's needed)
    | > >> >> >2. Changed the settings for Component Services -> My Computer ->
    | > >> Properties
    | > >> >> >-> COM Security -> Access Permissions -> Edit Limits...
    | > >> >> >For ANONYMOUS LOGON I allowed Remote Access
    | > >> >> >
    | > >> >> >I believe I have opened a potential security hole, hopefully
    | > temporary,
    | > >> but
    | > >> >> >at least I can debug.
    | > >> >> >Same for my colleauge which also upgraded to SP2 today. Remote
    | > >> debugging
    | > >> >> >didn't work but after performing these steps he got it working.
    | > >> >> >
    | > >> >> >Maybe someone more outthere could give the workaround a try and
    see
    | > if
    | > >> it
    | > >> >> >works. Please post feedback if this get you up and running again.
    | > >> >> >
    | > >> >> >Regards
    | > >> >> >Bengt
    | > >> >> >
    | > >> >> >"Jim Cheshire [MSFT]" wrote:
    | > >> >> >
    | > >> >> >> Hi Bengt,
    | > >> >> >>
    | > >> >> >> Are you an Administrator on the server? Is Windows Integrated
    | > >> >> >> authentication enabled?
    | > >> >> >>
    | > >> >> >> Jim Cheshire [MSFT]
    | > >> >> >> MCP+I, MCSE, MCSD, MCDBA
    | > >> >> >> Microsoft Developer Support
    | > >> >> >>
    | > >> >> >>
    | > >> >> >> This post is provided "AS-IS" with no warranties and confers
    no
    | > >> rights.
    | > >> >> >>
    | > >> >> >>
    | > >> >> >> --------------------
    | > >> >> >> >Thread-Topic: Unable to start debugging
    | > >> >> >> >thread-index: AcSAuu23A9j7wDUMTVKAVwndYW8Yjg==
    | > >> >> >> >X-WBNR-Posting-Host: 213.238.211.15
    | > >> >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt
    | > >
    | > >> >> >> >References: <#>
    | > >> >> >> <>
    | > >> >> >> <>
    | > >> >> >> <>
    | > >> >> >> >Subject: RE: Unable to start debugging
    | > >> >> >> >Date: Thu, 12 Aug 2004 15:23:01 -0700
    | > >> >> >> >Lines: 187
    | > >> >> >> >Message-ID:
    <>
    | > >> >> >> >MIME-Version: 1.0
    | > >> >> >> >Content-Type: text/plain;
    | > >> >> >> > charset="Utf-8"
    | > >> >> >> >Content-Transfer-Encoding: 8bit
    | > >> >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    | > >> >> >> >Content-Class: urn:content-classes:message
    | > >> >> >> >Importance: normal
    | > >> >> >> >Priority: normal
    | > >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | > >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > >> >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    | > >> >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | > >> >> >> >Xref: cpmsftngxa06.phx.gbl
    | > >> microsoft.public.dotnet.framework.aspnet:254021
    | > >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > >> >> >> >
    | > >> >> >> >Hi Jim
    | > >> >> >> >
    | > >> >> >> >Thanks for your prompt reply.
    | > >> >> >> >I have seen the article, even read it before I applied the
    | > service
    | > >> pack,
    | > >> so
    | > >> >> >> >I don't think that is the issue since, I forgot to mention, I
    | > have
    | > >> disabled
    | > >> >> >> >the ICF (Firewall).
    | > >> >> >> >Text from the article:
    | > >> >> >> >"If IFC is off, no firewall configuration is necessary."
    | > >> >> >> >
    | > >> >> >> >Other people, in other threads that also has the problem,
    have
    | > also
    | > >> disabled
    | > >> >> >> >the ICF.
    | > >> >> >> >
    | > >> >> >> >I just I applied the SP1 for the 1.1 .Net framwork on the XP
    SP2
    | > >> client
    | > >> but
    | > >> >> >> >still the same problem. "Access is denied" when trying to
    show
    | > the
    | > >> processes
    | > >> >> >> >on the remote server.
    | > >> >> >> >
    | > >> >> >> >My environment:
    | > >> >> >> >Client: Windows XP SP2, Visual Studio 2003, 1.1 SP1 .Net
    framwork
    | > >> >> >> >Server: Windows Server 2003
    | > >> >> >> >
    | > >> >> >> >Any other idÃ?Æ?Ã?©es?
    | > >> >> >> >
    | > >> >> >> >Regards
    | > >> >> >> >Bengt
    | > >> >> >> >P.S. I think it's great that the box is locked down as
    default,
    | > no
    | > >> doubt
    | > >> >> >> >about that D.S.
    | > >> >> >> >
    | > >> >> >> >"Jim Cheshire [MSFT]" wrote:
    | > >> >> >> >
    | > >> >> >> >> Hi Bengt,
    | > >> >> >> >>
    | > >> >> >> >> SP2 locks down your box. That's a very good thing . . .
    for
    | > the
    | > >> most
    | > >> part!
    | > >> >> >> >> It wreaks havoc for remote debugging because the firewall
    | > blocks
    | > >> DCOM
    | > >> >> >> >> communication, UDP ports, TCP ports, etc. You need to set
    up
    | > the
    | > >> firewall
    | > >> >> >> >> and open up the ports so that you can debug.
    | > >> >> >> >>
    | > >> >> >> >> Now before you say "typical Microsoft. How do I do
    that!?",
    | > >> here's
    | > >> an
    | > >> >> >> >> article that will walk you through it. (See, we DO think
    | > ahead!)
    | > >> >> >> >>
    | > >> >> >> >>
    | > >> >> >>
    | > >> >>
    | > >>
    | >
    http://msdn.microsoft.com/asp.net/using/understanding/security/default.aspx?
    | > >> >> >> >> pull=/library/en-us/dnwxp/html/xpsp2remotedebug.asp
    | > >> >> >> >>
    | > >> >> >> >> Jim Cheshire [MSFT]
    | > >> >> >> >> MCP+I, MCSE, MCSD, MCDBA
    | > >> >> >> >> Microsoft Developer Support
    | > >> >> >> >>
    | > >> >> >> >>
    | > >> >> >> >> This post is provided "AS-IS" with no warranties and
    confers no
    | > >> rights.
    | > >> >> >> >>
    | > >> >> >> >>
    | > >> >> >> >> --------------------
    | > >> >> >> >> >Thread-Topic: Unable to start debugging
    | > >> >> >> >> >thread-index: AcSAnif1rqcL0PHARUaHAnGDnE5bEg==
    | > >> >> >> >> >X-WBNR-Posting-Host: 213.238.211.15
    | > >> >> >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt
    | > >> >
    | > >> >> >> >> >References: <#>
    | > >> <>
    | > >> >> >> >> >Subject: RE: Unable to start debugging
    | > >> >> >> >> >Date: Thu, 12 Aug 2004 11:57:03 -0700
    | > >> >> >> >> >Lines: 99
    | > >> >> >> >> >Message-ID:
    | > <>
    | > >> >> >> >> >MIME-Version: 1.0
    | > >> >> >> >> >Content-Type: text/plain;
    | > >> >> >> >> > charset="Utf-8"
    | > >> >> >> >> >Content-Transfer-Encoding: 8bit
    | > >> >> >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    | > >> >> >> >> >Content-Class: urn:content-classes:message
    | > >> >> >> >> >Importance: normal
    | > >> >> >> >> >Priority: normal
    | > >> >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | > >> >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > >> >> >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    | > >> >> >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | > >> >> >> >> >Xref: cpmsftngxa06.phx.gbl
    | > >> microsoft.public.dotnet.framework.aspnet:253973
    | > >> >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > >> >> >> >> >
    | > >> >> >> >> >Hi Jim
    | > >> >> >> >> >
    | > >> >> >> >> >Great to see someone from MS here.. :)
    | > >> >> >> >> >
    | > >> >> >> >> >Even if Serdars problem aren't XP SP2 we are a lot of
    | > developers
    | > >> right
    | > >> now,
    | > >> >> >> >> >including my self, having problem with remote debugging
    after
    | > the
    | > >> >> >> >> >installation of XP SP2. My problem is 'Access denied'
    when
    | > the
    | > >> debugger
    | > >> is
    | > >> >> >> >> >going to view the processes at the remote machine (a Win
    2003
    | > >> server).
    | > >> >> >> >> >
    | > >> >> >> >> >Do you have any info regarding the, very serious, issue?
    Can't
    | > do
    | > >> my
    | > >> work
    | > >> >> >> >> >right now...
    | > >> >> >> >> >
    | > >> >> >> >> >Regards
    | > >> >> >> >> >Bengt
    | > >> >> >> >> >
    | > >> >> >> >> >
    | > >> >> >> >> >
    | > >> >> >> >> >
    | > >> >> >> >> >"Jim Cheshire [MSFT]" wrote:
    | > >> >> >> >> >
    | > >> >> >> >> >> Hi Serdar,
    | > >> >> >> >> >>
    | > >> >> >> >> >> Are you running SP2 on your Windows XP machine by any
    chance?
    | > >> >> >> >> >>
    | > >> >> >> >> >> Jim Cheshire [MSFT]
    | > >> >> >> >> >> MCP+I, MCSE, MCSD, MCDBA
    | > >> >> >> >> >> Microsoft Developer Support
    | > >> >> >> >> >>
    | > >> >> >> >> >>
    | > >> >> >> >> >> This post is provided "AS-IS" with no warranties and
    confers
    | > no
    | > >> rights.
    | > >> >> >> >> >>
    | > >> >> >> >> >> --------------------
    | > >> >> >> >> >> >From: "Serdar KalaycÃ?Æ?Ã?â??Ã?â??Ã?½"
    | > >> <>
    | > >> >> >> >> >> >Subject: Unable to start debugging
    | > >> >> >> >> >> >Date: Thu, 12 Aug 2004 18:27:12 +0300
    | > >> >> >> >> >> >Lines: 44
    | > >> >> >> >> >> >X-Priority: 3
    | > >> >> >> >> >> >X-MSMail-Priority: Normal
    | > >> >> >> >> >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    | > >> >> >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    | > >> >> >> >> >> >Message-ID: <#>
    | > >> >> >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > >> >> >> >> >> >NNTP-Posting-Host: 212.175.3.140
    | > >> >> >> >> >> >Path:
    | > >> >> >> >> >>
    | > >> >> >> >>
    | > >> >> >>
    | > >> >>
    | > >>
    | >
    cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    | > >> >> >> >> >> .phx.gbl
    | > >> >> >> >> >> >Xref: cpmsftngxa06.phx.gbl
    | > >> microsoft.public.dotnet.framework.aspnet:253914
    | > >> >> >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >Hi everybody,
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >My problem seems a bit clichÃ?Æ?Ã?â??Ã?â??Ã?¨
    but I could
    | > not
    | > >> work around.
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >Well I read lots of MSDN papers and discussions, but my
    | > >> problem
    | > >> is a
    | > >> bit
    | > >> >> >> >> >> >different from them. When I tried to run the project in
    | > debug
    | > >> mode
    | > >> (by
    | > >> >> >> >> >> >hitting F5) it gives an error message
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >"Error while trying to run project: Unable to start
    | > debugging
    | > >> on
    | > >> the
    | > >> web
    | > >> >> >> >> >> >server.
    | > >> >> >> >> >> >Click Help for more information"
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >While surfing the net I saw lots of error messages like
    | > this
    | > >> but
    | > >> all
    | > >> of
    | > >> them
    | > >> >> >> >> >> >had an explanation with them like "Access is denied" or
    | > "The
    | > >> project
    | > >> is
    | > >> not
    | > >> >> >> >> >> >configured for debugging" and so on. Mine has no
    | > >> explanations...
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >I went through lots of guidelines that say
    re-registering
    | > >> aspnet_isapi.dll,
    | > >> >> >> >> >> >running aspnet_regiis -i, checking server configuration
    | > >> whether
    | > >> it
    | > >> has
    | > >> >> >> >> >> >'Integrated Windows Authantication', creating the
    project
    | > with
    | > >> the
    | > >> name
    | > >> of
    | > >> >> >> >> >> >the server instead of the IP number and so on.
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >I must also mention that I can attach the process
    manually
    | > >> without
    | > >> any
    | > >> >> >> >> >> >problems.
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >The server is:
    | > >> >> >> >> >> >Win 2000 SP4 with IIS 5.0 and SQL 2000
    | > >> >> >> >> >> >Domain Controller
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >The client is:
    | > >> >> >> >> >> >Win XP Professional
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >Both has Framework 1.1 installed, and I also run Remote
    | > >> Debugging
    | > >> Setup
    | > >> from
    | > >> >> >> >> >> >VS.Net CD1 on the server. Just one thing to mention, it
    | > gave a
    | > >> warning
    | > >> while
    | > >> >> >> >> >> >installing Analyze Server concerning about it could not
    add
    | > >> the
    | > >> account
    | > >> to
    | > >> >> >> >> >> >the Debugger Users group, since it's a domain
    controller.
    | > >> >> >> >> >> >I log on using my domain account which is Administrator
    on
    | > >> client
    | > >> machine
    | > >> >> >> >> >> >and is in Domain Administrators and Debugger Users on
    the
    | > >> server.
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >Hope someone can help.
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >Thanks in advance
    | > >> >> >> >> >> >Serdar KALAYCI
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >
    | > >> >> >> >> >> >
    | > >> >> >> >> >>
    | > >> >> >> >> >>
    | > >> >> >> >> >
    | > >> >> >> >>
    | > >> >> >> >>
    | > >> >> >> >
    | > >> >> >>
    | > >> >> >>
    | > >> >> >
    | > >> >>
    | > >> >>
    | > >> >
    | > >
    | >
    | >
    |
    Jim Cheshire [MSFT], Sep 30, 2004
    #17
  18. Hi Jim,

    Thanks for trying to help me. I found out the problem. I had to specifically
    tell IIS to run on older version of framework instead of 2.0 that comes along
    with whidbey.

    Thanks once again
    Bhanu


    "Jim Cheshire [MSFT]" wrote:

    > Bhani,
    >
    > Those are the only three tabs you should see.
    >
    > What URL are you using when opening the site? What exact error message are
    > you seeing?
    >
    > Jim Cheshire [MSFT]
    > MCP+I, MCSE, MCSD, MCDBA
    > ASP.NET Developer Support
    >
    >
    > This post is provided "AS-IS" with no warranties and confers no rights.
    >
    >
    > --------------------
    > | Thread-Topic: Unable to start debugging
    > | thread-index: AcSlZhxxmqERKunzSyu0mkVNAlYnAQ==
    > | X-WBNR-Posting-Host: 195.229.241.181
    > | From: "=?Utf-8?B?QmhhbnUgUHJha2FzaA==?="
    > <>
    > | References: <#>
    > <>
    > <>
    > <>
    > <>
    > <>
    > <>
    > <>
    > <>
    > <>
    > <>
    > <>
    > | Subject: Re: Unable to start debugging
    > | Date: Tue, 28 Sep 2004 07:19:05 -0700
    > | Lines: 568
    > | Message-ID: <>
    > | MIME-Version: 1.0
    > | Content-Type: text/plain;
    > | charset="Utf-8"
    > | Content-Transfer-Encoding: 8bit
    > | X-Newsreader: Microsoft CDO for Windows 2000
    > | Content-Class: urn:content-classes:message
    > | Importance: normal
    > | Priority: normal
    > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > | Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > | Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:263980
    > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > |
    > | Hi,
    > |
    > | I have a different kind of problem.
    > |
    > | I have installed windows xp service pack 2, but in firewall.cpl, I can
    > only
    > | see three tabs General, Exceptions and Advanced. I can't see any other
    > tabs.
    > | Am I missing something here.
    > |
    > | Another thing, I am not doing remote debugging, I am trying to do local
    > | dubugging which used work before win xp 2, now gives the error that we
    > are
    > | discussing.
    > |
    > | Please help me.
    > |
    > | thank you
    > |
    > | Bhanu Prakash
    > |
    > | "Jim Cheshire [MSFT]" wrote:
    > |
    > | > No offense taken. You are dead on. I have submitted a change request
    > so
    > | > that we can get that corrected.
    > | >
    > | > Thanks.
    > | >
    > | > Jim Cheshire [MSFT]
    > | > MCP+I, MCSE, MCSD, MCDBA
    > | > Microsoft Developer Support
    > | >
    > | >
    > | > This post is provided "AS-IS" with no warranties and confers no rights.
    > | >
    > | >
    > | > --------------------
    > | > >From: (thor2001)
    > | > >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | > >Subject: Re: Unable to start debugging
    > | > >Date: 18 Aug 2004 13:12:56 -0700
    > | > >Organization: http://groups.google.com
    > | > >Lines: 460
    > | > >Message-ID: <>
    > | > >References: <#>
    > | > <>
    > | > <>
    > | > <>
    > | > <>
    > | > <>
    > | > <>
    > | > <>
    > | > <>
    > | > <>
    > | > >NNTP-Posting-Host: 67.176.120.6
    > | > >Content-Type: text/plain; charset=ISO-8859-1
    > | > >Content-Transfer-Encoding: 8bit
    > | > >X-Trace: posting.google.com 1092860018 10257 127.0.0.1 (18 Aug 2004
    > | > 20:13:38 GMT)
    > | > >X-Complaints-To:
    > | > >NNTP-Posting-Date: Wed, 18 Aug 2004 20:13:38 +0000 (UTC)
    > | > >Path:
    > | >
    > cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.sul.t-online.de!t-onlin
    > | >
    > e.de!news-spur1.maxwell.syr.edu!news.maxwell.syr.edu!postnews2.google.com!no
    > | > t-for-mail
    > | > >Xref: cpmsftngxa06.phx.gbl
    > microsoft.public.dotnet.framework.aspnet:255155
    > | > >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > | > >
    > | > >No offense, but you really should indicate that it applies to VS.NET
    > | > >2003. That is not clear at all and is leading to a lot of confusion.
    > | > > I will reinstall SP2 (after many wasted hours) at some point in the
    > | > >future. Hopefully it will work.
    > | > >
    > | > > (Jim Cheshire [MSFT]) wrote in message
    > | > news:<>...
    > | > >> Hi Bengt,
    > | > >>
    > | > >> If you look at the bottom of the article, it lists a workaround for
    > | > VS.NET
    > | > >> 2002 (which also applies to VS.NET 2003.) It tells you to do
    > exactly
    > | > what
    > | > >> you did to make this work. Hope that clears it up.
    > | > >>
    > | > >> Jim Cheshire [MSFT]
    > | > >> MCP+I, MCSE, MCSD, MCDBA
    > | > >> Microsoft Developer Support
    > | > >>
    > | > >>
    > | > >> This post is provided "AS-IS" with no warranties and confers no
    > rights.
    > | > >>
    > | > >> --------------------
    > | > >> >Thread-Topic: Unable to start debugging
    > | > >> >thread-index: AcSDvhEbeG5Ird3hRGyE6Tgl585HrA==
    > | > >> >X-WBNR-Posting-Host: 213.238.211.15
    > | > >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt >
    > | > >> >References: <#>
    > | > >> <>
    > | > >> <>
    > | > >> <>
    > | > >> <>
    > | > >> <>
    > | > >> <>
    > | > >> <>
    > | > >> >Subject: RE: Unable to start debugging
    > | > >> >Date: Mon, 16 Aug 2004 11:23:02 -0700
    > | > >> >Lines: 382
    > | > >> >Message-ID: <>
    > | > >> >MIME-Version: 1.0
    > | > >> >Content-Type: text/plain;
    > | > >> > charset="Utf-8"
    > | > >> >Content-Transfer-Encoding: 8bit
    > | > >> >X-Newsreader: Microsoft CDO for Windows 2000
    > | > >> >Content-Class: urn:content-classes:message
    > | > >> >Importance: normal
    > | > >> >Priority: normal
    > | > >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > | > >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | > >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > | > >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > | > >> >Xref: cpmsftngxa06.phx.gbl
    > | > microsoft.public.dotnet.framework.aspnet:254559
    > | > >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > | > >> >
    > | > >> >Hello Jim
    > | > >> >
    > | > >> >I'm not sure that I agree that the content of article solves my
    > | > problem.
    > | > >> >This is for two reasons:
    > | > >> >1. Configure the ICF is not a problem for me as I have disabled the
    > ICF.
    > | > >> >Text from article:
    > | > >> >"If ICF is off, you may not have to configure a firewall."
    > | > >> >
    > | > >> >2. Configuring COM Security in the Component Services part is only
    > | > >> relevant
    > | > >> >if you are not an Administrator of the client or the server. I'm on
    > | > both
    > | > >> the
    > | > >> >client and the server.
    > | > >> >Text from article:
    > | > >> >"If you run the debugger as a normal user (not as an
    > Administrator),
    > | > you
    > | > >> >must give full access rights to the folder where the executables
    > are
    > | > >> >located." and
    > | > >> >"In addition, if you are not an Administrator of the remote
    > computer,
    > | > you
    > | > >> >must have access permissions and launch permissions."
    > | > >> >
    > | > >> >What I did to make it work was not to add myself as user, I had to
    > | > allow
    > | > >> >Remote Access for ANONYMOUS LOGON.
    > | > >> >
    > | > >> >One thing that could solve my issue could be that I haven't
    > installed
    > | > SP1
    > | > >> >for .Net framework on the server since I do not have the
    > distribution
    > | > >> package
    > | > >> >for Win 2003 Server only for XP.
    > | > >> >
    > | > >> >I also received a mail today from MS regarding Biztalk 2004 and XP
    > SP2.
    > | > >> >http://support.microsoft.com/default.aspx?scid=kb;en-us;841893
    > | > >> >I think the problem with remote debugging is very similar to the
    > | > Biztalk
    > | > >> >problem. This explains the change of the RPC behaviour in SP2 and
    > why
    > | > it
    > | > >> work
    > | > >> >with ANONYMOUS LOGN, this was the default before SP2.
    > | > >> >
    > | > >> >Regards
    > | > >> >Bengt
    > | > >> >
    > | > >> >"Jim Cheshire [MSFT]" wrote:
    > | > >> >
    > | > >> >> Hi,
    > | > >> >>
    > | > >> >> That is something that often has to be done. See this article:
    > | > >> >>
    > | > >> >> http://support.microsoft.com/?id=833977
    > | > >> >>
    > | > >> >> Jim Cheshire [MSFT]
    > | > >> >> MCP+I, MCSE, MCSD, MCDBA
    > | > >> >> Microsoft Developer Support
    > | > >> >>
    > | > >> >>
    > | > >> >> This post is provided "AS-IS" with no warranties and confers no
    > | > rights.
    > | > >> >>
    > | > >> >> --------------------
    > | > >> >> >Thread-Topic: Unable to start debugging
    > | > >> >> >thread-index: AcSBXLOFlzjcjZlhTcOmJLnQyCPCGw==
    > | > >> >> >X-WBNR-Posting-Host: 213.238.211.15
    > | > >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt
    > >
    > | > >> >> >References: <#>
    > | > >> >> <>
    > | > >> >> <>
    > | > >> >> <>
    > | > >> >> <>
    > | > >> >> <>
    > | > >> >> >Subject: RE: Unable to start debugging
    > | > >> >> >Date: Fri, 13 Aug 2004 10:41:02 -0700
    > | > >> >> >Lines: 279
    > | > >> >> >Message-ID: <>
    > | > >> >> >MIME-Version: 1.0
    > | > >> >> >Content-Type: text/plain;
    > | > >> >> > charset="Utf-8"
    > | > >> >> >Content-Transfer-Encoding: 8bit
    > | > >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    > | > >> >> >Content-Class: urn:content-classes:message
    > | > >> >> >Importance: normal
    > | > >> >> >Priority: normal
    > | > >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > | > >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | > >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > | > >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > | > >> >> >Xref: cpmsftngxa06.phx.gbl
    > | > >> microsoft.public.dotnet.framework.aspnet:254227
    > | > >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > | > >> >> >
    > | > >> >> >Hi again Jim
    > | > >> >> >
    > | > >> >> >I'm an Administrator on both machines and Windows Integrated
    > | > >> authentication,
    > | > >> >> >it worked just fine before the upgrade.
    > | > >> >> >
    > | > >> >> >But actually I have get it up and running by doing this:
    > | > >> >> >1. Installed SP1 for 1.1 .Net framework (not sure if it's needed)
    > | > >> >> >2. Changed the settings for Component Services -> My Computer ->
    > | > >> Properties
    > | > >> >> >-> COM Security -> Access Permissions -> Edit Limits...
    > | > >> >> >For ANONYMOUS LOGON I allowed Remote Access
    > | > >> >> >
    > | > >> >> >I believe I have opened a potential security hole, hopefully
    > | > temporary,
    > | > >> but
    > | > >> >> >at least I can debug.
    > | > >> >> >Same for my colleauge which also upgraded to SP2 today. Remote
    > | > >> debugging
    > | > >> >> >didn't work but after performing these steps he got it working.
    > | > >> >> >
    > | > >> >> >Maybe someone more outthere could give the workaround a try and
    > see
    > | > if
    > | > >> it
    > | > >> >> >works. Please post feedback if this get you up and running again.
    > | > >> >> >
    > | > >> >> >Regards
    > | > >> >> >Bengt
    > | > >> >> >
    > | > >> >> >"Jim Cheshire [MSFT]" wrote:
    > | > >> >> >
    > | > >> >> >> Hi Bengt,
    > | > >> >> >>
    > | > >> >> >> Are you an Administrator on the server? Is Windows Integrated
    > | > >> >> >> authentication enabled?
    > | > >> >> >>
    > | > >> >> >> Jim Cheshire [MSFT]
    > | > >> >> >> MCP+I, MCSE, MCSD, MCDBA
    > | > >> >> >> Microsoft Developer Support
    > | > >> >> >>
    > | > >> >> >>
    > | > >> >> >> This post is provided "AS-IS" with no warranties and confers
    > no
    > | > >> rights.
    > | > >> >> >>
    > | > >> >> >>
    > | > >> >> >> --------------------
    > | > >> >> >> >Thread-Topic: Unable to start debugging
    > | > >> >> >> >thread-index: AcSAuu23A9j7wDUMTVKAVwndYW8Yjg==
    > | > >> >> >> >X-WBNR-Posting-Host: 213.238.211.15
    > | > >> >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt
    > | > >
    > | > >> >> >> >References: <#>
    > | > >> >> >> <>
    > | > >> >> >> <>
    > | > >> >> >> <>
    > | > >> >> >> >Subject: RE: Unable to start debugging
    > | > >> >> >> >Date: Thu, 12 Aug 2004 15:23:01 -0700
    > | > >> >> >> >Lines: 187
    > | > >> >> >> >Message-ID:
    > <>
    > | > >> >> >> >MIME-Version: 1.0
    > | > >> >> >> >Content-Type: text/plain;
    > | > >> >> >> > charset="Utf-8"
    > | > >> >> >> >Content-Transfer-Encoding: 8bit
    > | > >> >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    > | > >> >> >> >Content-Class: urn:content-classes:message
    > | > >> >> >> >Importance: normal
    > | > >> >> >> >Priority: normal
    > | > >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > | > >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | > >> >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > | > >> >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > | > >> >> >> >Xref: cpmsftngxa06.phx.gbl
    > | > >> microsoft.public.dotnet.framework.aspnet:254021
    > | > >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > | > >> >> >> >
    > | > >> >> >> >Hi Jim
    > | > >> >> >> >
    > | > >> >> >> >Thanks for your prompt reply.
    > | > >> >> >> >I have seen the article, even read it before I applied the
    > | > service
    > | > >> pack,
    > | > >> so
    > | > >> >> >> >I don't think that is the issue since, I forgot to mention, I
    > | > have
    > | > >> disabled
    > | > >> >> >> >the ICF (Firewall).
    > | > >> >> >> >Text from the article:
    > | > >> >> >> >"If IFC is off, no firewall configuration is necessary."
    > | > >> >> >> >
    > | > >> >> >> >Other people, in other threads that also has the problem,
    > have
    > | > also
    > | > >> disabled
    > | > >> >> >> >the ICF.
    > | > >> >> >> >
    > | > >> >> >> >I just I applied the SP1 for the 1.1 .Net framwork on the XP
    > SP2
    > | > >> client
    > | > >> but
    > | > >> >> >> >still the same problem. "Access is denied" when trying to
    > show
    > | > the
    > | > >> processes
    > | > >> >> >> >on the remote server.
    > | > >> >> >> >
    > | > >> >> >> >My environment:
    > | > >> >> >> >Client: Windows XP SP2, Visual Studio 2003, 1.1 SP1 .Net
    > framwork
    > | > >> >> >> >Server: Windows Server 2003
    > | > >> >> >> >
    > | > >> >> >> >Any other idÃ?Æ?Ã?©es?
    > | > >> >> >> >
    > | > >> >> >> >Regards
    > | > >> >> >> >Bengt
    > | > >> >> >> >P.S. I think it's great that the box is locked down as
    > default,
    > | > no
    > | > >> doubt
    > | > >> >> >> >about that D.S.
    > | > >> >> >> >
    > | > >> >> >> >"Jim Cheshire [MSFT]" wrote:
    > | > >> >> >> >
    > | > >> >> >> >> Hi Bengt,
    > | > >> >> >> >>
    > | > >> >> >> >> SP2 locks down your box. That's a very good thing . . .
    > for
    > | > the
    > | > >> most
    > | > >> part!
    > | > >> >> >> >> It wreaks havoc for remote debugging because the firewall
    > | > blocks
    > | > >> DCOM
    > | > >> >> >> >> communication, UDP ports, TCP ports, etc. You need to set
    > up
    > | > the
    > | > >> firewall
    > | > >> >> >> >> and open up the ports so that you can debug.
    > | > >> >> >> >>
    > | > >> >> >> >> Now before you say "typical Microsoft. How do I do
    > that!?",
    > | > >> here's
    > | > >> an
    > | > >> >> >> >> article that will walk you through it. (See, we DO think
    > | > ahead!)
    > | > >> >> >> >>
    > | > >> >> >> >>
    > | > >> >> >>
    > | > >> >>
    > | > >>
    > | >
    > http://msdn.microsoft.com/asp.net/using/understanding/security/default.aspx?
    > | > >> >> >> >> pull=/library/en-us/dnwxp/html/xpsp2remotedebug.asp
    > | > >> >> >> >>
    > | > >> >> >> >> Jim Cheshire [MSFT]
    > | > >> >> >> >> MCP+I, MCSE, MCSD, MCDBA
    > | > >> >> >> >> Microsoft Developer Support
    > | > >> >> >> >>
    > | > >> >> >> >>
    > | > >> >> >> >> This post is provided "AS-IS" with no warranties and
    > confers no
    > | > >> rights.
    > | > >> >> >> >>
    > | > >> >> >> >>
    > | > >> >> >> >> --------------------
    > | > >> >> >> >> >Thread-Topic: Unable to start debugging
    > | > >> >> >> >> >thread-index: AcSAnif1rqcL0PHARUaHAnGDnE5bEg==
    > | > >> >> >> >> >X-WBNR-Posting-Host: 213.238.211.15
    > | > >> >> >> >> >From: =?Utf-8?B?QmVuZ3QgSmF4?= <Bengt
    > | > >> >
    > | > >> >> >> >> >References: <#>
    > | > >> <>
    > | > >> >> >> >> >Subject: RE: Unable to start debugging
    > | > >> >> >> >> >Date: Thu, 12 Aug 2004 11:57:03 -0700
    > | > >> >> >> >> >Lines: 99
    > | > >> >> >> >> >Message-ID:
    > | > <>
    > | > >> >> >> >> >MIME-Version: 1.0
    > | > >> >> >> >> >Content-Type: text/plain;
    > | > >> >> >> >> > charset="Utf-8"
    > | > >> >> >> >> >Content-Transfer-Encoding: 8bit
    > | > >> >> >> >> >X-Newsreader: Microsoft CDO for Windows 2000
    > | > >> >> >> >> >Content-Class: urn:content-classes:message
    > | > >> >> >> >> >Importance: normal
    > | > >> >> >> >> >Priority: normal
    > | > >> >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > | > >> >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | > >> >> >> >> >NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
    > | > >> >> >> >> >Path: cpmsftngxa06.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > | > >> >> >> >> >Xref: cpmsftngxa06.phx.gbl
    > | > >> microsoft.public.dotnet.framework.aspnet:253973
    > | > >> >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > | > >> >> >> >> >
    > | > >> >> >> >> >Hi Jim
    > | > >> >> >> >> >
    > | > >> >> >> >> >Great to see someone from MS here.. :)
    > | > >> >> >> >> >
    > | > >> >> >> >> >Even if Serdars problem aren't XP SP2 we are a lot of
    > | > developers
    > | > >> right
    > | > >> now,
    > | > >> >> >> >> >including my self, having problem with remote debugging
    > after
    > | > the
    > | > >> >> >> >> >installation of XP SP2. My problem is 'Access denied'
    > when
    > | > the
    > | > >> debugger
    > | > >> is
    > | > >> >> >> >> >going to view the processes at the remote machine (a Win
    > 2003
    > | > >> server).
    > | > >> >> >> >> >
    > | > >> >> >> >> >Do you have any info regarding the, very serious, issue?
    > Can't
    > | > do
    > | > >> my
    > | > >> work
    > | > >> >> >> >> >right now...
    > | > >> >> >> >> >
    > | > >> >> >> >> >Regards
    > | > >> >> >> >> >Bengt
    > | > >> >> >> >> >
    > | > >> >> >> >> >
    > | > >> >> >> >> >
    > | > >> >> >> >> >
    > | > >> >> >> >> >"Jim Cheshire [MSFT]" wrote:
    > | > >> >> >> >> >
    > | > >> >> >> >> >> Hi Serdar,
    > | > >> >> >> >> >>
    > | > >> >> >> >> >> Are you running SP2 on your Windows XP machine by any
    > chance?
    > | > >> >> >> >> >>
    > | > >> >> >> >> >> Jim Cheshire [MSFT]
    > | > >> >> >> >> >> MCP+I, MCSE, MCSD, MCDBA
    > | > >> >> >> >> >> Microsoft Developer Support
    > | > >> >> >> >> >>
    > | > >> >> >> >> >>
    > | > >> >> >> >> >> This post is provided "AS-IS" with no warranties and
    > confers
    > | > no
    > | > >> rights.
    > | > >> >> >> >> >>
    > | > >> >> >> >> >> --------------------
    > | > >> >> >> >> >> >From: "Serdar KalaycÃ?Æ?Ã?â??Ã?â??Ã?½"
    > | > >> <>
    > | > >> >> >> >> >> >Subject: Unable to start debugging
    > | > >> >> >> >> >> >Date: Thu, 12 Aug 2004 18:27:12 +0300
    > | > >> >> >> >> >> >Lines: 44
    > | > >> >> >> >> >> >X-Priority: 3
    > | > >> >> >> >> >> >X-MSMail-Priority: Normal
    > | > >> >> >> >> >> >X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
    > | > >> >> >> >> >> >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
    > | > >> >> >> >> >> >Message-ID: <#>
    > | > >> >> >> >> >> >Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | > >> >> >> >> >> >NNTP-Posting-Host: 212.175.3.140
    > | > >> >> >> >> >> >Path:
    > | > >> >> >> >> >>
    > | > >> >> >> >>
    > | > >> >> >>
    > | > >> >>
    > | > >>
    > | >
    > cpmsftngxa06.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12
    > | > >> >> >> >> >> .phx.gbl
    > | > >> >> >> >> >> >Xref: cpmsftngxa06.phx.gbl
    > | > >> microsoft.public.dotnet.framework.aspnet:253914
    > | > >> >> >> >> >> >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >Hi everybody,
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >My problem seems a bit clichÃ?Æ?Ã?â??Ã?â??Ã?¨
    > but I could
    > | > not
    > | > >> work around.
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >Well I read lots of MSDN papers and discussions, but my
    > | > >> problem
    > | > >> is a
    > | > >> bit
    > | > >> >> >> >> >> >different from them. When I tried to run the project in
    > | > debug
    > | > >> mode
    > | > >> (by
    > | > >> >> >> >> >> >hitting F5) it gives an error message
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >"Error while trying to run project: Unable to start
    > | > debugging
    > | > >> on
    > | > >> the
    > | > >> web
    > | > >> >> >> >> >> >server.
    > | > >> >> >> >> >> >Click Help for more information"
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >While surfing the net I saw lots of error messages like
    > | > this
    > | > >> but
    > | > >> all
    > | > >> of
    > | > >> them
    > | > >> >> >> >> >> >had an explanation with them like "Access is denied" or
    > | > "The
    > | > >> project
    > | > >> is
    > | > >> not
    > | > >> >> >> >> >> >configured for debugging" and so on. Mine has no
    > | > >> explanations...
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >I went through lots of guidelines that say
    > re-registering
    > | > >> aspnet_isapi.dll,
    > | > >> >> >> >> >> >running aspnet_regiis -i, checking server configuration
    > | > >> whether
    > | > >> it
    > | > >> has
    > | > >> >> >> >> >> >'Integrated Windows Authantication', creating the
    > project
    > | > with
    > | > >> the
    > | > >> name
    > | > >> of
    > | > >> >> >> >> >> >the server instead of the IP number and so on.
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >I must also mention that I can attach the process
    > manually
    > | > >> without
    > | > >> any
    > | > >> >> >> >> >> >problems.
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >The server is:
    > | > >> >> >> >> >> >Win 2000 SP4 with IIS 5.0 and SQL 2000
    > | > >> >> >> >> >> >Domain Controller
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >The client is:
    > | > >> >> >> >> >> >Win XP Professional
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >Both has Framework 1.1 installed, and I also run Remote
    > | > >> Debugging
    > | > >> Setup
    > | > >> from
    > | > >> >> >> >> >> >VS.Net CD1 on the server. Just one thing to mention, it
    > | > gave a
    > | > >> warning
    > | > >> while
    > | > >> >> >> >> >> >installing Analyze Server concerning about it could not
    > add
    > | > >> the
    > | > >> account
    > | > >> to
    > | > >> >> >> >> >> >the Debugger Users group, since it's a domain
    > controller.
    > | > >> >> >> >> >> >I log on using my domain account which is Administrator
    > on
    > | > >> client
    > | > >> machine
    > | > >> >> >> >> >> >and is in Domain Administrators and Debugger Users on
    > the
    > | > >> server.
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >Hope someone can help.
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >Thanks in advance
    > | > >> >> >> >> >> >Serdar KALAYCI
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >> >
    > | > >> >> >> >> >>
    > | > >> >> >> >> >>
    > | > >> >> >> >> >
    > | > >> >> >> >>
    > | > >> >> >> >>
    > | > >> >> >> >
    > | > >> >> >>
    > | > >> >> >>
    > | > >> >> >
    > | > >> >>
    > | > >> >>
    > | > >> >
    > | > >
    > | >
    > | >
    > |
    >
    >
    =?Utf-8?B?QmhhbnUgUHJha2FzaA==?=, Sep 30, 2004
    #18
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ravi Shankar
    Replies:
    1
    Views:
    11,241
  2. Marc Hoeppner
    Replies:
    0
    Views:
    375
    Marc Hoeppner
    Jul 15, 2003
  3. Debugger
    Replies:
    0
    Views:
    370
    Debugger
    Jul 25, 2003
  4. Sung
    Replies:
    0
    Views:
    353
  5. loser
    Replies:
    3
    Views:
    1,325
    loser
    Aug 7, 2003
Loading...

Share This Page