Using FireFox 1.0 on new ASP.NET projects brings up authentication dialog when there should be none

Discussion in 'ASP .Net' started by ~~~ .NET Ed ~~~, Nov 15, 2004.

  1. This is a strange problem and I wonder if anybody has experienced this
    annoying anomaly.

    I created a new ASP.NET project with its web-shared directory on my WinXP
    Pro/IIS machine. I compile the project and everything is fine so far.

    Accessing the default page with Internet Explorer 6.0 shows the page as
    expected. I am however using FireFox as my browser (don't ask why). Using
    FireFox 1.0 on the new ASP.NET project brings up an authentication dialog:

    Please enter username and password for "" on
    http://localhost/MyWebProject.

    Now that is odd because the page in question (nor any of those within the
    project) request user authentication.

    However, I know that after some use (how much it depends) under some random
    circumstances, the project works fine with both browsers.

    I submitted a but to the FireFox team, but I am sure there is *something* in
    the newly created web applications (default settings) that make the other
    browser get confused. I want to know what that is because at the moment I am
    investigating a rendering issue so I need to have the project operational
    with both IE and FireFox.

    Thanks
    Emilio
    ~~~ .NET Ed ~~~, Nov 15, 2004
    #1
    1. Advertising

  2. ~~~ .NET Ed ~~~

    Curt_C [MVP] Guest

    Check IIS. Do you have "integrated auth" turned on? Dont think that FF
    supports it, only IE.

    --
    Curt Christianson
    Owner/Lead Developer, DF-Software
    Site: http://www.Darkfalz.com
    Blog: http://blog.Darkfalz.com


    "~~~ .NET Ed ~~~" <> wrote in message
    news:...
    > This is a strange problem and I wonder if anybody has experienced this
    > annoying anomaly.
    >
    > I created a new ASP.NET project with its web-shared directory on my WinXP
    > Pro/IIS machine. I compile the project and everything is fine so far.
    >
    > Accessing the default page with Internet Explorer 6.0 shows the page as
    > expected. I am however using FireFox as my browser (don't ask why). Using
    > FireFox 1.0 on the new ASP.NET project brings up an authentication dialog:
    >
    > Please enter username and password for "" on
    > http://localhost/MyWebProject.
    >
    > Now that is odd because the page in question (nor any of those within the
    > project) request user authentication.
    >
    > However, I know that after some use (how much it depends) under some
    > random
    > circumstances, the project works fine with both browsers.
    >
    > I submitted a but to the FireFox team, but I am sure there is *something*
    > in
    > the newly created web applications (default settings) that make the other
    > browser get confused. I want to know what that is because at the moment I
    > am
    > investigating a rendering issue so I need to have the project operational
    > with both IE and FireFox.
    >
    > Thanks
    > Emilio
    >
    >
    Curt_C [MVP], Nov 15, 2004
    #2
    1. Advertising

  3. Thanks a Million Curt! I had just noticed that I was getting these two
    headers in the response (used dHTTP utility)

    WWW-Authenticate: Negotiate
    WWW-Authenticate: NTLM

    That did not affect IE, but caused FF to stumble to its knees. I checked the
    local web share in question and indeed it had (seems to be the default)
    Integrated Authentication option checked. I disabled and enabled anonymous
    access and now it is fine.

    Thanks!
    Emilio

    "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
    news:...
    > Check IIS. Do you have "integrated auth" turned on? Dont think that FF
    > supports it, only IE.
    >
    > --
    > Curt Christianson
    > Owner/Lead Developer, DF-Software
    > Site: http://www.Darkfalz.com
    > Blog: http://blog.Darkfalz.com
    >
    >
    > "~~~ .NET Ed ~~~" <> wrote in message
    > news:...
    > > This is a strange problem and I wonder if anybody has experienced this
    > > annoying anomaly.
    > >
    > > I created a new ASP.NET project with its web-shared directory on my

    WinXP
    > > Pro/IIS machine. I compile the project and everything is fine so far.
    > >
    > > Accessing the default page with Internet Explorer 6.0 shows the page as
    > > expected. I am however using FireFox as my browser (don't ask why).

    Using
    > > FireFox 1.0 on the new ASP.NET project brings up an authentication

    dialog:
    > >
    > > Please enter username and password for "" on
    > > http://localhost/MyWebProject.
    > >
    > > Now that is odd because the page in question (nor any of those within

    the
    > > project) request user authentication.
    > >
    > > However, I know that after some use (how much it depends) under some
    > > random
    > > circumstances, the project works fine with both browsers.
    > >
    > > I submitted a but to the FireFox team, but I am sure there is

    *something*
    > > in
    > > the newly created web applications (default settings) that make the

    other
    > > browser get confused. I want to know what that is because at the moment

    I
    > > am
    > > investigating a rendering issue so I need to have the project

    operational
    > > with both IE and FireFox.
    > >
    > > Thanks
    > > Emilio
    > >
    > >

    >
    >
    ~~~ .NET Ed ~~~, Nov 15, 2004
    #3
  4. About if ur application needs integrated Windows Auth?

    "~~~ .NET Ed ~~~" <> wrote in message
    news:#o$...
    > Thanks a Million Curt! I had just noticed that I was getting these two
    > headers in the response (used dHTTP utility)
    >
    > WWW-Authenticate: Negotiate
    > WWW-Authenticate: NTLM
    >
    > That did not affect IE, but caused FF to stumble to its knees. I checked

    the
    > local web share in question and indeed it had (seems to be the default)
    > Integrated Authentication option checked. I disabled and enabled anonymous
    > access and now it is fine.
    >
    > Thanks!
    > Emilio
    >
    > "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
    > news:...
    > > Check IIS. Do you have "integrated auth" turned on? Dont think that FF
    > > supports it, only IE.
    > >
    > > --
    > > Curt Christianson
    > > Owner/Lead Developer, DF-Software
    > > Site: http://www.Darkfalz.com
    > > Blog: http://blog.Darkfalz.com
    > >
    > >
    > > "~~~ .NET Ed ~~~" <> wrote in message
    > > news:...
    > > > This is a strange problem and I wonder if anybody has experienced this
    > > > annoying anomaly.
    > > >
    > > > I created a new ASP.NET project with its web-shared directory on my

    > WinXP
    > > > Pro/IIS machine. I compile the project and everything is fine so far.
    > > >
    > > > Accessing the default page with Internet Explorer 6.0 shows the page

    as
    > > > expected. I am however using FireFox as my browser (don't ask why).

    > Using
    > > > FireFox 1.0 on the new ASP.NET project brings up an authentication

    > dialog:
    > > >
    > > > Please enter username and password for "" on
    > > > http://localhost/MyWebProject.
    > > >
    > > > Now that is odd because the page in question (nor any of those within

    > the
    > > > project) request user authentication.
    > > >
    > > > However, I know that after some use (how much it depends) under some
    > > > random
    > > > circumstances, the project works fine with both browsers.
    > > >
    > > > I submitted a but to the FireFox team, but I am sure there is

    > *something*
    > > > in
    > > > the newly created web applications (default settings) that make the

    > other
    > > > browser get confused. I want to know what that is because at the

    moment
    > I
    > > > am
    > > > investigating a rendering issue so I need to have the project

    > operational
    > > > with both IE and FireFox.
    > > >
    > > > Thanks
    > > > Emilio
    > > >
    > > >

    > >
    > >

    >
    >
    Patrick.O.Ige, Nov 16, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Maximilian

    forms authentication brings up dialog

    Maximilian, Nov 1, 2007, in forum: ASP .Net Security
    Replies:
    0
    Views:
    147
    Maximilian
    Nov 1, 2007
  2. length power
    Replies:
    2
    Views:
    72
    Rustom Mody
    Apr 10, 2014
  3. Skip Montanaro
    Replies:
    0
    Views:
    57
    Skip Montanaro
    Apr 10, 2014
  4. Johannes Schneider

    Re: why i have the output of [None, None, None]

    Johannes Schneider, Apr 10, 2014, in forum: Python
    Replies:
    0
    Views:
    50
    Johannes Schneider
    Apr 10, 2014
  5. Terry Reedy
    Replies:
    0
    Views:
    61
    Terry Reedy
    Apr 10, 2014
Loading...

Share This Page