Validator not being validated unless called individually

Discussion in 'ASP .Net Web Controls' started by Nathan Sokalski, Sep 11, 2008.

  1. I have a UserControl, one property of which I have added the
    ValidationPropertyAttribute to. The Validator I am using with this
    UserControl (which is a RequiredFieldValidator) is not executed on a
    postback, and not even if I call this.Validate(MyValidationGroup). However,
    if I call MyValidator.Validate(), it validates exactly as I want. I have
    included the ValidationGroup property in the RequiredFieldValidator, so I
    know that is not the problem. Why is this one validator being singled out?
    Thanks.

    Nathan Sokalski

    http://www.nathansokalski.com/
     
    Nathan Sokalski, Sep 11, 2008
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. DesignerX
    Replies:
    2
    Views:
    462
    Teemu Keiski
    Jul 24, 2003
  2. Ceri
    Replies:
    2
    Views:
    426
    Ceri Locke
    Dec 17, 2003
  3. Nathan Sokalski
    Replies:
    0
    Views:
    276
    Nathan Sokalski
    Sep 11, 2008
  4. Karen Grube

    Custom Validator needs to reset focus on validated control

    Karen Grube, Nov 28, 2004, in forum: ASP .Net Web Controls
    Replies:
    0
    Views:
    138
    Karen Grube
    Nov 28, 2004
  5. Gábor SEBESTYÉN

    Unless unless

    Gábor SEBESTYÉN, Jun 17, 2005, in forum: Ruby
    Replies:
    3
    Views:
    159
    Gábor SEBESTYÉN
    Jun 17, 2005
Loading...

Share This Page