viewstate getting corrupted

Discussion in 'ASP .Net' started by TS, Dec 2, 2005.

  1. TS

    TS Guest

    I have some inner exceptions on dev and production server saying:
    Invalid character in a Base-64 string. OR
    Invalid Length of a Base-64 string or something like that.

    I cannot recreate this issue and don't know why it is happening. Someone
    suggested that it occurs when someone clicks submit on a page then closes
    the browser before the response comes back, OR they click the submit button
    and before it comes back they click it again.

    Any ideas on why it is happening?

    thanks
    TS, Dec 2, 2005
    #1
    1. Advertising

  2. Hi,

    We have reviewed this issue and are currently researching on it. We will
    update you ASAP. Thanks for your patience!

    Kevin Yu
    =======
    "This posting is provided "AS IS" with no warranties, and confers no
    rights."
    Kevin Yu [MSFT], Dec 3, 2005
    #2
    1. Advertising

  3. Hi TS,

    As for ViewState getting corrupted problem, based on my experience, this is
    likely occuring when our ASP.NET application is running in webgarden mode
    or in webfarm environment. Because ASP.NET viewstate bydefault enable
    ViewState MAC (to checking viewstate integrited.....), and this
    sign/validate is depend on a machine specific key by default, so in webfarm
    envionement, the request could to dispatched to different server ,then the
    error occurs when machine B try validting a viewstate signed by server A 's
    machine key. Here is one web article mentioned this:

    http://www.codinghorror.com/blog/archives/000132.html]

    Regards,

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)


    --------------------
    | From: "TS" <>
    | Subject: viewstate getting corrupted
    | Date: Fri, 2 Dec 2005 16:23:28 -0600
    | Lines: 14
    | X-Priority: 3
    | X-MSMail-Priority: Normal
    | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    | X-RFC2646: Format=Flowed; Original
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    | Message-ID: <#YVG#>
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | NNTP-Posting-Host: 101nat080.tea.state.tx.us 198.214.101.80
    | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP12.phx.gbl
    | Xref: TK2MSFTNGXA02.phx.gbl
    microsoft.public.dotnet.framework.aspnet:362440
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    |
    | I have some inner exceptions on dev and production server saying:
    | Invalid character in a Base-64 string. OR
    | Invalid Length of a Base-64 string or something like that.
    |
    | I cannot recreate this issue and don't know why it is happening. Someone
    | suggested that it occurs when someone clicks submit on a page then closes
    | the browser before the response comes back, OR they click the submit
    button
    | and before it comes back they click it again.
    |
    | Any ideas on why it is happening?
    |
    | thanks
    |
    |
    |
    Steven Cheng[MSFT], Dec 5, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Gordon Moore
    Replies:
    0
    Views:
    433
    Gordon Moore
    Jun 27, 2003
  2. Hardy Wang
    Replies:
    5
    Views:
    344
    Hardy Wang
    Jul 4, 2003
  3. Trevor Andrew
    Replies:
    0
    Views:
    459
    Trevor Andrew
    Jul 25, 2003
  4. Gvnn
    Replies:
    2
    Views:
    1,227
    Saravana [MVP]
    Oct 18, 2003
  5. Ben Rush
    Replies:
    2
    Views:
    505
    Ben Rush
    Dec 5, 2003
Loading...

Share This Page