Visual studio 2003 "HTTP/1.1 500 Internal Server Error"

Discussion in 'ASP .Net' started by gerr, Feb 3, 2005.

  1. gerr

    gerr Guest

    Visual studio 2003 "HTTP/1.1 500 Internal Server Error" when trying to
    create a new Asp.net site with Visual Studio 2003 on localServer/IIS
    5.1.
    Anyone have any new solutions or urls to point me to for this problem
    short of reinstalling the local developer XP OS/IIS 5.1 ? I have tried
    everything else listed in various threads.
    I think my mistake was thinking the installation for v/st 2003 was
    going to upgrade my V/Studio.net 2001, ( I "ass umed", since it was not
    a total paradyne shift as it was from V/Studio 6 to V/Studio.net), I
    didn't de-install 2001/frwrk 1.0 first. So AFTER V/Studio 2003
    installation was done I add/removed programs- V/Studio 2001, plus
    framework 1.0x...oops!
    I guess I should have de-installed 2001/v 1.0 first. Did I miss a step
    in the installation that offered to upgrade my V/Studio.net
    2001/Framework 1.0x ???????

    Thanks all,

    Things I've tried
    iisreset /stop
    net user ASPNET /delete
    aspnet_regiis -i
    iisreset /start
    ----------
    1. Uninstall .NET framework 2.
    2. Uninstall ISS
    3. Reinstall ISS with default options.
    4. Install VS.NET prerequisites from the VS.NET installation.
    -----------
    Go to "Administrative Tools"
    - Open "Microsoft .Net 1.1 Configuration"
    - In the new window, expand the "Runtime Security Policy"
    - Expand "Machine", then "Code Groups", then "All_Code".
    - Right-Click on "My_Computer_Zone" and select properties.
    - On the "Permission Set" tab, the selected value should be "Full
    Trust"
    - Checked "Full Trust" was set.
    ------------
    no web.config allready in root.
    ------------------------------
    Com services seem ok
    -------------------------
    no errors in event log
    -----------------------
    Win Security on c:\inetpub and below open for vs dev account and
    IUSR...full control.
    ------------------------
    Went to IIS right click on "Default web site" properties --> Home
    directory --> Create (actually allread had that set)
    ------------------------
    Uncheck "Run WWW in IIS 5 isolation mode" <- Actually could not find
    that option in IIS mmc snap in.
    -----------------------
    gerr, Feb 3, 2005
    #1
    1. Advertising

  2. gerr

    Ziga Jakhel Guest

    Sure you have asp_net extensions registered with iis?

    Find aspnet_regiis.exe from framework 1.1. and run it, then try again.


    "gerr" <> wrote in message
    news:...
    > Visual studio 2003 "HTTP/1.1 500 Internal Server Error" when trying to
    > create a new Asp.net site with Visual Studio 2003 on localServer/IIS
    > 5.1.
    > Anyone have any new solutions or urls to point me to for this problem
    > short of reinstalling the local developer XP OS/IIS 5.1 ? I have tried
    > everything else listed in various threads.
    > I think my mistake was thinking the installation for v/st 2003 was
    > going to upgrade my V/Studio.net 2001, ( I "ass umed", since it was not
    > a total paradyne shift as it was from V/Studio 6 to V/Studio.net), I
    > didn't de-install 2001/frwrk 1.0 first. So AFTER V/Studio 2003
    > installation was done I add/removed programs- V/Studio 2001, plus
    > framework 1.0x...oops!
    > I guess I should have de-installed 2001/v 1.0 first. Did I miss a step
    > in the installation that offered to upgrade my V/Studio.net
    > 2001/Framework 1.0x ???????
    >
    > Thanks all,
    >
    > Things I've tried
    > iisreset /stop
    > net user ASPNET /delete
    > aspnet_regiis -i
    > iisreset /start
    > ----------
    > 1. Uninstall .NET framework 2.
    > 2. Uninstall ISS
    > 3. Reinstall ISS with default options.
    > 4. Install VS.NET prerequisites from the VS.NET installation.
    > -----------
    > Go to "Administrative Tools"
    > - Open "Microsoft .Net 1.1 Configuration"
    > - In the new window, expand the "Runtime Security Policy"
    > - Expand "Machine", then "Code Groups", then "All_Code".
    > - Right-Click on "My_Computer_Zone" and select properties.
    > - On the "Permission Set" tab, the selected value should be "Full
    > Trust"
    > - Checked "Full Trust" was set.
    > ------------
    > no web.config allready in root.
    > ------------------------------
    > Com services seem ok
    > -------------------------
    > no errors in event log
    > -----------------------
    > Win Security on c:\inetpub and below open for vs dev account and
    > IUSR...full control.
    > ------------------------
    > Went to IIS right click on "Default web site" properties --> Home
    > directory --> Create (actually allread had that set)
    > ------------------------
    > Uncheck "Run WWW in IIS 5 isolation mode" <- Actually could not find
    > that option in IIS mmc snap in.
    > -----------------------
    >
    Ziga Jakhel, Feb 3, 2005
    #2
    1. Advertising

  3. gerr

    sschneider

    Joined:
    Jul 6, 2006
    Messages:
    1
    Have you solved the HTTP/1.1 500 Internal Server Error problem?

    I had this problem on a new laptop, and ended up sending the laptop back to the vendor. Am curious if you have ever solved this problem.
    sschneider, Jul 6, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Rod
    Replies:
    9
    Views:
    3,726
    Jim Cheshire [MSFT]
    Jul 26, 2004
  2. John Bonds
    Replies:
    2
    Views:
    2,681
    Amaryllis
    Aug 3, 2004
  3. gerr
    Replies:
    1
    Views:
    4,273
    Kevin Spencer
    Feb 3, 2005
  4. Chuck B
    Replies:
    8
    Views:
    362
  5. Chuck B
    Replies:
    7
    Views:
    166
Loading...

Share This Page