Visual studio asp.net 2003 "HTTP/1.1 500 Internal Server Error"

Discussion in 'ASP .Net' started by gerr, Feb 3, 2005.

  1. gerr

    gerr Guest

    Visual studio 2003 "HTTP/1.1 500 Internal Server Error" when trying to
    create a new Asp.net site with Visual Studio 2003 on localServer XP
    Pro/IIS 5.1. Everything worked fine prior to installing V/Studio 2003.
    Was running V/Studio classic 6/Asp parallel with V/Studio 2002/aspx.
    Anyone have any new solutions or urls' to point me to for this problem
    short of reinstalling the local developer setup consisting of Win XP
    OS/IIS 5.1 along with FP 2003 ? I have pretty much tried everything
    else listed in various threads. I think my mistake was thinking the
    installation for V/Studio 2003 was going to offer to upgrade my
    V/Studio.net 2002, (I "assumed", since it was not a total paradyne
    shift as it was from V/Studio 6 to V/Studio.net, that this would be the
    case). Did I miss a step in the installation that offered to upgrade my
    V/Studio.net version 2002/Framework 1.0x ???????
    Anyway, I didn't de-install 2002/frwrk 1.0 first. So AFTER V/Studio
    2003 installation was done I add/removed programs- V/Studio 2002, plus
    framework 1.0x...oops!
    I guess I should have de-installed 2002/v 1.0 first.
    Does anyone have a web server product that they are having more success
    integrating with Asp.net 1.1x other than Microsoft's own IIS ?
    Thanks all,

    Here are some things other developers have used (from various threads
    around the world) to fix Microsoft's problem's integrating IIS with
    Asp.net v.1.1.4322

    iisreset /stop
    net user ASPNET /delete
    aspnet_regiis -i
    iisreset /start
    ----------
    1. Uninstall .NET framework 2.
    2. Uninstall ISS
    3. Reinstall ISS with default options.
    4. Install VS.NET prerequisites from the VS.NET installation. Etc.
    -----------
    Go to "Administrative Tools"
    - Open "Microsoft .Net 1.1 Configuration"
    - In the new window, expand the "Runtime Security Policy"
    - Expand "Machine", then "Code Groups", then "All_Code".
    - Right-Click on "My_Computer_Zone" and select properties.
    - On the "Permission Set" tab, the selected value should be "Full
    Trust"
    - Checked "Full Trust" was set.
    ------------
    checked and no web.config allready in root.
    ------------------------------
    Com services seemed ok . Someone had mangled Com Services and he said
    fixing that fixed it.
    -------------------------
    Server extensions checked out Ok
    -------------------------------------
    no errors in event log
    -----------------------
    Win Security on c:\inetpub and below open for vs dev account and
    IUSR...full control.
    ------------------------
    Went to IIS right click on "Default web site" properties --> Home
    directory --> Create (actually allready had that set)
    ------------------------
    Uncheck "Run WWW in IIS 5 isolation mode" <- Actually could not find
    that option in IIS 5.1 mmc snap in.
    -----------------------
     
    gerr, Feb 3, 2005
    #1
    1. Advertising

  2. You shouldn't have uninstalled anything. .Net works in such a way that you
    can (and probably should, for backwards-compatibility) have several
    different versions of the Framework on the same machine. If you wanted to
    uninstall VS.Net 2002, you could have uninstalled that without uninstalling
    the Framework. .Net Framework applications use the version of the Framework
    that they were built for.

    Typically (at least from my multiple experiences) you would simply install
    VS.Net 2003, which would also install the Framework, as well as set up
    ASP.on your IIS, all without your intervention. It's really fairly simple.

    --
    HTH,

    Kevin Spencer
    Microsoft MVP
    ..Net Developer
    Neither a follower nor a lender be.

    "gerr" <> wrote in message
    news:...
    > Visual studio 2003 "HTTP/1.1 500 Internal Server Error" when trying to
    > create a new Asp.net site with Visual Studio 2003 on localServer XP
    > Pro/IIS 5.1. Everything worked fine prior to installing V/Studio 2003.
    > Was running V/Studio classic 6/Asp parallel with V/Studio 2002/aspx.
    > Anyone have any new solutions or urls' to point me to for this problem
    > short of reinstalling the local developer setup consisting of Win XP
    > OS/IIS 5.1 along with FP 2003 ? I have pretty much tried everything
    > else listed in various threads. I think my mistake was thinking the
    > installation for V/Studio 2003 was going to offer to upgrade my
    > V/Studio.net 2002, (I "assumed", since it was not a total paradyne
    > shift as it was from V/Studio 6 to V/Studio.net, that this would be the
    > case). Did I miss a step in the installation that offered to upgrade my
    > V/Studio.net version 2002/Framework 1.0x ???????
    > Anyway, I didn't de-install 2002/frwrk 1.0 first. So AFTER V/Studio
    > 2003 installation was done I add/removed programs- V/Studio 2002, plus
    > framework 1.0x...oops!
    > I guess I should have de-installed 2002/v 1.0 first.
    > Does anyone have a web server product that they are having more success
    > integrating with Asp.net 1.1x other than Microsoft's own IIS ?
    > Thanks all,
    >
    > Here are some things other developers have used (from various threads
    > around the world) to fix Microsoft's problem's integrating IIS with
    > Asp.net v.1.1.4322
    >
    > iisreset /stop
    > net user ASPNET /delete
    > aspnet_regiis -i
    > iisreset /start
    > ----------
    > 1. Uninstall .NET framework 2.
    > 2. Uninstall ISS
    > 3. Reinstall ISS with default options.
    > 4. Install VS.NET prerequisites from the VS.NET installation. Etc.
    > -----------
    > Go to "Administrative Tools"
    > - Open "Microsoft .Net 1.1 Configuration"
    > - In the new window, expand the "Runtime Security Policy"
    > - Expand "Machine", then "Code Groups", then "All_Code".
    > - Right-Click on "My_Computer_Zone" and select properties.
    > - On the "Permission Set" tab, the selected value should be "Full
    > Trust"
    > - Checked "Full Trust" was set.
    > ------------
    > checked and no web.config allready in root.
    > ------------------------------
    > Com services seemed ok . Someone had mangled Com Services and he said
    > fixing that fixed it.
    > -------------------------
    > Server extensions checked out Ok
    > -------------------------------------
    > no errors in event log
    > -----------------------
    > Win Security on c:\inetpub and below open for vs dev account and
    > IUSR...full control.
    > ------------------------
    > Went to IIS right click on "Default web site" properties --> Home
    > directory --> Create (actually allready had that set)
    > ------------------------
    > Uncheck "Run WWW in IIS 5 isolation mode" <- Actually could not find
    > that option in IIS 5.1 mmc snap in.
    > -----------------------
    >
     
    Kevin Spencer, Feb 3, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. wh
    Replies:
    2
    Views:
    601
    Cowboy \(Gregory A. Beamer\)
    Jan 16, 2004
  2. John Bonds
    Replies:
    2
    Views:
    2,821
    Amaryllis
    Aug 3, 2004
  3. gerr
    Replies:
    2
    Views:
    8,374
    sschneider
    Jul 6, 2006
  4. xman
    Replies:
    0
    Views:
    581
  5. xman
    Replies:
    1
    Views:
    666
    Victor Bazarov
    Aug 17, 2005
Loading...

Share This Page