Visual Studio cannot create or open the application because the Web server on this computer is not r

Discussion in 'ASP .Net' started by Roberto Rocco, Oct 9, 2004.

  1. Whenever I try to create a new ASP Web Page I get this message :

    "Visual Studio cannot create or open the application because the Web server
    on this computer is not running. Start the Web server before proceeding."

    Well, looking at my services I find that both WWW Publishing Services and
    IIS are started.
    I also successfully restarted both of them, but still keep getting the error
    message.

    I also did a successful re-registering of aspnet_isapi.dll using
    aspnet_regiis -i and regsvr32 aspnet_isapi.dll.
    But: Still the same error-message...

    I finally deactivated my Windows firewall (I'm running Windows XP SP 2).
    Again with no success.

    Now I ran out of ideas...

    Can anybody give me a hint?

    Thanks in advance,

    Roberto Rocco.
     
    Roberto Rocco, Oct 9, 2004
    #1
    1. Advertising

  2. Open the IIS MMC under Web Site Properties/Home Directory Tab, check that
    Application Protection level. Try running the web site in Low (IIS Process)
    level.


    "Roberto Rocco" <> wrote in message
    news:%...
    > Whenever I try to create a new ASP Web Page I get this message :
    >
    > "Visual Studio cannot create or open the application because the Web
    > server on this computer is not running. Start the Web server before
    > proceeding."
    >
    > Well, looking at my services I find that both WWW Publishing Services and
    > IIS are started.
    > I also successfully restarted both of them, but still keep getting the
    > error message.
    >
    > I also did a successful re-registering of aspnet_isapi.dll using
    > aspnet_regiis -i and regsvr32 aspnet_isapi.dll.
    > But: Still the same error-message...
    >
    > I finally deactivated my Windows firewall (I'm running Windows XP SP 2).
    > Again with no success.
    >
    > Now I ran out of ideas...
    >
    > Can anybody give me a hint?
    >
    > Thanks in advance,
    >
    > Roberto Rocco.
    >
    >
    >
    >
    >
    >
    >
    >
    >
    >
    >
     
    Gavin Chapman, Oct 9, 2004
    #2
    1. Advertising

  3. Hello Gavin,

    thank you for your reply. I made a little progress, but still having
    problems:
    Here's my status:

    Following your suggestion I opened the IIS MMC under Web Site
    Properties/Home Directory Tab and checked the
    Application Protection level. It was set to "middle". I set it to low and
    with this setting I can access simple html with localhost.
    BUT: I still cannot enter http://localhost or create an new ASP project.

    BTW: After restarting the IIS the protection level wa set back to middle! Do
    I have to do something else to make the setting permanent?

    Finally, I looked at the event log and actually there's an error entry
    saying:
    "Event-ID 7034: The COM+ System Application service terminated unexpectedly.
    It has done this 3 time(s)."

    So might the COM+ System Application Servive be the reason? Or is the event
    log entry misleading here?

    May thanks in advance for every hint,

    Roberto Rocco.


    "Gavin Chapman" <> schrieb im Newsbeitrag
    news:41685263$...
    > Open the IIS MMC under Web Site Properties/Home Directory Tab, check that
    > Application Protection level. Try running the web site in Low (IIS
    > Process) level.
    >
    >
    > "Roberto Rocco" <> wrote in message
    > news:%...
    >> Whenever I try to create a new ASP Web Page I get this message :
    >>
    >> "Visual Studio cannot create or open the application because the Web
    >> server on this computer is not running. Start the Web server before
    >> proceeding."
    >>
    >> Well, looking at my services I find that both WWW Publishing Services and
    >> IIS are started.
    >> I also successfully restarted both of them, but still keep getting the
    >> error message.
    >>
    >> I also did a successful re-registering of aspnet_isapi.dll using
    >> aspnet_regiis -i and regsvr32 aspnet_isapi.dll.
    >> But: Still the same error-message...
    >>
    >> I finally deactivated my Windows firewall (I'm running Windows XP SP 2).
    >> Again with no success.
    >>
    >> Now I ran out of ideas...
    >>
    >> Can anybody give me a hint?
    >>
    >> Thanks in advance,
    >>
    >> Roberto Rocco.
    >>
    >>
    >>
    >>
    >>
    >>
    >>
    >>
    >>
    >>
    >>

    >
    >
     
    Roberto Rocco, Oct 10, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Matthew Louden
    Replies:
    1
    Views:
    3,845
    Felix Wang
    Jan 10, 2004
  2. wh
    Replies:
    2
    Views:
    597
    Cowboy \(Gregory A. Beamer\)
    Jan 16, 2004
  3. res
    Replies:
    0
    Views:
    449
  4. Thirumalai
    Replies:
    0
    Views:
    751
    Thirumalai
    May 22, 2006
  5. rockdale
    Replies:
    1
    Views:
    696
    Juan T. Llibre
    Aug 23, 2006
Loading...

Share This Page