VS2008 - Localhost debug ...

Discussion in 'ASP .Net' started by Michael Tissington, Apr 20, 2008.

  1. Michael Tissington, Apr 20, 2008
    #1
    1. Advertising

  2. "Michael Tissington" <> wrote in message
    news:%...
    > Recently upgraded to VS 2008 and trying to debug a web application.
    >
    > When I start the application the url is something like
    >
    > http://localhost:nnn/project_name/default.aspx
    >
    > This is new and causes my web to fail because of the project_name embedded
    > in the url.
    >
    > How do I get the url to be like
    >
    > http://localhost:nnnn/default.aspx ?
    >



    I don't know of a way to make the development web server serve a project as
    its root.

    I would tend to seek ways to make the app work in both scenarios by making
    use of ~/ prefixed urls where an absolute path in to the application is
    needed and using relative URLs where reasonable.

    Alternatively you can use IIS for debugging you just need to attach to the
    appropriate process to debug managed code.


    --
    Anthony Jones - MVP ASP/ASP.NET
    Anthony Jones, Apr 20, 2008
    #2
    1. Advertising

  3. re:
    !> How do I get the url to be like
    !> http://localhost:nnnn/default.aspx ?

    Hi, Michael.

    In your Website's project's Solution Explorer, highlight the Project's name,
    right-click it and select "Property Pages" from the dropdown menu.

    Then, selct the "Start URL" radio button, and write : http://localhost/ in the texbox.
    OK out of that dialog...and right-click default.aspx, and then "View in browser".

    The URL should have the format you want : http://localhost:nnnn/default.aspx




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Michael Tissington" <> wrote in message news:%...
    > Recently upgraded to VS 2008 and trying to debug a web application.
    >
    > When I start the application the url is something like
    >
    > http://localhost:nnn/project_name/default.aspx
    >
    > This is new and causes my web to fail because of the project_name embedded in the url.
    >
    > How do I get the url to be like
    >
    > http://localhost:nnnn/default.aspx ?
    >
    > Thanks...
    Juan T. Llibre, Apr 20, 2008
    #3
  4. re:
    !> select "Property Pages" from the dropdown menu.
    !> Then, select the "Start URL" radio button

    There should have been an intermediate step :

    Select "Start Options" in the left menu, if the Property Pages don't default to it.

    *Then* you can select the "Start URL" radio button.

    Sorry if I wan't clear enough.
    In any case, that's all you need to do.



    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Juan T. Llibre" <> wrote in message news:%...
    > re:
    > !> How do I get the url to be like
    > !> http://localhost:nnnn/default.aspx ?
    >
    > Hi, Michael.
    >
    > In your Website's project's Solution Explorer, highlight the Project's name,
    > right-click it and select "Property Pages" from the dropdown menu.
    >
    > Then, selct the "Start URL" radio button, and write : http://localhost/ in the texbox.
    > OK out of that dialog...and right-click default.aspx, and then "View in browser".
    >
    > The URL should have the format you want : http://localhost:nnnn/default.aspx
    >
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ======================================
    > "Michael Tissington" <> wrote in message news:%...
    >> Recently upgraded to VS 2008 and trying to debug a web application.
    >>
    >> When I start the application the url is something like
    >>
    >> http://localhost:nnn/project_name/default.aspx
    >>
    >> This is new and causes my web to fail because of the project_name embedded in the url.
    >>
    >> How do I get the url to be like
    >>
    >> http://localhost:nnnn/default.aspx ?
    >>
    >> Thanks...

    >
    >
    Juan T. Llibre, Apr 20, 2008
    #4
  5. Thanks for the idea about ~/ ... however this only works for server
    components, and I can not use it for things like href ...
    Michael Tissington, Apr 20, 2008
    #5
  6. Thanks for the idea about ~/ unfortunately this only works for server
    components ...

    This has only become a problem in VS 2008, in VS2005 it worked correctly
    .....

    I can't imagine why they changed this ???
    Michael Tissington, Apr 20, 2008
    #6
  7. re:
    !> I can't imagine why they changed this ???

    Nothing's changed.
    Follow the instructions I posted, and you'll have the exact behavior you want to have.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Michael Tissington" <> wrote in message news:...
    > Thanks for the idea about ~/ unfortunately this only works for server components ...
    >
    > This has only become a problem in VS 2008, in VS2005 it worked correctly ....
    >
    > I can't imagine why they changed this ???
    Juan T. Llibre, Apr 20, 2008
    #7
  8. Juan,

    I tried what you suggested and it did not help - exactly the same issue!
    Michael Tissington, Apr 20, 2008
    #8
  9. re:
    !> I tried what you suggested and it did not help - exactly the same issue!

    Then the problem is not the URL in question.
    The instructins I gave you *do* work to get a base URL.

    What is the error message displayed ?




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Michael Tissington" <> wrote in message news:%...
    > Juan,
    >
    > I tried what you suggested and it did not help - exactly the same issue!
    Juan T. Llibre, Apr 20, 2008
    #9
  10. No error is displayed, I get exactly the same results, to see if it was
    something in my website I have even tried creating a brand new website and
    after setting the startup options as you suggested I still get the
    following.

    http://localhost:nnn/<project>/default.aspx
    Michael Tissington, Apr 20, 2008
    #10
  11. Very strange - this is what I have things set to :(
    Michael Tissington, Apr 20, 2008
    #11
  12. Stranger still ... I can put anything (http://foo/) in the start url and it
    seems to be ignored ...
    Michael Tissington, Apr 20, 2008
    #12
  13. Both "localhost" and "YourMachineName", in the "Start URL",
    should provide base URLs using localhost.

    Do you have a "localhost" entry in your HOSTS file, pointing to 127.0.0.1 ?

    The HOSTS file is found in :

    Drive:\WINDOWS\system32\drivers\etc

    If you've never used it, you may only have a HOSTS.SAM file.

    Load it in Notepad, save it as hosts ( no txt extension ) and add this line to it :

    127.0.0.1 localhost

    Then, try again.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Michael Tissington" <> wrote in message news:uU%...
    > Very strange - this is what I have things set to :(
    Juan T. Llibre, Apr 21, 2008
    #13
  14. Thanks for you help with this ...

    Yes I already had a HOSTS file with the correct entry for localhost ...
    If I open IE and enter http://localhost I get the default page for IIS 7.
    Michael Tissington, Apr 21, 2008
    #14
  15. OK, I totally uninstalled VS 2008, and then reinstalled it and now it works
    correctly.

    Thanks for your help.
    Michael Tissington, Apr 21, 2008
    #15
  16. The simplest - and most reliable -- solution is to *NOT* use the built-in
    development server, and instead use IIS. In the property sheet for "Web"
    select IIS and click the button to create a an application root for your
    solution. The resultant url would then be

    http://localhost/myappname/default.aspx

    -- Peter
    To be a success, arm yourself with the tools you need and learn how to use
    them.

    Site: http://www.eggheadcafe.com
    http://petesbloggerama.blogspot.com
    http://ittyurl.net


    "Michael Tissington" wrote:

    > Recently upgraded to VS 2008 and trying to debug a web application.
    >
    > When I start the application the url is something like
    >
    > http://localhost:nnn/project_name/default.aspx
    >
    > This is new and causes my web to fail because of the project_name embedded
    > in the url.
    >
    > How do I get the url to be like
    >
    > http://localhost:nnnn/default.aspx ?
    >
    > Thanks...
    >
    >
    Peter Bromberg [C# MVP], Apr 21, 2008
    #16
  17. Hi Michael,

    It seems you've got what you want. Just some further clarity on this:

    If you're using Visual Studio test server for ASP.NET web site project in
    VS 2008, you can customize the port number and virtual path used by the
    test server. Just follow the below steps:

    **select your project(website) node in solution explorer

    ** in the property window you can find the "port number" and "virutal path"
    properties. You can customize to the value you want.

    Sincerely,

    Steven Cheng

    Microsoft MSDN Online Support Lead


    Delighting our customers is our #1 priority. We welcome your comments and
    suggestions about how we can improve the support we provide to you. Please
    feel free to let my manager know what you think of the level of service
    provided. You can send feedback directly to my manager at:
    .

    ==================================================
    Get notification to my posts through email? Please refer to
    http://msdn.microsoft.com/subscriptions/managednewsgroups/default.aspx#notif
    ications.

    ==================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.


    --------------------
    >From: "Michael Tissington" <>
    >In-Reply-To: <>
    >Subject: Re: VS2008 - Localhost debug ...
    >Date: Sun, 20 Apr 2008 16:39:54 -0700


    >
    >OK, I totally uninstalled VS 2008, and then reinstalled it and now it

    works
    >correctly.
    >
    >Thanks for your help.
    >
    >
    Steven Cheng [MSFT], Apr 21, 2008
    #17
  18. re:
    !> reinstalled it and now it works correctly.

    Whew !

    Glad you got rid of the problem.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Michael Tissington" <> wrote in message news:eXwgW$...
    > OK, I totally uninstalled VS 2008, and then reinstalled it and now it works correctly.
    >
    > Thanks for your help.
    Juan T. Llibre, Apr 21, 2008
    #18
  19. re:
    !> The resultant url would then be
    !> http://localhost/myappname/default.aspx

    Peter,

    I think his main focus was on getting rid of the directory name
    because his application would run as a root app on his server
    and he wanted to debug the app, in development, as a root-based URL.

    i.e., while debugging, he wanted a URL like this :

    http://localhost/default.aspx





    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Peter Bromberg [C# MVP]" <> wrote in message
    news:...
    > The simplest - and most reliable -- solution is to *NOT* use the built-in
    > development server, and instead use IIS. In the property sheet for "Web"
    > select IIS and click the button to create a an application root for your
    > solution. The resultant url would then be
    >
    > http://localhost/myappname/default.aspx
    >
    > -- Peter
    > To be a success, arm yourself with the tools you need and learn how to use
    > them.
    >
    > Site: http://www.eggheadcafe.com
    > http://petesbloggerama.blogspot.com
    > http://ittyurl.net
    >
    >
    > "Michael Tissington" wrote:
    >
    >> Recently upgraded to VS 2008 and trying to debug a web application.
    >>
    >> When I start the application the url is something like
    >>
    >> http://localhost:nnn/project_name/default.aspx
    >>
    >> This is new and causes my web to fail because of the project_name embedded
    >> in the url.
    >>
    >> How do I get the url to be like
    >>
    >> http://localhost:nnnn/default.aspx ?
    >>
    >> Thanks...
    >>
    >>
    Juan T. Llibre, Apr 21, 2008
    #19
  20. Hey guys,

    you dont need to do any of that... its very simple.
    Just highlight the project name at the top of the solutions explorer.
    You should see the properties box highlight underneath the solutions
    explorer.. if not you need to add this toolbar under tools.

    Just change the 'Virtual path' to '/' and run debug and bobs your uncle!
    Dont use 'Start URL' under startup options as someone said above... this
    will only confuse matters.



    *** Sent via Developersdex http://www.developersdex.com ***
    Random random, May 15, 2008
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jiong Feng
    Replies:
    0
    Views:
    798
    Jiong Feng
    Nov 19, 2003
  2. Alex
    Replies:
    4
    Views:
    555
    Hasani Blackwell
    Feb 8, 2005
  3. =?Utf-8?B?S2VuTGVl?=
    Replies:
    5
    Views:
    2,690
  4. EdwardH

    Localhost isn't localhost

    EdwardH, Sep 29, 2005, in forum: Java
    Replies:
    20
    Views:
    6,360
    Roedy Green
    Oct 1, 2005
  5. =?Utf-8?B?cm9kY2hhcg==?=

    vs2008 deploy to localhost

    =?Utf-8?B?cm9kY2hhcg==?=, Nov 7, 2007, in forum: ASP .Net
    Replies:
    13
    Views:
    695
    Juan T. Llibre
    Nov 8, 2007
Loading...

Share This Page