Web caching problem in request/response pages

Discussion in 'ASP General' started by John Hoge, Jul 14, 2003.

  1. John Hoge

    John Hoge Guest

    I have a set of pages which seems to produce very wierd errors:

    pagea.htm contains a form which posts to pageb.asp

    pageB.asp contains a script that works fine in response to this post,
    but produces an error when called by a GET method without passing any
    parameters. Since there is no link to pageB.asp, and it's unlikely
    that a visitor will type this URL in out of the blue, I didn't expect
    to see this error messages. Somehow it's popping up in my logs.

    Do most firewalles know not to cache a file with an .asp extention?
    Anybody have any other ideas as to what might be causing this?

    Thanks,
    John
     
    John Hoge, Jul 14, 2003
    #1
    1. Advertising

  2. Did you put any form validation on the posting page? This might stop
    crawlers and people from submitting bad data.

    -Andrew

    * * * Sent via DevBuilder http://www.devbuilder.org * * *
    Developer Resources for High End Developers.
     
    Andrew Durstewitz, Jul 14, 2003
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Hypo
    Replies:
    6
    Views:
    423
  2. Replies:
    1
    Views:
    6,286
    Ryan Stewart
    Dec 29, 2004
  3. Nathan Sokalski
    Replies:
    5
    Views:
    1,030
    Gaurav Vaish \(www.Edujini-Labs.com\)
    Jan 10, 2007
  4. Nathan Sokalski
    Replies:
    4
    Views:
    305
    Nathan Sokalski
    Dec 21, 2006
  5. Nathan Sokalski
    Replies:
    4
    Views:
    342
    Nathan Sokalski
    Dec 21, 2006
Loading...

Share This Page