Web.Config - customErrors

Discussion in 'ASP .Net' started by John Smith, May 11, 2004.

  1. John Smith

    John Smith Guest

    I am trying to implement custom error pages and I get this error message:

    ****************************************************************************
    ********
    ****************************************************************************
    ********
    Server Error in '/mfg' Application.
    ----------------------------------------------------------------------------
    ----

    Runtime Error
    Description: An application error occurred on the server. The current custom
    error settings for this application prevent the details of the application
    error from being viewed.

    Details: To enable the details of this specific error message to be viewable
    on the local server machine, please create a <customErrors> tag within a
    "web.config" configuration file located in the root directory of the current
    web application. This <customErrors> tag should then have its "mode"
    attribute set to "RemoteOnly". To enable the details to be viewable on
    remote machines, please set "mode" to "Off".


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly"/>
    </system.web>
    </configuration>


    Notes: The current error page you are seeing can be replaced by a custom
    error page by modifying the "defaultRedirect" attribute of the application's
    <customErrors> configuration tag to point to a custom error page URL.


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>
    ****************************************************************************
    ********
    ****************************************************************************
    ********

    My my customErrors tag in the Web.Config file looks like this:

    <customErrors defaultRedirect="errors.aspx" mode="On"/>

    I am working directly on the server (Win2k). Any ideas?

    Thanx.
     
    John Smith, May 11, 2004
    #1
    1. Advertising

  2. John Smith

    Ben Dewey Guest

    If you change your customErrors to Off with no defaultRedirect, do you still
    get an error?

    If not, try switching the order of the defaultRedirect and mode attributes.
    Its a long shot but it might work. Let me know how it works out.


    "John Smith" <> wrote in message
    news:O$...
    > I am trying to implement custom error pages and I get this error message:
    >
    >

    ****************************************************************************
    > ********
    >

    ****************************************************************************
    > ********
    > Server Error in '/mfg' Application.
    > --------------------------------------------------------------------------

    --
    > ----
    >
    > Runtime Error
    > Description: An application error occurred on the server. The current

    custom
    > error settings for this application prevent the details of the application
    > error from being viewed.
    >
    > Details: To enable the details of this specific error message to be

    viewable
    > on the local server machine, please create a <customErrors> tag within a
    > "web.config" configuration file located in the root directory of the

    current
    > web application. This <customErrors> tag should then have its "mode"
    > attribute set to "RemoteOnly". To enable the details to be viewable on
    > remote machines, please set "mode" to "Off".
    >
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="RemoteOnly"/>
    > </system.web>
    > </configuration>
    >
    >
    > Notes: The current error page you are seeing can be replaced by a custom
    > error page by modifying the "defaultRedirect" attribute of the

    application's
    > <customErrors> configuration tag to point to a custom error page URL.
    >
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
    > </system.web>
    > </configuration>
    >

    ****************************************************************************
    > ********
    >

    ****************************************************************************
    > ********
    >
    > My my customErrors tag in the Web.Config file looks like this:
    >
    > <customErrors defaultRedirect="errors.aspx" mode="On"/>
    >
    > I am working directly on the server (Win2k). Any ideas?
    >
    > Thanx.
    >
    >
    >
     
    Ben Dewey, May 11, 2004
    #2
    1. Advertising

  3. John Smith

    John Smith Guest

    I made a change to my customErrors tag to:

    <customErrors defaultRedirect="errors.aspx" mode="RemoteOnly"/>

    I tested with just an HTML file and it worked okay. I eliminated the the
    web.config as the problem it is now within my code. I found out that I am
    actually having a problem with this code:

    ****************************************************************************
    Private Sub Page_Load(ByVal sender As System.Object, ByVal e As
    System.EventArgs) Handles MyBase.Load
    '*** UserID Works fine ***
    Dim UserID As Integer = Session("UserID")
    Response.Write("UserID = " & UserID & "<BR>")

    '*** Problem resides in here ***
    Dim ErrorMessage As String = Server.GetLastError.ToString
    Response.Write("ErrorMessage = " & ErrorMessage & "<BR>")

    End Sub
    ****************************************************************************

    Any ideas on what I am doing wrong?

    Thanx


    "Ben Dewey" <> wrote in message
    news:%...
    > If you change your customErrors to Off with no defaultRedirect, do you

    still
    > get an error?
    >
    > If not, try switching the order of the defaultRedirect and mode

    attributes.
    > Its a long shot but it might work. Let me know how it works out.
    >
    >
    > "John Smith" <> wrote in message
    > news:O$...
    > > I am trying to implement custom error pages and I get this error

    message:
    > >
    > >

    >

    ****************************************************************************
    > > ********
    > >

    >

    ****************************************************************************
    > > ********
    > > Server Error in '/mfg' Application.

    >
    > --------------------------------------------------------------------------
    > --
    > > ----
    > >
    > > Runtime Error
    > > Description: An application error occurred on the server. The current

    > custom
    > > error settings for this application prevent the details of the

    application
    > > error from being viewed.
    > >
    > > Details: To enable the details of this specific error message to be

    > viewable
    > > on the local server machine, please create a <customErrors> tag within a
    > > "web.config" configuration file located in the root directory of the

    > current
    > > web application. This <customErrors> tag should then have its "mode"
    > > attribute set to "RemoteOnly". To enable the details to be viewable on
    > > remote machines, please set "mode" to "Off".
    > >
    > >
    > > <!-- Web.Config Configuration File -->
    > >
    > > <configuration>
    > > <system.web>
    > > <customErrors mode="RemoteOnly"/>
    > > </system.web>
    > > </configuration>
    > >
    > >
    > > Notes: The current error page you are seeing can be replaced by a custom
    > > error page by modifying the "defaultRedirect" attribute of the

    > application's
    > > <customErrors> configuration tag to point to a custom error page URL.
    > >
    > >
    > > <!-- Web.Config Configuration File -->
    > >
    > > <configuration>
    > > <system.web>
    > > <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
    > > </system.web>
    > > </configuration>
    > >

    >

    ****************************************************************************
    > > ********
    > >

    >

    ****************************************************************************
    > > ********
    > >
    > > My my customErrors tag in the Web.Config file looks like this:
    > >
    > > <customErrors defaultRedirect="errors.aspx" mode="On"/>
    > >
    > > I am working directly on the server (Win2k). Any ideas?
    > >
    > > Thanx.
    > >
    > >
    > >

    >
    >
     
    John Smith, May 11, 2004
    #3
  4. John Smith

    Ben Dewey Guest

    You need to check the Server.GetLastError before you call ToString on it.

    Example:
    If Server.GetLastError Is Nothing = False Then
    Dim ErrorMessage As String = Server.GetLastError.ToString()
    Response.Write("ErrorMessage = " & ErrorMessage & "<BR>")
    End If


    "John Smith" <> wrote in message
    news:...
    > I made a change to my customErrors tag to:
    >
    > <customErrors defaultRedirect="errors.aspx" mode="RemoteOnly"/>
    >
    > I tested with just an HTML file and it worked okay. I eliminated the the
    > web.config as the problem it is now within my code. I found out that I am
    > actually having a problem with this code:
    >
    >

    ****************************************************************************
    > Private Sub Page_Load(ByVal sender As System.Object, ByVal e As
    > System.EventArgs) Handles MyBase.Load
    > '*** UserID Works fine ***
    > Dim UserID As Integer = Session("UserID")
    > Response.Write("UserID = " & UserID & "<BR>")
    >
    > '*** Problem resides in here ***
    > Dim ErrorMessage As String = Server.GetLastError.ToString
    > Response.Write("ErrorMessage = " & ErrorMessage & "<BR>")
    >
    > End Sub
    >

    ****************************************************************************
    >
    > Any ideas on what I am doing wrong?
    >
    > Thanx
    >
    >
    > "Ben Dewey" <> wrote in message
    > news:%...
    > > If you change your customErrors to Off with no defaultRedirect, do you

    > still
    > > get an error?
    > >
    > > If not, try switching the order of the defaultRedirect and mode

    > attributes.
    > > Its a long shot but it might work. Let me know how it works out.
    > >
    > >
    > > "John Smith" <> wrote in message
    > > news:O$...
    > > > I am trying to implement custom error pages and I get this error

    > message:
    > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > ********
    > > >

    > >

    >

    ****************************************************************************
    > > > ********
    > > > Server Error in '/mfg' Application.

    > >

    >
    > --------------------------------------------------------------------------
    > > --
    > > > ----
    > > >
    > > > Runtime Error
    > > > Description: An application error occurred on the server. The current

    > > custom
    > > > error settings for this application prevent the details of the

    > application
    > > > error from being viewed.
    > > >
    > > > Details: To enable the details of this specific error message to be

    > > viewable
    > > > on the local server machine, please create a <customErrors> tag within

    a
    > > > "web.config" configuration file located in the root directory of the

    > > current
    > > > web application. This <customErrors> tag should then have its "mode"
    > > > attribute set to "RemoteOnly". To enable the details to be viewable on
    > > > remote machines, please set "mode" to "Off".
    > > >
    > > >
    > > > <!-- Web.Config Configuration File -->
    > > >
    > > > <configuration>
    > > > <system.web>
    > > > <customErrors mode="RemoteOnly"/>
    > > > </system.web>
    > > > </configuration>
    > > >
    > > >
    > > > Notes: The current error page you are seeing can be replaced by a

    custom
    > > > error page by modifying the "defaultRedirect" attribute of the

    > > application's
    > > > <customErrors> configuration tag to point to a custom error page URL.
    > > >
    > > >
    > > > <!-- Web.Config Configuration File -->
    > > >
    > > > <configuration>
    > > > <system.web>
    > > > <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
    > > > </system.web>
    > > > </configuration>
    > > >

    > >

    >

    ****************************************************************************
    > > > ********
    > > >

    > >

    >

    ****************************************************************************
    > > > ********
    > > >
    > > > My my customErrors tag in the Web.Config file looks like this:
    > > >
    > > > <customErrors defaultRedirect="errors.aspx" mode="On"/>
    > > >
    > > > I am working directly on the server (Win2k). Any ideas?
    > > >
    > > > Thanx.
    > > >
    > > >
    > > >

    > >
    > >

    >
    >
     
    Ben Dewey, May 11, 2004
    #4
  5. John Smith

    John Smith Guest

    I changed my code to check to see if it is nothing. I manually threw an
    applicationexception and it is not returning it. it is returning as
    nothing. any ideas?


    "Ben Dewey" <> wrote in message
    news:%...
    > You need to check the Server.GetLastError before you call ToString on it.
    >
    > Example:
    > If Server.GetLastError Is Nothing = False Then
    > Dim ErrorMessage As String = Server.GetLastError.ToString()
    > Response.Write("ErrorMessage = " & ErrorMessage & "<BR>")
    > End If
    >
    >
    > "John Smith" <> wrote in message
    > news:...
    > > I made a change to my customErrors tag to:
    > >
    > > <customErrors defaultRedirect="errors.aspx" mode="RemoteOnly"/>
    > >
    > > I tested with just an HTML file and it worked okay. I eliminated the

    the
    > > web.config as the problem it is now within my code. I found out that I

    am
    > > actually having a problem with this code:
    > >
    > >

    >

    ****************************************************************************
    > > Private Sub Page_Load(ByVal sender As System.Object, ByVal e As
    > > System.EventArgs) Handles MyBase.Load
    > > '*** UserID Works fine ***
    > > Dim UserID As Integer = Session("UserID")
    > > Response.Write("UserID = " & UserID & "<BR>")
    > >
    > > '*** Problem resides in here ***
    > > Dim ErrorMessage As String = Server.GetLastError.ToString
    > > Response.Write("ErrorMessage = " & ErrorMessage & "<BR>")
    > >
    > > End Sub
    > >

    >

    ****************************************************************************
    > >
    > > Any ideas on what I am doing wrong?
    > >
    > > Thanx
    > >
    > >
    > > "Ben Dewey" <> wrote in message
    > > news:%...
    > > > If you change your customErrors to Off with no defaultRedirect, do you

    > > still
    > > > get an error?
    > > >
    > > > If not, try switching the order of the defaultRedirect and mode

    > > attributes.
    > > > Its a long shot but it might work. Let me know how it works out.
    > > >
    > > >
    > > > "John Smith" <> wrote in message
    > > > news:O$...
    > > > > I am trying to implement custom error pages and I get this error

    > > message:
    > > > >
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > > ********
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > > ********
    > > > > Server Error in '/mfg' Application.
    > > >

    > >

    >
    > --------------------------------------------------------------------------
    > > > --
    > > > > ----
    > > > >
    > > > > Runtime Error
    > > > > Description: An application error occurred on the server. The

    current
    > > > custom
    > > > > error settings for this application prevent the details of the

    > > application
    > > > > error from being viewed.
    > > > >
    > > > > Details: To enable the details of this specific error message to be
    > > > viewable
    > > > > on the local server machine, please create a <customErrors> tag

    within
    > a
    > > > > "web.config" configuration file located in the root directory of the
    > > > current
    > > > > web application. This <customErrors> tag should then have its "mode"
    > > > > attribute set to "RemoteOnly". To enable the details to be viewable

    on
    > > > > remote machines, please set "mode" to "Off".
    > > > >
    > > > >
    > > > > <!-- Web.Config Configuration File -->
    > > > >
    > > > > <configuration>
    > > > > <system.web>
    > > > > <customErrors mode="RemoteOnly"/>
    > > > > </system.web>
    > > > > </configuration>
    > > > >
    > > > >
    > > > > Notes: The current error page you are seeing can be replaced by a

    > custom
    > > > > error page by modifying the "defaultRedirect" attribute of the
    > > > application's
    > > > > <customErrors> configuration tag to point to a custom error page

    URL.
    > > > >
    > > > >
    > > > > <!-- Web.Config Configuration File -->
    > > > >
    > > > > <configuration>
    > > > > <system.web>
    > > > > <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
    > > > > </system.web>
    > > > > </configuration>
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > > ********
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > > ********
    > > > >
    > > > > My my customErrors tag in the Web.Config file looks like this:
    > > > >
    > > > > <customErrors defaultRedirect="errors.aspx" mode="On"/>
    > > > >
    > > > > I am working directly on the server (Win2k). Any ideas?
    > > > >
    > > > > Thanx.
    > > > >
    > > > >
    > > > >
    > > >
    > > >

    > >
    > >

    >
    >
     
    John Smith, May 11, 2004
    #5
  6. John Smith

    Ben Dewey Guest

    My mistake, you don't need to check if the error is nothing, you do, on the
    other hand, need to have the code for the Page Error in the Page_Error event
    handler.

    Example:
    Private Sub Page_Load(ByVal sender As System.Object, ByVal e As
    System.EventArgs) Handles MyBase.Load
    Call throwAnError()
    End Sub

    Private Sub throwAnError()
    Throw New ApplicationException("some error")
    End Sub

    Private Sub Page_Error(ByVal sender As Object, ByVal e As System.EventArgs)
    Handles MyBase.Error
    Dim ErrorMessage As String = Server.GetLastError.Message
    Response.Write("ErrorMessage = " & ErrorMessage & "<BR>")
    End Sub


    "John Smith" <> wrote in message
    news:...
    > I changed my code to check to see if it is nothing. I manually threw an
    > applicationexception and it is not returning it. it is returning as
    > nothing. any ideas?
    >
    >
    > "Ben Dewey" <> wrote in message
    > news:%...
    > > You need to check the Server.GetLastError before you call ToString on

    it.
    > >
    > > Example:
    > > If Server.GetLastError Is Nothing = False Then
    > > Dim ErrorMessage As String = Server.GetLastError.ToString()
    > > Response.Write("ErrorMessage = " & ErrorMessage & "<BR>")
    > > End If
    > >
    > >
    > > "John Smith" <> wrote in message
    > > news:...
    > > > I made a change to my customErrors tag to:
    > > >
    > > > <customErrors defaultRedirect="errors.aspx" mode="RemoteOnly"/>
    > > >
    > > > I tested with just an HTML file and it worked okay. I eliminated the

    > the
    > > > web.config as the problem it is now within my code. I found out that

    I
    > am
    > > > actually having a problem with this code:
    > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > Private Sub Page_Load(ByVal sender As System.Object, ByVal e As
    > > > System.EventArgs) Handles MyBase.Load
    > > > '*** UserID Works fine ***
    > > > Dim UserID As Integer = Session("UserID")
    > > > Response.Write("UserID = " & UserID & "<BR>")
    > > >
    > > > '*** Problem resides in here ***
    > > > Dim ErrorMessage As String = Server.GetLastError.ToString
    > > > Response.Write("ErrorMessage = " & ErrorMessage & "<BR>")
    > > >
    > > > End Sub
    > > >

    > >

    >

    ****************************************************************************
    > > >
    > > > Any ideas on what I am doing wrong?
    > > >
    > > > Thanx
    > > >
    > > >
    > > > "Ben Dewey" <> wrote in message
    > > > news:%...
    > > > > If you change your customErrors to Off with no defaultRedirect, do

    you
    > > > still
    > > > > get an error?
    > > > >
    > > > > If not, try switching the order of the defaultRedirect and mode
    > > > attributes.
    > > > > Its a long shot but it might work. Let me know how it works out.
    > > > >
    > > > >
    > > > > "John Smith" <> wrote in message
    > > > > news:O$...
    > > > > > I am trying to implement custom error pages and I get this error
    > > > message:
    > > > > >
    > > > > >
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > > > ********
    > > > > >
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > > > ********
    > > > > > Server Error in '/mfg' Application.
    > > > >
    > > >

    > >

    >
    > --------------------------------------------------------------------------
    > > > > --
    > > > > > ----
    > > > > >
    > > > > > Runtime Error
    > > > > > Description: An application error occurred on the server. The

    > current
    > > > > custom
    > > > > > error settings for this application prevent the details of the
    > > > application
    > > > > > error from being viewed.
    > > > > >
    > > > > > Details: To enable the details of this specific error message to

    be
    > > > > viewable
    > > > > > on the local server machine, please create a <customErrors> tag

    > within
    > > a
    > > > > > "web.config" configuration file located in the root directory of

    the
    > > > > current
    > > > > > web application. This <customErrors> tag should then have its

    "mode"
    > > > > > attribute set to "RemoteOnly". To enable the details to be

    viewable
    > on
    > > > > > remote machines, please set "mode" to "Off".
    > > > > >
    > > > > >
    > > > > > <!-- Web.Config Configuration File -->
    > > > > >
    > > > > > <configuration>
    > > > > > <system.web>
    > > > > > <customErrors mode="RemoteOnly"/>
    > > > > > </system.web>
    > > > > > </configuration>
    > > > > >
    > > > > >
    > > > > > Notes: The current error page you are seeing can be replaced by a

    > > custom
    > > > > > error page by modifying the "defaultRedirect" attribute of the
    > > > > application's
    > > > > > <customErrors> configuration tag to point to a custom error page

    > URL.
    > > > > >
    > > > > >
    > > > > > <!-- Web.Config Configuration File -->
    > > > > >
    > > > > > <configuration>
    > > > > > <system.web>
    > > > > > <customErrors mode="On"

    defaultRedirect="mycustompage.htm"/>
    > > > > > </system.web>
    > > > > > </configuration>
    > > > > >
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > > > ********
    > > > > >
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > > > ********
    > > > > >
    > > > > > My my customErrors tag in the Web.Config file looks like this:
    > > > > >
    > > > > > <customErrors defaultRedirect="errors.aspx" mode="On"/>
    > > > > >
    > > > > > I am working directly on the server (Win2k). Any ideas?
    > > > > >
    > > > > > Thanx.
    > > > > >
    > > > > >
    > > > > >
    > > > >
    > > > >
    > > >
    > > >

    > >
    > >

    >
    >
     
    Ben Dewey, May 11, 2004
    #6
  7. John Smith

    John Smith Guest

    Thanx that works good, but I found another solution. I added
    Server.Transfer("customerror.aspx") in the Application_Error in the
    global.asax file.

    Thanx for all of your help.

    "Ben Dewey" <> wrote in message
    news:...
    > My mistake, you don't need to check if the error is nothing, you do, on

    the
    > other hand, need to have the code for the Page Error in the Page_Error

    event
    > handler.
    >
    > Example:
    > Private Sub Page_Load(ByVal sender As System.Object, ByVal e As
    > System.EventArgs) Handles MyBase.Load
    > Call throwAnError()
    > End Sub
    >
    > Private Sub throwAnError()
    > Throw New ApplicationException("some error")
    > End Sub
    >
    > Private Sub Page_Error(ByVal sender As Object, ByVal e As

    System.EventArgs)
    > Handles MyBase.Error
    > Dim ErrorMessage As String = Server.GetLastError.Message
    > Response.Write("ErrorMessage = " & ErrorMessage & "<BR>")
    > End Sub
    >
    >
    > "John Smith" <> wrote in message
    > news:...
    > > I changed my code to check to see if it is nothing. I manually threw an
    > > applicationexception and it is not returning it. it is returning as
    > > nothing. any ideas?
    > >
    > >
    > > "Ben Dewey" <> wrote in message
    > > news:%...
    > > > You need to check the Server.GetLastError before you call ToString on

    > it.
    > > >
    > > > Example:
    > > > If Server.GetLastError Is Nothing = False Then
    > > > Dim ErrorMessage As String = Server.GetLastError.ToString()
    > > > Response.Write("ErrorMessage = " & ErrorMessage & "<BR>")
    > > > End If
    > > >
    > > >
    > > > "John Smith" <> wrote in message
    > > > news:...
    > > > > I made a change to my customErrors tag to:
    > > > >
    > > > > <customErrors defaultRedirect="errors.aspx" mode="RemoteOnly"/>
    > > > >
    > > > > I tested with just an HTML file and it worked okay. I eliminated

    the
    > > the
    > > > > web.config as the problem it is now within my code. I found out

    that
    > I
    > > am
    > > > > actually having a problem with this code:
    > > > >
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > > Private Sub Page_Load(ByVal sender As System.Object, ByVal e As
    > > > > System.EventArgs) Handles MyBase.Load
    > > > > '*** UserID Works fine ***
    > > > > Dim UserID As Integer = Session("UserID")
    > > > > Response.Write("UserID = " & UserID & "<BR>")
    > > > >
    > > > > '*** Problem resides in here ***
    > > > > Dim ErrorMessage As String = Server.GetLastError.ToString
    > > > > Response.Write("ErrorMessage = " & ErrorMessage & "<BR>")
    > > > >
    > > > > End Sub
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > >
    > > > > Any ideas on what I am doing wrong?
    > > > >
    > > > > Thanx
    > > > >
    > > > >
    > > > > "Ben Dewey" <> wrote in message
    > > > > news:%...
    > > > > > If you change your customErrors to Off with no defaultRedirect, do

    > you
    > > > > still
    > > > > > get an error?
    > > > > >
    > > > > > If not, try switching the order of the defaultRedirect and mode
    > > > > attributes.
    > > > > > Its a long shot but it might work. Let me know how it works out.
    > > > > >
    > > > > >
    > > > > > "John Smith" <> wrote in message
    > > > > > news:O$...
    > > > > > > I am trying to implement custom error pages and I get this error
    > > > > message:
    > > > > > >
    > > > > > >
    > > > > >
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > > > > ********
    > > > > > >
    > > > > >
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > > > > ********
    > > > > > > Server Error in '/mfg' Application.
    > > > > >
    > > > >
    > > >

    > >

    >
    > --------------------------------------------------------------------------
    > > > > > --
    > > > > > > ----
    > > > > > >
    > > > > > > Runtime Error
    > > > > > > Description: An application error occurred on the server. The

    > > current
    > > > > > custom
    > > > > > > error settings for this application prevent the details of the
    > > > > application
    > > > > > > error from being viewed.
    > > > > > >
    > > > > > > Details: To enable the details of this specific error message to

    > be
    > > > > > viewable
    > > > > > > on the local server machine, please create a <customErrors> tag

    > > within
    > > > a
    > > > > > > "web.config" configuration file located in the root directory of

    > the
    > > > > > current
    > > > > > > web application. This <customErrors> tag should then have its

    > "mode"
    > > > > > > attribute set to "RemoteOnly". To enable the details to be

    > viewable
    > > on
    > > > > > > remote machines, please set "mode" to "Off".
    > > > > > >
    > > > > > >
    > > > > > > <!-- Web.Config Configuration File -->
    > > > > > >
    > > > > > > <configuration>
    > > > > > > <system.web>
    > > > > > > <customErrors mode="RemoteOnly"/>
    > > > > > > </system.web>
    > > > > > > </configuration>
    > > > > > >
    > > > > > >
    > > > > > > Notes: The current error page you are seeing can be replaced by

    a
    > > > custom
    > > > > > > error page by modifying the "defaultRedirect" attribute of the
    > > > > > application's
    > > > > > > <customErrors> configuration tag to point to a custom error page

    > > URL.
    > > > > > >
    > > > > > >
    > > > > > > <!-- Web.Config Configuration File -->
    > > > > > >
    > > > > > > <configuration>
    > > > > > > <system.web>
    > > > > > > <customErrors mode="On"

    > defaultRedirect="mycustompage.htm"/>
    > > > > > > </system.web>
    > > > > > > </configuration>
    > > > > > >
    > > > > >
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > > > > ********
    > > > > > >
    > > > > >
    > > > >
    > > >

    > >

    >

    ****************************************************************************
    > > > > > > ********
    > > > > > >
    > > > > > > My my customErrors tag in the Web.Config file looks like this:
    > > > > > >
    > > > > > > <customErrors defaultRedirect="errors.aspx" mode="On"/>
    > > > > > >
    > > > > > > I am working directly on the server (Win2k). Any ideas?
    > > > > > >
    > > > > > > Thanx.
    > > > > > >
    > > > > > >
    > > > > > >
    > > > > >
    > > > > >
    > > > >
    > > > >
    > > >
    > > >

    > >
    > >

    >
    >
     
    John Smith, May 12, 2004
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Dave

    CustomErrors in Web.Config

    Dave, May 21, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    491
    Curt_C [MVP]
    May 21, 2004
  2. Kelmen Wong

    web.config customErrors cached?

    Kelmen Wong, Jul 27, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    380
    Kelmen Wong
    Aug 2, 2004
  3. Ron Weldy

    Customerrors in web.config question

    Ron Weldy, Jan 18, 2005, in forum: ASP .Net
    Replies:
    10
    Views:
    9,778
    Razvan Petcu
    Jan 25, 2005
  4. Chumley Walrus

    customerrors tag in web.config

    Chumley Walrus, Jan 22, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    13,362
    Juan T. Llibre
    Jan 22, 2005
  5. Replies:
    1
    Views:
    478
    Juan T. Llibre
    Jul 21, 2006
Loading...

Share This Page