web config ERror

Discussion in 'ASP .Net Web Services' started by Savas Ates, Dec 2, 2004.

  1. Savas Ates

    Savas Ates Guest

    my web conhig code is like this and <customErrors mode="Off"/> was set off

    <compilation defaultLanguage="vb" debug="true"/>

    <!-- CUSTOM ERROR MESSAGES
    Set customErrors mode="Off" or "RemoteOnly" to enable custom error
    messages, "Off" to disable.
    Add <error> tags for each of the errors you want to handle.
    -->
    <customErrors mode="Off"/>

    <!-- AUTHENTICATION
    This section sets the authentication policies of the application.
    Possible modes are "Windows",
    "Forms", "Passport" and "None"
    -->
    <authentication mode="Windows"/>


    <!-- AUTHORIZATION
    This section sets the authorization policies of the application.
    You can allow or deny access
    to application resources by user or role. Wildcards: "*" mean
    everyone, "?" means anonymous
    (unauthenticated) users.
    -->
    <authorization>
    <allow users="*"/> <!-- Allow all users -->

    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Runtime Error
    Description: An application error occurred on the server. The current custom
    error settings for this application prevent the details of the application
    error from being viewed remotely (for security reasons). It could, however,
    be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable
    on remote machines, please create a <customErrors> tag within a "web.config"
    configuration file located in the root directory of the current web
    application. This <customErrors> tag should then have its "mode" attribute
    set to "Off".


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>


    Notes: The current error page you are seeing can be replaced by a custom
    error page by modifying the "defaultRedirect" attribute of the application's
    <customErrors> configuration tag to point to a custom error page URL.


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>
    Savas Ates, Dec 2, 2004
    #1
    1. Advertising

  2. Savas Ates

    Dan Rogers Guest

    Hi Savas?

    Is there an issue that I can help you with? This error message is
    displayed when a web service has thrown an exception that is not caught,
    and the calling browser is not on the same machine as the web service. It
    usually indicates that there is a problem (bug?) in the program. By
    default, a stack trace is surpressed so as to not reveal too much to a
    remote caller.

    I hope this helps,

    Dan Rogers
    Microsoft Corporation
    --------------------
    >From: "Savas Ates" <>
    >Subject: web config ERror
    >Date: Thu, 2 Dec 2004 10:04:29 +0200
    >Lines: 70
    >X-Priority: 3
    >X-MSMail-Priority: Normal
    >X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    >X-RFC2646: Format=Flowed; Original
    >Message-ID: <>
    >Newsgroups: microsoft.public.dotnet.framework.aspnet.webservices
    >NNTP-Posting-Host: dsl81-215-37958.adsl.ttnet.net.tr 81.215.148.70
    >Path:

    cpmsftngxa10.phx.gbl!TK2MSFTNGXA03.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP11
    phx.gbl
    >Xref: cpmsftngxa10.phx.gbl

    microsoft.public.dotnet.framework.aspnet.webservices:26985
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.webservices
    >
    > my web conhig code is like this and <customErrors mode="Off"/> was set

    off
    >
    > <compilation defaultLanguage="vb" debug="true"/>
    >
    > <!-- CUSTOM ERROR MESSAGES
    > Set customErrors mode="Off" or "RemoteOnly" to enable custom

    error
    >messages, "Off" to disable.
    > Add <error> tags for each of the errors you want to handle.
    > -->
    > <customErrors mode="Off"/>
    >
    > <!-- AUTHENTICATION
    > This section sets the authentication policies of the

    application.
    >Possible modes are "Windows",
    > "Forms", "Passport" and "None"
    > -->
    > <authentication mode="Windows"/>
    >
    >
    > <!-- AUTHORIZATION
    > This section sets the authorization policies of the application.
    >You can allow or deny access
    > to application resources by user or role. Wildcards: "*" mean
    >everyone, "?" means anonymous
    > (unauthenticated) users.
    > -->
    > <authorization>
    > <allow users="*"/> <!-- Allow all users -->
    >
    >Server Error in '/' Application.
    >---------------------------------------------------------------------------

    -----
    >
    >Runtime Error
    >Description: An application error occurred on the server. The current

    custom
    >error settings for this application prevent the details of the application
    >error from being viewed remotely (for security reasons). It could,

    however,
    >be viewed by browsers running on the local server machine.
    >
    >Details: To enable the details of this specific error message to be

    viewable
    >on remote machines, please create a <customErrors> tag within a

    "web.config"
    >configuration file located in the root directory of the current web
    >application. This <customErrors> tag should then have its "mode" attribute
    >set to "Off".
    >
    >
    ><!-- Web.Config Configuration File -->
    >
    ><configuration>
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    ></configuration>
    >
    >
    >Notes: The current error page you are seeing can be replaced by a custom
    >error page by modifying the "defaultRedirect" attribute of the

    application's
    ><customErrors> configuration tag to point to a custom error page URL.
    >
    >
    ><!-- Web.Config Configuration File -->
    >
    ><configuration>
    > <system.web>
    > <customErrors mode="RemoteOnly"

    defaultRedirect="mycustompage.htm"/>
    > </system.web>
    ></configuration>
    >
    >
    >
    >
    >
    Dan Rogers, Dec 2, 2004
    #2
    1. Advertising

  3. Savas Ates

    Guest

    how do I get to my ''root directory" and change my ''web configuration'' and have the mode set to off I want to create a profile to be able to log onto the blockbuster.ca/getmore site ?

    **********************************************************************
    Sent via Fuzzy Software @ http://www.fuzzysoftware.com/
    Comprehensive, categorised, searchable collection of links to ASP & ASP.NET resources...
    , Dec 23, 2004
    #3
  4. Savas Ates

    Dan Rogers Guest

    Hi Jonathan,

    I'm not following you. If you need to change your web.config file, it is
    typically found in the virtual root that is serving your web service. I'm
    not sure what config changes you want to make, and I don't know what this
    has to do with blockbuster's site. If you just want to go to their web
    page and log in, you should do that.

    I tried that URL and there is very little for you to do with your root
    directory or web config file ... that is a simple cookie based portal login
    page. You won't be able to call it via a web service proxy. Just use your
    browser...

    Dan
    --------------------
    >From: Jonathan Welch ()
    >Subject: Re: web config ERror
    >References: <>
    >Message-ID: <>
    >Newsgroups: microsoft.public.dotnet.framework.aspnet.webservices
    >Date: Thu, 23 Dec 2004 12:21:23 -0800
    >NNTP-Posting-Host: shared2.orcsweb.com 66.129.69.1
    >Lines: 1
    >Path:

    cpmsftngxa10.phx.gbl!TK2MSFTFEED02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP11
    .phx.gbl
    >Xref: cpmsftngxa10.phx.gbl

    microsoft.public.dotnet.framework.aspnet.webservices:27376
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.webservices
    >
    >how do I get to my ''root directory" and change my ''web configuration''

    and have the mode set to off I want to create a profile to be able to log
    onto the blockbuster.ca/getmore site ?
    >
    >**********************************************************************
    >Sent via Fuzzy Software @ http://www.fuzzysoftware.com/
    >Comprehensive, categorised, searchable collection of links to ASP &

    ASP.NET resources...
    >
    Dan Rogers, Jan 4, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?RGFuaWVs?=

    Machine.config & web.config

    =?Utf-8?B?RGFuaWVs?=, Jan 18, 2004, in forum: ASP .Net
    Replies:
    2
    Views:
    13,268
    Hermit Dave
    Jan 18, 2004
  2. Ivan
    Replies:
    1
    Views:
    3,039
    Natty Gur
    May 21, 2004
  3. Benny Ng
    Replies:
    9
    Views:
    9,902
    Benny Ng
    Oct 13, 2005
  4. CSharpner
    Replies:
    0
    Views:
    996
    CSharpner
    Apr 9, 2007
  5. CSharpner
    Replies:
    0
    Views:
    432
    CSharpner
    Apr 19, 2004
Loading...

Share This Page