Web.config file

Discussion in 'ASP .Net' started by Murat Dikici, Nov 7, 2003.

  1. Murat Dikici

    Murat Dikici Guest

    Hello,
    The file structure on the server is:

    /FileUpload
    - Web.config
    - upload.aspx

    I try to run the upload.aspx but it gives me a runtime error message like
    this:
    ----------------
    Description: An application error occurred on the server. The current custom
    error settings for this application prevent the details of the application
    error from being viewed remotely (for security reasons). It could, however,
    be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable
    on remote machines, please create a <customErrors> tag within a "web.config"
    configuration file located in the root directory of the current web
    application. This <customErrors> tag should then have its "mode" attribute
    set to "Off".
    --------------

    Web.config file is like this:
    ---------
    <configuration>

    <system.web>
    <customErrors mode="Off"/>
    </system.web>

    </configuration>
    -----------

    The same file works on my local server. What can be the reason?
     
    Murat Dikici, Nov 7, 2003
    #1
    1. Advertising

  2. Have you modified the web.config file, with the tag: <customErrors
    mode="Off"/>

    For security purposes, ASP.NET will only show errors when you view the site
    on the local machine. In your case, as you are viewing the files from a
    server, you need to turn off the custom errors, so that you can see the
    error message, which will help you to debug the problem.

    Hope this helps,

    Mun




    "Murat Dikici" <> wrote in message
    news:...
    > Hello,
    > The file structure on the server is:
    >
    > /FileUpload
    > - Web.config
    > - upload.aspx
    >
    > I try to run the upload.aspx but it gives me a runtime error message like
    > this:
    > ----------------
    > Description: An application error occurred on the server. The current

    custom
    > error settings for this application prevent the details of the application
    > error from being viewed remotely (for security reasons). It could,

    however,
    > be viewed by browsers running on the local server machine.
    >
    > Details: To enable the details of this specific error message to be

    viewable
    > on remote machines, please create a <customErrors> tag within a

    "web.config"
    > configuration file located in the root directory of the current web
    > application. This <customErrors> tag should then have its "mode" attribute
    > set to "Off".
    > --------------
    >
    > Web.config file is like this:
    > ---------
    > <configuration>
    >
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    >
    > </configuration>
    > -----------
    >
    > The same file works on my local server. What can be the reason?
     
    Munsifali Rashid, Nov 7, 2003
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Benny Ng
    Replies:
    9
    Views:
    10,259
    Benny Ng
    Oct 13, 2005
  2. CSharpner
    Replies:
    0
    Views:
    1,148
    CSharpner
    Apr 9, 2007
  3. M Irfan
    Replies:
    2
    Views:
    3,999
    M Irfan
    Apr 18, 2007
  4. Ollie Riches
    Replies:
    1
    Views:
    1,693
    Gregory A. Beamer
    Dec 4, 2008
  5. kampy
    Replies:
    9
    Views:
    379
    Steven D'Aprano
    Oct 19, 2012
Loading...

Share This Page