Web Config IIS 7.0

Discussion in 'ASP General' started by anon, Sep 19, 2008.

  1. anon

    anon Guest

    I am not sure if this is the right forum.

    Environment : Windows server 2008, IIS 7.0

    I get the 'Could not load the file or assembly 'blowery.web.httpCompress' or
    one of its dependencies. The system cannot fond the file specified error.
    When I comment out the line in the web config file, I get the error on the
    line following that.

    I have all the dll files in the bin folder.

    I am attaching the web config file.

    Is this a permission issue ?

    Thanks in advance

    <?xml version="1.0"?>
    <configuration>
    <configSections>
    <sectionGroup name="system.web.extensions"
    type="System.Web.Configuration.SystemWebExtensionsSectionGroup,
    System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
    PublicKeyToken=31bf3856ad364e35">
    <sectionGroup name="scripting"
    type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions,
    Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
    <section name="scriptResourceHandler"
    type="System.Web.Configuration.ScriptingScriptResourceHandlerSection,
    System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
    PublicKeyToken=31bf3856ad364e35" requirePermission="false"
    allowDefinition="MachineToApplication"/>
    <sectionGroup name="webServices"
    type="System.Web.Configuration.ScriptingWebServicesSectionGroup,
    System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
    PublicKeyToken=31bf3856ad364e35">
    <section name="jsonSerialization"
    type="System.Web.Configuration.ScriptingJsonSerializationSection,
    System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
    PublicKeyToken=31bf3856ad364e35" requirePermission="false"
    allowDefinition="Everywhere"/>
    <section name="profileService"
    type="System.Web.Configuration.ScriptingProfileServiceSection,
    System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
    PublicKeyToken=31bf3856ad364e35" requirePermission="false"
    allowDefinition="MachineToApplication"/>
    <section name="authenticationService"
    type="System.Web.Configuration.ScriptingAuthenticationServiceSection,
    System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
    PublicKeyToken=31bf3856ad364e35" requirePermission="false"
    allowDefinition="MachineToApplication"/>
    </sectionGroup>
    </sectionGroup>
    </sectionGroup>
    <sectionGroup name="blowery.web">
    <section name="httpCompress"
    type="blowery.Web.HttpCompress.SectionHandler, blowery.Web.HttpCompress"/>
    </sectionGroup>
    <sectionGroup name="applicationSettings"
    type="System.Configuration.ApplicationSettingsGroup, System, Version=2.0.0.0,
    Culture=neutral, PublicKeyToken=b77a5c561934e089">
    <section name="SMWeb05.Properties.Settings"
    type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0,
    Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false"/>
    </sectionGroup>
    </configSections>
    <appSettings>
    <add key="Login.BruteForceDetection.TriesBeforeBlock" value="10"/>
    <add key="Login.BruteForceDetection.BlockTime" value="5"/>
    <add key="MailServiceAddress" value="IPC"/>
    </appSettings>
    <connectionStrings/>
    <!-- This adds an http Compression Module to SmarterMail.
    see http://www.blowery.org/code/HttpCompressionModule.html for more
    info
    -->
    <blowery.web>
    <!--
    acceptable values:
    <compressionModule preferredAlgorithm="deflate|gzip"
    compressionLevel="high|normal|low|none"/>
    gzip always uses compressionLevel="normal"
    -->
    <httpCompress preferredAlgorithm="deflate" compressionLevel="low">
    <excludedMimeTypes>
    <add type="image/gif"/>
    <add type="image/jpg"/>
    <add type="image/jpeg"/>
    <add type="application/octet-stream"/>
    <add type="application/vnd.syncml+xml"/>
    </excludedMimeTypes>
    <excludedPaths>
    <add path="frmReadMail_Attachment.aspx"/>
    <add path="WebResource.axd"/>
    <add path="frmKeepAlive.aspx"/>
    <add path="frmPrintPreview.aspx"/>
    </excludedPaths>
    </httpCompress>
    </blowery.web>
    <system.web>
    <xhtmlConformance mode="Transitional"/>
    <httpModules>
    <clear/>
    <add name="OutputCache" type="System.Web.Caching.OutputCacheModule"/>
    <add name="Session" type="System.Web.SessionState.SessionStateModule"/>
    <!-- <add name="FormsAuthentication"
    type="System.Web.Security.FormsAuthenticationModule" />
    <add name="RoleManager" type="System.Web.Security.RoleManagerModule" />
    <add name="UrlAuthorization"
    type="System.Web.Security.UrlAuthorizationModule" />
    <add name="FileAuthorization"
    type="System.Web.Security.FileAuthorizationModule" />
    <add name="AnonymousIdentification"
    type="System.Web.Security.AnonymousIdentificationModule" />
    -->
    <add name="ErrorHandlerModule"
    type="System.Web.Mobile.ErrorHandlerModule, System.Web.Mobile,
    Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    <add name="ScriptModule" type="System.Web.Handlers.ScriptModule,
    System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
    PublicKeyToken=31bf3856ad364e35"/>
    <add name="CompressionModule" type="blowery.Web.HttpCompress.HttpModule,
    blowery.web.HttpCompress"/>
    <add name="RadUploadModule"
    type="Telerik.WebControls.RadUploadHttpModule, RadUpload.Net2"/>
    </httpModules>
    <httpHandlers>
    <add verb="*" path="EditorStyleSheetHandler.ashx"
    type="SMWeb05.HelperClasses.Handler.EditorStyleSheetHandler"/>
    <add verb="*" path="StyleSheet.ashx"
    type="SmarterTools.Web.HttpHandlers.CommonCssHandler, SmarterTools.Web"/>
    <add verb="*" path="Javascript.ashx"
    type="SmarterTools.Web.HttpHandlers.CommonJSHandler, SmarterTools.Web"/>
    <add verb="*" path="TempResourceHandler.ashx"
    type="SmarterTools.Web.HttpHandlers.TempResourceHandler, SmarterTools.Web"/>
    <remove verb="*" path="*.asmx"/>
    <add verb="*" path="*.asmx" validate="false"
    type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions,
    Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    <add verb="*" path="*_AppService.axd" validate="false"
    type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions,
    Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    <add verb="*" path="Telerik.RadUploadProgressHandler.aspx"
    type="Telerik.WebControls.RadUploadProgressHandler, RadUpload.Net2"></add>
    <add verb="GET,HEAD" path="ScriptResource.axd"
    type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions,
    Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
    validate="false"/>
    </httpHandlers>
    <pages validateRequest="false" buffer="true">
    <controls>
    <add tagPrefix="STWC" namespace="SmarterTools.Web.Controls"
    assembly="SmarterTools.Web"/>
    <add tagPrefix="SMWC" namespace="SMWeb05.UserControls"
    assembly="SMWeb05"/>
    <add tagPrefix="UC" namespace="SMWeb05.UserControls" assembly="SMWeb05"/>
    <add tagPrefix="asp" namespace="System.Web.UI"
    assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
    PublicKeyToken=31bf3856ad364e35"/>
    </controls>
    </pages>
    <compilation debug="false">
    <assemblies>
    <add assembly="System.Web.Extensions, Version=1.0.61025.0,
    Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    <add assembly="System.Design, Version=2.0.0.0, Culture=neutral,
    PublicKeyToken=B03F5F7F11D50A3A"/>
    <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral,
    PublicKeyToken=B77A5C561934E089"/>
    </assemblies>
    </compilation>
    <urlMappings enabled="true">
    <add url="~/Main/frmMessagesX.aspx" mappedUrl="~/Main/frmMessages.aspx"/>
    <add url="~/Main/frmMessagesAdv.aspx" mappedUrl="~/Main/frmMessages.aspx"/>
    </urlMappings>
    <authentication mode="Windows"/>
    <httpRuntime maxRequestLength="10240"/>
    <customErrors mode="Off" defaultRedirect="frmError.aspx"/>
    </system.web>
    <system.web.extensions>
    <scripting>
    <scriptResourceHandler enableCompression="false" enableCaching="true"/>
    </scripting>
    </system.web.extensions>
    <!--<system.webServer>
    <validation validateIntegratedModeConfiguration="false"/>
    <modules>
    <add name="ScriptModule" preCondition="integratedMode"
    type="System.Web.Handlers.ScriptModule, System.Web.Extensions,
    Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    </modules>
    <handlers>
    <remove name="WebServiceHandlerFactory-Integrated" />
    <add name="ScriptHandlerFactory" verb="*" path="*.asmx"
    preCondition="integratedMode"
    type="System.Web.Script.Services.ScriptHandlerFactory,
    System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
    PublicKeyToken=31bf3856ad364e35"/>
    <add name="ScriptHandlerFactoryAppServices" verb="*"
    path="*_AppService.axd" preCondition="integratedMode"
    type="System.Web.Script.Services.ScriptHandlerFactory,
    System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
    PublicKeyToken=31bf3856ad364e35"/>
    <add name="ScriptResource" preCondition="integratedMode"
    verb="GET,HEAD" path="ScriptResource.axd"
    type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions,
    Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
    </handlers>
    </system.webServer>-->
    <applicationSettings>
    <SMWeb05.Properties.Settings>
    <setting name="SMWeb05_ProductInfo_ProductInfo" serializeAs="String">
    <value>http://www.smartertools.com/billing/services/ProductInfo.asmx</value>
    </setting>
    </SMWeb05.Properties.Settings>
    </applicationSettings>
    </configuration>
     
    anon, Sep 19, 2008
    #1
    1. Advertising

  2. anon wrote:
    > I am not sure if this is the right forum.
    >

    It's not :)
    There was no way for you to know it (except maybe by browsing through some
    of the previous questions in this newsgroup before posting yours - always a
    recommended practice) , but this is a classic (COM-based) asp newsgroup.
    ASP.Net bears very little resemblance to classic ASP so, while you may be
    lucky enough to find a dotnet-knowledgeable person here who can answer your
    question, you can eliminate the luck factor by posting your question to a
    group where those dotnet-knowledgeable people hang out. I suggest
    microsoft.public.dotnet.framework.aspnet or the forums at www.asp.net.
    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"
     
    Bob Barrows [MVP], Sep 19, 2008
    #2
    1. Advertising

  3. anon

    anon Guest

    Thank you.

    "Bob Barrows [MVP]" wrote:

    > anon wrote:
    > > I am not sure if this is the right forum.
    > >

    > It's not :)
    > There was no way for you to know it (except maybe by browsing through some
    > of the previous questions in this newsgroup before posting yours - always a
    > recommended practice) , but this is a classic (COM-based) asp newsgroup.
    > ASP.Net bears very little resemblance to classic ASP so, while you may be
    > lucky enough to find a dotnet-knowledgeable person here who can answer your
    > question, you can eliminate the luck factor by posting your question to a
    > group where those dotnet-knowledgeable people hang out. I suggest
    > microsoft.public.dotnet.framework.aspnet or the forums at www.asp.net.
    > --
    > Microsoft MVP - ASP/ASP.NET
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"
    >
    >
    >
     
    anon, Sep 19, 2008
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?RGFuaWVs?=

    Machine.config & web.config

    =?Utf-8?B?RGFuaWVs?=, Jan 18, 2004, in forum: ASP .Net
    Replies:
    2
    Views:
    13,477
    Hermit Dave
    Jan 18, 2004
  2. Benny Ng
    Replies:
    9
    Views:
    10,254
    Benny Ng
    Oct 13, 2005
  3. Eric
    Replies:
    1
    Views:
    5,075
    Karl Seguin
    Nov 17, 2005
  4. =?Utf-8?B?RGF2aWQgV2lsbGlhbXM=?=

    Web.Config parsing errors with Web App projects using IIS

    =?Utf-8?B?RGF2aWQgV2lsbGlhbXM=?=, May 17, 2006, in forum: ASP .Net
    Replies:
    1
    Views:
    18,443
    =?Utf-8?B?RGF2aWQgV2lsbGlhbXM=?=
    May 19, 2006
  5. CSharpner
    Replies:
    0
    Views:
    1,145
    CSharpner
    Apr 9, 2007
Loading...

Share This Page