WEB CONFIG PROBLEM

Discussion in 'ASP .Net Web Services' started by Savas Ates, Apr 30, 2005.

  1. Savas Ates

    Savas Ates Guest

    I created i simple web service.. It runs well in my local Pc..

    But when i copied it into my server it fails... it is about web config
    custom errors i turned it off but it still doesnt work..(<customErrors
    mode="Off" />) Can anyone help me ?

    Description: An application error occurred on the server. The current custom
    error settings for this application prevent the details of the application
    error from being viewed remotely (for security reasons). It could, however,
    be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable
    on remote machines, please create a <customErrors> tag within a "web.config"
    configuration file located in the root directory of the current web
    application. This <customErrors> tag should then have its "mode" attribute
    set to "Off".


    ------------------------------ THIS IS MY WEB.CONFIG
    FILE-------------------------------------------

    <?xml version="1.0" encoding="utf-8" ?>

    <configuration>


    <system.web>




    <compilation defaultLanguage="vb" debug="true" />


    <customErrors mode="Off" />


    <authentication mode="None" />



    <authorization>

    <allow users="*" /> <!-- Allow all users -->


    </authorization>


    <trace enabled="false" requestLimit="10" pageOutput="false"
    traceMode="SortByTime" localOnly="true" />




    <sessionState

    mode="InProc"

    stateConnectionString="tcpip=127.0.0.1:42424"

    sqlConnectionString="data source=127.0.0.1Trusted_Connection=yes"

    cookieless="false"

    timeout="20"

    />


    <globalization requestEncoding="utf-8" responseEncoding="utf-8" />


    </system.web>

    </configuration>
    Savas Ates, Apr 30, 2005
    #1
    1. Advertising

  2. what about machine.config ? does it allow overrides ?

    --

    Thanks,
    Yunus Emre ALPÖZEN
    BSc, MCAD.NET

    "Savas Ates" <> wrote in message
    news:%...
    >I created i simple web service.. It runs well in my local Pc..
    >
    > But when i copied it into my server it fails... it is about web config
    > custom errors i turned it off but it still doesnt work..(<customErrors
    > mode="Off" />) Can anyone help me ?
    >
    > Description: An application error occurred on the server. The current
    > custom
    > error settings for this application prevent the details of the application
    > error from being viewed remotely (for security reasons). It could,
    > however,
    > be viewed by browsers running on the local server machine.
    >
    > Details: To enable the details of this specific error message to be
    > viewable
    > on remote machines, please create a <customErrors> tag within a
    > "web.config"
    > configuration file located in the root directory of the current web
    > application. This <customErrors> tag should then have its "mode" attribute
    > set to "Off".
    >
    >
    > ------------------------------ THIS IS MY WEB.CONFIG
    > FILE-------------------------------------------
    >
    > <?xml version="1.0" encoding="utf-8" ?>
    >
    > <configuration>
    >
    >
    > <system.web>
    >
    >
    >
    >
    > <compilation defaultLanguage="vb" debug="true" />
    >
    >
    > <customErrors mode="Off" />
    >
    >
    > <authentication mode="None" />
    >
    >
    >
    > <authorization>
    >
    > <allow users="*" /> <!-- Allow all users -->
    >
    >
    > </authorization>
    >
    >
    > <trace enabled="false" requestLimit="10" pageOutput="false"
    > traceMode="SortByTime" localOnly="true" />
    >
    >
    >
    >
    > <sessionState
    >
    > mode="InProc"
    >
    > stateConnectionString="tcpip=127.0.0.1:42424"
    >
    > sqlConnectionString="data source=127.0.0.1Trusted_Connection=yes"
    >
    > cookieless="false"
    >
    > timeout="20"
    >
    > />
    >
    >
    > <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
    >
    >
    > </system.web>
    >
    > </configuration>
    >
    >
    >
    >
    >
    >
    >
    Yunus Emre ALPÖZEN [MCAD.NET], May 1, 2005
    #2
    1. Advertising

  3. Savas Ates

    Savas Ates Guest

    i dont have any machine.config file in my root server in web server field...
    Savas Ates, May 3, 2005
    #3
  4. machine.config file is located under
    %WINDOWS%>\Microsoft.NET\Framework\%Version%\CONFIG\

    --

    Thanks,
    Yunus Emre ALPÖZEN
    BSc, MCAD.NET

    "Savas Ates" <> wrote in message
    news:OFIuwq$...
    >i dont have any machine.config file in my root server in web server
    >field...
    >
    Yunus Emre ALPÖZEN [MCAD.NET], May 3, 2005
    #4
  5. Savas Ates

    Savas Ates Guest

    ok i found it... which setting i must change to fix the problem... in
    machine.config file there are lots of codes...
    Savas Ates, May 4, 2005
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?RGFuaWVs?=

    Machine.config & web.config

    =?Utf-8?B?RGFuaWVs?=, Jan 18, 2004, in forum: ASP .Net
    Replies:
    2
    Views:
    13,293
    Hermit Dave
    Jan 18, 2004
  2. =?Utf-8?B?QXVndXN0aW4gUHJhc2FubmEuIEo=?=

    Web.Config Get Config settings at runtime.

    =?Utf-8?B?QXVndXN0aW4gUHJhc2FubmEuIEo=?=, Feb 5, 2004, in forum: ASP .Net
    Replies:
    3
    Views:
    2,253
    Kevin Spencer
    Feb 6, 2004
  3. Bob
    Replies:
    7
    Views:
    956
    Saravana [MVP]
    May 5, 2004
  4. Benny Ng
    Replies:
    9
    Views:
    9,938
    Benny Ng
    Oct 13, 2005
  5. CSharpner
    Replies:
    0
    Views:
    1,010
    CSharpner
    Apr 9, 2007
Loading...

Share This Page