web.config section encryption and IIS7

Discussion in 'ASP .Net Security' started by Olivier MATROT, Jan 23, 2008.

  1. I'm using ASP.NET 2.0 on IIS7.
    I would like to encrypt some configuration section in the web.config file.
    However, after doing this, I only have blank pages when accessing the site.
    There is no error at all.
    Going back to an unencrypted web.config solve the problem.
    Any help appreciated.

    TIA.
    Olivier MATROT, Jan 23, 2008
    #1
    1. Advertising

  2. Found the solution myself.

    The encryption is unsupported with an appPool runing in Integrated managed
    pipeline mode.

    I've switched to Classic pipeline mode and it is working fine.


    "Olivier MATROT" wrote:

    > I'm using ASP.NET 2.0 on IIS7.
    > I would like to encrypt some configuration section in the web.config file.
    > However, after doing this, I only have blank pages when accessing the site.
    > There is no error at all.
    > Going back to an unencrypted web.config solve the problem.
    > Any help appreciated.
    >
    > TIA.
    Olivier MATROT, Jan 30, 2008
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Luis Serrano
    Replies:
    0
    Views:
    2,364
    Luis Serrano
    May 4, 2009
  2. Chuck
    Replies:
    3
    Views:
    1,509
    Chuck
    Aug 10, 2010
  3. Olivier MATROT

    web.config section encryption fails

    Olivier MATROT, Jan 11, 2008, in forum: ASP .Net Security
    Replies:
    1
    Views:
    178
    Olivier MATROT
    Feb 25, 2008
  4. .Net Sports

    web.config file for IIS7 and classic asp

    .Net Sports, Sep 7, 2009, in forum: ASP .Net Web Controls
    Replies:
    0
    Views:
    773
    .Net Sports
    Sep 7, 2009
  5. kampy
    Replies:
    9
    Views:
    306
    Steven D'Aprano
    Oct 19, 2012
Loading...

Share This Page