Web Service & Web.Config

Discussion in 'ASP .Net Web Services' started by Raj, Dec 18, 2009.

  1. Raj

    Raj Guest

    I have created a web service using .NET framework 2.0

    after uploading and trying to access i get this error:

    Server Error in '/' Application.
    Runtime Error
    Description: An application error occurred on the server. The current custom
    error settings for this application prevent the details of the application
    error from being viewed remotely (for security reasons). It could, however,
    be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable
    on remote machines, please create a <customErrors> tag within a "web.config"
    configuration file located in the root directory of the current web
    application. This <customErrors> tag should then have its "mode" attribute
    set to "Off".

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>


    Notes: The current error page you are seeing can be replaced by a custom
    error page by modifying the "defaultRedirect" attribute of the application's
    <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>

    My Web.Config is:
    <?xml version="1.0"?>
    <configuration>
    <appSettings/>
    <connectionStrings/>
    <system.web>
    <!--
    Set compilation debug="true" to insert debugging
    symbols into the compiled page. Because this
    affects performance, set this value to true only
    during development.
    -->
    <compilation debug="true">
    </compilation>
    <!--
    The <authentication> section enables configuration
    of the security authentication mode used by
    ASP.NET to identify an incoming user.
    -->
    <authentication mode="None"/>
    <!--
    The <customErrors> section enables configuration
    of what to do if/when an unhandled error occurs
    during the execution of a request. Specifically,
    it enables developers to configure html error pages
    to be displayed in place of a error stack trace.-->
    <customErrors mode="RemoteOnly" defaultRedirect
    ="aspnet_client/system_web/2_0_50727/WebServices/WebService1/WebForm1.aspx"/>
    <!-- defaultRedirect="WebForm1.aspx">
    <error statusCode="403" redirect="NoAccess.htm" />
    <error statusCode="404" redirect="FileNotFound.htm" />
    </customErrors>
    -->
    <webServices>
    <protocols>
    <add name="HttpGet"/>
    <add name="HttpPost"/>
    </protocols>
    </webServices>
    </system.web>
    </configuration>

    I have tried changing mode to On/Off no respite

    The same is working fine on the local server

    Anything else to be done?

    Any help would be appreciated

    Thank you

    Regards
    Raj
    Raj, Dec 18, 2009
    #1
    1. Advertising

  2. Raj

    andyMac Guest

    I am having the same issue. was this resolved? Anyone know a solution to
    this?

    "Raj" wrote:

    > I have created a web service using .NET framework 2.0
    >
    > after uploading and trying to access i get this error:
    >
    > Server Error in '/' Application.
    > Runtime Error
    > Description: An application error occurred on the server. The current custom
    > error settings for this application prevent the details of the application
    > error from being viewed remotely (for security reasons). It could, however,
    > be viewed by browsers running on the local server machine.
    >
    > Details: To enable the details of this specific error message to be viewable
    > on remote machines, please create a <customErrors> tag within a "web.config"
    > configuration file located in the root directory of the current web
    > application. This <customErrors> tag should then have its "mode" attribute
    > set to "Off".
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    > </configuration>
    >
    >
    > Notes: The current error page you are seeing can be replaced by a custom
    > error page by modifying the "defaultRedirect" attribute of the application's
    > <customErrors> configuration tag to point to a custom error page URL.
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    > </system.web>
    > </configuration>
    >
    > My Web.Config is:
    > <?xml version="1.0"?>
    > <configuration>
    > <appSettings/>
    > <connectionStrings/>
    > <system.web>
    > <!--
    > Set compilation debug="true" to insert debugging
    > symbols into the compiled page. Because this
    > affects performance, set this value to true only
    > during development.
    > -->
    > <compilation debug="true">
    > </compilation>
    > <!--
    > The <authentication> section enables configuration
    > of the security authentication mode used by
    > ASP.NET to identify an incoming user.
    > -->
    > <authentication mode="None"/>
    > <!--
    > The <customErrors> section enables configuration
    > of what to do if/when an unhandled error occurs
    > during the execution of a request. Specifically,
    > it enables developers to configure html error pages
    > to be displayed in place of a error stack trace.-->
    > <customErrors mode="RemoteOnly" defaultRedirect
    > ="aspnet_client/system_web/2_0_50727/WebServices/WebService1/WebForm1.aspx"/>
    > <!-- defaultRedirect="WebForm1.aspx">
    > <error statusCode="403" redirect="NoAccess.htm" />
    > <error statusCode="404" redirect="FileNotFound.htm" />
    > </customErrors>
    > -->
    > <webServices>
    > <protocols>
    > <add name="HttpGet"/>
    > <add name="HttpPost"/>
    > </protocols>
    > </webServices>
    > </system.web>
    > </configuration>
    >
    > I have tried changing mode to On/Off no respite
    >
    > The same is working fine on the local server
    >
    > Anything else to be done?
    >
    > Any help would be appreciated
    >
    > Thank you
    >
    > Regards
    > Raj
    andyMac, Feb 15, 2010
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Joe
    Replies:
    1
    Views:
    409
  2. Benny Ng
    Replies:
    9
    Views:
    9,904
    Benny Ng
    Oct 13, 2005
  3. CSharpner
    Replies:
    0
    Views:
    996
    CSharpner
    Apr 9, 2007
  4. Replies:
    0
    Views:
    113
  5. Leo Violette
    Replies:
    0
    Views:
    1,000
    Leo Violette
    Apr 17, 2009
Loading...

Share This Page