WebSerivces not accessible when deployed.

Discussion in 'ASP .Net Web Services' started by Vijay Balki, Sep 16, 2003.

  1. Vijay Balki

    Vijay Balki Guest

    I have a development environment setup on my Laptop that runs Win2000. I
    also have IIS running and local SQLServer running. I developed a client in
    VS.NET 2003 for a XP machine, that will access a webservice, connecting to
    the local SQL Server. Everything works perfectly fine in my WIN2000 laptop.

    Now I build a setup project and install the client on the XP box. The XP box
    has IIS and a SQL Server. I have transferred the webservice files to the XP
    IIS and the SQL Server database also. When I run the client on the XP box
    and try to access the webservice, it fails with the following message.

    System.Net.WebException: The request failed with HTTP status 405: Method
    not allowed.

    what's wrong???

    VJ
    Vijay Balki, Sep 16, 2003
    #1
    1. Advertising

  2. Vijay Balki

    otuo Guest

    you have a windows security issue. check that yo give
    uername passeord to aspnet on the host machine
    >-----Original Message-----
    >I have a development environment setup on my Laptop that

    runs Win2000. I
    >also have IIS running and local SQLServer running. I

    developed a client in
    >VS.NET 2003 for a XP machine, that will access a

    webservice, connecting to
    >the local SQL Server. Everything works perfectly fine in

    my WIN2000 laptop.
    >
    >Now I build a setup project and install the client on

    the XP box. The XP box
    >has IIS and a SQL Server. I have transferred the

    webservice files to the XP
    >IIS and the SQL Server database also. When I run the

    client on the XP box
    >and try to access the webservice, it fails with the

    following message.
    >
    > System.Net.WebException: The request failed with HTTP

    status 405: Method
    >not allowed.
    >
    >what's wrong???
    >
    >VJ
    >
    >
    >
    >.
    >
    otuo, Sep 16, 2003
    #2
    1. Advertising

  3. Vijay Balki

    Vijay Balki Guest

    Hi.. I am not sure I understand what you are saying. Could you please
    explain?
    There is a ASPNET user account that has same properties on both machines.

    "otuo" <> wrote in message
    news:062301c37c97$525e6610$...
    > you have a windows security issue. check that yo give
    > uername passeord to aspnet on the host machine
    > >-----Original Message-----
    > >I have a development environment setup on my Laptop that

    > runs Win2000. I
    > >also have IIS running and local SQLServer running. I

    > developed a client in
    > >VS.NET 2003 for a XP machine, that will access a

    > webservice, connecting to
    > >the local SQL Server. Everything works perfectly fine in

    > my WIN2000 laptop.
    > >
    > >Now I build a setup project and install the client on

    > the XP box. The XP box
    > >has IIS and a SQL Server. I have transferred the

    > webservice files to the XP
    > >IIS and the SQL Server database also. When I run the

    > client on the XP box
    > >and try to access the webservice, it fails with the

    > following message.
    > >
    > > System.Net.WebException: The request failed with HTTP

    > status 405: Method
    > >not allowed.
    > >
    > >what's wrong???
    > >
    > >VJ
    > >
    > >
    > >
    > >.
    > >
    Vijay Balki, Sep 16, 2003
    #3
  4. Vijay Balki

    Vijay Balki Guest

    Re: WebSerivces not accessible when deployed. - Found the solution

    I found this one out...

    I had installed ASP.NET and then IIS. The order matters very much here. IIS
    installation does not register the ASP.NET version found on the machine. You
    have to manually register ASP.NET. This is even true if you install Visual
    Studio.NET and then IIS. Or the option is to install IIS first and then
    ASP.NET. In either case to be safe, I would manually register the ASP.NET
    version I want to work with IIS by following the steps below.

    From the command line (command prompt), navigate to the .NET version
    directory, you want to register with the IIS. For example:
    C:\Winnt\Microsoft.Net\Framework\v1.0.XXXX

    Run the following command, to register ASP.NET
    aspnet_regiis.exe -i

    Reset IIS, Run the following command:
    iisreset.exe

    For the Microsoft folks,

    Maybe in the future version of IIS a automatic registration of ASP.NET found
    on the machine can be included or at least give some sort of warning at end
    of installation asking to do a manual register. Also, the error message was
    confusing in saying "Method not allowed" for the below condition. Maybe a
    better message will also help identify the problem. The message made me
    chase security issues..

    VJ


    "Vijay Balki" <> wrote in message
    news:...
    > I have a development environment setup on my Laptop that runs Win2000. I
    > also have IIS running and local SQLServer running. I developed a client in
    > VS.NET 2003 for a XP machine, that will access a webservice, connecting to
    > the local SQL Server. Everything works perfectly fine in my WIN2000

    laptop.
    >
    > Now I build a setup project and install the client on the XP box. The XP

    box
    > has IIS and a SQL Server. I have transferred the webservice files to the

    XP
    > IIS and the SQL Server database also. When I run the client on the XP box
    > and try to access the webservice, it fails with the following message.
    >
    > System.Net.WebException: The request failed with HTTP status 405: Method
    > not allowed.
    >
    > what's wrong???
    >
    > VJ
    >
    >
    >
    Vijay Balki, Sep 18, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    0
    Views:
    347
  2. Replies:
    1
    Views:
    820
    =?Utf-8?B?QnJhZCBSb2JlcnRz?=
    Dec 8, 2004
  3. Dave
    Replies:
    1
    Views:
    9,739
    Steven Cheng[MSFT]
    Oct 24, 2005
  4. kpg
    Replies:
    3
    Views:
    5,478
  5. Guest
    Replies:
    1
    Views:
    515
    Andrea D'Onofrio [MSFT]
    May 21, 2004
Loading...

Share This Page