what does this error mean `activate': can't activate activesupport (=3.0.1, runtime) for ["activerec

Discussion in 'Ruby' started by Junkone, Oct 23, 2010.

  1. Junkone

    Junkone Guest

    i am using active record in my program and cannot understand what this
    error means.

    require 'watir'

    include Watir
    require 'active_record'

    ActiveRecord::Base.establish_connection(
    :adapter => "mysql",
    :host => "127.0.0.1",
    #:host => "sun",
    :database => "Trader",
    :username => "root",
    :password => "password"
    )
    class Rawdata < ActiveRecord::Base
    set_table_name "rawdatas"

    end

    E:\TradingTools\trader\app\helpers>GrabMBTTrades.rb
    C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:233:in `activate': can't
    activate
    activesupport (= 3.0.1, runtime) for ["activerecord-3.0.1"], already
    activated a
    ctivesupport-2.3.9 for ["firewatir-1.6.6", "watir-1.6.6"]
    (Gem::LoadError)
    from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:249:in
    `activate'
    from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:248:in
    `each'
    from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:248:in
    `activate'
    from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/
    custom_require.rb:35:in
    `require'
    from E:/TradingTools/trader/app/helpers/GrabMBTTrades.rb:8
    Junkone, Oct 23, 2010
    #1
    1. Advertising

  2. Junkone

    Luis Lavena Guest

    Re: what does this error mean `activate': can't activateactivesupport (= 3.0.1, runtime) for ["activerecord-3.0.1"]

    On Oct 23, 11:37 am, Junkone <> wrote:
    > i am using active record in my program and cannot understand what this
    > error means.
    >
    > require 'watir'
    >
    > include Watir
    > require 'active_record'
    >
    > ActiveRecord::Base.establish_connection(
    > :adapter => "mysql",
    > :host => "127.0.0.1",
    > #:host => "sun",
    > :database => "Trader",
    > :username => "root",
    > :password => "password"
    > )
    > class Rawdata < ActiveRecord::Base
    >    set_table_name "rawdatas"
    >
    > end
    >
    > E:\TradingTools\trader\app\helpers>GrabMBTTrades.rb
    > C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:233:in `activate': can't
    > activate
    > activesupport (= 3.0.1, runtime) for ["activerecord-3.0.1"], already
    > activated a
    > ctivesupport-2.3.9 for ["firewatir-1.6.6", "watir-1.6.6"]
    > (Gem::LoadError)


    It is telling you that firewater and watir required activesupport
    2.3.9, so if you want ActiveSupport 3.0.1 you need to require it first
    (before requiring watir)

    --
    Luis Lavena
    Luis Lavena, Oct 23, 2010
    #2
    1. Advertising

  3. Re: what does this error mean `activate': can't activateactivesupport (= 3.0.1, runtime) for ["activerecord-3.0.1"]

    In that case Watir will raise an exception because it strictly loads
    2.3.9. There is plan to remove active-support dependency completely in
    FireWatir

    Jarmo

    On Oct 23, 5:58 pm, Luis Lavena <> wrote:
    > On Oct 23, 11:37 am, Junkone <> wrote:
    >
    >
    >
    >
    >
    > > i am using active record in my program and cannot understand what this
    > > error means.

    >
    > > require 'watir'

    >
    > > include Watir
    > > require 'active_record'

    >
    > > ActiveRecord::Base.establish_connection(
    > > :adapter => "mysql",
    > > :host => "127.0.0.1",
    > > #:host => "sun",
    > > :database => "Trader",
    > > :username => "root",
    > > :password => "password"
    > > )
    > > class Rawdata < ActiveRecord::Base
    > >    set_table_name "rawdatas"

    >
    > > end

    >
    > > E:\TradingTools\trader\app\helpers>GrabMBTTrades.rb
    > > C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:233:in `activate': can't
    > > activate
    > > activesupport (= 3.0.1, runtime) for ["activerecord-3.0.1"], already
    > > activated a
    > > ctivesupport-2.3.9 for ["firewatir-1.6.6", "watir-1.6.6"]
    > > (Gem::LoadError)

    >
    > It is telling you that firewater and watir required activesupport
    > 2.3.9, so if you want ActiveSupport 3.0.1 you need to require it first
    > (before requiring watir)
    >
    > --
    > Luis Lavena
    Jarmo Pertman, Oct 27, 2010
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. C Barrington-Leigh
    Replies:
    1
    Views:
    1,178
    Tim Leslie
    Sep 10, 2010
  2. han
    Replies:
    0
    Views:
    213
  3. john peter
    Replies:
    3
    Views:
    264
    Logan Capaldo
    Mar 31, 2006
  4. Trans
    Replies:
    0
    Views:
    116
    Trans
    Sep 12, 2006
  5. Tim Bray
    Replies:
    0
    Views:
    89
    Tim Bray
    Oct 13, 2006
Loading...

Share This Page