why wont this work ?

Discussion in 'ASP General' started by Graham Mattingley, Jan 22, 2004.

  1. Hi Group,

    I have this code, that was pointed out to me, but it returns the error
    ADODB.Stream error '800a0bba'

    File could not be opened.

    /image_counter/default.asp, line 5

    I have the IUSR permission set the the file "e:/test.gif" - but it dont seem
    to work..

    any ideas please :)



    Regards

    Graham Mattingley

    this is all the code from the asp page
    ============================
    <%
    Set adoStream = Server.CreateObject("ADODB.Stream")
    adoStream.Open()
    adoStream.Type = 1
    adoStream.LoadFromFile("e:/test.gif")

    Response.BinaryWrite adoStream.Read()

    adoStream.Close: Set adoStream = Nothing
    Response.End
    %>
     
    Graham Mattingley, Jan 22, 2004
    #1
    1. Advertising

  2. Graham Mattingley

    Ray at Guest

    Just a real quick guess, but could it be that you're using a forward slash
    in a file system path? That should be a backslash, e:\test.gif

    Ray at home

    "Graham Mattingley" <> wrote in message
    news:buoaph$r1j$1$...
    > Hi Group,
    >
    > I have this code, that was pointed out to me, but it returns the error
    > ADODB.Stream error '800a0bba'
    >
    > File could not be opened.
    >
    > /image_counter/default.asp, line 5
    >
    > I have the IUSR permission set the the file "e:/test.gif" - but it dont

    seem
    > to work..
    >
    > any ideas please :)
    >
    >
    >
    > Regards
    >
    > Graham Mattingley
    >
    > this is all the code from the asp page
    > ============================
    > <%
    > Set adoStream = Server.CreateObject("ADODB.Stream")
    > adoStream.Open()
    > adoStream.Type = 1
    > adoStream.LoadFromFile("e:/test.gif")
    >
    > Response.BinaryWrite adoStream.Read()
    >
    > adoStream.Close: Set adoStream = Nothing
    > Response.End
    > %>
    >
    >
     
    Ray at, Jan 22, 2004
    #2
    1. Advertising

  3. Graham Mattingley

    Tom Guest

    I was having this problem as well after we moved from NT4 Server to
    2003 Server. For some reason, when I went into IIS > Website > Home
    Directory tab > Application Configuration button > App Options tab,
    and turned off Enable Buffering, it worked again. This setting matched
    the setting on the NT4.

    TM
     
    Tom, Feb 18, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Rookie

    why wont this method work?

    Rookie, Aug 30, 2003, in forum: Java
    Replies:
    2
    Views:
    386
    Benny
    Aug 30, 2003
  2. ß Ø ® G
    Replies:
    8
    Views:
    358
    ß Ø ® G
    Oct 6, 2003
  3. Mr. SweatyFinger
    Replies:
    2
    Views:
    2,000
    Smokey Grindel
    Dec 2, 2006
  4. =?Utf-8?B?cm9kY2hhcg==?=

    why wont this dang thing work...

    =?Utf-8?B?cm9kY2hhcg==?=, Mar 8, 2007, in forum: ASP .Net
    Replies:
    0
    Views:
    360
    =?Utf-8?B?cm9kY2hhcg==?=
    Mar 8, 2007
  5. Milsnips
    Replies:
    4
    Views:
    406
    Juan T. Llibre
    Apr 3, 2007
Loading...

Share This Page