Win2K: error creating ASP.NET Web Application

Discussion in 'ASP .Net Web Services' started by Agoston Bejo, Aug 20, 2004.

  1. Agoston Bejo

    Agoston Bejo Guest

    Hi,
    I have Visual .Net installed under Windows 2000 Professional. When I try to
    create a new ASP.NET Web Project, the following error message pops up:

    "Visual Studio .NET has detected that the specified Web server is not
    running ASP.NET version 1.1. You will be unable to run ASP.NET Web
    applications or services."

    Before answering without thinking, please have a look at what hasn't worked
    up to now.

    1. IIS 5.0 is installed.
    Please don't bother advising "set ASP.NET v1.1 to 'Allowed' in IIS 6.0 under
    Web Service Extensions as Microsoft Knowledge Base Article 817267 says",
    unless you realize that in IIS 5.0 there's no such setting as "Web Service
    Extensions", AND you know where to download IIS 6.0 for Win2K Pro - which is
    impossible according to what people say on the net. (But do tell me if I'm
    wrong about this one!)

    2. Frontpage Server Extensions is configured in IIS for the "Default Web
    Site" - as Setup\WebServer.htm says on the install CD.

    3. I've tried running the aspnet_regiis.exe utility then registering
    Aspnet_isapi.dll as MS Knowledge Base Article 306005 says.

    4. The whole .NET Framework has been uninstalled then reinstalled.

    Thx for any advice!
     
    Agoston Bejo, Aug 20, 2004
    #1
    1. Advertising

  2. Agoston Bejo

    Helene Day Guest

    Try the following

    C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i



    "Agoston Bejo" <> wrote in message
    news:O66w$...
    > Hi,
    > I have Visual .Net installed under Windows 2000 Professional. When I try

    to
    > create a new ASP.NET Web Project, the following error message pops up:
    >
    > "Visual Studio .NET has detected that the specified Web server is not
    > running ASP.NET version 1.1. You will be unable to run ASP.NET Web
    > applications or services."
    >
    > Before answering without thinking, please have a look at what hasn't

    worked
    > up to now.
    >
    > 1. IIS 5.0 is installed.
    > Please don't bother advising "set ASP.NET v1.1 to 'Allowed' in IIS 6.0

    under
    > Web Service Extensions as Microsoft Knowledge Base Article 817267 says",
    > unless you realize that in IIS 5.0 there's no such setting as "Web Service
    > Extensions", AND you know where to download IIS 6.0 for Win2K Pro - which

    is
    > impossible according to what people say on the net. (But do tell me if I'm
    > wrong about this one!)
    >
    > 2. Frontpage Server Extensions is configured in IIS for the "Default Web
    > Site" - as Setup\WebServer.htm says on the install CD.
    >
    > 3. I've tried running the aspnet_regiis.exe utility then registering
    > Aspnet_isapi.dll as MS Knowledge Base Article 306005 says.
    >
    > 4. The whole .NET Framework has been uninstalled then reinstalled.
    >
    > Thx for any advice!
    >
    >
     
    Helene Day, Aug 20, 2004
    #2
    1. Advertising

  3. Agoston Bejo

    Agoston Bejo Guest

    Thanks, but that was in the 3rd place in my list. :)



    "Helene Day" <noSpam@noSpam> wrote in message
    news:O#...
    > Try the following
    >
    > C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i
    >
    >
    >
    > "Agoston Bejo" <> wrote in message
    > news:O66w$...
    > > Hi,
    > > I have Visual .Net installed under Windows 2000 Professional. When I

    try
    > to
    > > create a new ASP.NET Web Project, the following error message pops up:
    > >
    > > "Visual Studio .NET has detected that the specified Web server is not
    > > running ASP.NET version 1.1. You will be unable to run ASP.NET Web
    > > applications or services."
    > >
    > > Before answering without thinking, please have a look at what hasn't

    > worked
    > > up to now.
    > >
    > > 1. IIS 5.0 is installed.
    > > Please don't bother advising "set ASP.NET v1.1 to 'Allowed' in IIS 6.0

    > under
    > > Web Service Extensions as Microsoft Knowledge Base Article 817267 says",
    > > unless you realize that in IIS 5.0 there's no such setting as "Web

    Service
    > > Extensions", AND you know where to download IIS 6.0 for Win2K Pro -

    which
    > is
    > > impossible according to what people say on the net. (But do tell me if

    I'm
    > > wrong about this one!)
    > >
    > > 2. Frontpage Server Extensions is configured in IIS for the "Default Web
    > > Site" - as Setup\WebServer.htm says on the install CD.
    > >
    > > 3. I've tried running the aspnet_regiis.exe utility then registering
    > > Aspnet_isapi.dll as MS Knowledge Base Article 306005 says.
    > >
    > > 4. The whole .NET Framework has been uninstalled then reinstalled.
    > >
    > > Thx for any advice!
    > >
    > >

    >
    >
     
    Agoston Bejo, Aug 20, 2004
    #3
  4. Well, can you make sure that .aspx and the rest of the ASP.NET related
    extentions have handlers associated with them. You can check that in the
    "Application Mappings" the default web sites "Customize" dialog.





    "Agoston Bejo" <> wrote in message
    news:...
    > Thanks, but that was in the 3rd place in my list. :)
    >
    >
    >
    > "Helene Day" <noSpam@noSpam> wrote in message
    > news:O#...
    > > Try the following
    > >
    > > C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i
    > >
    > >
    > >
    > > "Agoston Bejo" <> wrote in message
    > > news:O66w$...
    > > > Hi,
    > > > I have Visual .Net installed under Windows 2000 Professional. When I

    > try
    > > to
    > > > create a new ASP.NET Web Project, the following error message pops up:
    > > >
    > > > "Visual Studio .NET has detected that the specified Web server is not
    > > > running ASP.NET version 1.1. You will be unable to run ASP.NET Web
    > > > applications or services."
    > > >
    > > > Before answering without thinking, please have a look at what hasn't

    > > worked
    > > > up to now.
    > > >
    > > > 1. IIS 5.0 is installed.
    > > > Please don't bother advising "set ASP.NET v1.1 to 'Allowed' in IIS 6.0

    > > under
    > > > Web Service Extensions as Microsoft Knowledge Base Article 817267

    says",
    > > > unless you realize that in IIS 5.0 there's no such setting as "Web

    > Service
    > > > Extensions", AND you know where to download IIS 6.0 for Win2K Pro -

    > which
    > > is
    > > > impossible according to what people say on the net. (But do tell me if

    > I'm
    > > > wrong about this one!)
    > > >
    > > > 2. Frontpage Server Extensions is configured in IIS for the "Default

    Web
    > > > Site" - as Setup\WebServer.htm says on the install CD.
    > > >
    > > > 3. I've tried running the aspnet_regiis.exe utility then registering
    > > > Aspnet_isapi.dll as MS Knowledge Base Article 306005 says.
    > > >
    > > > 4. The whole .NET Framework has been uninstalled then reinstalled.
    > > >
    > > > Thx for any advice!
    > > >
    > > >

    > >
    > >

    >
    >
     
    Girish bharadwaj, Sep 11, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Good Enchiladas

    Remote Debugging ASP.NET VS.NET Win2K?

    Good Enchiladas, Apr 13, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    512
    Good Enchiladas
    Apr 13, 2004
  2. Tony Lewis
    Replies:
    0
    Views:
    589
    Tony Lewis
    Oct 24, 2003
  3. Good Enchiladas

    Remote Debugging ASP.NET VS.NET Win2K?

    Good Enchiladas, Apr 13, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    293
    Good Enchiladas
    Apr 13, 2004
  4. Agoston Bejo
    Replies:
    3
    Views:
    510
    Girish bharadwaj
    Sep 11, 2004
  5. Alla
    Replies:
    3
    Views:
    239
    Andrea D'Onofrio [MSFT]
    Jan 9, 2004
Loading...

Share This Page