window.opener lost on postback

Discussion in 'ASP .Net' started by Peter Morris [Droopy eyes software], Feb 7, 2005.

  1. Hi all

    I have a form which pops open from my page. This form asks the user to
    enter some values which are then validated on the server. The problem is
    that the window.opener seems to be lost after a postback.

    In FireFox it works fine, setting a form value of window.opener works, but
    in IE it opens a new window.

    Can anyone suggest a solution?


    --
    Pete
    ====
    Read or write articles on just about anything
    http://www.HowToDoThings.com

    My blog
    http://blogs.slcdug.org/petermorris/
     
    Peter Morris [Droopy eyes software], Feb 7, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andrew Bewley via DotNetMonster.com

    window to window communication (window.opener)

    Andrew Bewley via DotNetMonster.com, Feb 3, 2005, in forum: ASP .Net
    Replies:
    0
    Views:
    1,090
    Andrew Bewley via DotNetMonster.com
    Feb 3, 2005
  2. =?Utf-8?B?TXJGZXo=?=

    Child window property window.opener null after postback

    =?Utf-8?B?TXJGZXo=?=, Apr 28, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    5,707
    =?Utf-8?B?TXJGZXo=?=
    Apr 28, 2005
  3. MrFez
    Replies:
    1
    Views:
    230
    Yunus Emre ALPĂ–ZEN [MCP]
    Apr 28, 2005
  4. window.opener, form.opener?

    , Jul 14, 2006, in forum: Javascript
    Replies:
    5
    Views:
    300
  5. Frank

    window.opener lost in postback

    Frank, Mar 30, 2007, in forum: Javascript
    Replies:
    4
    Views:
    367
    Frank
    Apr 8, 2007
Loading...

Share This Page