wxTheClipboard problem, IDLE vs PythonWin

Discussion in 'Python' started by Chris Munchenberg, Oct 7, 2004.

  1. I know its a while since this was posted, and likely has been solve. But I just came up against the same problem and couldn't find an answer on Google, so here is my take on it all.

    It appears that the wx.TheClipboard only works effectively inside a wx.App main loop (or at least that got rid of my problems with it). Doesn't mean you have to show a gui interface.
    Hope this helps,

    Chris.

    > I have a need to write data to the Windows clipboard from a Python script.
    > I found a nice, simple solution @
    > http://wiki.wxpython.org/index.cgi/ClipBoard. The problem is, I can only
    > get it to work from within the PythonWin and SPE IDE's. I get errors if I
    > try to run the exact same code from the command line or via IDLE's
    > interactive shell. I can't figure it out. Any ideas? Possibly something
    > missing from my PYTHONPATH environment variable?
    >
    > Any help is appreciated. Thanks,
    > Tim
     
    Chris Munchenberg, Oct 7, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. stephan
    Replies:
    0
    Views:
    459
    stephan
    Jul 30, 2003
  2. Pete Jereb
    Replies:
    1
    Views:
    392
    Nick Vargish
    Oct 2, 2003
  3. Tim Rice
    Replies:
    1
    Views:
    457
    Tom B.
    Aug 28, 2004
  4. David S.
    Replies:
    0
    Views:
    439
    David S.
    Feb 16, 2005
  5. W. eWatson
    Replies:
    15
    Views:
    621
    Steve Holden
    Feb 15, 2009
Loading...

Share This Page