XEmacs python-mode question

Discussion in 'Python' started by Thomas Heller, Jan 13, 2006.

  1. I'm trying to customize the python interpreter that is used to execute
    my scripts from within WinXP, XEmacs, python-mode version
    $Revision4.70$, but cannot get it to work.

    The only thing that works is M-x customize-group python, and change the
    value of 'Python Command'. However, this changes the interpreter for
    all buffers, but I want different buffers use different interpreters.
    Is that possible?

    What I tried so far:

    Insert several variants of '#! py23.cmd' at the top of the buffer - no
    effect.

    Insert this into the buffer - no effect:
    ## Local Variables:
    ## py-python-command: "py23"
    ## End:

    Execute "M-x set-variable py-python-command py23" - no effect.

    Can anyone help?

    Thomas
     
    Thomas Heller, Jan 13, 2006
    #1
    1. Advertising

  2. Thomas Heller

    Guest

    Thomas> I'm trying to customize the python interpreter that is used to
    Thomas> execute my scripts from within WinXP, XEmacs, python-mode
    Thomas> version $Revision4.70$, but cannot get it to work.

    Thomas> The only thing that works is M-x customize-group python, and
    Thomas> change the value of 'Python Command'. However, this changes the
    Thomas> interpreter for all buffers, but I want different buffers use
    Thomas> different interpreters. Is that possible?

    Thomas,

    py-python-command is not buffer local. Try executing

    (make-variable-buffer-local 'py-python-command)

    and let me know if that allows your Local Variables setting to work.

    Skip
     
    , Jan 13, 2006
    #2
    1. Advertising

  3. writes:

    > Thomas> I'm trying to customize the python interpreter that is used to
    > Thomas> execute my scripts from within WinXP, XEmacs, python-mode
    > Thomas> version $Revision4.70$, but cannot get it to work.
    >
    > Thomas> The only thing that works is M-x customize-group python, and
    > Thomas> change the value of 'Python Command'. However, this changes the
    > Thomas> interpreter for all buffers, but I want different buffers use
    > Thomas> different interpreters. Is that possible?
    >
    > Thomas,
    >
    > py-python-command is not buffer local. Try executing
    >
    > (make-variable-buffer-local 'py-python-command)
    >
    > and let me know if that allows your Local Variables setting to work.


    No, it doesn't work. The only ugly workaround that I found was to use
    py-toggle-shells, and create a jython.bat file which invokes the other
    interpreter.

    Thomas
     
    Thomas Heller, Jan 13, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ian Adams
    Replies:
    0
    Views:
    342
    Ian Adams
    Apr 16, 2004
  2. Jorge Godoy

    Folding in XEmacs with python mode.

    Jorge Godoy, Jul 25, 2004, in forum: Python
    Replies:
    0
    Views:
    390
    Jorge Godoy
    Jul 25, 2004
  3. Thomas Fischer

    xemacs vhdl mode goto error

    Thomas Fischer, Aug 20, 2006, in forum: VHDL
    Replies:
    10
    Views:
    2,844
  4. bluesforsalvador
    Replies:
    0
    Views:
    609
    bluesforsalvador
    Jun 9, 2008
  5. bluesforsalvador

    Xemacs vhdl-mode editing header string

    bluesforsalvador, Jun 9, 2008, in forum: VHDL
    Replies:
    0
    Views:
    409
    bluesforsalvador
    Jun 9, 2008
Loading...

Share This Page