Xilinx Spartan-3E starter kit : VGA

Discussion in 'VHDL' started by Peak, May 21, 2009.

  1. Peak

    Peak

    Joined:
    May 21, 2009
    Messages:
    2
    Location:
    France
    Hello everyone,

    I'm new to velocityreviews. I'm searching for an answer about a problem I have with VGA port on Xilinx Spartan-3E starter kit.

    For the moment and for tests, i'm trying to use switches as color selector for the entire screen (each switch is mapped on a color bit, red, green and blue color bits).

    The resolution is 640x480 @ 60Hz. I use the timings shown in starter kit user guide. The monitor detect the correct resolution and the correct frequency. But I've a problem with the colors. The screen show the correct color for a few seconds and then become black. Each time I change the state of a switch, the screen do this. I tried with constants for each color bit. For example : '1' for red, '0' for green and '1' for blue, but the screen remains totally black.

    I've correctly edit the ucf constraint file like in the user guide.

    Has anyone an idea about the problem?

    Thanks for your help.

    Peak.
     
    Peak, May 21, 2009
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Leon Heller

    Spartan 3 Starter Kit group formed

    Leon Heller, Jun 6, 2005, in forum: VHDL
    Replies:
    0
    Views:
    545
    Leon Heller
    Jun 6, 2005
  2. mBird
    Replies:
    3
    Views:
    6,090
    mBird
    Feb 23, 2006
  3. dev648237923

    Serial Port on Spartan 3 Starter Kit

    dev648237923, Jul 7, 2006, in forum: VHDL
    Replies:
    3
    Views:
    5,074
    Frank Buss
    Jul 7, 2006
  4. Javi
    Replies:
    2
    Views:
    1,455
  5. TTX
    Replies:
    0
    Views:
    1,206
Loading...

Share This Page