XML::XSLT is no longer doing disable-output-escaping

Discussion in 'Perl Misc' started by rollin368@gmail.com, May 25, 2006.

  1. Guest

    We have an XSL file that specifies disabling output escaping as
    follows.

    =====
    <xsl:template match="parag"><P><xsl:value-of select="."
    disable-output-escaping="yes"/></P></xsl:template>
    =====

    It used to work on our Linux servers, but no longer does! For example,
    $#169;, the copyright symbol, is getting translated as the symbol when
    we do not want it to.

    We added DBD::Mysql recently but that is the one big change I am aware
    of, besides a change to /etc/sysconfig/i18n.

    The variable LANG is "en_US.UTF-8" as of now.

    Is there another configuration that needs changing?
     
    , May 25, 2006
    #1
    1. Advertising

  2. Guest

    I am finding that XML::XSLT will not escape © but DOES escape
    –.

    and example of this is the following...
    ==========
    <parag>As hard as it was in the © Senate to pull together a
    winning coalition on immigration reform,
    getting to "yes" with the House – in a form that can again pass
    both bodies – will be even tou
    gher.</parag>
    ==========

    Is there any way to prevent the – character from being escaped?
     
    , May 26, 2006
    #2
    1. Advertising

  3. Dr.Ruud Guest

    schreef:

    > I am finding that XML::XSLT will not escape © but DOES escape
    > –.
    >
    > and example of this is the following...
    > ==========
    > <parag>As hard as it was in the © Senate to pull together a
    > winning coalition on immigration reform,
    > getting to "yes" with the House – in a form that can again pass
    > both bodies – will be even tou
    > gher.</parag>
    > ==========
    >
    > Is there any way to prevent the – character from being escaped?


    Did you also try with HTML-entities like "&copy;" and "&ndash;"?

    --
    Affijn, Ruud

    "Gewoon is een tijger."
     
    Dr.Ruud, May 26, 2006
    #3
  4. Guest

    It appears I have the same issue with a named entity reference like
    &ndash.

    In a Solaris system running XML::XSLT it seems to not have these
    issues.
    If I output as html a single byte entity such as © will not be
    escapped but &ndash; is.

    For text XSL is there a way to restrict the character set output and
    have XML::XSLT do smart substitution?
     
    , May 26, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Joe Price
    Replies:
    6
    Views:
    652
    Joe Price
    Sep 26, 2003
  2. Lisa
    Replies:
    1
    Views:
    6,134
    Martin Honnen
    Jul 7, 2004
  3. Troot

    disable-output-escaping

    Troot, Mar 1, 2006, in forum: XML
    Replies:
    5
    Views:
    2,652
    Troot
    Mar 2, 2006
  4. David Henderson
    Replies:
    3
    Views:
    3,287
    Jerinaw
    Dec 30, 2010
  5. Sean T Allen

    library for doing html escaping...

    Sean T Allen, Apr 29, 2005, in forum: Ruby
    Replies:
    2
    Views:
    112
Loading...

Share This Page