XSL-1000: (Fatal Error) Error while parsing XSL file (org.apache.xerces.parsers.AbstractSAXParser$At

Discussion in 'Java' started by Kevin Flood, Sep 8, 2004.

  1. Kevin Flood

    Kevin Flood Guest

    (Apologies, ignore the last post!)

    Hi

    I'm trying to get a web-app working on aix on an Oracle 10g but
    getting this
    error:

    2004-09-08 05:25:32,738 41036 ERROR
    [AJPRequestHandler-ApplicationServerThread-10] ui.ActionServlet -
    Unexpected error thrown in servlet
    javax.servlet.ServletException: XSL-1000: (Fatal Error) Error while
    parsing XSL file (org.apache.xerces.parsers.AbstractSAXParser$AttributesProxy).
    at com.evermind.server.http.EvermindPageContext.handlePageThrowable(EvermindPageContext.java:595)
    at com.evermind.server.http.EvermindPageContext.handlePageException(EvermindPageContext.java:537)
    at _organisationselect._jspService(_organisationselect.java:1740)


    The error happens on any jsp page that performs a taglib x:transform.
    The app works fine on Oracle 10g on an NT box and fine on Tomcat 4.1.3
    server.

    I ran the xerces reporting tool (java
    org.apache.xalan.xslt.EnvironmentCheck) and got the following results:

    Oracle 10g on AIX SERVER (doesn't work):


    #---- BEGIN writeEnvironmentReport(Revision: 1.27): Useful stuff
    found: ----
    version.DOM.draftlevel=2.0fd
    java.class.path=
    version.JAXP=1.1 or higher
    java.ext.dirs=/usr/java14_64/jre/lib/ext
    #---- BEGIN Listing XML-related jars in:
    foundclasses.sun.boot.class.path ----
    xml.jar-apparent.version=xml.jar present-unknown-version
    xml.jar-path=/usr/java14_64/jre/lib/xml.jar
    #----- END Listing XML-related jars in:
    foundclasses.sun.boot.class.path -----
    version.xerces2=XML4J 4.3.1
    version.b2bxml=1.2.1
    version.xerces1=not-present
    version.xalan2_2=XSLT4J Java 2.6.1
    version.xalan1=not-present
    version.ant=not-present
    java.version=1.4.2
    version.DOM=2.0
    version.crimson=not-present
    sun.boot.class.path=/usr/java14_64/jre/lib/core.jar:/usr/java14_64/jre/lib/graphics.jar:/usr/java14_
    64/jre/lib/security.jar:/usr/java14_64/jre/lib/server.jar:/usr/java14_64/jre/lib/xml.jar:/usr/java14
    _64/jre/lib/charsets.jar:/usr/java14_64/jre/classes:/usr/java14_64/jre/lib/ibmcertpathprovider.jar:/
    usr/java14_64/jre/lib/ibmjaaslm.jar:/usr/java14_64/jre/lib/ibmjcefw.jar:/usr/java14_64/jre/lib/ibmjg
    ssprovider.jar:/usr/java14_64/jre/lib/ibmjssefips.jar:/usr/java14_64/jre/lib/ibmjsseprovider.jar:/us
    r/java14_64/jre/lib/ibmorb.jar:/usr/java14_64/jre/lib/ibmorbapi.jar:/usr/java14_64/jre/lib/ibmpkcs.jar
    version.SAX=2.0
    version.xalan2x=XSLT4J Java 2.6.1
    #----- END writeEnvironmentReport: Useful properties found: -----
    # YAHOO! Your environment seems to be OK.



    Oracle 10g on NT Server (works ok):
    #---- BEGIN writeEnvironmentReport($Revision: 1.14 $): Useful stuff
    found: ----
    version.DOM.draftlevel=2.0fd
    java.class.path=C:\Program Files\jwhich;
    version.JAXP=1.1
    java.ext.dirs=C:\Program Files\Java\j2re1.4.2_05\lib\ext
    version.xerces2=not-present
    version.xerces1=not-present
    version.xalan2_2=Xalan Java 2.4.1
    version.xalan1=not-present
    version.ant=not-present
    java.version=1.4.2_05
    version.DOM=2.0
    version.crimson=present-unknown-version
    sun.boot.class.path=C:\Program
    Files\Java\j2re1.4.2_05\lib\rt.jar;C:\Program Files\Java\j2re1.4.2_05
    \lib\i18n.jar;C:\Program
    Files\Java\j2re1.4.2_05\lib\sunrsasign.jar;C:\Program
    Files\Java\j2re1.4.2_
    05\lib\jsse.jar;C:\Program
    Files\Java\j2re1.4.2_05\lib\jce.jar;C:\Program
    Files\Java\j2re1.4.2_05\li
    b\charsets.jar;C:\Program Files\Java\j2re1.4.2_05\classes
    version.SAX=2.0
    version.xalan2x=Xalan Java 2.4.1
    #----- END writeEnvironmentReport: Useful properties found: -----
    # YAHOO! Your environment seems to be OK.


    I'm sure this is a parser version/conflict issue but has anyone got
    any specific ideas?

    Any help would be much appreciated.

    All the best,

    Kevin
     
    Kevin Flood, Sep 8, 2004
    #1
    1. Advertising

  2. Kevin Flood

    Kevin Flood Guest

    For anyone who's interested:
    Solved this problem by upgrading the version of the jdk that is
    bundled with Oracle App Server to jdk version 1.4.2_04.

    Kevin

    (Kevin Flood) wrote in message news:<>...
    > (Apologies, ignore the last post!)
    >
    > Hi
    >
    > I'm trying to get a web-app working on aix on an Oracle 10g but
    > getting this
    > error:
    >
    > 2004-09-08 05:25:32,738 41036 ERROR
    > [AJPRequestHandler-ApplicationServerThread-10] ui.ActionServlet -
    > Unexpected error thrown in servlet
    > javax.servlet.ServletException: XSL-1000: (Fatal Error) Error while
    > parsing XSL file (org.apache.xerces.parsers.AbstractSAXParser$AttributesProxy).
    > at com.evermind.server.http.EvermindPageContext.handlePageThrowable(EvermindPageContext.java:595)
    > at com.evermind.server.http.EvermindPageContext.handlePageException(EvermindPageContext.java:537)
    > at _organisationselect._jspService(_organisationselect.java:1740)
    >
    >
    > The error happens on any jsp page that performs a taglib x:transform.
    > The app works fine on Oracle 10g on an NT box and fine on Tomcat 4.1.3
    > server.
    >
    > I ran the xerces reporting tool (java
    > org.apache.xalan.xslt.EnvironmentCheck) and got the following results:
    >
    > Oracle 10g on AIX SERVER (doesn't work):
    >
    >
    > #---- BEGIN writeEnvironmentReport(Revision: 1.27): Useful stuff
    > found: ----
    > version.DOM.draftlevel=2.0fd
    > java.class.path=
    > version.JAXP=1.1 or higher
    > java.ext.dirs=/usr/java14_64/jre/lib/ext
    > #---- BEGIN Listing XML-related jars in:
    > foundclasses.sun.boot.class.path ----
    > xml.jar-apparent.version=xml.jar present-unknown-version
    > xml.jar-path=/usr/java14_64/jre/lib/xml.jar
    > #----- END Listing XML-related jars in:
    > foundclasses.sun.boot.class.path -----
    > version.xerces2=XML4J 4.3.1
    > version.b2bxml=1.2.1
    > version.xerces1=not-present
    > version.xalan2_2=XSLT4J Java 2.6.1
    > version.xalan1=not-present
    > version.ant=not-present
    > java.version=1.4.2
    > version.DOM=2.0
    > version.crimson=not-present
    > sun.boot.class.path=/usr/java14_64/jre/lib/core.jar:/usr/java14_64/jre/lib/graphics.jar:/usr/java14_
    > 64/jre/lib/security.jar:/usr/java14_64/jre/lib/server.jar:/usr/java14_64/jre/lib/xml.jar:/usr/java14
    > _64/jre/lib/charsets.jar:/usr/java14_64/jre/classes:/usr/java14_64/jre/lib/ibmcertpathprovider.jar:/
    > usr/java14_64/jre/lib/ibmjaaslm.jar:/usr/java14_64/jre/lib/ibmjcefw.jar:/usr/java14_64/jre/lib/ibmjg
    > ssprovider.jar:/usr/java14_64/jre/lib/ibmjssefips.jar:/usr/java14_64/jre/lib/ibmjsseprovider.jar:/us
    > r/java14_64/jre/lib/ibmorb.jar:/usr/java14_64/jre/lib/ibmorbapi.jar:/usr/java14_64/jre/lib/ibmpkcs.jar
    > version.SAX=2.0
    > version.xalan2x=XSLT4J Java 2.6.1
    > #----- END writeEnvironmentReport: Useful properties found: -----
    > # YAHOO! Your environment seems to be OK.
    >
    >
    >
    > Oracle 10g on NT Server (works ok):
    > #---- BEGIN writeEnvironmentReport($Revision: 1.14 $): Useful stuff
    > found: ----
    > version.DOM.draftlevel=2.0fd
    > java.class.path=C:\Program Files\jwhich;
    > version.JAXP=1.1
    > java.ext.dirs=C:\Program Files\Java\j2re1.4.2_05\lib\ext
    > version.xerces2=not-present
    > version.xerces1=not-present
    > version.xalan2_2=Xalan Java 2.4.1
    > version.xalan1=not-present
    > version.ant=not-present
    > java.version=1.4.2_05
    > version.DOM=2.0
    > version.crimson=present-unknown-version
    > sun.boot.class.path=C:\Program
    > Files\Java\j2re1.4.2_05\lib\rt.jar;C:\Program Files\Java\j2re1.4.2_05
    > \lib\i18n.jar;C:\Program
    > Files\Java\j2re1.4.2_05\lib\sunrsasign.jar;C:\Program
    > Files\Java\j2re1.4.2_
    > 05\lib\jsse.jar;C:\Program
    > Files\Java\j2re1.4.2_05\lib\jce.jar;C:\Program
    > Files\Java\j2re1.4.2_05\li
    > b\charsets.jar;C:\Program Files\Java\j2re1.4.2_05\classes
    > version.SAX=2.0
    > version.xalan2x=Xalan Java 2.4.1
    > #----- END writeEnvironmentReport: Useful properties found: -----
    > # YAHOO! Your environment seems to be OK.
    >
    >
    > I'm sure this is a parser version/conflict issue but has anyone got
    > any specific ideas?
    >
    > Any help would be much appreciated.
    >
    > All the best,
    >
    > Kevin
     
    Kevin Flood, Sep 13, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.

Share This Page