XSL-FO special character to PDF

Discussion in 'XML' started by Bal, Dec 4, 2003.

  1. Bal

    Bal Guest

    Hi,
    I am trying to generate a pdf using a XML file and rendering the page
    through XSL Stylesheet to a PDF. But the page has some special
    characters, as its for a chequ website.

    My Code below is

    <--xsl:page-->

    <?xml version="1.0" encoding="UTF-8"?>
    <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
    version="1.0">
    <xsl:template match="/">
    <fo:root xmlns:fo="http://www.w3.org/1999/XSL/Format">.....
    Ň

    <--/xsl:page-->

    My problem is that when the page renders in the PDF the special
    character Ň
    renders as just #.
    I have trawled through most of the newsgroups and no luck, only to
    know (or think) that the problem is with the unicoding.
    Please could you help me
    Thanks

    Brandon
    Bal, Dec 4, 2003
    #1
    1. Advertising

  2. Bal

    John Root Guest

    On 12/4/03 3:41 AM, in article
    , "Bal" <>
    wrote:

    > My problem is that when the page renders in the PDF the special
    > character Ň
    > renders as just #.


    Brandon,

    The font-family you are calling does not contain a glyph for this character.
    Hence the output '#'. By default, FOP only uses the base 14 fonts.

    To use a font that includes this glyph, you need to build a font metrics
    file (in xml) for the font using either PFMReader or TTFReader (part of the
    Apache FOP distribution), then register the font with FOP by modifying or
    setting up an FOP configuration file.

    John

    ~~~~~~~~~~~~~~
    John Root
    Publishing Systems

    ~~~~~~~~~~~~~~
    John Root, Dec 4, 2003
    #2
    1. Advertising

  3. Bal

    Bal Guest

    John Root <> wrote in message news:<BBF4B90B.106D6%>...
    > On 12/4/03 3:41 AM, in article
    > , "Bal" <>
    > wrote:
    >
    > > My problem is that when the page renders in the PDF the special
    > > character Ň
    > > renders as just #.

    >
    > Brandon,
    >
    > The font-family you are calling does not contain a glyph for this character.
    > Hence the output '#'. By default, FOP only uses the base 14 fonts.
    >
    > To use a font that includes this glyph, you need to build a font metrics
    > file (in xml) for the font using either PFMReader or TTFReader (part of the
    > Apache FOP distribution), then register the font with FOP by modifying or
    > setting up an FOP configuration file.
    >
    > John
    >
    > ~~~~~~~~~~~~~~
    > John Root
    > Publishing Systems
    >
    > ~~~~~~~~~~~~~~




    Thanks John,
    I have tried changing the config file, and it seems to have worked:)))!!!
    Bal, Dec 8, 2003
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Gaizka
    Replies:
    5
    Views:
    2,251
    Gaizka
    Oct 13, 2004
  2. Replies:
    1
    Views:
    3,589
    A. Bolmarcich
    May 27, 2005
  3. cybernerdsx2

    xsl:for-each with special expression

    cybernerdsx2, Dec 7, 2005, in forum: XML
    Replies:
    2
    Views:
    535
    Peter Flynn
    Dec 8, 2005
  4. Ricardo Pog
    Replies:
    1
    Views:
    400
    Austin Ziegler
    Mar 26, 2008
  5. Sean Nakasone
    Replies:
    1
    Views:
    343
    Farrel Lifson
    Apr 14, 2008
Loading...

Share This Page