YAML warning

Discussion in 'Ruby' started by Jim Freeze, Oct 1, 2003.

  1. Jim Freeze

    Jim Freeze Guest

    Hi

    In 1.8.0, I get the following warning when $VERBOSE = true:

    src/yaml.y.rb:208: warning: ambiguous first argument; make sure


    Why Why? :)

    --
    Jim Freeze
    ----------
     
    Jim Freeze, Oct 1, 2003
    #1
    1. Advertising

  2. On Wednesday 01 October 2003 09:16 am, Jim Freeze wrote:
    > In 1.8.0, I get the following warning when $VERBOSE = true:
    >
    > src/yaml.y.rb:208: warning: ambiguous first argument; make sure


    There should be no yaml.y.rb references in YAML modules later than 0.49.2.
    This error seems to indicate that an older version is being loaded. You
    didn't try to install YAML over Ruby 1.8?

    _why
     
    why the lucky stiff, Oct 2, 2003
    #2
    1. Advertising

  3. Jim Freeze

    Jim Freeze Guest

    On Friday, 3 October 2003 at 2:46:13 +0900, why the lucky stiff wrote:
    > On Wednesday 01 October 2003 09:16 am, Jim Freeze wrote:
    > > In 1.8.0, I get the following warning when $VERBOSE = true:
    > >
    > > src/yaml.y.rb:208: warning: ambiguous first argument; make sure

    >
    > There should be no yaml.y.rb references in YAML modules later than 0.49.2.
    > This error seems to indicate that an older version is being loaded. You
    > didn't try to install YAML over Ruby 1.8?
    >


    Ahh yes. It was an old copy of yaml lying around.

    Thanks

    --
    Jim Freeze
    ----------
    Absurdity, n.:
    A statement or belief manifestly inconsistent with one's own
    opinion.
    -- Ambrose Bierce, "The Devil's Dictionary"
     
    Jim Freeze, Oct 2, 2003
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. RubyQuestions
    Replies:
    0
    Views:
    241
    RubyQuestions
    Dec 3, 2003
  2. Paul Battley

    YAML.dump/YAML.load bug

    Paul Battley, Aug 3, 2005, in forum: Ruby
    Replies:
    0
    Views:
    201
    Paul Battley
    Aug 3, 2005
  3. Eric Promislow
    Replies:
    4
    Views:
    228
    Eric Promislow
    Oct 31, 2006
  4. Joshua Choi

    yaml.rb and YAML "%" directives

    Joshua Choi, Jan 14, 2007, in forum: Ruby
    Replies:
    1
    Views:
    193
  5. Fransiscus Xaverius

    YAML Problem YAML::Object

    Fransiscus Xaverius, Dec 14, 2007, in forum: Ruby
    Replies:
    2
    Views:
    167
    Fransiscus Xaverius
    Dec 14, 2007
Loading...

Share This Page