IE 6 Blocks Javascript

Discussion in 'Javascript' started by Mike Scholl, Feb 17, 2005.

  1. Mike Scholl

    Mike Scholl Guest

    Can someone help me here.

    I have a web site with some javscript. When I upgraded to WinXP IE6 etc I
    found that opening my site I get an Information Bar message that Internet
    Explorer has restricted this file from showing active content. Presumably
    anyone else accessing my site gets the same message.
    However when I access other sites with javascript I don't get the message.
    Ergo it must be my code that is the problem.


    Mike
     
    Mike Scholl, Feb 17, 2005
    #1
    1. Advertisements

  2. Mike Scholl

    Randy Webb Guest

    Search the groups.google.com archives of comp.lang.javascript for the
    string "Mark of the Web" and read the thread. It will answer your
    question, and, tell you the solution.
     
    Randy Webb, Feb 17, 2005
    #2
    1. Advertisements

  3. Mike Scholl

    Kien Guest

    Hi,

    If you test the page *locally* you'll get the message.
    But if you upload it and see it online, you won't.
    The bar is there to warn you that the script is accessing something in
    your *local* hard-drive, like images or text-files or something.

    Kien
     
    Kien, Feb 19, 2005
    #3
  4. Mike Scholl

    Randy Webb Guest

    NO. The bar is not there for that reason. Had you bothered to read the
    article/thread I mentioned you would have found that out. An empty
    script block as such:

    <script type="text/javascript"></script>

    will cause that bar to be present. Now, how is that script above
    "accessing something on your local hard drive"?

    And read the group FAQ. It will do you good.

    --
    Randy
    comp.lang.javascript FAQ - http://jibbering.com/faq & newsgroup weekly
    Answer:It destroys the order of the conversation
    Question: Why?
    Answer: Top-Posting.
    Question: Whats the most annoying thing on Usenet?
     
    Randy Webb, Feb 19, 2005
    #4
  5. Mike Scholl

    Kien Guest

    Hi Randy,

    OK I take that back but ...
    The "Mark of the Web" didn't work.
    I tested it locally and the bar is still there.

    Isn't there a way to manually and locally switch of this annoying
    "feature" of IE6 WXP sp2?

    Kien
     
    Kien, Feb 22, 2005
    #5
  6. Mike Scholl

    Randy Webb Guest

    Sample code? I have never had it fail in IE6 XP SP2.
    I think, not sure, that you can edit the registry but not sure.
     
    Randy Webb, Feb 22, 2005
    #6
  7. Mike Scholl

    Grant Wagner Guest

    Correctly inserting the "Mark of the Web" does work:

    <!-- saved from url=(0014)about:internet -->
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    <title>Title</title>
    </head>
    <body>
    </body>
    </html>

    The above places the script in the Internet zone, and therefore IE does
    not block any script, since script in the Internet zone can not do the
    damage that one running in the My Computer zone can.
    Yes.

    Tools > Internet Options > Advanced
    Security section
    check "Allow active content to run in files on My Computer"
     
    Grant Wagner, Feb 23, 2005
    #7
  8. JRS: In article <ke5Td.218$>, dated Wed, 23 Feb
    2005 19:57:04, seen in Grant Wagner
    <> posted :

    IMHO, the Mark should be in the FAQ.

    Since there seems to be some difficulty or delaying element as regards
    FAQ updates, can the newsgroup itself develop an item on the Mark,
    suitable for direct quotation or insertion?

    The above is no doubt correct, but IMHO a little more explanation would
    be appropriate for a FAQ response.
     
    Dr John Stockton, Feb 24, 2005
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.