Missing assembly / dependencies error

S

Scott Hamlin

I am receiving an error while trying to use Crystal Reports with .NET, which
I have pasted below. The main problem is this message:

File or assembly name CrystalDecisions.CrystalReports.Engine, or one of
its dependencies, was not found.

I have checked the winnt/assembly directory and the assembly is there. I
have two versions of the file - 9.1.5000.0 and 9.1.3300.0. I have tried both
with no luck. Is there another assembly that
CrystalDecisions.CrystalReports.Engine depends upon to work? I have added a
few others, but nothing has thusfar worked.

Thank you,
Scott



Server Error in '/JuryFees' Application.
----------------------------------------------------------------------------
----

Configuration Error
Description: An error occurred during the processing of a configuration file
required to service this request. Please review the specific error details
below and modify your configuration file appropriately.

Parser Error Message: File or assembly name
CrystalDecisions.CrystalReports.Engine, or one of its dependencies, was not
found.

Source Error:


Line 17: <compilation defaultLanguage="vb" debug="true">
Line 18: <assemblies>
Line 19: <add assembly="CrystalDecisions.CrystalReports.Engine,
Version=9.1.5000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/>
Line 20: <add assembly="CrystalDecisions.ReportSource,
Version=9.1.5000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/>
Line 21: <add assembly="CrystalDecisions.Shared, Version=9.1.5000.0,
Culture=neutral, PublicKeyToken=692fbea5521e1304"/>


Source File: c:\inetpub\wwwroot\JuryFees\web.config Line: 19

Assembly Load Trace: The following information can be helpful to determine
why the assembly 'CrystalDecisions.CrystalReports.Engine' could not be
loaded.


=== Pre-bind state information ===
LOG: DisplayName = CrystalDecisions.CrystalReports.Engine,
Version=9.1.5000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304
(Fully-specified)
LOG: Appbase = file:///c:/inetpub/wwwroot/JuryFees
LOG: Initial PrivatePath = bin
Calling assembly : (Unknown).
===

LOG: Publisher policy file is not found.
LOG: No redirect found in host configuration file
(C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet.config).
LOG: Using machine configuration file from
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\config\machine.config.
LOG: Post-policy reference: CrystalDecisions.CrystalReports.Engine,
Version=9.1.5000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/juryfees/fd86348f/b84fa5a7/CrystalDecisions.CrystalReports.Engine.DLL.
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/juryfees/fd86348f/b84fa5a7/CrystalDecisions.CrystalReports.Engine/Crys
talDecisions.CrystalReports.Engine.DLL.
LOG: Attempting download of new URL
file:///c:/inetpub/wwwroot/JuryFees/bin/CrystalDecisions.CrystalReports.Engi
ne.DLL.
LOG: Attempting download of new URL
file:///c:/inetpub/wwwroot/JuryFees/bin/CrystalDecisions.CrystalReports.Engi
ne/CrystalDecisions.CrystalReports.Engine.DLL.
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/juryfees/fd86348f/b84fa5a7/CrystalDecisions.CrystalReports.Engine.EXE.
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/juryfees/fd86348f/b84fa5a7/CrystalDecisions.CrystalReports.Engine/Crys
talDecisions.CrystalReports.Engine.EXE.
LOG: Attempting download of new URL
file:///c:/inetpub/wwwroot/JuryFees/bin/CrystalDecisions.CrystalReports.Engi
ne.EXE.
LOG: Attempting download of new URL
file:///c:/inetpub/wwwroot/JuryFees/bin/CrystalDecisions.CrystalReports.Engi
ne/CrystalDecisions.CrystalReports.Engine.EXE.
 
S

Scott Hamlin

I figured it out. Crystal 10 was installed on the server, but not on my
machine, so that is why I was receiving conflicting assembly versions.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Forum statistics

Threads
473,818
Messages
2,569,727
Members
45,661
Latest member
NadineBour

Latest Threads

Top