Problems with aspnet_wp.exe

Discussion in 'ASP .Net' started by Guest, Nov 30, 2004.

  1. Guest

    Guest Guest

    System: Windows 2000 SP4
    ..NET Frameworks Installed: 1.0, 1.1 SP1
    ..NET Framework In Question: 1.1 SP1
    Web Server: IIS 5
    Process Model User: machine
    Development Environment: VS.NET 2003
    Development System: WinXP

    The wednesday before Thanksgiving our web server started exhibiting some
    incredibly strange behavior. On every hit of the a page it loads and
    subsequently unloads the aspnet_wp.exe. I can watch it happen in Task
    Manager when I load a page in the browser.

    The web app is relatively involved so I removed the references, excluded
    nearly everything and created a simple "hello world" type ASPX page w/ a
    codebehind class. Even with this super simplified assembly the behaviour
    occurs.

    I have uninstalled all .NET frameworks along w/ IIS, deleted the contents of
    \winnt\system32\intesrv and then reinstalled IIS followed by both frameworks
    in order by version and the problem persists.

    To may dismay, the event logs show nothing!

    If anyone can offer any suggestions on how to proceed I would really
    appreciate it.

    Thanks!
     
    Guest, Nov 30, 2004
    #1
    1. Advertisements

  2. Guest

    Guest Guest

    Contact Microsoft directly. I am assuming that you have exhausted all other
    methods like searching google gropus, microsoft KB, etc.
     
    Guest, Nov 30, 2004
    #2
    1. Advertisements

  3. Guest

    gerry Guest

    Was there any resolution to this problem ?
    We just starting encountering this same behaviour on W2kServer - I am
    assuming this is related to recent windows updates.

    Gerry
     
    gerry, Dec 20, 2004
    #3
  4. Guest

    Guest Guest

    Gerry,

    We did get this issue resolved. My apologies for not having posted the
    resolution for everyone's benefit. As it turns out, it was something
    extremely simple in the end. We had attempted to install a profiling tool
    on the web server and the install had gone tragically wrong with side effects
    that were pretty extreme. In short, IIS and the ASP.NET wouldn't play nice
    together anymore even after removing and re-adding script maps and several
    other similar steps. In the end we had to backup the metabase, uninstall
    IIS, reboot, reinstall, IIS, reboot, restore the metabase. After completing
    those steps ASP.NET and IIS began playing nice again but we noticed the
    problem described in this post. It turned out that somehow durring all the
    previous madness the Cache ISAPI Applications checkbox at the tob of the
    dialog that appears after clicking the Configuration button on the Home
    Directory tab of Web Site properties had gotten un-checked. Simply checking
    Cache ISAPI Applications fixed the issue. No one had even though to check it
    before that because we "knew" it hadn't been changed.

    That's probably a bit long-winded but I hope it helps.
     
    Guest, Dec 20, 2004
    #4
  5. Guest

    gerry Guest

    Thanks Everett.
    That fixed it. This must have been the undocumented result of a recent
    windows update as this happened on all of our my sites and since I am the
    only one with access to them I know that this setting was not altered
    manually.

    Thanks again

    Gerry
     
    gerry, Dec 20, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.