Request.ServerVariables("Logon_User")


T

T.

Hello,

I'm trying to pull the logon user's name using
Request.ServerVariables("LOGON_USER")...which is returning nothing...so I
need help in determining why it's returning nothing, or I need the format in
which it returns the username so that I can hard code it. Does it return
anything with the username?

Thanks...
 
Ad

Advertisements

S

Shiva

Hi,
It will be empty if anonymous access is allowed. Deny anonymous
authentication and turn on Basic, Digest or Integrated auth to force
authentication and hence get a value for LOGON_USER server variable.

HTH

Hello,

I'm trying to pull the logon user's name using
Request.ServerVariables("LOGON_USER")...which is returning nothing...so I
need help in determining why it's returning nothing, or I need the format in
which it returns the username so that I can hard code it. Does it return
anything with the username?

Thanks...
 
T

T.

Shiva my friend...this is exactly what I did...and no luck.

strLoginID = Request.ServerVariables("LOGON_USER")
response.write strLoginID

Returns nothing....
 
M

Marina

Do you have only windows authentication on, on the virtual directory your
app is in?
 
T

T.

That option is selected but not available...so I tried every possible
combinations for those options...also my web.config authenication is set to
"Windows"
 
W

William F. Robertson, Jr.

What do you mean the option for integrated authentication is "selected but
not available"?

If you are using NT authentication, dump the logon_user lookup and go with
User.Idenity.Name.

bill
 
Ad

Advertisements

Joined
Nov 18, 2008
Messages
1
Reaction score
0
Hi,

In my virtual directory security, whenever I disable the anonymous access and Integrated windows authentication checked, users from my intranet site have to logon with there windows login. Is there a way to bypass the logon?

Thanks,
 
Ad

Advertisements

Joined
Apr 28, 2011
Messages
1
Reaction score
0
Request.ServerVariables("LOGON_USER") displays login info, but it displays the user logged on to the server and not the local user name.
 

Top