ResourcePool is not supported


D

David

Hello
When I try to open a connection to a sql server database
from my aspnet app I get the following exception
message: 'ResourcePool' is not supported on the current
platform. I can connect OK using the exact same code to
the same database from a win forms app. I haven't
recently re installed the framework to try and solve
another issue,which has now been solved. As a result of
this and reading posts relating to this issue i have ran
regsvr32 for comsvcs.dll and oledb32.dll.

My O/s is Win 2000 sp3 and I am connecting to a Sql Server
2000 database also with sp3

Has any got any suggestions as to what my next move should
be.

Thanks

David
 
Ad

Advertisements

Hi Yanhong!

Do you have any other suggestions regarding this issue?

I get the same error message trying to run a project originally written on
VS.NET and FW1.0 now working on VS.NET 2003 and FW1.1.

The stack trace is as follows:

Exception Details: System.PlatformNotSupportedException: 'ResourcePool' is
not supported on the current platform.

Source Error:

An unhandled exception was generated during the execution of the
current web request. Information regarding the origin and location of the
exception can be identified using the exception stack trace below.

Stack Trace:

[PlatformNotSupportedException: 'ResourcePool' is not supported on the
current platform.]
System.EnterpriseServices.Platform.Assert(Boolean fSuccess, String
function) +69
System.EnterpriseServices.Platform.Assert(Version platform, String
function) +71
System.EnterpriseServices.ResourcePool..ctor(TransactionEndDelegate cb)
+38
System.Data.SqlClient.ConnectionPool..ctor(DefaultPoolControl ctrl) +797
System.Data.SqlClient.PoolManager.FindOrCreatePool(DefaultPoolControl
ctrl, IntPtr SID) +260

System.Data.SqlClient.SqlConnectionPoolManager.GetPooledConnection(SqlConnec
tionString options, Boolean& isInTransaction) +358
System.Data.SqlClient.SqlConnection.Open() +384

Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.DiscoverSpParameter
Set(SqlConnection connection, String spName, Boolean
includeReturnValueParameter) in c:\documents and settings\bjarne l. gram\my
documents\my projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2429

Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.GetSpParameterSetIn
ternal(SqlConnection connection, String spName, Boolean
includeReturnValueParameter) in c:\documents and settings\bjarne l. gram\my
documents\my projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2602

Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.GetSpParameterSet(S
tring connectionString, String spName, Boolean includeReturnValueParameter)
in c:\documents and settings\bjarne l. gram\my documents\my
projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2546

Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.GetSpParameterSet(S
tring connectionString, String spName) in c:\documents and settings\bjarne
l. gram\my documents\my
projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2526
Microsoft.ApplicationBlocks.Data.SqlHelper.ExecuteReader(String
connectionString, String spName, Object[] parameterValues) in c:\documents
and settings\bjarne l. gram\my documents\my
projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:909
....


Best regards

Bjarne L. Gram
Seniorconsultant - MCP
Ementor Norge AS
Microsoft Gold Certified Partner
(e-mail address removed)

Yan-Hong Huang said:
Hello David,

I am glad that the problem is resovled. Generally speaking, when the web
applicaiton is set to used anonymous and
windows authentication in IIS. Then a client will try to access it using
anonymous. If it successes, then it will use anonymoust
to set up the connections. If it failed(when some page denies access to
anonymous user), it will try windows authentication.
 
Y

Yan-Hong Huang[MSFT]

Hello Bjarne,

This problem is some times caused by incorrect version of comadmin.dll on your system. You can check the following:
1) check in the registry for the existence of the key:

HKEY_CLASSES_ROOT \ CLSID \ {6EB22881-8A19-11D0-81B6-00A0C9231C29}

the InprocServer32 value should have a default which points to a dll somewhere in the windows directory (system32\com
\comadmin.dll)

2) confirm that comadmin.dll does exist in the location pointed to by the registry.

3) to make sure COM+ is working, you might want to open up the Component Services Explorer (under Administrative Tools),
and try clicking down on "My Computer" to get a list of COM+ Applications...

Hope it helps.

Best regards,
Yanhong Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

--------------------
!From: "[email protected]" <[email protected]>
!References: <[email protected]> <[email protected]>
<[email protected]>
!Subject: Re: ResourcePool is not supported
!Date: Tue, 12 Aug 2003 11:45:50 +0200
!Lines: 133
!X-Priority: 3
!X-MSMail-Priority: Normal
!X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!Message-ID: <#[email protected]>
!Newsgroups: microsoft.public.dotnet.framework.aspnet
!NNTP-Posting-Host: gate.ementor.no 62.148.39.70
!Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP09.phx.gbl
!Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:167019
!X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!
!Hi Yanhong!
!
!Do you have any other suggestions regarding this issue?
!
!I get the same error message trying to run a project originally written on
!VS.NET and FW1.0 now working on VS.NET 2003 and FW1.1.
!
!The stack trace is as follows:
!
!Exception Details: System.PlatformNotSupportedException: 'ResourcePool' is
!not supported on the current platform.
!
!Source Error:
!
! An unhandled exception was generated during the execution of the
!current web request. Information regarding the origin and location of the
!exception can be identified using the exception stack trace below.
!
!Stack Trace:
!
![PlatformNotSupportedException: 'ResourcePool' is not supported on the
!current platform.]
! System.EnterpriseServices.Platform.Assert(Boolean fSuccess, String
!function) +69
! System.EnterpriseServices.Platform.Assert(Version platform, String
!function) +71
! System.EnterpriseServices.ResourcePool..ctor(TransactionEndDelegate cb)
!+38
! System.Data.SqlClient.ConnectionPool..ctor(DefaultPoolControl ctrl) +797
! System.Data.SqlClient.PoolManager.FindOrCreatePool(DefaultPoolControl
!ctrl, IntPtr SID) +260
!
!System.Data.SqlClient.SqlConnectionPoolManager.GetPooledConnection(SqlConnec
!tionString options, Boolean& isInTransaction) +358
! System.Data.SqlClient.SqlConnection.Open() +384
!
!Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.DiscoverSpParameter
!Set(SqlConnection connection, String spName, Boolean
!includeReturnValueParameter) in c:\documents and settings\bjarne l. gram\my
!documents\my projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2429
!
!Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.GetSpParameterSetIn
!ternal(SqlConnection connection, String spName, Boolean
!includeReturnValueParameter) in c:\documents and settings\bjarne l. gram\my
!documents\my projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2602
!
!Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.GetSpParameterSet(S
!tring connectionString, String spName, Boolean includeReturnValueParameter)
!in c:\documents and settings\bjarne l. gram\my documents\my
!projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2546
!
!Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.GetSpParameterSet(S
!tring connectionString, String spName) in c:\documents and settings\bjarne
!l. gram\my documents\my
!projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2526
! Microsoft.ApplicationBlocks.Data.SqlHelper.ExecuteReader(String
!connectionString, String spName, Object[] parameterValues) in c:\documents
!and settings\bjarne l. gram\my documents\my
!projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:909
!...
!
!
!Best regards
!
!Bjarne L. Gram
!Seniorconsultant - MCP
!Ementor Norge AS
!Microsoft Gold Certified Partner
[email protected]
!
!!> Hello David,
!>
!> I am glad that the problem is resovled. Generally speaking, when the web
!applicaiton is set to used anonymous and
!> windows authentication in IIS. Then a client will try to access it using
!anonymous. If it successes, then it will use anonymoust
!> to set up the connections. If it failed(when some page denies access to
!anonymous user), it will try windows authentication.
!> You could check it in IIS logs.
!>
!> Thanks very much for participating the community.
!>
!> Best regards,
!> Yanhong Huang
!> Microsoft Online Partner Support
!>
!> Get Secure! - www.microsoft.com/security
!> This posting is provided "AS IS" with no warranties, and confers no
!rights.
!>
!> --------------------
!> !Content-Class: urn:content-classes:message
!> !From: "David" <[email protected]>
!> !Sender: "David" <[email protected]>
!> !References: <[email protected]>
!> !Subject: ResourcePool is not supported
!> !Date: Wed, 6 Aug 2003 02:08:48 -0700
!> !Lines: 13
!> !Message-ID: <[email protected]>
!> !MIME-Version: 1.0
!> !Content-Type: text/plain;
!> ! charset="iso-8859-1"
!> !Content-Transfer-Encoding: 7bit
!> !X-Newsreader: Microsoft CDO for Windows 2000
!> !X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
!> !Thread-Index: AcNb+lh3Rk5TNBs6Qg2Fb3z+GtNeTg==
!> !Newsgroups: microsoft.public.dotnet.framework.aspnet
!> !Path: cpmsftngxa06.phx.gbl
!> !Xref: cpmsftngxa06.phx.gbl
!microsoft.public.dotnet.framework.aspnet:165287
!> !NNTP-Posting-Host: TK2MSFTNGXA08 10.40.1.160
!> !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!> !
!> !Morning
!> !
!> !Came in today and sorted it in 5 minutes, annoying when
!> !that happens. I'd recreated my web project from
!> !sourcesafe yesterday and when it created the projected it
!> !had annoymous autentication switched on in IIS. All I had
!> !to do was switch this off. The Project was already set to
!> !use Windows Authentication in the Web.config but the
!> !AnnoymousAuthentication option in IIS seemed to overide it.
!> !
!> !Everything is now hunky doory
!> !
!> !David
!> !
!>
!>
!
!
!
 
Hi Yan-Huang!

Thanks for the rapid response!

I had the key, and the file, and COM+ was running, *but* ASPNET had no
rights for the key, neither had it rights for:
HKLM\SOFTWARE\Microsoft\MSSQLServer\Client\SuperSocketNetLib\LastConnect

I started regmon and checked for errors and foung ACCESS DENIED on both
these keys. I've now given ASPNET Full Control on comadmin.dll CLSID key and
everything works fine.

*But*, is this correct?

Should ASPNET have access rights for the MSSQLServer key as well?

I'd like to know what is good enough so I can adjust these rights back...




Yan-Hong Huang said:
Hello Bjarne,

This problem is some times caused by incorrect version of comadmin.dll on
your system. You can check the following:
1) check in the registry for the existence of the key:

HKEY_CLASSES_ROOT \ CLSID \ {6EB22881-8A19-11D0-81B6-00A0C9231C29}

the InprocServer32 value should have a default which points to a dll
somewhere in the windows directory (system32\com
\comadmin.dll)

2) confirm that comadmin.dll does exist in the location pointed to by the registry.

3) to make sure COM+ is working, you might want to open up the Component
Services Explorer (under Administrative Tools),
and try clicking down on "My Computer" to get a list of COM+ Applications...

Hope it helps.

Best regards,
Yanhong Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.
<[email protected]>
!Subject: Re: ResourcePool is not supported
!Date: Tue, 12 Aug 2003 11:45:50 +0200
!Lines: 133
!X-Priority: 3
!X-MSMail-Priority: Normal
!X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!Message-ID: <#[email protected]>
!Newsgroups: microsoft.public.dotnet.framework.aspnet
!NNTP-Posting-Host: gate.ementor.no 62.148.39.70
!Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP09.phx.gbl
!Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:167019
!X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!
!Hi Yanhong!
!
!Do you have any other suggestions regarding this issue?
!
!I get the same error message trying to run a project originally written on
!VS.NET and FW1.0 now working on VS.NET 2003 and FW1.1.
!
!The stack trace is as follows:
!
!Exception Details: System.PlatformNotSupportedException: 'ResourcePool' is
!not supported on the current platform.
!
!Source Error:
!
! An unhandled exception was generated during the execution of the
!current web request. Information regarding the origin and location of the
!exception can be identified using the exception stack trace below.
!
!Stack Trace:
!
![PlatformNotSupportedException: 'ResourcePool' is not supported on the
!current platform.]
! System.EnterpriseServices.Platform.Assert(Boolean fSuccess, String
!function) +69
! System.EnterpriseServices.Platform.Assert(Version platform, String
!function) +71
! System.EnterpriseServices.ResourcePool..ctor(TransactionEndDelegate cb)
!+38
! System.Data.SqlClient.ConnectionPool..ctor(DefaultPoolControl ctrl) +797
! System.Data.SqlClient.PoolManager.FindOrCreatePool(DefaultPoolControl
!ctrl, IntPtr SID) +260
!
!System.Data.SqlClient.SqlConnectionPoolManager.GetPooledConnection(SqlConne
c
!tionString options, Boolean& isInTransaction) +358
! System.Data.SqlClient.SqlConnection.Open() +384
!
!Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.DiscoverSpParamete
r
!Set(SqlConnection connection, String spName, Boolean
!includeReturnValueParameter) in c:\documents and settings\bjarne l. gram\my
!documents\my
projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2429
!Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.GetSpParameterSetI
n
!ternal(SqlConnection connection, String spName, Boolean
!includeReturnValueParameter) in c:\documents and settings\bjarne l. gram\my
!documents\my
projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2602
!Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.GetSpParameterSet(
S
!tring connectionString, String spName, Boolean includeReturnValueParameter)
!in c:\documents and settings\bjarne l. gram\my documents\my
!projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2546
!
!Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.GetSpParameterSet(
S
!tring connectionString, String spName) in c:\documents and settings\bjarne
!l. gram\my documents\my
!projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2526
! Microsoft.ApplicationBlocks.Data.SqlHelper.ExecuteReader(String
!connectionString, String spName, Object[] parameterValues) in c:\documents
!and settings\bjarne l. gram\my documents\my
!projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:909
!...
!
!
!Best regards
!
!Bjarne L. Gram
!Seniorconsultant - MCP
!Ementor Norge AS
!Microsoft Gold Certified Partner
[email protected]
!
!!> Hello David,
!>
!> I am glad that the problem is resovled. Generally speaking, when the web
!applicaiton is set to used anonymous and
!> windows authentication in IIS. Then a client will try to access it using
!anonymous. If it successes, then it will use anonymoust
!> to set up the connections. If it failed(when some page denies access to
!anonymous user), it will try windows authentication.
!> You could check it in IIS logs.
!>
!> Thanks very much for participating the community.
!>
!> Best regards,
!> Yanhong Huang
!> Microsoft Online Partner Support
!>
!> Get Secure! - www.microsoft.com/security
!> This posting is provided "AS IS" with no warranties, and confers no
!rights.
!>
!> --------------------
!> !Content-Class: urn:content-classes:message
!> !From: "David" <[email protected]>
!> !Sender: "David" <[email protected]>
!> !References: <[email protected]>
!> !Subject: ResourcePool is not supported
!> !Date: Wed, 6 Aug 2003 02:08:48 -0700
!> !Lines: 13
!> !Message-ID: <[email protected]>
!> !MIME-Version: 1.0
!> !Content-Type: text/plain;
!> ! charset="iso-8859-1"
!> !Content-Transfer-Encoding: 7bit
!> !X-Newsreader: Microsoft CDO for Windows 2000
!> !X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
!> !Thread-Index: AcNb+lh3Rk5TNBs6Qg2Fb3z+GtNeTg==
!> !Newsgroups: microsoft.public.dotnet.framework.aspnet
!> !Path: cpmsftngxa06.phx.gbl
!> !Xref: cpmsftngxa06.phx.gbl
!microsoft.public.dotnet.framework.aspnet:165287
!> !NNTP-Posting-Host: TK2MSFTNGXA08 10.40.1.160
!> !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!> !
!> !Morning
!> !
!> !Came in today and sorted it in 5 minutes, annoying when
!> !that happens. I'd recreated my web project from
!> !sourcesafe yesterday and when it created the projected it
!> !had annoymous autentication switched on in IIS. All I had
!> !to do was switch this off. The Project was already set to
!> !use Windows Authentication in the Web.config but the
!> !AnnoymousAuthentication option in IIS seemed to overide it.
!> !
!> !Everything is now hunky doory
!> !
!> !David
!> !
!>
!>
!
!
!
 
Ad

Advertisements

Y

Yan-Hong Huang[MSFT]

Hi,

I think you need to impersonate some account in asp.net web applcation to
access that key. Thanks.

Best regards,
Yanhong Huang
Microsoft Online Partner Support

Get Secure! ¨C www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

--------------------
!From: "[email protected]" <[email protected]>
!References: <[email protected]>
<[email protected]>
<[email protected]>
<#[email protected]>
<[email protected]>
!Subject: Re: ResourcePool is not supported
!Date: Wed, 13 Aug 2003 18:31:14 +0200
!Lines: 234
!X-Priority: 3
!X-MSMail-Priority: Normal
!X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!Message-ID: <[email protected]>
!Newsgroups: microsoft.public.dotnet.framework.aspnet
!NNTP-Posting-Host: 062016178247.customer.alfanett.no 62.16.178.247
!Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP09.phx.gbl
!Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:167549
!X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!
!Hi Yan-Huang!
!
!Thanks for the rapid response!
!
!I had the key, and the file, and COM+ was running, *but* ASPNET had no
!rights for the key, neither had it rights for:
!HKLM\SOFTWARE\Microsoft\MSSQLServer\Client\SuperSocketNetLib\LastConnect
!
!I started regmon and checked for errors and foung ACCESS DENIED on both
!these keys. I've now given ASPNET Full Control on comadmin.dll CLSID key
and
!everything works fine.
!
!*But*, is this correct?
!
!Should ASPNET have access rights for the MSSQLServer key as well?
!
!I'd like to know what is good enough so I can adjust these rights back...
!
!
!
!
!!> Hello Bjarne,
!>
!> This problem is some times caused by incorrect version of comadmin.dll on
!your system. You can check the following:
!> 1) check in the registry for the existence of the key:
!>
!> HKEY_CLASSES_ROOT \ CLSID \ {6EB22881-8A19-11D0-81B6-00A0C9231C29}
!>
!> the InprocServer32 value should have a default which points to a dll
!somewhere in the windows directory (system32\com
!> \comadmin.dll)
!>
!> 2) confirm that comadmin.dll does exist in the location pointed to by the
!registry.
!>
!> 3) to make sure COM+ is working, you might want to open up the Component
!Services Explorer (under Administrative Tools),
!> and try clicking down on "My Computer" to get a list of COM+
!Applications...
!>
!> Hope it helps.
!>
!> Best regards,
!> Yanhong Huang
!> Microsoft Online Partner Support
!>
!> Get Secure! - www.microsoft.com/security
!> This posting is provided "AS IS" with no warranties, and confers no
!rights.
!>
!> --------------------
!> !From: "[email protected]" <[email protected]>
!> !References: <[email protected]>
!<[email protected]>
!> <[email protected]>
!> !Subject: Re: ResourcePool is not supported
!> !Date: Tue, 12 Aug 2003 11:45:50 +0200
!> !Lines: 133
!> !X-Priority: 3
!> !X-MSMail-Priority: Normal
!> !X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
!> !X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
!> !Message-ID: <#[email protected]>
!> !Newsgroups: microsoft.public.dotnet.framework.aspnet
!> !NNTP-Posting-Host: gate.ementor.no 62.148.39.70
!> !Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP09.phx.gbl
!> !Xref: cpmsftngxa06.phx.gbl
!microsoft.public.dotnet.framework.aspnet:167019
!> !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!> !
!> !Hi Yanhong!
!> !
!> !Do you have any other suggestions regarding this issue?
!> !
!> !I get the same error message trying to run a project originally written
!on
!> !VS.NET and FW1.0 now working on VS.NET 2003 and FW1.1.
!> !
!> !The stack trace is as follows:
!> !
!> !Exception Details: System.PlatformNotSupportedException: 'ResourcePool'
!is
!> !not supported on the current platform.
!> !
!> !Source Error:
!> !
!> ! An unhandled exception was generated during the execution of the
!> !current web request. Information regarding the origin and location of
the
!> !exception can be identified using the exception stack trace below.
!> !
!> !Stack Trace:
!> !
!> ![PlatformNotSupportedException: 'ResourcePool' is not supported on the
!> !current platform.]
!> ! System.EnterpriseServices.Platform.Assert(Boolean fSuccess, String
!> !function) +69
!> ! System.EnterpriseServices.Platform.Assert(Version platform, String
!> !function) +71
!> ! System.EnterpriseServices.ResourcePool..ctor(TransactionEndDelegate
!cb)
!> !+38
!> ! System.Data.SqlClient.ConnectionPool..ctor(DefaultPoolControl ctrl)
!+797
!> ! System.Data.SqlClient.PoolManager.FindOrCreatePool(DefaultPoolControl
!> !ctrl, IntPtr SID) +260
!> !
!>
!!System.Data.SqlClient.SqlConnectionPoolManager.GetPooledConnection(SqlConn
e
!c
!> !tionString options, Boolean& isInTransaction) +358
!> ! System.Data.SqlClient.SqlConnection.Open() +384
!> !
!>
!!Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.DiscoverSpParamet
e
!r
!> !Set(SqlConnection connection, String spName, Boolean
!> !includeReturnValueParameter) in c:\documents and settings\bjarne l.
!gram\my
!> !documents\my
!projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2429
!> !
!>
!!Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.GetSpParameterSet
I
!n
!> !ternal(SqlConnection connection, String spName, Boolean
!> !includeReturnValueParameter) in c:\documents and settings\bjarne l.
!gram\my
!> !documents\my
!projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2602
!> !
!>
!!Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.GetSpParameterSet
(
!S
!> !tring connectionString, String spName, Boolean
!includeReturnValueParameter)
!> !in c:\documents and settings\bjarne l. gram\my documents\my
!> !projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2546
!> !
!>
!!Microsoft.ApplicationBlocks.Data.SqlHelperParameterCache.GetSpParameterSet
(
!S
!> !tring connectionString, String spName) in c:\documents and
!settings\bjarne
!> !l. gram\my documents\my
!> !projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:2526
!> ! Microsoft.ApplicationBlocks.Data.SqlHelper.ExecuteReader(String
!> !connectionString, String spName, Object[] parameterValues) in
!c:\documents
!> !and settings\bjarne l. gram\my documents\my
!> !projects\rdg\microsoft.applicationblocks.data\sqlhelper.cs:909
!> !...
!> !
!> !
!> !Best regards
!> !
!> !Bjarne L. Gram
!> !Seniorconsultant - MCP
!> !Ementor Norge AS
!> !Microsoft Gold Certified Partner
!> [email protected]
!> !
!> !!> !> Hello David,
!> !>
!> !> I am glad that the problem is resovled. Generally speaking, when the
!web
!> !applicaiton is set to used anonymous and
!> !> windows authentication in IIS. Then a client will try to access it
!using
!> !anonymous. If it successes, then it will use anonymoust
!> !> to set up the connections. If it failed(when some page denies access
to
!> !anonymous user), it will try windows authentication.
!> !> You could check it in IIS logs.
!> !>
!> !> Thanks very much for participating the community.
!> !>
!> !> Best regards,
!> !> Yanhong Huang
!> !> Microsoft Online Partner Support
!> !>
!> !> Get Secure! - www.microsoft.com/security
!> !> This posting is provided "AS IS" with no warranties, and confers no
!> !rights.
!> !>
!> !> --------------------
!> !> !Content-Class: urn:content-classes:message
!> !> !From: "David" <[email protected]>
!> !> !Sender: "David" <[email protected]>
!> !> !References: <[email protected]>
!> !> !Subject: ResourcePool is not supported
!> !> !Date: Wed, 6 Aug 2003 02:08:48 -0700
!> !> !Lines: 13
!> !> !Message-ID: <[email protected]>
!> !> !MIME-Version: 1.0
!> !> !Content-Type: text/plain;
!> !> ! charset="iso-8859-1"
!> !> !Content-Transfer-Encoding: 7bit
!> !> !X-Newsreader: Microsoft CDO for Windows 2000
!> !> !X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
!> !> !Thread-Index: AcNb+lh3Rk5TNBs6Qg2Fb3z+GtNeTg==
!> !> !Newsgroups: microsoft.public.dotnet.framework.aspnet
!> !> !Path: cpmsftngxa06.phx.gbl
!> !> !Xref: cpmsftngxa06.phx.gbl
!> !microsoft.public.dotnet.framework.aspnet:165287
!> !> !NNTP-Posting-Host: TK2MSFTNGXA08 10.40.1.160
!> !> !X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!> !> !
!> !> !Morning
!> !> !
!> !> !Came in today and sorted it in 5 minutes, annoying when
!> !> !that happens. I'd recreated my web project from
!> !> !sourcesafe yesterday and when it created the projected it
!> !> !had annoymous autentication switched on in IIS. All I had
!> !> !to do was switch this off. The Project was already set to
!> !> !use Windows Authentication in the Web.config but the
!> !> !AnnoymousAuthentication option in IIS seemed to overide it.
!> !> !
!> !> !Everything is now hunky doory
!> !> !
!> !> !David
!> !> !
!> !>
!> !>
!> !
!> !
!> !
!>
!>
!
!
!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top