web.config Configuration Error when deploy

Discussion in 'ASP .Net' started by Xu ChunMing, Jul 16, 2003.

  1. Xu ChunMing

    Xu ChunMing Guest

    I develop a Asp.net application using VS.NET
    and It work well on my computer .

    but when I deploy the application to another IIS runming manching .
    I just copy the whole folder of the application including bin subfolder to
    aother machine .

    When I access it via Internet Explorer ,the following error happend.

    Does any one have some idea about it ?
    Any assistant will be greately appreciated!


    Server Error in '/tunnel' Application.

    Configuration Error
    Description: An error occurred during the processing of a configuration file
    required to service this request. Please review the specific error details
    below and modify your configuration file appropriately.

    Parser Error Message: It is an error to use a section registered as
    allowDefinition='MachineToApplication' beyond application level. This error
    can be caused by a virtual directory not being configured as an application
    in IIS.

    Source Error:

    Line 36: "Passport" and "None"
    Line 37: -->
    Line 38: <authentication mode="Windows" />
    Line 39:

    Source File: C:\TunnelingTest\AspProxy\web.config Line: 38

    Version Information: Microsoft .NET Framework Version:1.0.3705.288; ASP.NET
    Xu ChunMing, Jul 16, 2003
    1. Advertisements

  2. Hi,

    open up the IIS MMC on the target system, open the properties of 'tunnel',
    goto home directory and click create in the application settings/application
    name area. That should help!

    Best regards,

    Marc Höppner
    Marc Hoeppner, Jul 16, 2003
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.