ASP.NET application works in IIS PWS, but not in remote IIS.

Discussion in 'ASP .Net' started by Matthew Louden, Nov 7, 2003.

  1. My ASP.NET application is running without error in my local machine (IIS
    PWS). However, once I upload all the ASPX files to the remote IIS machine
    with Windows Server 2003 OS, it no longer works.

    Here's the run-time error, any ideas??


    Server Error in '/' Application.


    Runtime Error
    Description: An application error occurred on the server. The current custom
    error settings for this application prevent the details of the application
    error from being viewed remotely (for security reasons). It could, however,
    be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable
    on remote machines, please create a <customErrors> tag within a "web.config"
    configuration file located in the root directory of the current web
    application. This <customErrors> tag should then have its "mode" attribute
    set to "Off".

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>


    Notes: The current error page you are seeing can be replaced by a custom
    error page by modifying the "defaultRedirect" attribute of the application's
    <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>
    Matthew Louden, Nov 7, 2003
    #1
    1. Advertising

  2. Make sure ASP.NET is enabled on the Windows 2003 server. By default, it is
    not. Also, make sure you load the DLL, from IL compilation, in the bin
    folder. You might want to turn off custom errors, as suggested, and see what
    is causing the issue. You can always go back to the default after you fix
    the problem.

    --
    Gregory A. Beamer
    MVP; MCP: +I, SE, SD, DBA

    **********************************************************************
    Think Outside the Box!
    **********************************************************************
    "Matthew Louden" <> wrote in message
    news:...
    > My ASP.NET application is running without error in my local machine (IIS
    > PWS). However, once I upload all the ASPX files to the remote IIS machine
    > with Windows Server 2003 OS, it no longer works.
    >
    > Here's the run-time error, any ideas??
    >
    >
    > Server Error in '/' Application.
    >
    >
    > Runtime Error
    > Description: An application error occurred on the server. The current

    custom
    > error settings for this application prevent the details of the application
    > error from being viewed remotely (for security reasons). It could,

    however,
    > be viewed by browsers running on the local server machine.
    >
    > Details: To enable the details of this specific error message to be

    viewable
    > on remote machines, please create a <customErrors> tag within a

    "web.config"
    > configuration file located in the root directory of the current web
    > application. This <customErrors> tag should then have its "mode" attribute
    > set to "Off".
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    > </configuration>
    >
    >
    > Notes: The current error page you are seeing can be replaced by a custom
    > error page by modifying the "defaultRedirect" attribute of the

    application's
    > <customErrors> configuration tag to point to a custom error page URL.
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="RemoteOnly"

    defaultRedirect="mycustompage.htm"/>
    > </system.web>
    > </configuration>
    >
    >
    Cowboy \(Gregory A. Beamer\), Nov 7, 2003
    #2
    1. Advertising

  3. How can I enable ASP.NET in windows 2003 server? I couldn't see that setting
    in IIS 6.0

    "Cowboy (Gregory A. Beamer)" <> wrote in
    message news:...
    > Make sure ASP.NET is enabled on the Windows 2003 server. By default, it is
    > not. Also, make sure you load the DLL, from IL compilation, in the bin
    > folder. You might want to turn off custom errors, as suggested, and see

    what
    > is causing the issue. You can always go back to the default after you fix
    > the problem.
    >
    > --
    > Gregory A. Beamer
    > MVP; MCP: +I, SE, SD, DBA
    >
    > **********************************************************************
    > Think Outside the Box!
    > **********************************************************************
    > "Matthew Louden" <> wrote in message
    > news:...
    > > My ASP.NET application is running without error in my local machine (IIS
    > > PWS). However, once I upload all the ASPX files to the remote IIS

    machine
    > > with Windows Server 2003 OS, it no longer works.
    > >
    > > Here's the run-time error, any ideas??
    > >
    > >
    > > Server Error in '/' Application.
    > >
    > >
    > > Runtime Error
    > > Description: An application error occurred on the server. The current

    > custom
    > > error settings for this application prevent the details of the

    application
    > > error from being viewed remotely (for security reasons). It could,

    > however,
    > > be viewed by browsers running on the local server machine.
    > >
    > > Details: To enable the details of this specific error message to be

    > viewable
    > > on remote machines, please create a <customErrors> tag within a

    > "web.config"
    > > configuration file located in the root directory of the current web
    > > application. This <customErrors> tag should then have its "mode"

    attribute
    > > set to "Off".
    > >
    > > <!-- Web.Config Configuration File -->
    > >
    > > <configuration>
    > > <system.web>
    > > <customErrors mode="Off"/>
    > > </system.web>
    > > </configuration>
    > >
    > >
    > > Notes: The current error page you are seeing can be replaced by a custom
    > > error page by modifying the "defaultRedirect" attribute of the

    > application's
    > > <customErrors> configuration tag to point to a custom error page URL.
    > >
    > > <!-- Web.Config Configuration File -->
    > >
    > > <configuration>
    > > <system.web>
    > > <customErrors mode="RemoteOnly"

    > defaultRedirect="mycustompage.htm"/>
    > > </system.web>
    > > </configuration>
    > >
    > >

    >
    >
    Matthew Louden, Nov 7, 2003
    #3
  4. Hello

    I suggest you do as the error message says. i.e. change customeErrors mode
    to Off. This will give you another error message with the exact details of
    the error cause.
    The cause of the error can be anything.

    Best regards

    Sherif

    "Matthew Louden" <> wrote in message
    news:...
    > My ASP.NET application is running without error in my local machine (IIS
    > PWS). However, once I upload all the ASPX files to the remote IIS machine
    > with Windows Server 2003 OS, it no longer works.
    >
    > Here's the run-time error, any ideas??
    >
    >
    > Server Error in '/' Application.
    >
    >
    > Runtime Error
    > Description: An application error occurred on the server. The current

    custom
    > error settings for this application prevent the details of the application
    > error from being viewed remotely (for security reasons). It could,

    however,
    > be viewed by browsers running on the local server machine.
    >
    > Details: To enable the details of this specific error message to be

    viewable
    > on remote machines, please create a <customErrors> tag within a

    "web.config"
    > configuration file located in the root directory of the current web
    > application. This <customErrors> tag should then have its "mode" attribute
    > set to "Off".
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    > </configuration>
    >
    >
    > Notes: The current error page you are seeing can be replaced by a custom
    > error page by modifying the "defaultRedirect" attribute of the

    application's
    > <customErrors> configuration tag to point to a custom error page URL.
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="RemoteOnly"

    defaultRedirect="mycustompage.htm"/>
    > </system.web>
    > </configuration>
    >
    >
    Sherif ElMetainy, Nov 7, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tarundeep Singh Kalra

    How to upgrade IIS (PWS) to support asp.net 1.1

    Tarundeep Singh Kalra, Apr 13, 2004, in forum: ASP .Net
    Replies:
    3
    Views:
    1,933
    Tarundeep Singh Kalra
    Apr 19, 2004
  2. John Kennedy
    Replies:
    5
    Views:
    210
    Carl Prothman [MVP]
    Aug 14, 2003
  3. John Kennedy
    Replies:
    5
    Views:
    422
    Carl Prothman [MVP]
    Aug 14, 2003
  4. Aksahy
    Replies:
    2
    Views:
    112
    Ken Schaefer
    Aug 5, 2003
  5. Dan Nash
    Replies:
    22
    Views:
    306
    Dan Nash
    Mar 7, 2004
Loading...

Share This Page