error while loading shared libraries

Discussion in 'C Programming' started by onkar, Oct 27, 2007.

  1. onkar

    onkar Guest

    how do I get rid of exporting LD_LIBRARY_PATH (to get rid of " error
    while loading shared libraries") while compiling it self in the
    Makefile.

    how to incorporate some kind of export statement in Makeifle ??

    Onkar
     
    onkar, Oct 27, 2007
    #1
    1. Advertising

  2. onkar

    santosh Guest

    onkar wrote:

    > how do I get rid of exporting LD_LIBRARY_PATH (to get rid of " error
    > while loading shared libraries") while compiling it self in the
    > Makefile.
    >
    > how to incorporate some kind of export statement in Makeifle ??


    Please post to <news:comp.unix.programmer>
     
    santosh, Oct 27, 2007
    #2
    1. Advertising

  3. "onkar" <> wrote in message
    > how do I get rid of exporting LD_LIBRARY_PATH (to get rid of " error
    > while loading shared libraries") while compiling it self in the
    > Makefile.
    >
    > how to incorporate some kind of export statement in Makeifle ??
    >

    Compile with cc (or whatever your compiler is) *.c to compile all the source
    files. It will almost certainly complain that some bits and pieces - headers
    or libraries - are missing. So add them to the command line until it works.
    If you must have a makefile, try to work out how to put those same options
    into it.

    --
    Free games and programming goodies.
    http://www.personal.leeds.ac.uk/~bgy1mm
     
    Malcolm McLean, Oct 27, 2007
    #3
  4. "Malcolm McLean" <> writes:
    > "onkar" <> wrote in message
    >> how do I get rid of exporting LD_LIBRARY_PATH (to get rid of " error
    >> while loading shared libraries") while compiling it self in the
    >> Makefile.
    >>
    >> how to incorporate some kind of export statement in Makeifle ??
    >>

    > Compile with cc (or whatever your compiler is) *.c to compile all the
    > source files. It will almost certainly complain that some bits and
    > pieces - headers or libraries - are missing. So add them to the
    > command line until it works.
    > If you must have a makefile, try to work out how to put those same
    > options into it.


    That's bad advice. For good advice, post to comp.unix.programmer.

    --
    Keith Thompson (The_Other_Keith) <http://www.ghoti.net/~kst>
    San Diego Supercomputer Center <*> <http://users.sdsc.edu/~kst>
    "We must do something. This is something. Therefore, we must do this."
    -- Antony Jay and Jonathan Lynn, "Yes Minister"
     
    Keith Thompson, Oct 27, 2007
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. ^CrazyCoder^
    Replies:
    3
    Views:
    7,269
    Terrence Benade
    Sep 15, 2003
  2. David
    Replies:
    1
    Views:
    498
    David
    Jul 19, 2004
  3. Douglass Turner
    Replies:
    2
    Views:
    2,052
    Manfred Bartz
    Sep 4, 2003
  4. Karsten Wutzke
    Replies:
    21
    Views:
    921
    Roedy Green
    Jun 29, 2007
  5. Sriram Srinivasan
    Replies:
    13
    Views:
    570
    Benjamin Kaplan
    Nov 12, 2009
Loading...

Share This Page