EXECUTE permission denied on object 'sp_sdidebug', database 'maste

Discussion in 'ASP .Net' started by =?Utf-8?B?S2Vu?=, Sep 30, 2004.

  1. Hi guys,

    this is a curios thing, everything was working fine then I had to restore my
    development machine( VS.NET, SQL server etc) now I'm receiveing this error
    from my asp aplication only in RELEASE mode, but everything works good in
    DEBUG mode, this is happening when I run my app against my local SQLDB and
    against a hosting DB.

    EXECUTE permission denied on object 'sp_sdidebug', database 'master', owner
    'dbo'.

    Any sugg we'll b apre...

    thks

    Ken
    =?Utf-8?B?S2Vu?=, Sep 30, 2004
    #1
    1. Advertising

  2. You need to grant permissions to that stored procedure for the calling user.
    In the SQL Analyzer type:
    GRANT EXECUTE ON sp_sdidebug TO <user here>

    HTH

    "Ken" wrote:

    > Hi guys,
    >
    > this is a curios thing, everything was working fine then I had to restore my
    > development machine( VS.NET, SQL server etc) now I'm receiveing this error
    > from my asp aplication only in RELEASE mode, but everything works good in
    > DEBUG mode, this is happening when I run my app against my local SQLDB and
    > against a hosting DB.
    >
    > EXECUTE permission denied on object 'sp_sdidebug', database 'master', owner
    > 'dbo'.
    >
    > Any sugg we'll b apre...
    >
    > thks
    >
    > Ken
    =?Utf-8?B?RU5JWklO?=, Sep 30, 2004
    #2
    1. Advertising

  3. Hi Ken,

    On my local machine I've never had to grant execute permissions for a SP.
    Did you have to do that before your restore? If not the permissions might
    be a little whacked. Did you install VS.Net before SQL Server? If so maybe
    the aspnet account was setup without the permissions for SQL. Or after you
    setup your machine the first time, way back, did you ever do anything to add
    the aspnet account or your Windows login account to the SQL Server
    permissions list? I'm just throwing those out there to maybe point you in
    the right direction. I've never encountered this locally and when I've
    encountered it in production I've always done what the guy mentioned in the
    reply before mine. Good luck! Ken.

    --
    Ken Dopierala Jr.
    For great ASP.Net web hosting try:
    http://www.webhost4life.com/default.asp?refid=Spinlight

    "Ken" <> wrote in message
    news:...
    > Hi guys,
    >
    > this is a curios thing, everything was working fine then I had to restore

    my
    > development machine( VS.NET, SQL server etc) now I'm receiveing this

    error
    > from my asp aplication only in RELEASE mode, but everything works good in
    > DEBUG mode, this is happening when I run my app against my local SQLDB and
    > against a hosting DB.
    >
    > EXECUTE permission denied on object 'sp_sdidebug', database 'master',

    owner
    > 'dbo'.
    >
    > Any sugg we'll b apre...
    >
    > thks
    >
    > Ken
    Ken Dopierala Jr., Sep 30, 2004
    #3
  4. Re: EXECUTE permission denied on object 'sp_sdidebug', database 'm

    Hi

    I'm geting some clues,

    > On my local machine I've never had to grant execute permissions for a SP.
    > Did you have to do that before your restore?

    No

    >Did you install VS.Net before SQL Server?do anything to add

    Yes, is it not the order?

    >Or after you
    > setup your machine the first time, way back, did you ever do anything to add
    > the aspnet account or your Windows login account to the SQL Server
    > permissions list?


    Umm I remember I had another problem running the aspnet app (not this one),
    and the only aditional thing I did was to run the Aspnet_regiis.exe utility,
    should I have to run it again?

    also, I run the 'GRANT EXECUTE ON sp_sdidebug TO dbo' on my local Master
    Database, and nothing happen...the error is stil here

    by the way I'dont get why the master DB is involved...

    The production environmet is a hosting company, so I have only a user
    account on my Application DB not on Master DB, so I cant run the script...


    Ken
    =?Utf-8?B?S2Vu?=, Oct 1, 2004
    #4
  5. RE: EXECUTE permission denied on object 'sp_sdidebug', database 'm

    Hi,

    It does not work, the error is stil here:

    EXECUTE permission denied on object 'sp_sdidebug', database 'master', owner
    'dbo'.

    Why is the error on Master DB?

    Ken

    "ENIZIN" wrote:

    > You need to grant permissions to that stored procedure for the calling user.
    > In the SQL Analyzer type:
    > GRANT EXECUTE ON sp_sdidebug TO <user here>
    >
    > HTH
    >
    > "Ken" wrote:
    >
    > > Hi guys,
    > >
    > > this is a curios thing, everything was working fine then I had to restore my
    > > development machine( VS.NET, SQL server etc) now I'm receiveing this error
    > > from my asp aplication only in RELEASE mode, but everything works good in
    > > DEBUG mode, this is happening when I run my app against my local SQLDB and
    > > against a hosting DB.
    > >
    > > EXECUTE permission denied on object 'sp_sdidebug', database 'master', owner
    > > 'dbo'.
    > >
    > > Any sugg we'll b apre...
    > >
    > > thks
    > >
    > > Ken
    =?Utf-8?B?S2Vu?=, Oct 1, 2004
    #5
  6. Re: EXECUTE permission denied on object 'sp_sdidebug', database 'm

    Hi,

    It is just your local machine where you are having problems right? Or are
    you having the same problem with your production site and database? I think
    you need to install SQL Server before installing VS.Net and the .Net
    framework. That is the way I've alway done it. You might want to try to
    re-install VS.Net and the framework and see if that clears things up now
    that SQL is installed. There is probably a way to setup the permissions for
    the aspnet account manually but I don't know how to do it. Good luck! Ken.

    --
    Ken Dopierala Jr.
    For great ASP.Net web hosting try:
    http://www.webhost4life.com/default.asp?refid=Spinlight
    If you sign up under me and need help, email me.

    "Ken" <> wrote in message
    news:...
    > Hi
    >
    > I'm geting some clues,
    >
    > > On my local machine I've never had to grant execute permissions for a

    SP.
    > > Did you have to do that before your restore?

    > No
    >
    > >Did you install VS.Net before SQL Server?do anything to add

    > Yes, is it not the order?
    >
    > >Or after you
    > > setup your machine the first time, way back, did you ever do anything to

    add
    > > the aspnet account or your Windows login account to the SQL Server
    > > permissions list?

    >
    > Umm I remember I had another problem running the aspnet app (not this

    one),
    > and the only aditional thing I did was to run the Aspnet_regiis.exe

    utility,
    > should I have to run it again?
    >
    > also, I run the 'GRANT EXECUTE ON sp_sdidebug TO dbo' on my local Master
    > Database, and nothing happen...the error is stil here
    >
    > by the way I'dont get why the master DB is involved...
    >
    > The production environmet is a hosting company, so I have only a user
    > account on my Application DB not on Master DB, so I cant run the script...
    >
    >
    > Ken
    >
    >
    Ken Dopierala Jr., Oct 1, 2004
    #6
  7. =?Utf-8?B?S2Vu?=

    TGHW Guest

    Hi Ken,

    This problem comes from the Project Properties setting "Enable SQ
    Debugging" being set to true. Disable that setting, and it should wor
    fine.

    ++Tyler

    Ken wrote:
    > *Hi guys,
    >
    > this is a curios thing, everything was working fine then I had t
    > restore my
    > development machine( VS.NET, SQL server etc) now I'm receiveing thi
    > error
    > from my asp aplication only in RELEASE mode, but everything work
    > good in
    > DEBUG mode, this is happening when I run my app against my loca
    > SQLDB and
    > against a hosting DB.
    >
    > EXECUTE permission denied on object 'sp_sdidebug', database 'master'
    > owner
    > 'dbo'.
    >
    > Any sugg we'll b apre...
    >
    > thks
    >
    > Ken



    -
    TGH
    -----------------------------------------------------------------------
    Posted via http://www.codecomments.co
    -----------------------------------------------------------------------
    TGHW, Dec 1, 2005
    #7
  8. =?Utf-8?B?S2Vu?=

    Ferdinand Guest

    When you install Windows XP Service Pack 2, you cannot debug SQL fro
    VS.

    Read the following article in KB
    http://support.microsoft.com/default.aspx?scid=kb;en-us;839280

    You can correct this with SQL Server Service Pack 4 or a hot fix.

    TGHW wrote:
    > *Hi Ken,
    >
    > This problem comes from the Project Properties setting "Enable SQ
    > Debugging" being set to true. Disable that setting, and it shoul
    > work fine.
    >
    > ++Tyler



    -
    Ferdinan
    -----------------------------------------------------------------------
    Posted via http://www.codecomments.co
    -----------------------------------------------------------------------
    Ferdinand, Mar 21, 2006
    #8
  9. =?Utf-8?B?S2Vu?=

    blomm

    Joined:
    Jul 6, 2006
    Messages:
    2
    Microsoft data access components

    try installing MDAC 2.8 on the machine that is querying your database, that did the trick for me.
    Mike
    blomm, Jul 7, 2006
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jiggaz
    Replies:
    9
    Views:
    20,992
  2. =?Utf-8?B?U2FsYW1FbGlhcw==?=

    permission denied on object sp_sdidebug

    =?Utf-8?B?U2FsYW1FbGlhcw==?=, Dec 6, 2004, in forum: ASP .Net
    Replies:
    2
    Views:
    1,776
    Steven Cheng[MSFT]
    Dec 7, 2004
  3. =?Utf-8?B?ZGF2aWQ=?=
    Replies:
    1
    Views:
    614
    Jason Bentley
    Mar 28, 2005
  4. Jeff
    Replies:
    1
    Views:
    3,653
  5. Prasath
    Replies:
    0
    Views:
    159
    Prasath
    Oct 14, 2004
Loading...

Share This Page