Help: Runtime Error - Server Error in '/' Application

Discussion in 'ASP .Net' started by Kevin Farless, Jul 19, 2004.

  1. Hi all,

    I'm having trouble viewing any .aspx pages on my hosting company's server.
    The server is a new box running Windows Server 2003 default installation.
    I'm the first client to try using ASP.NET on this box and the administrator
    of the server has never setup an ASP.NET site before, so most likely the
    problem I'm experiencing is server settings related.

    Note in the Web.config below that the <customErrors mode="Off"/> is present,
    but is having no affect on the error message the server is producing. What
    server settings should I suggest the administrator change?

    Thanks in advance, Kevin.

    Here is the Web.config file:

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>

    Here is the 'test.aspx' page I'm trying to view:

    <%@ Page Language="VB" ContentType="text/html" ResponseEncoding="iso-8859-1"
    %>
    <html>
    <head>
    <title>Test ASPNET</title>
    </head>
    <body>
    Test ASPNET
    </body>
    </html>

    This is the error I'm getting:

    Server Error in '/' Application.
    ----------------------------------------------------------------------------
    ----

    Runtime Error
    Description: An application error occurred on the server. The current custom
    error settings for this application prevent the details of the application
    error from being viewed remotely (for security reasons). It could, however,
    be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable
    on remote machines, please create a <customErrors> tag within a "web.config"
    configuration file located in the root directory of the current web
    application. This <customErrors> tag should then have its "mode" attribute
    set to "Off".

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>


    Notes: The current error page you are seeing can be replaced by a custom
    error page by modifying the "defaultRedirect" attribute of the application's
    <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>
    Kevin Farless, Jul 19, 2004
    #1
    1. Advertising

  2. In default Windows 2003 instalation iis is not installed. The administrator must install it and allow to parse *.aspx files. (I have seen a howto somewere in msdn, but i don't remember exactly where. Look for "Internet information services")
    =?Utf-8?B?bWVua2F1cg==?=, Jul 20, 2004
    #2
    1. Advertising

  3. I believe that IIS is installed. The server correctly handles .htm, .html,
    ..asp pages correctly. The above problem is specific to .aspx pages only.

    Thanks in advance, Kevin.

    "menkaur" <> wrote in message
    news:...
    > In default Windows 2003 instalation iis is not installed. The

    administrator must install it and allow to parse *.aspx files. (I have seen
    a howto somewere in msdn, but i don't remember exactly where. Look for
    "Internet information services")
    Kevin Farless, Jul 20, 2004
    #3
  4. if so, do:
    Administrative tools->iis manager->local computer(or this server?)-> ASP.Net: Allow.
    If it does not work, allow everithing (but it will damage server sequrity)
    =?Utf-8?B?bWVua2F1cg==?=, Jul 21, 2004
    #4
  5. Kevin Farless

    nborders Guest

    I am having the same problem, and cannot figure out what has gone
    wrong with my server.

    I'm about ready to pull my hair out with this problem! Any help would
    be appreciated.

    ~n

    "Kevin Farless" <(blockspam)> wrote in message news:<Oe0$>...
    > I believe that IIS is installed. The server correctly handles .htm, .html,
    > .asp pages correctly. The above problem is specific to .aspx pages only.
    >
    > Thanks in advance, Kevin.
    >
    > "menkaur" <> wrote in message
    > news:...
    > > In default Windows 2003 instalation iis is not installed. The

    > administrator must install it and allow to parse *.aspx files. (I have seen
    > a howto somewere in msdn, but i don't remember exactly where. Look for
    > "Internet information services")
    nborders, Jul 30, 2004
    #5
  6. if the last one did not help, go to
    iis Manager->WebSites
    Then select directory where your application is in. Rigth click ->Properties ->Directory ->Create (Application). In my case it helped
    =?Utf-8?B?bWVua2F1cg==?=, Jul 31, 2004
    #6
  7. Kevin Farless

    Saber Guest

    Re: Runtime Error - Server Error in '/' Application

    If you use FTP to upload files, be sure to upload "bin" folder and its
    files.

    --
    Saber S.
    http://maghalat.com (Persian)
    ^^^^^^^^^^^^^^^^^^^^^^^^
    "Kevin Farless" <(blockspam)> wrote in message
    news:...
    > Hi all,
    >
    > I'm having trouble viewing any .aspx pages on my hosting company's server.
    > The server is a new box running Windows Server 2003 default installation.
    > I'm the first client to try using ASP.NET on this box and the
    > administrator
    > of the server has never setup an ASP.NET site before, so most likely the
    > problem I'm experiencing is server settings related.
    >
    > Note in the Web.config below that the <customErrors mode="Off"/> is
    > present,
    > but is having no affect on the error message the server is producing.
    > What
    > server settings should I suggest the administrator change?
    >
    > Thanks in advance, Kevin.
    >
    > Here is the Web.config file:
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    > </configuration>
    >
    > Here is the 'test.aspx' page I'm trying to view:
    >
    > <%@ Page Language="VB" ContentType="text/html"
    > ResponseEncoding="iso-8859-1"
    > %>
    > <html>
    > <head>
    > <title>Test ASPNET</title>
    > </head>
    > <body>
    > Test ASPNET
    > </body>
    > </html>
    >
    > This is the error I'm getting:
    >
    > Server Error in '/' Application.
    > ----------------------------------------------------------------------------
    > ----
    >
    > Runtime Error
    > Description: An application error occurred on the server. The current
    > custom
    > error settings for this application prevent the details of the application
    > error from being viewed remotely (for security reasons). It could,
    > however,
    > be viewed by browsers running on the local server machine.
    >
    > Details: To enable the details of this specific error message to be
    > viewable
    > on remote machines, please create a <customErrors> tag within a
    > "web.config"
    > configuration file located in the root directory of the current web
    > application. This <customErrors> tag should then have its "mode" attribute
    > set to "Off".
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    > </configuration>
    >
    >
    > Notes: The current error page you are seeing can be replaced by a custom
    > error page by modifying the "defaultRedirect" attribute of the
    > application's
    > <customErrors> configuration tag to point to a custom error page URL.
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="RemoteOnly"
    > defaultRedirect="mycustompage.htm"/>
    > </system.web>
    > </configuration>
    >
    >
    Saber, Aug 1, 2004
    #7
  8. Kevin Farless

    Saber Guest

    Re: Runtime Error - Server Error in '/' Application

    If you use FTP to upload files, be sure to upload "bin" folder and its
    files.

    --
    Saber S.
    http://maghalat.com (Persian)
    ^^^^^^^^^^^^^^^^^^^^^^^^
    "Kevin Farless" <(blockspam)> wrote in message
    news:...
    > Hi all,
    >
    > I'm having trouble viewing any .aspx pages on my hosting company's server.
    > The server is a new box running Windows Server 2003 default installation.
    > I'm the first client to try using ASP.NET on this box and the
    > administrator
    > of the server has never setup an ASP.NET site before, so most likely the
    > problem I'm experiencing is server settings related.
    >
    > Note in the Web.config below that the <customErrors mode="Off"/> is
    > present,
    > but is having no affect on the error message the server is producing.
    > What
    > server settings should I suggest the administrator change?
    >
    > Thanks in advance, Kevin.
    >
    > Here is the Web.config file:

    ...
    Saber, Aug 1, 2004
    #8
  9. Kevin Farless

    Todd Konesky Guest

    I was having the same problem, here's how I fixed it.

    You need to make sure the virtual directories in iis are created as
    Applications. (properties/homepage/create)

    If not you'll keep getting that error and the web.config file with the
    mode=Off setting won't be read because the applications doesn't exist.

    -todd

    (nborders) wrote in message news:<>...
    > I am having the same problem, and cannot figure out what has gone
    > wrong with my server.
    >
    > I'm about ready to pull my hair out with this problem! Any help would
    > be appreciated.
    >
    > ~n
    >
    > "Kevin Farless" <(blockspam)> wrote in message news:<Oe0$>...
    > > I believe that IIS is installed. The server correctly handles .htm, .html,
    > > .asp pages correctly. The above problem is specific to .aspx pages only.
    > >
    > > Thanks in advance, Kevin.
    > >
    > > "menkaur" <> wrote in message
    > > news:...
    > > > In default Windows 2003 instalation iis is not installed. The

    > > administrator must install it and allow to parse *.aspx files. (I have seen
    > > a howto somewere in msdn, but i don't remember exactly where. Look for
    > > "Internet information services")
    Todd Konesky, Aug 5, 2004
    #9
  10. Kevin Farless

    Guest Guest


    > Hi all,
    >
    > I'm having trouble viewing any .aspx pages on my hosting company's server.
    > The server is a new box running Windows Server 2003 default installation.
    > I'm the first client to try using ASP.NET on this box and the administrator
    > of the server has never setup an ASP.NET site before, so most likely the
    > problem I'm experiencing is server settings related.
    >
    > Note in the Web.config below that the <customErrors mode="Off"/> is present,
    > but is having no affect on the error message the server is producing. What
    > server settings should I suggest the administrator change?
    >
    > Thanks in advance, Kevin.
    >
    > Here is the Web.config file:
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    > </configuration>
    >
    > Here is the 'test.aspx' page I'm trying to view:
    >
    > <%@ Page Language="VB" ContentType="text/html" ResponseEncoding="iso-8859-1"
    > %>
    > <html>
    > <head>
    > <title>Test ASPNET</title>
    > </head>
    > <body>
    > Test ASPNET
    > </body>
    > </html>
    >
    > This is the error I'm getting:
    >
    > Server Error in '/' Application.
    > ----------------------------------------------------------------------------
    > ----
    >
    > Runtime Error
    > Description: An application error occurred on the server. The current custom
    > error settings for this application prevent the details of the application
    > error from being viewed remotely (for security reasons). It could, however,
    > be viewed by browsers running on the local server machine.
    >
    > Details: To enable the details of this specific error message to be viewable
    > on remote machines, please create a <customErrors> tag within a "web.config"
    > configuration file located in the root directory of the current web
    > application. This <customErrors> tag should then have its "mode" attribute
    > set to "Off".
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    > </configuration>
    >
    >
    > Notes: The current error page you are seeing can be replaced by a custom
    > error page by modifying the "defaultRedirect" attribute of the application's
    > <customErrors> configuration tag to point to a custom error page URL.
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    > </system.web>
    > </configuration>
    >
    >


    User submitted from AEWNET (http://www.aewnet.com/)
    Guest, May 9, 2005
    #10
  11. Kevin Farless

    Guest Guest


    > Hi all,
    >
    > I'm having trouble viewing any .aspx pages on my hosting company's server.
    > The server is a new box running Windows Server 2003 default installation.
    > I'm the first client to try using ASP.NET on this box and the administrator
    > of the server has never setup an ASP.NET site before, so most likely the
    > problem I'm experiencing is server settings related.
    >
    > Note in the Web.config below that the <customErrors mode="Off"/> is present,
    > but is having no affect on the error message the server is producing. What
    > server settings should I suggest the administrator change?
    >
    > Thanks in advance, Kevin.
    >
    > Here is the Web.config file:
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    > </configuration>
    >
    > Here is the 'test.aspx' page I'm trying to view:
    >
    > <%@ Page Language="VB" ContentType="text/html" ResponseEncoding="iso-8859-1"
    > %>
    > <html>
    > <head>
    > <title>Test ASPNET</title>
    > </head>
    > <body>
    > Test ASPNET
    > </body>
    > </html>
    >
    > This is the error I'm getting:
    >
    > Server Error in '/' Application.
    > ----------------------------------------------------------------------------
    > ----
    >
    > Runtime Error
    > Description: An application error occurred on the server. The current custom
    > error settings for this application prevent the details of the application
    > error from being viewed remotely (for security reasons). It could, however,
    > be viewed by browsers running on the local server machine.
    >
    > Details: To enable the details of this specific error message to be viewable
    > on remote machines, please create a <customErrors> tag within a "web.config"
    > configuration file located in the root directory of the current web
    > application. This <customErrors> tag should then have its "mode" attribute
    > set to "Off".
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    > </configuration>
    >
    >
    > Notes: The current error page you are seeing can be replaced by a custom
    > error page by modifying the "defaultRedirect" attribute of the application's
    > <customErrors> configuration tag to point to a custom error page URL.
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    > </system.web>
    > </configuration>
    >
    >


    User submitted from AEWNET (http://www.aewnet.com/)
    Guest, May 9, 2005
    #11
  12. Kevin Farless

    Brock Allen Guest

    Without more detailed error information, there's not much that we can do
    to help. From the little bit you've provided, though, my guess is that you
    have a type in your XML file so the application fails to even load. You should
    term serv into the server and see the actual error. There might even be an
    entry in the event log describing what happened.

    -Brock
    DevelopMentor
    http://staff.develop.com/ballen



    >> Hi all,
    >>
    >> I'm having trouble viewing any .aspx pages on my hosting company's
    >> server. The server is a new box running Windows Server 2003 default
    >> installation. I'm the first client to try using ASP.NET on this box
    >> and the administrator of the server has never setup an ASP.NET site
    >> before, so most likely the problem I'm experiencing is server
    >> settings related.
    >>
    >> Note in the Web.config below that the <customErrors mode="Off"/> is
    >> present, but is having no affect on the error message the server is
    >> producing. What server settings should I suggest the administrator
    >> change?
    >>
    >> Thanks in advance, Kevin.
    >>
    >> Here is the Web.config file:
    >>
    >> <configuration>
    >> <system.web>
    >> <customErrors mode="Off"/>
    >> </system.web>
    >> </configuration>
    >> Here is the 'test.aspx' page I'm trying to view:
    >>
    >> <%@ Page Language="VB" ContentType="text/html"
    >> ResponseEncoding="iso-8859-1"
    >> %>
    >> <html>
    >> <head>
    >> <title>Test ASPNET</title>
    >> </head>
    >> <body>
    >> Test ASPNET
    >> </body>
    >> </html>
    >> This is the error I'm getting:
    >>
    >> Server Error in '/' Application.
    >> ---------------------------------------------------------------------
    >> ------- ----
    >>
    >> Runtime Error
    >> Description: An application error occurred on the server. The current
    >> custom
    >> error settings for this application prevent the details of the
    >> application
    >> error from being viewed remotely (for security reasons). It could,
    >> however,
    >> be viewed by browsers running on the local server machine.
    >> Details: To enable the details of this specific error message to be
    >> viewable on remote machines, please create a <customErrors> tag
    >> within a "web.config" configuration file located in the root
    >> directory of the current web application. This <customErrors> tag
    >> should then have its "mode" attribute set to "Off".
    >>
    >> <!-- Web.Config Configuration File -->
    >>
    >> <configuration>
    >> <system.web>
    >> <customErrors mode="Off"/>
    >> </system.web>
    >> </configuration>
    >> Notes: The current error page you are seeing can be replaced by a
    >> custom error page by modifying the "defaultRedirect" attribute of the
    >> application's <customErrors> configuration tag to point to a custom
    >> error page URL.
    >>
    >> <!-- Web.Config Configuration File -->
    >>
    >> <configuration>
    >> <system.web>
    >> <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    >> </system.web>
    >> </configuration>

    > User submitted from AEWNET (http://www.aewnet.com/)
    >
    Brock Allen, May 9, 2005
    #12
  13. From the server machine run

    http://localhost/YourTestPage.aspx - it will display error in more details

    and please post the error messages back in order we can work together.

    good lucks,
    dinh


    "unknown" wrote:

    >
    =?Utf-8?B?RGluaA==?=, May 25, 2005
    #13
  14. Kevin Farless

    chesterchass

    Joined:
    Oct 3, 2007
    Messages:
    1
    I had had the same error and solved it by changing my server supporting ASP.Net version into 2.0.

    But when i try to run my application it shows no error but loading like forever.

    I tried putting up some simple aspx pages n it is running.

    Can it be that my application has problems or can there be anychance i can solve it withouht touching my application since it runs smoothly on local with no error.
    chesterchass, Oct 3, 2007
    #14
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ketul Patel
    Replies:
    1
    Views:
    724
    Alvin Bruney
    Nov 29, 2003
  2. Marina Anufreichik
    Replies:
    10
    Views:
    698
    Rajasekhar Patta
    Feb 17, 2005
  3. Krunom Ancini
    Replies:
    2
    Views:
    5,166
  4. -
    Replies:
    2
    Views:
    397
    Alan Krueger
    Jul 29, 2005
  5. Hal Vaughan
    Replies:
    11
    Views:
    1,108
    Gordon Beaton
    May 22, 2006
Loading...

Share This Page