How do you set up http://localhost?

Discussion in 'ASP .Net' started by M Skabialka, Apr 20, 2005.

  1. M Skabialka

    M Skabialka Guest

    After you install Visual Studio 2003 on Windows XP Pro, what else do you
    have to do in order to create web applications.

    When I try it tryies to locate it at
    http://localhost/quickstart/WebApplication1

    I don't have localhost set up. How is that done?

    Thanks,
    Mich
     
    M Skabialka, Apr 20, 2005
    #1
    1. Advertising

  2. at a command prompt or at the run dialog box, run inetmgr (internet service
    manager)
    find your default website, and pull up the property pages. examine the path
    for the virtual directory. this path maps to local host. for instance, it
    may map to c:\inetpub\wwwroot by default. next, examine the quickstart
    folder in inetmgr, it should be configured as a virtual directory. if it
    isn't you will need to turn it into a virtual directory. then your link
    should work

    --
    Regards,
    Alvin Bruney - ASP.NET MVP

    [Shameless Author Plug]
    The Microsoft Office Web Components Black Book with .NET
    Now available @ www.lulu.com/owc
    "M Skabialka" <> wrote in message
    news:...
    > After you install Visual Studio 2003 on Windows XP Pro, what else do you
    > have to do in order to create web applications.
    >
    > When I try it tryies to locate it at
    > http://localhost/quickstart/WebApplication1
    >
    > I don't have localhost set up. How is that done?
    >
    > Thanks,
    > Mich
    >
     
    Alvin Bruney [MVP - ASP.NET], Apr 20, 2005
    #2
    1. Advertising

  3. M Skabialka

    Guest

    Hi,

    Just check by typing http://localhost/ in the browser. If you get help
    page on iis then its ok. else install iis first and then go for web
    applications.
    if iis is installed then try the above solution given by Alvin

    Regards,
    angrez
     
    , Apr 21, 2005
    #3
  4. M Skabialka

    M Skabialka Guest

    I opened IIS as you suggested, and found the default website. In properties
    it says that the local path is "c:\inetpub\wwwroot".

    However, there is no quickstart folder; there are these:

    MyPC (local computer)
    Web Sites
    IISHelp
    Scripts
    tsweb
    AspDotNetIntroLab1
    aspnet_client
    aspnet_webadmin
    images
    MovieReviews
    TestASP
    WebApplication1
    _private
    _vti_cnf
    _vti_log
    _vti_pvt
    _vti_script
    _vti_txt
    Default SMTP Virtual Server
    Domains
    Current Sessions

    How do I get a quickstart folder in there, and how so I set it up as a
    virtual directory?
    Thanks
    Mich

    "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    news:...
    > at a command prompt or at the run dialog box, run inetmgr (internet
    > service manager)
    > find your default website, and pull up the property pages. examine the
    > path for the virtual directory. this path maps to local host. for
    > instance, it may map to c:\inetpub\wwwroot by default. next, examine the
    > quickstart folder in inetmgr, it should be configured as a virtual
    > directory. if it isn't you will need to turn it into a virtual directory.
    > then your link should work
    >
    > --
    > Regards,
    > Alvin Bruney - ASP.NET MVP
    >
    > [Shameless Author Plug]
    > The Microsoft Office Web Components Black Book with .NET
    > Now available @ www.lulu.com/owc
    > "M Skabialka" <> wrote in message
    > news:...
    >> After you install Visual Studio 2003 on Windows XP Pro, what else do you
    >> have to do in order to create web applications.
    >>
    >> When I try it tries to locate it at
    >> http://localhost/quickstart/WebApplication1
    >>
    >> I don't have localhost set up. How is that done?
    >>
    >> Thanks,
    >> Mich
    >>

    >
    >
     
    M Skabialka, Apr 21, 2005
    #4
  5. the quickstart application is not on your drive. even if you created it, you
    don't have the files. you can have a look for the quickstart application on
    the installation cd or on the web if you care to spend time looking

    --
    Regards,
    Alvin Bruney - ASP.NET MVP

    [Shameless Author Plug]
    The Microsoft Office Web Components Black Book with .NET
    Now available @ www.lulu.com/owc
    "M Skabialka" <> wrote in message
    news:%...
    >I opened IIS as you suggested, and found the default website. In
    >properties it says that the local path is "c:\inetpub\wwwroot".
    >
    > However, there is no quickstart folder; there are these:
    >
    > MyPC (local computer)
    > Web Sites
    > IISHelp
    > Scripts
    > tsweb
    > AspDotNetIntroLab1
    > aspnet_client
    > aspnet_webadmin
    > images
    > MovieReviews
    > TestASP
    > WebApplication1
    > _private
    > _vti_cnf
    > _vti_log
    > _vti_pvt
    > _vti_script
    > _vti_txt
    > Default SMTP Virtual Server
    > Domains
    > Current Sessions
    >
    > How do I get a quickstart folder in there, and how so I set it up as a
    > virtual directory?
    > Thanks
    > Mich
    >
    > "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    > news:...
    >> at a command prompt or at the run dialog box, run inetmgr (internet
    >> service manager)
    >> find your default website, and pull up the property pages. examine the
    >> path for the virtual directory. this path maps to local host. for
    >> instance, it may map to c:\inetpub\wwwroot by default. next, examine the
    >> quickstart folder in inetmgr, it should be configured as a virtual
    >> directory. if it isn't you will need to turn it into a virtual directory.
    >> then your link should work
    >>
    >> --
    >> Regards,
    >> Alvin Bruney - ASP.NET MVP
    >>
    >> [Shameless Author Plug]
    >> The Microsoft Office Web Components Black Book with .NET
    >> Now available @ www.lulu.com/owc
    >> "M Skabialka" <> wrote in message
    >> news:...
    >>> After you install Visual Studio 2003 on Windows XP Pro, what else do you
    >>> have to do in order to create web applications.
    >>>
    >>> When I try it tries to locate it at
    >>> http://localhost/quickstart/WebApplication1
    >>>
    >>> I don't have localhost set up. How is that done?
    >>>
    >>> Thanks,
    >>> Mich
    >>>

    >>
    >>

    >
    >
     
    Alvin Bruney [MVP - ASP.NET], Apr 22, 2005
    #5
  6. M Skabialka

    M Skabialka Guest

    I uninstalled all versions of .NET Framework, then reinstalled 1.1 and SDK.
    I un and reinstalled MSDE 2000 and now in IIS there is a quickstart item.
    Not knowing how to open these items I searched for .sln files and opened one
    OK. However, when I try to create a new web application, the default site
    is http://localhost/quickstart/WebApplication1
    and I get an error
    The Web server reported the following error when attempting to create or
    open the Web project located at the following URL:
    'http//:localhost/quickstart/WebApplication1' 'HTTP/1.1 500 Server Error'.

    SQL Server (SQLEXPRESS) is running.
    IIS is running and shows a default web site.

    I still can't create Web Applications with Visual Studio 2003 60 day trial.
    I am still new to this kind of software, and am not sure what to try next.

    Any advise would be very appreciated,
    Thanks,
    Mich

    "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    news:...
    > the quickstart application is not on your drive. even if you created it,
    > you don't have the files. you can have a look for the quickstart
    > application on the installation cd or on the web if you care to spend time
    > looking
    >
    > --
    > Regards,
    > Alvin Bruney - ASP.NET MVP
    >
    > [Shameless Author Plug]
    > The Microsoft Office Web Components Black Book with .NET
    > Now available @ www.lulu.com/owc
    > "M Skabialka" <> wrote in message
    > news:%...
    >>I opened IIS as you suggested, and found the default website. In
    >>properties it says that the local path is "c:\inetpub\wwwroot".
    >>
    >> However, there is no quickstart folder; there are these:
    >>
    >> MyPC (local computer)
    >> Web Sites
    >> IISHelp
    >> Scripts
    >> tsweb
    >> AspDotNetIntroLab1
    >> aspnet_client
    >> aspnet_webadmin
    >> images
    >> MovieReviews
    >> TestASP
    >> WebApplication1
    >> _private
    >> _vti_cnf
    >> _vti_log
    >> _vti_pvt
    >> _vti_script
    >> _vti_txt
    >> Default SMTP Virtual Server
    >> Domains
    >> Current Sessions
    >>
    >> How do I get a quickstart folder in there, and how so I set it up as a
    >> virtual directory?
    >> Thanks
    >> Mich
    >>
    >> "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    >> news:...
    >>> at a command prompt or at the run dialog box, run inetmgr (internet
    >>> service manager)
    >>> find your default website, and pull up the property pages. examine the
    >>> path for the virtual directory. this path maps to local host. for
    >>> instance, it may map to c:\inetpub\wwwroot by default. next, examine the
    >>> quickstart folder in inetmgr, it should be configured as a virtual
    >>> directory. if it isn't you will need to turn it into a virtual
    >>> directory. then your link should work
    >>>
    >>> --
    >>> Regards,
    >>> Alvin Bruney - ASP.NET MVP
    >>>
    >>> [Shameless Author Plug]
    >>> The Microsoft Office Web Components Black Book with .NET
    >>> Now available @ www.lulu.com/owc
    >>> "M Skabialka" <> wrote in message
    >>> news:...
    >>>> After you install Visual Studio 2003 on Windows XP Pro, what else do
    >>>> you have to do in order to create web applications.
    >>>>
    >>>> When I try it tries to locate it at
    >>>> http://localhost/quickstart/WebApplication1
    >>>>
    >>>> I don't have localhost set up. How is that done?
    >>>>
    >>>> Thanks,
    >>>> Mich
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
     
    M Skabialka, Apr 22, 2005
    #6
  7. go to the file project, select new project, give it a default name. from
    that point, your application should open. Is that what you are doing (from
    Visual Studio?)

    --
    Regards,
    Alvin Bruney - ASP.NET MVP

    [Shameless Author Plug]
    The Microsoft Office Web Components Black Book with .NET
    Now available @ www.lulu.com/owc
    "M Skabialka" <> wrote in message
    news:eQXPu$...
    >I uninstalled all versions of .NET Framework, then reinstalled 1.1 and SDK.
    >I un and reinstalled MSDE 2000 and now in IIS there is a quickstart item.
    > Not knowing how to open these items I searched for .sln files and opened
    > one OK. However, when I try to create a new web application, the default
    > site is http://localhost/quickstart/WebApplication1
    > and I get an error
    > The Web server reported the following error when attempting to create or
    > open the Web project located at the following URL:
    > 'http//:localhost/quickstart/WebApplication1' 'HTTP/1.1 500 Server Error'.
    >
    > SQL Server (SQLEXPRESS) is running.
    > IIS is running and shows a default web site.
    >
    > I still can't create Web Applications with Visual Studio 2003 60 day
    > trial.
    > I am still new to this kind of software, and am not sure what to try next.
    >
    > Any advise would be very appreciated,
    > Thanks,
    > Mich
    >
    > "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    > news:...
    >> the quickstart application is not on your drive. even if you created it,
    >> you don't have the files. you can have a look for the quickstart
    >> application on the installation cd or on the web if you care to spend
    >> time looking
    >>
    >> --
    >> Regards,
    >> Alvin Bruney - ASP.NET MVP
    >>
    >> [Shameless Author Plug]
    >> The Microsoft Office Web Components Black Book with .NET
    >> Now available @ www.lulu.com/owc
    >> "M Skabialka" <> wrote in message
    >> news:%...
    >>>I opened IIS as you suggested, and found the default website. In
    >>>properties it says that the local path is "c:\inetpub\wwwroot".
    >>>
    >>> However, there is no quickstart folder; there are these:
    >>>
    >>> MyPC (local computer)
    >>> Web Sites
    >>> IISHelp
    >>> Scripts
    >>> tsweb
    >>> AspDotNetIntroLab1
    >>> aspnet_client
    >>> aspnet_webadmin
    >>> images
    >>> MovieReviews
    >>> TestASP
    >>> WebApplication1
    >>> _private
    >>> _vti_cnf
    >>> _vti_log
    >>> _vti_pvt
    >>> _vti_script
    >>> _vti_txt
    >>> Default SMTP Virtual Server
    >>> Domains
    >>> Current Sessions
    >>>
    >>> How do I get a quickstart folder in there, and how so I set it up as a
    >>> virtual directory?
    >>> Thanks
    >>> Mich
    >>>
    >>> "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    >>> news:...
    >>>> at a command prompt or at the run dialog box, run inetmgr (internet
    >>>> service manager)
    >>>> find your default website, and pull up the property pages. examine the
    >>>> path for the virtual directory. this path maps to local host. for
    >>>> instance, it may map to c:\inetpub\wwwroot by default. next, examine
    >>>> the quickstart folder in inetmgr, it should be configured as a virtual
    >>>> directory. if it isn't you will need to turn it into a virtual
    >>>> directory. then your link should work
    >>>>
    >>>> --
    >>>> Regards,
    >>>> Alvin Bruney - ASP.NET MVP
    >>>>
    >>>> [Shameless Author Plug]
    >>>> The Microsoft Office Web Components Black Book with .NET
    >>>> Now available @ www.lulu.com/owc
    >>>> "M Skabialka" <> wrote in message
    >>>> news:...
    >>>>> After you install Visual Studio 2003 on Windows XP Pro, what else do
    >>>>> you have to do in order to create web applications.
    >>>>>
    >>>>> When I try it tries to locate it at
    >>>>> http://localhost/quickstart/WebApplication1
    >>>>>
    >>>>> I don't have localhost set up. How is that done?
    >>>>>
    >>>>> Thanks,
    >>>>> Mich
    >>>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
     
    Alvin Bruney [MVP - ASP.NET], Apr 24, 2005
    #7
  8. M Skabialka

    M Skabialka Guest

    I open Visual Studio, go to File, New, Project.
    I select ASP .Net Web Application
    The name and default location is http://localhost/quickstart/WebApplication1
    I click OK, then get the message:
    The Web server reported the following error when attempting to create or
    open the Web project located at the following URL:
    'http//:localhost/quickstart/WebApplication1' 'HTTP/1.1 500 Server Error'.

    If I try Explorer to see what is at this location
    http://localhost/quickstart
    I get an error 500 - The page cannot be displayed

    I can create Windows Applications, but not ASP .Net Web Applications.
    I am using WinXP Pro, and VS .NET 2003 60 day trial (whose time is running
    out!)

    Mich

    "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    news:%...
    > go to the file project, select new project, give it a default name. from
    > that point, your application should open. Is that what you are doing (from
    > Visual Studio?)
    >
    > --
    > Regards,
    > Alvin Bruney - ASP.NET MVP
    >
    > [Shameless Author Plug]
    > The Microsoft Office Web Components Black Book with .NET
    > Now available @ www.lulu.com/owc
    > "M Skabialka" <> wrote in message
    > news:eQXPu$...
    >>I uninstalled all versions of .NET Framework, then reinstalled 1.1 and
    >>SDK. I un and reinstalled MSDE 2000 and now in IIS there is a quickstart
    >>item.
    >> Not knowing how to open these items I searched for .sln files and opened
    >> one OK. However, when I try to create a new web application, the default
    >> site is http://localhost/quickstart/WebApplication1
    >> and I get an error
    >> The Web server reported the following error when attempting to create or
    >> open the Web project located at the following URL:
    >> 'http//:localhost/quickstart/WebApplication1' 'HTTP/1.1 500 Server
    >> Error'.
    >>
    >> SQL Server (SQLEXPRESS) is running.
    >> IIS is running and shows a default web site.
    >>
    >> I still can't create Web Applications with Visual Studio 2003 60 day
    >> trial.
    >> I am still new to this kind of software, and am not sure what to try
    >> next.
    >>
    >> Any advise would be very appreciated,
    >> Thanks,
    >> Mich
    >>
    >> "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    >> news:...
    >>> the quickstart application is not on your drive. even if you created it,
    >>> you don't have the files. you can have a look for the quickstart
    >>> application on the installation cd or on the web if you care to spend
    >>> time looking
    >>>
    >>> --
    >>> Regards,
    >>> Alvin Bruney - ASP.NET MVP
    >>>
    >>> [Shameless Author Plug]
    >>> The Microsoft Office Web Components Black Book with .NET
    >>> Now available @ www.lulu.com/owc
    >>> "M Skabialka" <> wrote in message
    >>> news:%...
    >>>>I opened IIS as you suggested, and found the default website. In
    >>>>properties it says that the local path is "c:\inetpub\wwwroot".
    >>>>
    >>>> However, there is no quickstart folder; there are these:
    >>>>
    >>>> MyPC (local computer)
    >>>> Web Sites
    >>>> IISHelp
    >>>> Scripts
    >>>> tsweb
    >>>> AspDotNetIntroLab1
    >>>> aspnet_client
    >>>> aspnet_webadmin
    >>>> images
    >>>> MovieReviews
    >>>> TestASP
    >>>> WebApplication1
    >>>> _private
    >>>> _vti_cnf
    >>>> _vti_log
    >>>> _vti_pvt
    >>>> _vti_script
    >>>> _vti_txt
    >>>> Default SMTP Virtual Server
    >>>> Domains
    >>>> Current Sessions
    >>>>
    >>>> How do I get a quickstart folder in there, and how so I set it up as a
    >>>> virtual directory?
    >>>> Thanks
    >>>> Mich
    >>>>
    >>>> "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    >>>> news:...
    >>>>> at a command prompt or at the run dialog box, run inetmgr (internet
    >>>>> service manager)
    >>>>> find your default website, and pull up the property pages. examine the
    >>>>> path for the virtual directory. this path maps to local host. for
    >>>>> instance, it may map to c:\inetpub\wwwroot by default. next, examine
    >>>>> the quickstart folder in inetmgr, it should be configured as a virtual
    >>>>> directory. if it isn't you will need to turn it into a virtual
    >>>>> directory. then your link should work
    >>>>>
    >>>>> --
    >>>>> Regards,
    >>>>> Alvin Bruney - ASP.NET MVP
    >>>>>
    >>>>> [Shameless Author Plug]
    >>>>> The Microsoft Office Web Components Black Book with .NET
    >>>>> Now available @ www.lulu.com/owc
    >>>>> "M Skabialka" <> wrote in message
    >>>>> news:...
    >>>>>> After you install Visual Studio 2003 on Windows XP Pro, what else do
    >>>>>> you have to do in order to create web applications.
    >>>>>>
    >>>>>> When I try it tries to locate it at
    >>>>>> http://localhost/quickstart/WebApplication1
    >>>>>>
    >>>>>> I don't have localhost set up. How is that done?
    >>>>>>
    >>>>>> Thanks,
    >>>>>> Mich
    >>>>>>
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
     
    M Skabialka, Apr 25, 2005
    #8
  9. M Skabialka

    Nassos Guest

    Hi Man,
    What you need is to setup the IIS of windows, to do this go to add/remove
    programs -->Windows Components, and in the list that apears check the IIS
    put the CD of windows and thats ALL!!!
    Hope that helps.
    "M Skabialka" <> wrote in message
    news:...
    >I open Visual Studio, go to File, New, Project.
    > I select ASP .Net Web Application
    > The name and default location is
    > http://localhost/quickstart/WebApplication1
    > I click OK, then get the message:
    > The Web server reported the following error when attempting to create or
    > open the Web project located at the following URL:
    > 'http//:localhost/quickstart/WebApplication1' 'HTTP/1.1 500 Server Error'.
    >
    > If I try Explorer to see what is at this location
    > http://localhost/quickstart
    > I get an error 500 - The page cannot be displayed
    >
    > I can create Windows Applications, but not ASP .Net Web Applications.
    > I am using WinXP Pro, and VS .NET 2003 60 day trial (whose time is running
    > out!)
    >
    > Mich
    >
    > "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    > news:%...
    >> go to the file project, select new project, give it a default name. from
    >> that point, your application should open. Is that what you are doing
    >> (from Visual Studio?)
    >>
    >> --
    >> Regards,
    >> Alvin Bruney - ASP.NET MVP
    >>
    >> [Shameless Author Plug]
    >> The Microsoft Office Web Components Black Book with .NET
    >> Now available @ www.lulu.com/owc
    >> "M Skabialka" <> wrote in message
    >> news:eQXPu$...
    >>>I uninstalled all versions of .NET Framework, then reinstalled 1.1 and
    >>>SDK. I un and reinstalled MSDE 2000 and now in IIS there is a quickstart
    >>>item.
    >>> Not knowing how to open these items I searched for .sln files and opened
    >>> one OK. However, when I try to create a new web application, the
    >>> default site is http://localhost/quickstart/WebApplication1
    >>> and I get an error
    >>> The Web server reported the following error when attempting to create or
    >>> open the Web project located at the following URL:
    >>> 'http//:localhost/quickstart/WebApplication1' 'HTTP/1.1 500 Server
    >>> Error'.
    >>>
    >>> SQL Server (SQLEXPRESS) is running.
    >>> IIS is running and shows a default web site.
    >>>
    >>> I still can't create Web Applications with Visual Studio 2003 60 day
    >>> trial.
    >>> I am still new to this kind of software, and am not sure what to try
    >>> next.
    >>>
    >>> Any advise would be very appreciated,
    >>> Thanks,
    >>> Mich
    >>>
    >>> "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    >>> news:...
    >>>> the quickstart application is not on your drive. even if you created
    >>>> it, you don't have the files. you can have a look for the quickstart
    >>>> application on the installation cd or on the web if you care to spend
    >>>> time looking
    >>>>
    >>>> --
    >>>> Regards,
    >>>> Alvin Bruney - ASP.NET MVP
    >>>>
    >>>> [Shameless Author Plug]
    >>>> The Microsoft Office Web Components Black Book with .NET
    >>>> Now available @ www.lulu.com/owc
    >>>> "M Skabialka" <> wrote in message
    >>>> news:%...
    >>>>>I opened IIS as you suggested, and found the default website. In
    >>>>>properties it says that the local path is "c:\inetpub\wwwroot".
    >>>>>
    >>>>> However, there is no quickstart folder; there are these:
    >>>>>
    >>>>> MyPC (local computer)
    >>>>> Web Sites
    >>>>> IISHelp
    >>>>> Scripts
    >>>>> tsweb
    >>>>> AspDotNetIntroLab1
    >>>>> aspnet_client
    >>>>> aspnet_webadmin
    >>>>> images
    >>>>> MovieReviews
    >>>>> TestASP
    >>>>> WebApplication1
    >>>>> _private
    >>>>> _vti_cnf
    >>>>> _vti_log
    >>>>> _vti_pvt
    >>>>> _vti_script
    >>>>> _vti_txt
    >>>>> Default SMTP Virtual Server
    >>>>> Domains
    >>>>> Current Sessions
    >>>>>
    >>>>> How do I get a quickstart folder in there, and how so I set it up as a
    >>>>> virtual directory?
    >>>>> Thanks
    >>>>> Mich
    >>>>>
    >>>>> "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    >>>>> news:...
    >>>>>> at a command prompt or at the run dialog box, run inetmgr (internet
    >>>>>> service manager)
    >>>>>> find your default website, and pull up the property pages. examine
    >>>>>> the path for the virtual directory. this path maps to local host. for
    >>>>>> instance, it may map to c:\inetpub\wwwroot by default. next, examine
    >>>>>> the quickstart folder in inetmgr, it should be configured as a
    >>>>>> virtual directory. if it isn't you will need to turn it into a
    >>>>>> virtual directory. then your link should work
    >>>>>>
    >>>>>> --
    >>>>>> Regards,
    >>>>>> Alvin Bruney - ASP.NET MVP
    >>>>>>
    >>>>>> [Shameless Author Plug]
    >>>>>> The Microsoft Office Web Components Black Book with .NET
    >>>>>> Now available @ www.lulu.com/owc
    >>>>>> "M Skabialka" <> wrote in message
    >>>>>> news:...
    >>>>>>> After you install Visual Studio 2003 on Windows XP Pro, what else do
    >>>>>>> you have to do in order to create web applications.
    >>>>>>>
    >>>>>>> When I try it tries to locate it at
    >>>>>>> http://localhost/quickstart/WebApplication1
    >>>>>>>
    >>>>>>> I don't have localhost set up. How is that done?
    >>>>>>>
    >>>>>>> Thanks,
    >>>>>>> Mich
    >>>>>>>
    >>>>>>
    >>>>>>
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
     
    Nassos, Apr 26, 2005
    #9
  10. M Skabialka

    M Skabialka Guest

    SQL Server (SQLEXPRESS) is running.
    IIS is running and shows a default web site.

    Something else is wrong somewhere!!!!
    I have removed and reinstalled every aspect of Visual Studio, .Net
    Framework, IIS, MSDE, etc...
    And still it doesn't work!

    Mich

    "Nassos" <> wrote in message
    news:...
    > Hi Man,
    > What you need is to setup the IIS of windows, to do this go to add/remove
    > programs -->Windows Components, and in the list that apears check the IIS
    > put the CD of windows and thats ALL!!!
    > Hope that helps.
    > "M Skabialka" <> wrote in message
    > news:...
    >>I open Visual Studio, go to File, New, Project.
    >> I select ASP .Net Web Application
    >> The name and default location is
    >> http://localhost/quickstart/WebApplication1
    >> I click OK, then get the message:
    >> The Web server reported the following error when attempting to create or
    >> open the Web project located at the following URL:
    >> 'http//:localhost/quickstart/WebApplication1' 'HTTP/1.1 500 Server
    >> Error'.
    >>
    >> If I try Explorer to see what is at this location
    >> http://localhost/quickstart
    >> I get an error 500 - The page cannot be displayed
    >>
    >> I can create Windows Applications, but not ASP .Net Web Applications.
    >> I am using WinXP Pro, and VS .NET 2003 60 day trial (whose time is
    >> running out!)
    >>
    >> Mich
    >>
    >> "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    >> news:%...
    >>> go to the file project, select new project, give it a default name. from
    >>> that point, your application should open. Is that what you are doing
    >>> (from Visual Studio?)
    >>>
    >>> --
    >>> Regards,
    >>> Alvin Bruney - ASP.NET MVP
    >>>
    >>> [Shameless Author Plug]
    >>> The Microsoft Office Web Components Black Book with .NET
    >>> Now available @ www.lulu.com/owc
    >>> "M Skabialka" <> wrote in message
    >>> news:eQXPu$...
    >>>>I uninstalled all versions of .NET Framework, then reinstalled 1.1 and
    >>>>SDK. I un and reinstalled MSDE 2000 and now in IIS there is a quickstart
    >>>>item.
    >>>> Not knowing how to open these items I searched for .sln files and
    >>>> opened one OK. However, when I try to create a new web application,
    >>>> the default site is http://localhost/quickstart/WebApplication1
    >>>> and I get an error
    >>>> The Web server reported the following error when attempting to create
    >>>> or open the Web project located at the following URL:
    >>>> 'http//:localhost/quickstart/WebApplication1' 'HTTP/1.1 500 Server
    >>>> Error'.
    >>>>
    >>>> SQL Server (SQLEXPRESS) is running.
    >>>> IIS is running and shows a default web site.
    >>>>
    >>>> I still can't create Web Applications with Visual Studio 2003 60 day
    >>>> trial.
    >>>> I am still new to this kind of software, and am not sure what to try
    >>>> next.
    >>>>
    >>>> Any advise would be very appreciated,
    >>>> Thanks,
    >>>> Mich
    >>>>
    >>>> "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    >>>> news:...
    >>>>> the quickstart application is not on your drive. even if you created
    >>>>> it, you don't have the files. you can have a look for the quickstart
    >>>>> application on the installation cd or on the web if you care to spend
    >>>>> time looking
    >>>>>
    >>>>> --
    >>>>> Regards,
    >>>>> Alvin Bruney - ASP.NET MVP
    >>>>>
    >>>>> [Shameless Author Plug]
    >>>>> The Microsoft Office Web Components Black Book with .NET
    >>>>> Now available @ www.lulu.com/owc
    >>>>> "M Skabialka" <> wrote in message
    >>>>> news:%...
    >>>>>>I opened IIS as you suggested, and found the default website. In
    >>>>>>properties it says that the local path is "c:\inetpub\wwwroot".
    >>>>>>
    >>>>>> However, there is no quickstart folder; there are these:
    >>>>>>
    >>>>>> MyPC (local computer)
    >>>>>> Web Sites
    >>>>>> IISHelp
    >>>>>> Scripts
    >>>>>> tsweb
    >>>>>> AspDotNetIntroLab1
    >>>>>> aspnet_client
    >>>>>> aspnet_webadmin
    >>>>>> images
    >>>>>> MovieReviews
    >>>>>> TestASP
    >>>>>> WebApplication1
    >>>>>> _private
    >>>>>> _vti_cnf
    >>>>>> _vti_log
    >>>>>> _vti_pvt
    >>>>>> _vti_script
    >>>>>> _vti_txt
    >>>>>> Default SMTP Virtual Server
    >>>>>> Domains
    >>>>>> Current Sessions
    >>>>>>
    >>>>>> How do I get a quickstart folder in there, and how so I set it up as
    >>>>>> a virtual directory?
    >>>>>> Thanks
    >>>>>> Mich
    >>>>>>
    >>>>>> "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    >>>>>> news:...
    >>>>>>> at a command prompt or at the run dialog box, run inetmgr (internet
    >>>>>>> service manager)
    >>>>>>> find your default website, and pull up the property pages. examine
    >>>>>>> the path for the virtual directory. this path maps to local host.
    >>>>>>> for instance, it may map to c:\inetpub\wwwroot by default. next,
    >>>>>>> examine the quickstart folder in inetmgr, it should be configured as
    >>>>>>> a virtual directory. if it isn't you will need to turn it into a
    >>>>>>> virtual directory. then your link should work
    >>>>>>>
    >>>>>>> --
    >>>>>>> Regards,
    >>>>>>> Alvin Bruney - ASP.NET MVP
    >>>>>>>
    >>>>>>> [Shameless Author Plug]
    >>>>>>> The Microsoft Office Web Components Black Book with .NET
    >>>>>>> Now available @ www.lulu.com/owc
    >>>>>>> "M Skabialka" <> wrote in message
    >>>>>>> news:...
    >>>>>>>> After you install Visual Studio 2003 on Windows XP Pro, what else
    >>>>>>>> do you have to do in order to create web applications.
    >>>>>>>>
    >>>>>>>> When I try it tries to locate it at
    >>>>>>>> http://localhost/quickstart/WebApplication1
    >>>>>>>>
    >>>>>>>> I don't have localhost set up. How is that done?
    >>>>>>>>
    >>>>>>>> Thanks,
    >>>>>>>> Mich
    >>>>>>>>
    >>>>>>>
    >>>>>>>
    >>>>>>
    >>>>>>
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
     
    M Skabialka, Apr 26, 2005
    #10
  11. M Skabialka

    Mark Newby Guest

    M Skabialka wrote:
    > SQL Server (SQLEXPRESS) is running.
    > IIS is running and shows a default web site.
    >
    > Something else is wrong somewhere!!!!
    > I have removed and reinstalled every aspect of Visual Studio, .Net
    > Framework, IIS, MSDE, etc...
    > And still it doesn't work!


    I'm no expert, but based on what i did to get it working in winxp pro...

    in case you've got a muddled configuration, open "Add/Remove Programs"
    from Control Panel, select "Windows Components" (or similar name) and
    remove all of IIS. then reboot and install it again using same process.
    Make sure you install all the Server Extensions stuff.

    when you install IIS this way it defaults to starting automatically when
    you boot up.

    open the mmc: right click "My Computer" icon, select "Manage...". expand
    "Services", select IIS, right-click on "Default Web Site", select New
    Virtual Folder ...create a folder, eg C:\Inetpub\wwwroot\MyTestArea
    ....and finish the wizard.

    create a new "sub web" to enable all the Server Extensions (I think
    these are used by Visual Studio): from the above mmc, right click the
    new virtual folder you created and choose "Configure Server Extensions",
    and accept all the defaults.

    Now open up Visual Studio and create a new web project, selecting the
    path as http://localhost/MyTestArea/WebApplication1, or whatever. add a
    control to WebForm1, then hit F5 and it should run it in debug mode.

    hope that helps. worked for me :)

    mark
     
    Mark Newby, Apr 27, 2005
    #11
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jiong Feng
    Replies:
    0
    Views:
    846
    Jiong Feng
    Nov 19, 2003
  2. Paul Glavich [MVP - ASP.NET]
    Replies:
    0
    Views:
    450
    Paul Glavich [MVP - ASP.NET]
    Jun 20, 2004
  3. T. Regan
    Replies:
    3
    Views:
    713
    T. Regan
    Jun 21, 2004
  4. NNTP
    Replies:
    2
    Views:
    992
    =?Utf-8?B?S2V2aW4gVG9kZA==?=
    Mar 18, 2005
  5. larkpics
    Replies:
    9
    Views:
    9,020
    Patrick.O.Ige
    Oct 22, 2005
Loading...

Share This Page