listbox losing multiple selections thru proxy, but not locally

Discussion in 'ASP .Net Web Controls' started by bthomasIDFG, Oct 12, 2005.

  1. bthomasIDFG

    bthomasIDFG Guest

    Multiple selections to listboxes (but not checkbox lists) are cleared on
    postback when connecting through a proxy on the internet, but not when
    connecting directly to the server on the intranet or on my development
    machine. Single selections to the listbox works. This is not hosted in a
    web farm type setup. SelectionMode="Multiple". Again this works locally.

    See an example at
    http://fishandgame.idaho.gov/ifwis/huntplanner/listboxsilliness.aspx
    Make a multiple selection and press the submit to postback. You will see
    viewstate is preserved in the checkboxlist and radiobuttonlist but not in the
    listbox. If only one item is selected in the listbox state is preserved.

    What is going on here? Out of ideas (for the day at least)
     
    bthomasIDFG, Oct 12, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. bill yeager

    multiple listbox selections

    bill yeager, Aug 12, 2003, in forum: ASP .Net
    Replies:
    0
    Views:
    450
    bill yeager
    Aug 12, 2003
  2. =?Utf-8?B?QWRpcw==?=
    Replies:
    0
    Views:
    384
    =?Utf-8?B?QWRpcw==?=
    Oct 19, 2004
  3. zdrakec
    Replies:
    0
    Views:
    524
    zdrakec
    Jul 22, 2005
  4. zdrakec
    Replies:
    0
    Views:
    472
    zdrakec
    Jul 22, 2005
  5. THTB
    Replies:
    0
    Views:
    197
Loading...

Share This Page