problem with adding IDs to webcontrols in datagrid

Discussion in 'ASP .Net Datagrid Control' started by rob.bowley@gmail.com, Sep 16, 2005.

  1. Guest

    I have programatically created textboxes with IDs within my datagrid.
    This appears to work fine as when I view source it all looks good. The
    problem is that I now can't return the bound values contained in the
    textboxes. They are there as they're displayed on the page, but when I
    debug it simply comes up with an empty text field. I can return the
    values if I remove the IDs, but I want to be able to fire a JavaScript
    event which calculates row totals and it would be very difficult to
    locate the textboxes without IDs.

    Has anyone else had the same problem?
     
    , Sep 16, 2005
    #1
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Chris
    Replies:
    2
    Views:
    1,915
    Chris Barrow
    Jul 22, 2003
  2. EMW
    Replies:
    5
    Views:
    400
  3. Jim Bancroft

    DataGrid appending to my ItemTemplate IDs?

    Jim Bancroft, Dec 28, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    373
    Jim Bancroft
    Dec 28, 2004
  4. JV
    Replies:
    1
    Views:
    445
  5. Replies:
    6
    Views:
    1,075
  6. Replies:
    2
    Views:
    937
    Beat Bolli
    Jun 21, 2005
  7. kito
    Replies:
    2
    Views:
    599
  8. MikeD

    IDs in a DataGrid

    MikeD, Nov 27, 2003, in forum: ASP .Net Web Controls
    Replies:
    4
    Views:
    201
    MikeD
    Dec 1, 2003
Loading...