style guideline for naming variables?

J

John Salerno

After reading the PEP, I'm still not quite sure if there is a
recommended (or widely preferred) method of naming variables. Here are
the relevant bits:
Global Variable Names

(Let's hope that these variables are meant for use inside one module
only.) The conventions are about the same as those for functions.

Modules that are designed for use via "from M import *" should use the
__all__ mechanism to prevent exporting globals, or use the the older
convention of prefixing such globals with an underscore (which you might
want to do to indicate these globals are "module non-public").

Function Names

Function names should be lowercase, with words separated by underscores
as necessary to improve readability.

mixedCase is allowed only in contexts where that's already the
prevailing style (e.g. threading.py), to retain backwards compatibility.
>
Method Names and Instance Variables

Use the function naming rules: lowercase with words separated by
underscores as necessary to improve readability.

Use one leading underscore only for non-public methods and instance
variables.

To avoid name clashes with subclasses, use two leading underscores to
invoke Python's name mangling rules.

Python mangles these names with the class name: if class Foo has an
attribute named __a, it cannot be accessed by Foo.__a. (An insistent
user could still gain access by calling Foo._Foo__a.) Generally, double
leading underscores should be used only to avoid name conflicts with
attributes in classes designed to be subclassed.

Note: there is some controversy about the use of __names (see below).

It refers to instance variables, which I assume includes all variables
that aren't global, and the suggestion is to follow function
conventions, which would be this:

some_function

But this seems awkward to me. someFunction seems nicer, but it is
specifically mentioned not to do this for new code.

So I'm just curious how other people handle the multiword situation.
Underscores, or Pascal case?
 
J

John Salerno

John said:
some_function

But this seems awkward to me. someFunction seems nicer

Sorry, I was asking about variables but used a function example. But
really I'm asking about any situation where you might want to use
multiple words (except for classes, which is recommended to use Camel
case, and that seems fine).
 
D

Duncan Smith

John said:
After reading the PEP, I'm still not quite sure if there is a
recommended (or widely preferred) method of naming variables. Here are
the relevant bits:



It refers to instance variables, which I assume includes all variables
that aren't global, and the suggestion is to follow function
conventions, which would be this:

some_function

But this seems awkward to me. someFunction seems nicer, but it is
specifically mentioned not to do this for new code.

So I'm just curious how other people handle the multiword situation.
Underscores, or Pascal case?

SomeClass

someFunction

some_variable

FWIW

Duncan
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
473,769
Messages
2,569,581
Members
45,056
Latest member
GlycogenSupporthealth

Latest Threads

Top