Survey: What do you name your User table?

Discussion in 'ASP .Net' started by jasonkester, Sep 2, 2005.

  1. jasonkester

    jasonkester Guest

    Most of the sites that I build have to deal with security at some
    point, and this means that somewhere in the database there needs to be
    a list of Users.

    The naming convention that I (and most everybody I've ever worked with
    that cares about such things) use dictates that a table should be named
    according to what it contains, and that this name should be singular.
    So, Customer, User, Entry are all good, while Customers, Users, Entries
    are not so good. Thus, nobody has to deal with Junior Dev Jimmy's
    magic ID generation code that occasionally tries to bind a column to
    "EntrieID".

    The issue I keep running into is that "User" is essentially a reserved
    word in ASP.NET, being a property of Page. Thus, I can't use it as the
    ClassName for my DataObject that wraps the User table. Thus, I
    probably shouldn't be naming the table "User", since every other
    DataObject always is named after the table it represents.

    I've tried going with "Login" to describe users, but this usually
    crashes into somebody's Login.aspx Page object, and besides it's not
    quite descriptive enough for my tastes.

    That leaves us with "Users" (thus breaking our naming convention),
    "tblUser" "UserTable" or "UserRecord" (which all look silly on the
    url), "Individual" or "Dude" (which I've actually gone with in the
    past).

    I'm curious what other people have come up with to attack this problem.
    I'm sure I'm not the only one running into it. Let me know what you
    think!


    Jason Kester
    Expat Software Consulting Services
    http://www.expatsoftware.com/
     
    jasonkester, Sep 2, 2005
    #1
    1. Advertising

  2. jasonkester

    Bruce Barker Guest

    because tables are sets, i (like the sqlserver dev group) always make them
    pural, so my users table name is Users. in your case UserInfo is probably a
    good name.

    -- bruce (sqlwork.com)

    "jasonkester" <> wrote in message
    news:...
    > Most of the sites that I build have to deal with security at some
    > point, and this means that somewhere in the database there needs to be
    > a list of Users.
    >
    > The naming convention that I (and most everybody I've ever worked with
    > that cares about such things) use dictates that a table should be named
    > according to what it contains, and that this name should be singular.
    > So, Customer, User, Entry are all good, while Customers, Users, Entries
    > are not so good. Thus, nobody has to deal with Junior Dev Jimmy's
    > magic ID generation code that occasionally tries to bind a column to
    > "EntrieID".
    >
    > The issue I keep running into is that "User" is essentially a reserved
    > word in ASP.NET, being a property of Page. Thus, I can't use it as the
    > ClassName for my DataObject that wraps the User table. Thus, I
    > probably shouldn't be naming the table "User", since every other
    > DataObject always is named after the table it represents.
    >
    > I've tried going with "Login" to describe users, but this usually
    > crashes into somebody's Login.aspx Page object, and besides it's not
    > quite descriptive enough for my tastes.
    >
    > That leaves us with "Users" (thus breaking our naming convention),
    > "tblUser" "UserTable" or "UserRecord" (which all look silly on the
    > url), "Individual" or "Dude" (which I've actually gone with in the
    > past).
    >
    > I'm curious what other people have come up with to attack this problem.
    > I'm sure I'm not the only one running into it. Let me know what you
    > think!
    >
    >
    > Jason Kester
    > Expat Software Consulting Services
    > http://www.expatsoftware.com/
    >
     
    Bruce Barker, Sep 3, 2005
    #2
    1. Advertising

  3. jasonkester

    WJ Guest

    UserProfile, UserRegistrationInfo, RegisteredUsers, UserCredentials....

    Johm
     
    WJ, Sep 3, 2005
    #3
  4. jasonkester

    Sorgfelt

    Joined:
    Feb 21, 2012
    Messages:
    1
    Dude, AppUser, Account, Credential, Operator.
    I just read that someone once named it the Dude table. Before that, I used AppUser or Account, but I like Dude better, because it won't conflict with anything, is short (same length as User), AppUser is two words which makes some things awkward looking, and Account might conflict with customer account or bank account in some apps. You might use the name Credential, which shouldn't conflict with most database applications. Credential would be an especially good name for the password table, if you keep separate tables, because Password is also a keyword in many places. A user operates your application, so Operator might be good. However, since I work too often with people who are lavish followers of the big gorilla (Microsoft), rather than thorough logic, I sometimes cave in to calling it the Users table, since that is the Microsoft default name for such a thing, even if all of my other table names are singular.
     
    Sorgfelt, Feb 21, 2012
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Your Encryption Site
    Replies:
    11
    Views:
    737
    Kim André Akerø
    Apr 24, 2008
  2. Suganya
    Replies:
    0
    Views:
    480
    Suganya
    Apr 29, 2008
  3. VanL
    Replies:
    1
    Views:
    362
    Giampaolo Rodola'
    Aug 7, 2009
  4. Mark Shapiro
    Replies:
    3
    Views:
    582
    Mark Shapiro
    Oct 8, 2011
  5. c676228
    Replies:
    3
    Views:
    198
    c676228
    Sep 14, 2006
Loading...

Share This Page