Tomcat 4.0 on XP, Startup, Bind problem

Discussion in 'Java' started by Robert Kattke, Aug 30, 2004.

  1. BindException: Address already in use: JVM_Bind

    complete Stack Trace available upon request.
    Some various interactions which may contribute to problem.
    -Recent Install of Zone Alarm Firewall(ZA):(Startup fails even when ZA
    off)
    -IBM HTTP Server is running, but can't seem to find it or kill it Task
    Manager process list. Must have installed it with Websphere(WAS) but
    have not used it.
    -I'm using Cable Modem
    -Apache2 is running although, IBM is serving at http://localhost
    -I've generally used Tomcat as a stand-alone at http://localhost:8080

    Various log excerpts and clues:
    netstat shows only 5-6 ports being used; none suspect
    3306 and 1046 for local MySQL, and a few around 1050 for ?Cable
    Modem?

    from catalina_log.2004-08-30.txt
    2004-08-30 15:59:42 HttpConnector Opening server socket on all host IP
    addresses

    from mod_jk.log
    [Mon Aug 30 01:37:40 2004] [jk_ajp_common.c (1239)]: In
    jk_worker_t::validate for worker ajp13 contact is 127.0.0.1:8009

    Recenly tried to remove many start up applications using selective
    startup.
    Any suggestions or references to resolve this ? TIA for your
    response.
    Robert Kattke, Aug 30, 2004
    #1
    1. Advertising

  2. At first I was hoping this was just a Zone Alarm related issue, but
    error occurs even after ZA is turned off. I did get a successful
    startup once, but I don't know what was changed to allow that.

    I did notice in task.mgr multiple Apache.exe processes, some started
    by SYSTEM, others by Administrator. Why so many ? (up to 5)
    Again, I also need to know the process name for IBM HTTP Server.
    Any advice, suggestions ?
    Robert Kattke, Sep 2, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Henry Fleming

    Tomcat Startup Problem

    Henry Fleming, Nov 1, 2003, in forum: Java
    Replies:
    3
    Views:
    776
    David Rabinowitz
    Nov 2, 2003
  2. moongateclimber

    Tomcat startup problem

    moongateclimber, Nov 19, 2004, in forum: Java
    Replies:
    2
    Views:
    6,904
    moongateclimber
    Nov 22, 2004
  3. Kevin Lam

    Tomcat startup problem

    Kevin Lam, Dec 31, 2004, in forum: Java
    Replies:
    1
    Views:
    517
  4. Kevin Lam

    Tomcat startup problem

    Kevin Lam, Jan 1, 2005, in forum: Java
    Replies:
    0
    Views:
    421
    Kevin Lam
    Jan 1, 2005
  5. WebHost
    Replies:
    2
    Views:
    5,265
Loading...

Share This Page