FYI: ruby 200 CentOS aredridel RPMs - missing dependency on libyaml

Discussion in 'Ruby' started by lfast1234, Oct 23, 2013.

  1. lfast1234

    lfast1234 Guest

    I just installed ruby 200 and all the related packages from ftp5.gwdg.de/pub/opensuse/repositories/home:/aredridel/CentOS_CentOS-6/x86_64/ruby-2.0.0.0-45.1.x86_64.rpm
    - thanks for building that suite! Sweet!

    But I had a small problem. When I ran "gem" I get the following error:
    /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:45:in `require': libyaml-0.so.2: cannot open shared object file: No such file or directory - /usr/lib64/gems/ruby/psych-2.0.0/lib/psych.so (LoadError)

    Turned out the missing file was actually libyaml. When I explicitly installed that, gem started working.

    Thank you aredridel for doing all the heavy lifting!
     
    lfast1234, Oct 23, 2013
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.