installation of Statistics::Test::WilcoxonRankSum

E

ela

Installation (by cpan) of Statistics::Test::WilcoxonRankSum failed and then
I tried installing its dependent module Contextual::Return, then I
encountered the following errors:


Writing Makefile for Contextual::Return
Writing MYMETA.yml and MYMETA.json
cp lib/Contextual/Return.pm blib/lib/Contextual/Return.pm
cp lib/Contextual/Return/Failure.pm blib/lib/Contextual/Return/Failure.pm
Manifying blib/man3/Contextual::Return.3pm
Manifying blib/man3/Contextual::Return::Failure.3pm
DCONWAY/Contextual-Return-0.003001.tar.gz
/usr/bin/make -- OK
Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00.load.t ................... 1/1 # Testing Contextual::Return
t/00.load.t ................... ok
t/args.t ...................... syntax error at t/args.t line 6, near "BOOL
"
syntax error at t/args.t line 8, near "NUM "
Execution of t/args.t aborted due to compilation errors.
t/args.t ...................... Dubious, test returned 255 (wstat 65280,
0xff00)
No subtests run
t/args_RESULT.t ............... Type of arg 1 to Contextual::Return::RESULT
must be block or sub {} (not single ref constructor) at t/args_RESULT.t line
5, near "};"
syntax error at t/args_RESULT.t line 5, near "; undef"
Type of arg 1 to Contextual::Return::RESULT must be block or sub {} (not
single ref constructor) at t/args_RESULT.t line 6, near "};"
Type of arg 1 to Contextual::Return::RESULT must be block or sub {} (not
single ref constructor) at t/args_RESULT.t line 7, near "};"
syntax error at t/args_RESULT.t line 7, near "; undef"
Execution of t/args_RESULT.t aborted due to compilation errors.
t/args_RESULT.t ............... Dubious, test returned 255 (wstat 65280,
0xff00)
No subtests run
t/caller.t .................... syntax error at t/caller.t line 6, near
"SCALAR "
syntax error at t/caller.t line 8, near "}"
Execution of t/caller.t aborted due to compilation errors.
t/caller.t .................... Dubious, test returned 255 (wstat 65280,
0xff00)
No subtests run
t/cleanup.t ................... syntax error at t/cleanup.t line 11, near
"NUM "



What's the problem? And what's the reference books for solving this kinda
problems?
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Forum statistics

Threads
473,704
Messages
2,569,333
Members
44,614
Latest member
BeauGuay3

Latest Threads

Top